aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-05-19 17:07:12 +0000
committerpsykose <alice@ayaya.dev>2023-05-19 19:07:12 +0200
commit6aa187e82d6226fac1171af095da541d56fcf592 (patch)
tree951927807e118e543de07ecc583f952982531a45
parent7d9f9a82c91209ba597a724c9cabe75e647d39b9 (diff)
main/llvm16: symlink LLVMgold to bfd-plugins dir
closes #14945
-rw-r--r--main/llvm16/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/main/llvm16/APKBUILD b/main/llvm16/APKBUILD
index f70b4153ec9..8204816771d 100644
--- a/main/llvm16/APKBUILD
+++ b/main/llvm16/APKBUILD
@@ -10,7 +10,7 @@ _pkgname=llvm
pkgver=16.0.4
_majorver=${pkgver%%.*}
pkgname=$_pkgname$_majorver
-pkgrel=2
+pkgrel=3
pkgdesc="Low Level Virtual Machine compiler system, version $_majorver"
arch="all"
url="https://llvm.org/"
@@ -267,8 +267,13 @@ linktools() {
$_prefix/lib/LLVMgold* \
if [ "$_default_llvm" = yes ]; then
- ln -sf llvm$_majorver/lib/LLVMgold.so "$subpkgdir"/usr/lib/
- ln -sf llvm$_majorver/lib/libLTO.so "$subpkgdir"/usr/lib/
+ ln -sfv llvm$_majorver/lib/LLVMgold.so "$subpkgdir"/usr/lib/
+ ln -sfv llvm$_majorver/lib/libLTO.so "$subpkgdir"/usr/lib/
+
+ # for bfd to work with clang -flto, you need to put the linker plugin in the bfd dir too,
+ # not just usr/lib.
+ mkdir -p "$subpkgdir"/usr/lib/bfd-plugins/
+ ln -sfv ../llvm$_majorver/lib/LLVMgold.so "$subpkgdir"/usr/lib/bfd-plugins/
fi
}