aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-02-14 11:36:22 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2019-02-14 11:39:53 +0100
commit6b5172b41e520d82d714d987bcc446383165438a (patch)
tree3f658cddc2723f52bbf22e80bf348d20108e04f2
parent8cf450503b9e57661ebfd9da49ba2ca8ff1ae768 (diff)
testing/abduco: add check
-rw-r--r--testing/abduco/APKBUILD13
-rw-r--r--testing/abduco/fix-tests.patch15
2 files changed, 25 insertions, 3 deletions
diff --git a/testing/abduco/APKBUILD b/testing/abduco/APKBUILD
index d5e67a0f560..b4d3d7ea19b 100644
--- a/testing/abduco/APKBUILD
+++ b/testing/abduco/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=abduco
pkgver=0.6
-pkgrel=0
+pkgrel=1
pkgdesc="Session management in a clean and simple way"
url="http://www.brain-dump.org/projects/abduco/"
arch="all"
@@ -12,13 +12,19 @@ depends_dev=""
makedepends=""
install=""
subpackages="$pkgname-doc"
-source="http://www.brain-dump.org/projects/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://www.brain-dump.org/projects/$pkgname/$pkgname-$pkgver.tar.gz
+ fix-tests.patch"
builddir="$srcdir"/$pkgname-$pkgver
build() {
make -C "$builddir"
}
+check() {
+ cd "$builddir"
+ ./testsuite.sh
+}
+
package() {
cd "$builddir"
make PREFIX=/usr DESTDIR="$pkgdir" install
@@ -26,4 +32,5 @@ package() {
"$pkgdir"/usr/share/doc/$pkgname/README.md
}
-sha512sums="3b70a5cc10f0a2743dcbdf6eebdcfcee0e4f4ff8c6ce0bf0aa9f55c3fa85ab43aa659997735e063eab36aba69f91be7bb5519f3f632bff1b9098f5179165c1f2 abduco-0.6.tar.gz"
+sha512sums="3b70a5cc10f0a2743dcbdf6eebdcfcee0e4f4ff8c6ce0bf0aa9f55c3fa85ab43aa659997735e063eab36aba69f91be7bb5519f3f632bff1b9098f5179165c1f2 abduco-0.6.tar.gz
+0d9e5be04bfd9d0826c54d7a8ad8435dcd3559efd7eabca11ebab86f20acabd4d97e1c1fb81e895865e73034d4a2e278f409236f301a6d71ac907af66ced046b fix-tests.patch"
diff --git a/testing/abduco/fix-tests.patch b/testing/abduco/fix-tests.patch
new file mode 100644
index 00000000000..746e438eb17
--- /dev/null
+++ b/testing/abduco/fix-tests.patch
@@ -0,0 +1,15 @@
+Without this change pgrep seems to return the PID of the abduco process
+spawned in the previous line because it may not be removed yet. Removing
+the pgrep invocation is not the best solution but good enough for now.
+
+diff -upr abduco-0.6.orig/testsuite.sh abduco-0.6/testsuite.sh
+--- abduco-0.6.orig/testsuite.sh 2019-02-14 11:33:19.521290879 +0100
++++ abduco-0.6/testsuite.sh 2019-02-14 11:33:29.361298623 +0100
+@@ -55,7 +55,6 @@ expected_abduco_detached_output() {
+
+ check_environment() {
+ [ "`$ABDUCO | wc -l`" -gt 1 ] && echo Abduco session exists && exit 1;
+- pgrep abduco && echo Abduco process exists && exit 1;
+ return 0;
+ }
+