aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2019-11-06 10:39:42 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-03-10 16:36:46 -0300
commit6c34b9a10bcdcdac04a11569c50b61fb50c4ea6e (patch)
treeeafc08318fbdaf759305a8018434cdc178c70b67
parent405bbad926a985d6abba5fabd1f2266e050a2d18 (diff)
main/clang: fix packaging
Keep /usr/lib/clang/x.y.z/include in the main package as all these headers (altivec.h, msa.h, x86intrin.h etc) are required to build programs *with* clang, not against it.
-rw-r--r--main/clang/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/main/clang/APKBUILD b/main/clang/APKBUILD
index 7d75ba290dc..3cb3e419a97 100644
--- a/main/clang/APKBUILD
+++ b/main/clang/APKBUILD
@@ -4,7 +4,7 @@
pkgname=clang
# Note: Update together with llvm.
pkgver=9.0.1
-pkgrel=4
+pkgrel=5
_llvmver=${pkgver%%.*}
pkgdesc="A C language family front-end for LLVM"
arch="all"
@@ -94,6 +94,14 @@ static() {
mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
}
+dev() {
+ default_dev
+
+ # move back usr/lib/clang/x.y.z/include with files such as altivec.h, msa.h etc
+ # these are needed to build programs *with* clang, not *against* it.
+ mv "$subpkgdir"/usr/lib/clang "$pkgdir"/usr/lib/
+}
+
analyzer() {
pkgdesc="Clang source code analysis framework"
depends="$pkgname=$pkgver-r$pkgrel perl python3"