aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 03:47:08 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 07:58:06 -0300
commit6e29a0d239bc86a2118bcc561e4373969750b9b6 (patch)
tree4e2f3065a86d9d1e2f38642c530ea66aed890e19
parente9986eae8b8dd1b5b04222717a37cce4ced75e80 (diff)
community/lua-fun: enable luajit on s390x
-rw-r--r--community/lua-fun/APKBUILD15
1 files changed, 2 insertions, 13 deletions
diff --git a/community/lua-fun/APKBUILD b/community/lua-fun/APKBUILD
index 97a07d92231..db61815f04c 100644
--- a/community/lua-fun/APKBUILD
+++ b/community/lua-fun/APKBUILD
@@ -10,17 +10,10 @@ url="https://rtsisyk.github.io/luafun/"
arch="noarch"
license="MIT"
depends="lua"
-checkdepends=""
-provides=""
+checkdepends="luajit"
source="$pkgname-$pkgver.tar.gz::https://github.com/rtsisyk/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-# luajit is not available for selected arches
-case "$CARCH" in
- s390x) _luajit="";;
- *) checkdepends="$checkdepends luajit" _luajit="jit";;
-esac
-
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
checkdepends="$checkdepends lua$_v"
@@ -28,17 +21,13 @@ for _v in $_luaversions; do
done
check() {
- cd "$builddir"
-
- local lver; for lver in $_luaversions $_luajit; do
+ local lver; for lver in $_luaversions jit; do
msg "Testing on Lua $lver"
lua$lver tests/runtest tests/*.lua
done
}
package() {
- cd "$builddir"
-
install -m 644 -D fun.lua "$pkgdir"/usr/share/lua/common/fun.lua
echo 'rock_manifest = {}' > rock_manifest