aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-29 20:53:45 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-29 20:53:45 -0300
commit6e692ffb6467368615abc54620ffb79747e1393f (patch)
tree4b5677aac6223cb509ee8357e3f06cf8f948ff98
parent345b493878f83923bbd61f64846bf696dc402db6 (diff)
main/bluez: fix shebang for bluez-simple-agent
-rw-r--r--main/bluez/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index 984b5d8072a..c0e8e61a719 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
pkgver=5.54
-pkgrel=4
+pkgrel=5
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch="all"
@@ -75,6 +75,9 @@ package() {
install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth
install -Dm755 "$srcdir"/rfcomm.initd "$pkgdir"/etc/init.d/rfcomm
install -Dm644 "$srcdir"/rfcomm.confd "$pkgdir"/etc/conf.d/rfcomm
+
+ # Fix shebang for the installed binary
+ sed 's|^#!/usr/bin/python$|#!/usr/bin/env python3|g' -i test/simple-agent
install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent
}