aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Lorin <androw95220@gmail.com>2022-03-20 12:01:52 +0100
committeralice <alice@ayaya.dev>2022-03-20 22:04:04 +0000
commit6ee9bb87bc04ea581f51d3bf5ffc271c9a886487 (patch)
tree6e306b52d5a8a173a3201d02df17261f5e2b3842
parentbb512929868e881208531528c7d80f7e15f93e9b (diff)
testing/php7-pdlib, testing/php8-pdlib: disable checks on s390x
-rw-r--r--testing/php7-pdlib/APKBUILD3
-rw-r--r--testing/php8-pdlib/APKBUILD3
2 files changed, 6 insertions, 0 deletions
diff --git a/testing/php7-pdlib/APKBUILD b/testing/php7-pdlib/APKBUILD
index f5670fc2ffe..5fa8bd59184 100644
--- a/testing/php7-pdlib/APKBUILD
+++ b/testing/php7-pdlib/APKBUILD
@@ -13,6 +13,9 @@ makedepends="php7-dev pkgconf php7-bz2"
source="php-$_extname-$pkgver.tar.gz::https://github.com/goodspb/$_extname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_extname-$pkgver"
+#disable check on s390x as Frontal face detection failling
+[ "$CARCH" = "s390x" ] && options="!check"
+
build() {
phpize7
./configure --prefix=/usr --with-php-config=php-config7
diff --git a/testing/php8-pdlib/APKBUILD b/testing/php8-pdlib/APKBUILD
index da28f04076a..15e670fc98f 100644
--- a/testing/php8-pdlib/APKBUILD
+++ b/testing/php8-pdlib/APKBUILD
@@ -14,6 +14,9 @@ source="php-$_extname-$pkgver.tar.gz::https://github.com/goodspb/$_extname/archi
https://github.com/goodspb/pdlib/commit/a31d3bc709321b784ecd93c983b476a0a298bfa0.patch"
builddir="$srcdir/$_extname-$pkgver"
+#disable check on s390x as Frontal face detection failling
+[ "$CARCH" = "s390x" ] && options="!check"
+
build() {
phpize8
./configure --prefix=/usr --with-php-config=php-config8