aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-04 23:53:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-04 23:53:38 -0300
commit70e92fb9f1badaec91a70c50182485cf684578db (patch)
tree8adc65d08e9ac5a7226cdecbdd8769017e319575
parent99e64592e10f41d71bdfc0fbec98399c00d46e62 (diff)
main/xcb-util-cursor: fix url
-rw-r--r--main/xcb-util-cursor/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/main/xcb-util-cursor/APKBUILD b/main/xcb-util-cursor/APKBUILD
index b97c84f85ba..47107512ce7 100644
--- a/main/xcb-util-cursor/APKBUILD
+++ b/main/xcb-util-cursor/APKBUILD
@@ -2,22 +2,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xcb-util-cursor
pkgver=0.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="X C-language Binding - cursor library (port of libXcursor)"
-url="https://xcb.freedesktop.org/"
+url="https://gitlab.freedesktop.org/xorg/lib/libxcb-cursor"
arch="all"
license="MIT"
-depends=
depends_dev="xcb-util-dev"
makedepends="$depends_dev m4 util-macros xcb-util-image-dev xcb-util-renderutil-dev"
checkdepends="check-dev"
-install=""
subpackages="$pkgname-dev"
source="https://xcb.freedesktop.org/dist/xcb-util-cursor-$pkgver.tar.gz
"
build() {
- cd "$builddir"
export CFLAGS="$CFLAGS -std=gnu99"
./configure \
--build=$CBUILD \
@@ -31,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}