aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-09 23:02:25 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-09 23:03:10 -0300
commit71422a70753279ebc94f0cb05a0685720020caaa (patch)
tree4e68a708d4539ca7a284effbae24c60252500992
parent052a1e22daef37ec4873e98650b9c2d6e55f7275 (diff)
testing/idris: try using v1-sandbox instead of sandbox
-rw-r--r--testing/idris/APKBUILD12
1 files changed, 2 insertions, 10 deletions
diff --git a/testing/idris/APKBUILD b/testing/idris/APKBUILD
index b8a6cc63ea3..9fbfb5cdd7d 100644
--- a/testing/idris/APKBUILD
+++ b/testing/idris/APKBUILD
@@ -88,8 +88,6 @@ prepare() {
die "Requirements file is outdated, run 'abuild cabal_update'"
fi
- cd "$builddir"
-
# Create cabal config and fetch index.
HOME="$_cabal_home" cabal update
@@ -98,7 +96,7 @@ prepare() {
# Create Cabal sandbox that will be used for all subsequent cabal
# invocations. This is something like Python virtual env.
- cmd="cabal sandbox init"
+ cmd="cabal v1-sandbox init"
msg "$cmd"
HOME="$_cabal_home" $cmd
@@ -106,12 +104,10 @@ prepare() {
# Note: cabal-doctest is a transitive dependency for libffi-0.1 not idris
cmd="cabal fetch --no-dependencies $(_cabal_pkgs) cabal-doctest-1.0.2 libffi-0.1"
msg "$cmd"
- HOME="$_cabal_home" $cmd
+ HOME="$_cabal_home" $cmd
}
build() {
- cd "$builddir"
-
# Build dependencies
# Note: for libffi force constraints manually via the freeze file to prevent
# cabal from possibly using newer constraints for libffi that might intersect
@@ -140,14 +136,10 @@ build() {
# TODO: Run upstream tests and/or figure out how to set paths to be able
# to compile hello_world for check.
check() {
- cd "$builddir"
-
./dist/build/idris/idris --version
}
package() {
- cd "$builddir"
-
HOME="$_cabal_home" cabal copy --destdir="$pkgdir"
cd "$pkgdir"