aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r <j.r@jugendhacker.de>2021-06-25 17:11:45 +0000
committerLeo <thinkabit.ukim@gmail.com>2021-07-25 01:06:42 +0000
commit71b1b89f9181ec637a6b8614c53a5489343d1ccd (patch)
tree8048d9ebe28d13453f66f87b4a337748a629119e
parent8a217427e6453e04b3151986691616cc7ff65975 (diff)
testing/libstrophe: new aport
https://strophe.im/libstrophe/ Simple, lightweight C library for writing XMPP clients
-rw-r--r--testing/libstrophe/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/libstrophe/APKBUILD b/testing/libstrophe/APKBUILD
new file mode 100644
index 00000000000..5eb0eb0b7ac
--- /dev/null
+++ b/testing/libstrophe/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: j.r <j.r@jugendhacker.de>
+pkgname=libstrophe
+pkgver=0.10.1
+pkgrel=0
+pkgdesc="Simple, lightweight C library for writing XMPP clients"
+url="https://strophe.im/libstrophe/"
+arch="all"
+license="GPL-3.0-or-later MIT"
+makedepends="expat-dev openssl-dev"
+subpackages="$pkgname-dev"
+source="https://github.com/strophe/libstrophe/releases/download/$pkgver/libstrophe-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+1ee3cb76cdc76711b4928d69fb8add974ab8359b729ec12003d73530c93492f4e8d208cacbd50f8db7509bc01f56a9f945348bc3a6fdd18a7080b751fff8a783 libstrophe-0.10.1.tar.gz
+"