aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-03-18 19:16:21 +0000
committerpsykose <alice@ayaya.dev>2023-03-18 20:16:39 +0100
commit72ebf84d36aabbf1bf7654e7e714940943d7360b (patch)
tree231890f6e3eed6e290651861f791f77ebeac1a20
parentf7bcf0a4025b2d4b5cb535423ee540ec681c0dea (diff)
community/webkit2gtk-6.0: add another riscv64 patch
-rw-r--r--community/webkit2gtk-6.0/APKBUILD2
-rw-r--r--community/webkit2gtk-6.0/riscv-fix-7.patch30
2 files changed, 32 insertions, 0 deletions
diff --git a/community/webkit2gtk-6.0/APKBUILD b/community/webkit2gtk-6.0/APKBUILD
index 34fa4329e47..9fa9d087f68 100644
--- a/community/webkit2gtk-6.0/APKBUILD
+++ b/community/webkit2gtk-6.0/APKBUILD
@@ -63,6 +63,7 @@ source="https://webkitgtk.org/releases/webkitgtk-$pkgver.tar.xz
riscv-fix-4.patch
riscv-fix-5.patch
riscv-fix-6.patch
+ riscv-fix-7.patch
"
builddir="$srcdir/webkitgtk-$pkgver"
@@ -167,4 +168,5 @@ a5a5d62aea820c087f7919b617bef5adefa6f34a8189fe1993250535ff59585bed4c6fd24d69caae
1c33fa822a245f0f8db1caa3b368d3dd56e2595e509fd422d7d888bbe23288426907a4dd4fc0e14a1d28ff3c3240cb69e4ef8a6326ec27eb1db50c31b84da006 riscv-fix-4.patch
ba730685aee231d0941229601e4dedc70c53737c7702d9b58600f9bf4eff793490b218f042750145363902570a0915da720726bd969092b402d03413536db714 riscv-fix-5.patch
e7193564d415c4c71d735e897ce74b6efa49eb43060e8a44a494e854ae67099588bc982bce1a6ced27726589e2f93fc2e1ff8c5bb99b3444cb7d479c31b233e0 riscv-fix-6.patch
+15c34e6fc59279627ea6801d8954a95c5d8ba711cfb6ae7aad1335739675940a244137c6b1a055ae6f7c8017da07430d9b1b9a4b789cdc4c9072b585a4573bd1 riscv-fix-7.patch
"
diff --git a/community/webkit2gtk-6.0/riscv-fix-7.patch b/community/webkit2gtk-6.0/riscv-fix-7.patch
new file mode 100644
index 00000000000..ff38c195bd7
--- /dev/null
+++ b/community/webkit2gtk-6.0/riscv-fix-7.patch
@@ -0,0 +1,30 @@
+Patch-Source: https://github.com/chimera-linux/cports/blob/eef4da03f5aaa0c3d5648a1fc238603d80475398/main/webkitgtk/patches/prefer-pthread.patch
+--
+From: Alberto Garcia <berto@igalia.com>
+Description: Enable THREADS_PREFER_PTHREAD_FLAG
+ This fixes a FTBFS in riscv64
+Bug: https://bugs.webkit.org/show_bug.cgi?id=182622
+Bug-Debian: https://bugs.debian.org/895969
+Origin: https://trac.webkit.org/changeset/231843
+Index: webkitgtk/Source/cmake/OptionsGTK.cmake
+===================================================================
+--- webkitgtk.orig/Source/cmake/OptionsGTK.cmake
++++ webkitgtk/Source/cmake/OptionsGTK.cmake
+@@ -13,6 +13,8 @@ endif ()
+
+ set(USER_AGENT_BRANDING "" CACHE STRING "Branding to add to user agent string")
+
++set(THREADS_PREFER_PTHREAD_FLAG ON)
++
+ find_package(Cairo 1.14.0 REQUIRED)
+ find_package(Fontconfig 2.8.0 REQUIRED)
+ find_package(Freetype 2.4.2 REQUIRED)
+Index: webkitgtk/Source/cmake/OptionsJSCOnly.cmake
+===================================================================
+--- webkitgtk.orig/Source/cmake/OptionsJSCOnly.cmake
++++ webkitgtk/Source/cmake/OptionsJSCOnly.cmake
+@@ -1,3 +1,4 @@
++set(THREADS_PREFER_PTHREAD_FLAG ON)
+ find_package(Threads REQUIRED)
+
+ if (MSVC)