aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-19 14:05:22 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-19 14:16:51 +0100
commit730cdcef6901750f4029d4c3b8639ce02ee3ead1 (patch)
treeb64f30934154b7804989d63b97b7a9a4e4c0bb06
parent671c5ffae7ed535bec43cefbfbe937d32daa6720 (diff)
downloadaports-730cdcef6901750f4029d4c3b8639ce02ee3ead1.tar.gz
aports-730cdcef6901750f4029d4c3b8639ce02ee3ead1.tar.bz2
aports-730cdcef6901750f4029d4c3b8639ce02ee3ead1.tar.xz
main/*: fix homepage url and source from http:// to https://
Most of these updates is based on data from https://repology.org/, detection based on permanent redirect from http:// to https://. $source urls are updated when they contain $url as substring.
-rw-r--r--main/a2ps/APKBUILD2
-rw-r--r--main/abuild/APKBUILD2
-rw-r--r--main/acct/APKBUILD2
-rw-r--r--main/acf-alpine-baselayout/APKBUILD2
-rw-r--r--main/acf-alpine-conf/APKBUILD2
-rw-r--r--main/acf-amavisd-new/APKBUILD2
-rw-r--r--main/acf-apk-tools/APKBUILD2
-rw-r--r--main/acf-asterisk/APKBUILD2
-rw-r--r--main/acf-awall/APKBUILD2
-rw-r--r--main/acf-chrony/APKBUILD2
-rw-r--r--main/acf-clamav/APKBUILD2
-rw-r--r--main/acf-clamsmtp/APKBUILD2
-rw-r--r--main/acf-core/APKBUILD2
-rw-r--r--main/acf-dansguardian/APKBUILD2
-rw-r--r--main/acf-db/APKBUILD2
-rw-r--r--main/acf-dhcp/APKBUILD2
-rw-r--r--main/acf-dnscache/APKBUILD2
-rw-r--r--main/acf-dnsmasq/APKBUILD2
-rw-r--r--main/acf-dovecot/APKBUILD2
-rw-r--r--main/acf-fetchmail/APKBUILD2
-rw-r--r--main/acf-freeradius3/APKBUILD2
-rw-r--r--main/acf-freeswitch/APKBUILD2
-rw-r--r--main/acf-gross/APKBUILD2
-rw-r--r--main/acf-ipsec-tools/APKBUILD2
-rw-r--r--main/acf-iptables/APKBUILD2
-rw-r--r--main/acf-jquery/APKBUILD2
-rw-r--r--main/acf-kamailio/APKBUILD2
-rw-r--r--main/acf-lib/APKBUILD2
-rw-r--r--main/acf-lighttpd/APKBUILD2
-rw-r--r--main/acf-nsd/APKBUILD2
-rw-r--r--main/acf-opennhrp/APKBUILD2
-rw-r--r--main/acf-openntpd/APKBUILD2
-rw-r--r--main/acf-openssh/APKBUILD2
-rw-r--r--main/acf-openssl/APKBUILD2
-rw-r--r--main/acf-openvpn/APKBUILD2
-rw-r--r--main/acf-pingu/APKBUILD2
-rw-r--r--main/acf-postfix/APKBUILD2
-rw-r--r--main/acf-ppp/APKBUILD2
-rw-r--r--main/acf-provisioning/APKBUILD2
-rw-r--r--main/acf-quagga/APKBUILD2
-rw-r--r--main/acf-samba/APKBUILD2
-rw-r--r--main/acf-skins/APKBUILD2
-rw-r--r--main/acf-snort/APKBUILD2
-rw-r--r--main/acf-squid/APKBUILD2
-rw-r--r--main/acf-tcpproxy/APKBUILD2
-rw-r--r--main/acf-tinydns/APKBUILD2
-rw-r--r--main/acf-weblog/APKBUILD2
-rw-r--r--main/aconf/APKBUILD2
-rw-r--r--main/acpi/APKBUILD2
-rw-r--r--main/alpine-baselayout/APKBUILD2
-rw-r--r--main/alpine-mirrors/APKBUILD2
-rw-r--r--main/apache-mod-auth-kerb/APKBUILD2
-rw-r--r--main/apk-tools/APKBUILD2
-rw-r--r--main/appstream-glib/APKBUILD4
-rw-r--r--main/atk/APKBUILD2
-rw-r--r--main/atop/APKBUILD4
-rw-r--r--main/autoconf/APKBUILD2
-rw-r--r--main/automake/APKBUILD2
-rw-r--r--main/awall/APKBUILD2
-rw-r--r--main/bash/APKBUILD2
-rw-r--r--main/bbsuid/APKBUILD2
-rw-r--r--main/bcache-tools/APKBUILD2
-rw-r--r--main/binutils/APKBUILD2
-rw-r--r--main/bison/APKBUILD2
-rw-r--r--main/bitlbee/APKBUILD2
-rw-r--r--main/brlaser/APKBUILD2
-rw-r--r--main/busybox-initscripts/APKBUILD2
-rw-r--r--main/c-ares/APKBUILD4
-rw-r--r--main/cabextract/APKBUILD4
-rw-r--r--main/cgit/APKBUILD2
-rw-r--r--main/checkbashisms/APKBUILD2
-rw-r--r--main/cifs-utils/APKBUILD2
-rw-r--r--main/compat-pvgrub/APKBUILD2
-rw-r--r--main/coreutils/APKBUILD2
-rw-r--r--main/cpufreqd/APKBUILD2
-rw-r--r--main/cpufrequtils/APKBUILD2
-rw-r--r--main/cracklib-words/APKBUILD2
-rw-r--r--main/cracklib/APKBUILD2
-rw-r--r--main/cramfs/APKBUILD2
-rw-r--r--main/crconf/APKBUILD2
-rw-r--r--main/cups/APKBUILD2
-rw-r--r--main/daq/APKBUILD2
-rw-r--r--main/darkhttpd/APKBUILD4
-rw-r--r--main/db/APKBUILD2
-rw-r--r--main/debootstrap/APKBUILD2
-rw-r--r--main/dhcpcd-dbus/APKBUILD2
-rw-r--r--main/dhcpcd-ui/APKBUILD2
-rw-r--r--main/dhcpcd/APKBUILD2
-rw-r--r--main/diffutils/APKBUILD2
-rw-r--r--main/dmenu/APKBUILD2
-rw-r--r--main/ethtool/APKBUILD2
-rw-r--r--main/feh/APKBUILD2
-rw-r--r--main/findutils/APKBUILD2
-rw-r--r--main/flashrom/APKBUILD2
-rw-r--r--main/garcon/APKBUILD2
-rw-r--r--main/gawk/APKBUILD2
-rw-r--r--main/gdbm/APKBUILD2
-rw-r--r--main/gdk-pixbuf/APKBUILD2
-rw-r--r--main/gdl/APKBUILD2
-rw-r--r--main/gengetopt/APKBUILD2
-rw-r--r--main/gettext/APKBUILD2
-rw-r--r--main/ghostscript/APKBUILD2
-rw-r--r--main/giflib/APKBUILD2
-rw-r--r--main/gitolite/APKBUILD2
-rw-r--r--main/glade/APKBUILD2
-rw-r--r--main/glade3/APKBUILD2
-rw-r--r--main/glu/APKBUILD2
-rw-r--r--main/gmp/APKBUILD2
-rw-r--r--main/gnats/APKBUILD2
-rw-r--r--main/gnome-mime-data/APKBUILD2
-rw-r--r--main/gnome-vfs/APKBUILD2
-rw-r--r--main/gnuchess/APKBUILD2
-rw-r--r--main/gperf/APKBUILD2
-rw-r--r--main/gphoto2/APKBUILD2
-rw-r--r--main/gpicview/APKBUILD2
-rw-r--r--main/grep/APKBUILD2
-rw-r--r--main/groff/APKBUILD2
-rw-r--r--main/gsl/APKBUILD2
-rw-r--r--main/gst-plugins-bad/APKBUILD4
-rw-r--r--main/gst-plugins-bad0.10/APKBUILD4
-rw-r--r--main/gst-plugins-base/APKBUILD4
-rw-r--r--main/gst-plugins-base0.10/APKBUILD4
-rw-r--r--main/gst-plugins-good/APKBUILD4
-rw-r--r--main/gst-plugins-good0.10/APKBUILD4
-rw-r--r--main/gst-plugins-ugly/APKBUILD4
-rw-r--r--main/gst-plugins-ugly0.10/APKBUILD4
-rw-r--r--main/gstreamer/APKBUILD4
-rw-r--r--main/gstreamer0.10/APKBUILD4
-rw-r--r--main/gtk+/APKBUILD2
-rw-r--r--main/gtk+2.0/APKBUILD2
-rw-r--r--main/gtk+3.0/APKBUILD2
-rw-r--r--main/gtk-doc/APKBUILD2
-rw-r--r--main/gtk-engines/APKBUILD2
-rw-r--r--main/gtk-xfce-engine/APKBUILD2
-rw-r--r--main/gtkglext/APKBUILD2
-rw-r--r--main/guile/APKBUILD2
-rw-r--r--main/gzip/APKBUILD2
-rw-r--r--main/hdparm/APKBUILD2
-rw-r--r--main/help2man/APKBUILD2
-rw-r--r--main/hicolor-icon-theme/APKBUILD2
-rw-r--r--main/i3lock/APKBUILD2
-rw-r--r--main/igmpproxy/APKBUILD2
-rw-r--r--main/imlib2/APKBUILD2
-rw-r--r--main/indent/APKBUILD2
-rw-r--r--main/inotify-tools/APKBUILD2
-rw-r--r--main/installkernel/APKBUILD2
-rw-r--r--main/iproute2-qos/APKBUILD2
-rw-r--r--main/irssi/APKBUILD2
-rw-r--r--main/java-common/APKBUILD2
-rw-r--r--main/java-gcj-compat/APKBUILD2
-rw-r--r--main/jbig2dec/APKBUILD2
-rw-r--r--main/jwhois/APKBUILD2
-rw-r--r--main/ldoc/APKBUILD2
-rw-r--r--main/libass/APKBUILD2
-rw-r--r--main/libavc1394/APKBUILD2
-rw-r--r--main/libbonobo/APKBUILD2
-rw-r--r--main/libbsd/APKBUILD4
-rw-r--r--main/libcddb/APKBUILD2
-rw-r--r--main/libcdio-paranoia/APKBUILD2
-rw-r--r--main/libcdio/APKBUILD2
-rw-r--r--main/libcrystalhd/APKBUILD2
-rw-r--r--main/libdc1394/APKBUILD2
-rw-r--r--main/libebml/APKBUILD2
-rw-r--r--main/libepoxy/APKBUILD2
-rw-r--r--main/libexecinfo/APKBUILD2
-rw-r--r--main/libexif/APKBUILD2
-rw-r--r--main/libgnome/APKBUILD2
-rw-r--r--main/libgnomekbd/APKBUILD2
-rw-r--r--main/libgsasl/APKBUILD2
-rw-r--r--main/libgsf/APKBUILD2
-rw-r--r--main/libgss/APKBUILD2
-rw-r--r--main/libidl/APKBUILD2
-rw-r--r--main/libidn/APKBUILD2
-rw-r--r--main/libmaa/APKBUILD2
-rw-r--r--main/libmatroska/APKBUILD2
-rw-r--r--main/libmicrohttpd/APKBUILD2
-rw-r--r--main/libmms/APKBUILD2
-rw-r--r--main/libmspack/APKBUILD4
-rw-r--r--main/libnet/APKBUILD2
-rw-r--r--main/libnice/APKBUILD2
-rw-r--r--main/libnih/APKBUILD4
-rw-r--r--main/libogg/APKBUILD2
-rw-r--r--main/liboil/APKBUILD2
-rw-r--r--main/libpthread-stubs/APKBUILD2
-rw-r--r--main/libqrencode/APKBUILD2
-rw-r--r--main/libraw/APKBUILD4
-rw-r--r--main/libraw1394/APKBUILD2
-rw-r--r--main/librevenge/APKBUILD4
-rw-r--r--main/libssh2/APKBUILD2
-rw-r--r--main/libtasn1/APKBUILD2
-rw-r--r--main/libtool/APKBUILD2
-rw-r--r--main/libunistring/APKBUILD2
-rw-r--r--main/libvdpau/APKBUILD2
-rw-r--r--main/libvpx/APKBUILD2
-rw-r--r--main/libxcb/APKBUILD4
-rw-r--r--main/libxfce4ui/APKBUILD2
-rw-r--r--main/libxfce4util/APKBUILD2
-rw-r--r--main/libxkbcommon/APKBUILD2
-rw-r--r--main/libxscrnsaver/APKBUILD2
-rw-r--r--main/libxshmfence/APKBUILD4
-rw-r--r--main/lsof/APKBUILD2
-rw-r--r--main/lua-aports/APKBUILD4
-rw-r--r--main/lua-augeas/APKBUILD2
-rw-r--r--main/lua-cjson/APKBUILD2
-rw-r--r--main/lua/APKBUILD2
-rw-r--r--main/lua5.1/APKBUILD4
-rw-r--r--main/lua5.2/APKBUILD4
-rw-r--r--main/lua5.3/APKBUILD4
-rw-r--r--main/lxdm/APKBUILD2
-rw-r--r--main/m4/APKBUILD2
-rw-r--r--main/make/APKBUILD2
-rw-r--r--main/man-pages/APKBUILD2
-rw-r--r--main/minicom/APKBUILD2
-rw-r--r--main/mkinitfs/APKBUILD2
-rw-r--r--main/mrtg/APKBUILD4
-rw-r--r--main/mtools/APKBUILD2
-rw-r--r--main/multisort/APKBUILD2
-rw-r--r--main/nagios/APKBUILD2
-rw-r--r--main/nano/APKBUILD4
-rw-r--r--main/ncdu/APKBUILD2
-rw-r--r--main/ncurses/APKBUILD2
-rw-r--r--main/ncurses5/APKBUILD2
-rw-r--r--main/newsbeuter/APKBUILD4
-rw-r--r--main/ngircd/APKBUILD4
-rw-r--r--main/nodejs/APKBUILD2
-rw-r--r--main/nss-pam-ldapd/APKBUILD4
-rw-r--r--main/ntop/APKBUILD2
-rw-r--r--main/openipmi/APKBUILD2
-rw-r--r--main/opennhrp/APKBUILD2
-rw-r--r--main/openresolv/APKBUILD2
-rw-r--r--main/openvpn-ad-check/APKBUILD2
-rw-r--r--main/orage/APKBUILD2
-rw-r--r--main/p11-kit/APKBUILD4
-rw-r--r--main/pacman/APKBUILD2
-rw-r--r--main/pam-pgsql/APKBUILD2
-rw-r--r--main/parallel/APKBUILD2
-rw-r--r--main/parted/APKBUILD2
-rw-r--r--main/patch/APKBUILD2
-rw-r--r--main/pingu/APKBUILD2
-rw-r--r--main/poppler-qt4/APKBUILD4
-rw-r--r--main/poppler/APKBUILD4
-rw-r--r--main/postgresql/APKBUILD2
-rw-r--r--main/pptpd/APKBUILD2
-rw-r--r--main/pth/APKBUILD2
-rw-r--r--main/putty/APKBUILD2
-rw-r--r--main/pwgen/APKBUILD2
-rw-r--r--main/py-asn1-modules/APKBUILD2
-rw-r--r--main/py-cryptography/APKBUILD2
-rw-r--r--main/py-ecdsa/APKBUILD2
-rw-r--r--main/py-egenix-mx-base/APKBUILD2
-rw-r--r--main/py-enum34/APKBUILD2
-rw-r--r--main/py-flup/APKBUILD4
-rw-r--r--main/py-gnutls/APKBUILD2
-rw-r--r--main/py-gst0.10/APKBUILD4
-rw-r--r--main/py-imaging/APKBUILD2
-rw-r--r--main/py-itsdangerous/APKBUILD2
-rw-r--r--main/py-roman/APKBUILD2
-rw-r--r--main/py-rsa/APKBUILD2
-rw-r--r--main/py-setuptools/APKBUILD2
-rw-r--r--main/py-simplejson/APKBUILD2
-rw-r--r--main/py-simpleparse/APKBUILD2
-rw-r--r--main/py-six/APKBUILD2
-rw-r--r--main/quazip/APKBUILD2
-rw-r--r--main/rarian/APKBUILD2
-rw-r--r--main/rdiff-backup/APKBUILD2
-rw-r--r--main/redis/APKBUILD2
-rw-r--r--main/rtapd/APKBUILD2
-rw-r--r--main/rtnppd/APKBUILD2
-rw-r--r--main/run-parts/APKBUILD2
-rw-r--r--main/sed/APKBUILD2
-rw-r--r--main/ser2net/APKBUILD4
-rw-r--r--main/setup-box/APKBUILD2
-rw-r--r--main/sircbot/APKBUILD2
-rw-r--r--main/smokeping/APKBUILD4
-rw-r--r--main/sngtc_client/APKBUILD2
-rw-r--r--main/snort/APKBUILD2
-rw-r--r--main/sntpc/APKBUILD2
-rw-r--r--main/soxr/APKBUILD4
-rw-r--r--main/spandsp/APKBUILD2
-rw-r--r--main/speex/APKBUILD2
-rw-r--r--main/speexdsp/APKBUILD2
-rw-r--r--main/squark/APKBUILD2
-rw-r--r--main/ssh-getkey-ldap/APKBUILD2
-rw-r--r--main/sshguard/APKBUILD2
-rw-r--r--main/st/APKBUILD2
-rw-r--r--main/strongswan/APKBUILD2
-rw-r--r--main/sudo/APKBUILD2
-rw-r--r--main/swatch/APKBUILD2
-rw-r--r--main/tar/APKBUILD2
-rw-r--r--main/texinfo/APKBUILD2
-rw-r--r--main/tftp-hpa/APKBUILD4
-rw-r--r--main/unionfs-fuse/APKBUILD2
-rw-r--r--main/wget/APKBUILD2
-rw-r--r--main/wv/APKBUILD2
-rw-r--r--main/xcb-proto/APKBUILD4
-rw-r--r--main/xcb-util-cursor/APKBUILD4
-rw-r--r--main/xcb-util-image/APKBUILD4
-rw-r--r--main/xcb-util-keysyms/APKBUILD4
-rw-r--r--main/xcb-util-renderutil/APKBUILD4
-rw-r--r--main/xcb-util-wm/APKBUILD4
-rw-r--r--main/xdg-utils/APKBUILD2
-rw-r--r--main/xf86-video-modesetting/APKBUILD2
-rw-r--r--main/xf86-video-nouveau/APKBUILD2
-rw-r--r--main/xfce4-appfinder/APKBUILD2
-rw-r--r--main/xfce4-dev-tools/APKBUILD2
-rw-r--r--main/xfce4-mixer/APKBUILD2
-rw-r--r--main/xfce4-panel/APKBUILD2
-rw-r--r--main/xfce4-session/APKBUILD2
-rw-r--r--main/xfce4-settings/APKBUILD2
-rw-r--r--main/xfce4-terminal/APKBUILD2
-rw-r--r--main/xfce4-whiskermenu-plugin/APKBUILD2
-rw-r--r--main/xfce4/APKBUILD2
-rw-r--r--main/xfconf/APKBUILD2
-rw-r--r--main/xfdesktop/APKBUILD2
-rw-r--r--main/xfwm4-themes/APKBUILD2
-rw-r--r--main/xfwm4/APKBUILD2
-rw-r--r--main/xmlindent/APKBUILD2
-rw-r--r--main/xprop/APKBUILD2
-rw-r--r--main/xscreensaver/APKBUILD2
-rw-r--r--main/xwininfo/APKBUILD2
-rw-r--r--main/xz/APKBUILD4
-rw-r--r--main/zd1211-firmware/APKBUILD2
-rw-r--r--main/zmap/APKBUILD2
323 files changed, 370 insertions, 370 deletions
diff --git a/main/a2ps/APKBUILD b/main/a2ps/APKBUILD
index 82efb87f9e..bb73f6c340 100644
--- a/main/a2ps/APKBUILD
+++ b/main/a2ps/APKBUILD
@@ -3,7 +3,7 @@ pkgname=a2ps
pkgver=4.14
pkgrel=7
pkgdesc="a2ps is an Any to PostScript filter"
-url="http://www.gnu.org/software/a2ps/"
+url="https://www.gnu.org/software/a2ps/"
arch="all"
license="GPL3"
depends="ghostscript imagemagick perl"
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 45b16a8050..01c91f1839 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -4,7 +4,7 @@ pkgver=3.1.0
_ver=${pkgver%_git*}
pkgrel=3
pkgdesc="Script to build Alpine Packages"
-url="http://git.alpinelinux.org/cgit/abuild/"
+url="https://git.alpinelinux.org/cgit/abuild/"
arch="all"
license="GPL2"
depends="fakeroot sudo pax-utils libressl apk-tools>=2.0.7-r1 libc-utils
diff --git a/main/acct/APKBUILD b/main/acct/APKBUILD
index ea1fe92bc1..9111102309 100644
--- a/main/acct/APKBUILD
+++ b/main/acct/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acct
pkgver=6.6.4
pkgrel=0
pkgdesc="The GNU Accounting Utilities"
-url="http://www.gnu.org/software/acct/"
+url="https://www.gnu.org/software/acct/"
arch="all"
license="GPL3+"
depends=""
diff --git a/main/acf-alpine-baselayout/APKBUILD b/main/acf-alpine-baselayout/APKBUILD
index 7b1850c003..60ce7af663 100644
--- a/main/acf-alpine-baselayout/APKBUILD
+++ b/main/acf-alpine-baselayout/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-alpine-baselayout
pkgver=0.13.1
pkgrel=1
pkgdesc="A web-based system administration interface for alpine-baselayout"
-url="http://git.alpinelinux.org/cgit/acf/acf-alpine-baselayout"
+url="https://git.alpinelinux.org/cgit/acf/acf-alpine-baselayout"
arch="noarch"
license="GPL2"
depends="acf-core lua-json4 lua-posix"
diff --git a/main/acf-alpine-conf/APKBUILD b/main/acf-alpine-conf/APKBUILD
index 005ba62d3c..3064598a85 100644
--- a/main/acf-alpine-conf/APKBUILD
+++ b/main/acf-alpine-conf/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-alpine-conf
pkgver=0.9.0
pkgrel=3
pkgdesc="A web-based system administration interface for alpine-conf"
-url="http://git.alpinelinux.org/cgit/acf/acf-alpine-conf"
+url="https://git.alpinelinux.org/cgit/acf/acf-alpine-conf"
arch="noarch"
license="GPL2"
depends="acf-core lua-posix libressl"
diff --git a/main/acf-amavisd-new/APKBUILD b/main/acf-amavisd-new/APKBUILD
index 4681400393..7396da739d 100644
--- a/main/acf-amavisd-new/APKBUILD
+++ b/main/acf-amavisd-new/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-amavisd-new
pkgver=0.4.0
pkgrel=2
pkgdesc="ACF module for amavis"
-url="http://git.alpinelinux.org/cgit/acf/acf-amavisd-new"
+url="https://git.alpinelinux.org/cgit/acf/acf-amavisd-new"
arch="noarch"
license="GPL2"
depends="acf-core amavisd-new"
diff --git a/main/acf-apk-tools/APKBUILD b/main/acf-apk-tools/APKBUILD
index 88c5670d36..6c1a0fdbf2 100644
--- a/main/acf-apk-tools/APKBUILD
+++ b/main/acf-apk-tools/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-apk-tools
pkgver=0.11.0
pkgrel=1
pkgdesc="ACF module for apk"
-url="http://git.alpinelinux.org/cgit/acf/acf-apk-tools"
+url="https://git.alpinelinux.org/cgit/acf/acf-apk-tools"
arch="noarch"
license="GPL2"
depends="acf-core lua-posix apk-tools"
diff --git a/main/acf-asterisk/APKBUILD b/main/acf-asterisk/APKBUILD
index 5022d2b2c2..4a56d2684a 100644
--- a/main/acf-asterisk/APKBUILD
+++ b/main/acf-asterisk/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-asterisk
pkgver=0.7.0
pkgrel=2
pkgdesc="A web-based system administration interface for asterisk"
-url="http://git.alpinelinux.org/cgit/acf/acf-asterisk"
+url="https://git.alpinelinux.org/cgit/acf/acf-asterisk"
arch="noarch"
license="GPL2"
depends="acf-core asterisk"
diff --git a/main/acf-awall/APKBUILD b/main/acf-awall/APKBUILD
index b3d4e8223e..cb0dc354dd 100644
--- a/main/acf-awall/APKBUILD
+++ b/main/acf-awall/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-awall
pkgver=0.4.1
pkgrel=2
pkgdesc="ACF for Alpine Wall"
-url="http://git.alpinelinux.org/cgit/acf/acf-awall"
+url="https://git.alpinelinux.org/cgit/acf/acf-awall"
arch="noarch"
license="GPL2"
depends="acf-core awall"
diff --git a/main/acf-chrony/APKBUILD b/main/acf-chrony/APKBUILD
index c75ae6a910..1bb06cb246 100644
--- a/main/acf-chrony/APKBUILD
+++ b/main/acf-chrony/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-chrony
pkgver=0.8.0
pkgrel=2
pkgdesc="A web-based system administration interface for chrony"
-url="http://git.alpinelinux.org/cgit/acf/acf-chrony"
+url="https://git.alpinelinux.org/cgit/acf/acf-chrony"
arch="noarch"
license="GPL2"
depends="acf-core lua-posix chrony"
diff --git a/main/acf-clamav/APKBUILD b/main/acf-clamav/APKBUILD
index a2d9fd7787..4eb56b09d9 100644
--- a/main/acf-clamav/APKBUILD
+++ b/main/acf-clamav/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-clamav
pkgver=0.8.0
pkgrel=2
pkgdesc="A web-based system administration interface for clamav"
-url="http://git.alpinelinux.org/cgit/acf/acf-clamav"
+url="https://git.alpinelinux.org/cgit/acf/acf-clamav"
arch="noarch"
license="GPL2"
depends="acf-core clamav"
diff --git a/main/acf-clamsmtp/APKBUILD b/main/acf-clamsmtp/APKBUILD
index 162d4a7dd5..861404c6bc 100644
--- a/main/acf-clamsmtp/APKBUILD
+++ b/main/acf-clamsmtp/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-clamsmtp
pkgver=0.6.0
pkgrel=2
pkgdesc="A web-based system administration interface for clamsmtp"
-url="http://git.alpinelinux.org/cgit/acf/acf-clamsmtp"
+url="https://git.alpinelinux.org/cgit/acf/acf-clamsmtp"
arch="noarch"
license="GPL2"
depends="acf-core clamsmtp"
diff --git a/main/acf-core/APKBUILD b/main/acf-core/APKBUILD
index 8796ba0713..adc3d6a601 100644
--- a/main/acf-core/APKBUILD
+++ b/main/acf-core/APKBUILD
@@ -5,7 +5,7 @@ pkgname=acf-core
pkgver=0.21.1
pkgrel=0
pkgdesc="A web-based system administration interface framework"
-url="http://git.alpinelinux.org/cgit/acf/acf-core"
+url="https://git.alpinelinux.org/cgit/acf/acf-core"
arch="noarch"
license="GPL2"
install="$pkgname.post-upgrade"
diff --git a/main/acf-dansguardian/APKBUILD b/main/acf-dansguardian/APKBUILD
index 1c1701c031..79b6ef7a8e 100644
--- a/main/acf-dansguardian/APKBUILD
+++ b/main/acf-dansguardian/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-dansguardian
pkgver=0.8.0
pkgrel=2
pkgdesc="A web-based system administration interface for dansguardian"
-url="http://git.alpinelinux.org/cgit/acf/acf-dansguardian"
+url="https://git.alpinelinux.org/cgit/acf/acf-dansguardian"
arch="noarch"
license="GPL2"
depends="acf-core dansguardian"
diff --git a/main/acf-db/APKBUILD b/main/acf-db/APKBUILD
index 7ae516beff..e30448628b 100644
--- a/main/acf-db/APKBUILD
+++ b/main/acf-db/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-db
pkgver=0.2.1
pkgrel=2
pkgdesc="A web-based system administration interface for databases"
-url="http://git.alpinelinux.org/cgit/acf/acf-db"
+url="https://git.alpinelinux.org/cgit/acf/acf-db"
arch="noarch"
license="GPL2"
depends="acf-core acf-db-lib"
diff --git a/main/acf-dhcp/APKBUILD b/main/acf-dhcp/APKBUILD
index 1087ea3e8d..f5e5c76dd2 100644
--- a/main/acf-dhcp/APKBUILD
+++ b/main/acf-dhcp/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-dhcp
pkgver=0.9.1
pkgrel=0
pkgdesc="A web-based system administration interface for dhcp"
-url="http://git.alpinelinux.org/cgit/acf/acf-dhcp"
+url="https://git.alpinelinux.org/cgit/acf/acf-dhcp"
arch="noarch"
license="GPL2"
depends="acf-core dhcp"
diff --git a/main/acf-dnscache/APKBUILD b/main/acf-dnscache/APKBUILD
index 585adebb95..4ebcd14907 100644
--- a/main/acf-dnscache/APKBUILD
+++ b/main/acf-dnscache/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-dnscache
pkgver=0.6.0
pkgrel=2
pkgdesc="A web-based system administration interface for dnscache"
-url="http://git.alpinelinux.org/cgit/acf/acf-dnscache"
+url="https://git.alpinelinux.org/cgit/acf/acf-dnscache"
arch="noarch"
license="GPL2"
depends="acf-core lua-posix dnscache"
diff --git a/main/acf-dnsmasq/APKBUILD b/main/acf-dnsmasq/APKBUILD
index fe1f2430fa..5855945c14 100644
--- a/main/acf-dnsmasq/APKBUILD
+++ b/main/acf-dnsmasq/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-dnsmasq
pkgver=0.7.1
pkgrel=0
pkgdesc="A web-based system administration interface for dnsmasq"
-url="http://git.alpinelinux.org/cgit/acf/acf-dnsmasq"
+url="https://git.alpinelinux.org/cgit/acf/acf-dnsmasq"
arch="noarch"
license="GPL2"
depends="acf-core dnsmasq"
diff --git a/main/acf-dovecot/APKBUILD b/main/acf-dovecot/APKBUILD
index 678a21aab7..b7503e13e9 100644
--- a/main/acf-dovecot/APKBUILD
+++ b/main/acf-dovecot/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-dovecot
pkgver=0.6.0
pkgrel=2
pkgdesc="A web-based system administration interface for dovecot"
-url="http://git.alpinelinux.org/cgit/acf/acf-dovecot"
+url="https://git.alpinelinux.org/cgit/acf/acf-dovecot"
arch="noarch"
license="GPL2"
depends="acf-core dovecot"
diff --git a/main/acf-fetchmail/APKBUILD b/main/acf-fetchmail/APKBUILD
index 9a5f8b168d..54058d5810 100644
--- a/main/acf-fetchmail/APKBUILD
+++ b/main/acf-fetchmail/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-fetchmail
pkgver=0.9.0
pkgrel=2
pkgdesc="A web-based system administration interface for fetchmail"
-url="http://git.alpinelinux.org/cgit/acf/acf-fetchmail"
+url="https://git.alpinelinux.org/cgit/acf/acf-fetchmail"
arch="noarch"
license="GPL2"
depends="acf-core fetchmail"
diff --git a/main/acf-freeradius3/APKBUILD b/main/acf-freeradius3/APKBUILD
index acada38f1f..1821b2e669 100644
--- a/main/acf-freeradius3/APKBUILD
+++ b/main/acf-freeradius3/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-freeradius3
pkgver=0.3.1
pkgrel=0
pkgdesc="ACF for freeradius 3"
-url="http://git.alpinelinux.org/cgit/acf/acf-freeradius3"
+url="https://git.alpinelinux.org/cgit/acf/acf-freeradius3"
arch="noarch"
license="GPL2"
depends="acf-core freeradius>3"
diff --git a/main/acf-freeswitch/APKBUILD b/main/acf-freeswitch/APKBUILD
index 90e70c92fd..0fbe36c367 100644
--- a/main/acf-freeswitch/APKBUILD
+++ b/main/acf-freeswitch/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-freeswitch
pkgver=0.8.0
pkgrel=2
pkgdesc="ACF for freeswitch"
-url="http://git.alpinelinux.org/cgit/acf/acf-freeswitch"
+url="https://git.alpinelinux.org/cgit/acf/acf-freeswitch"
arch="noarch"
license="GPL2"
depends="acf-core freeswitch lua-xml"
diff --git a/main/acf-gross/APKBUILD b/main/acf-gross/APKBUILD
index f695abb6f6..8da0462f09 100644
--- a/main/acf-gross/APKBUILD
+++ b/main/acf-gross/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-gross
pkgver=0.6.0
pkgrel=2
pkgdesc="A web-based system administration interface for gross"
-url="http://git.alpinelinux.org/cgit/acf/acf-gross"
+url="https://git.alpinelinux.org/cgit/acf/acf-gross"
arch="noarch"
license="GPL2"
depends="acf-core gross"
diff --git a/main/acf-ipsec-tools/APKBUILD b/main/acf-ipsec-tools/APKBUILD
index 05fcd4690e..6900a6bf66 100644
--- a/main/acf-ipsec-tools/APKBUILD
+++ b/main/acf-ipsec-tools/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-ipsec-tools
pkgver=0.12.0
pkgrel=2
pkgdesc="A web-based system administration interface for ipsec-tools"
-url="http://git.alpinelinux.org/cgit/acf/acf-ipsec-tools"
+url="https://git.alpinelinux.org/cgit/acf/acf-ipsec-tools"
arch="noarch"
license="GPL2"
depends="acf-core ipsec-tools"
diff --git a/main/acf-iptables/APKBUILD b/main/acf-iptables/APKBUILD
index cb494d60fc..b40a8ceac5 100644
--- a/main/acf-iptables/APKBUILD
+++ b/main/acf-iptables/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-iptables
pkgver=0.7.1
pkgrel=2
pkgdesc="A web-based system administration interface for iptables"
-url="http://git.alpinelinux.org/cgit/acf/acf-iptables"
+url="https://git.alpinelinux.org/cgit/acf/acf-iptables"
arch="noarch"
license="GPL2"
depends="acf-core iptables"
diff --git a/main/acf-jquery/APKBUILD b/main/acf-jquery/APKBUILD
index 7759aeab4a..b33578d1aa 100644
--- a/main/acf-jquery/APKBUILD
+++ b/main/acf-jquery/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-jquery
pkgver=0.4.2
pkgrel=1
pkgdesc="jquery libraries for ACF"
-url="http://git.alpinelinux.org/cgit/acf/acf-jquery"
+url="https://git.alpinelinux.org/cgit/acf/acf-jquery"
arch="noarch"
license="GPL2"
depends=""
diff --git a/main/acf-kamailio/APKBUILD b/main/acf-kamailio/APKBUILD
index 87a847f13e..7361f3e0b8 100644
--- a/main/acf-kamailio/APKBUILD
+++ b/main/acf-kamailio/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-kamailio
pkgver=0.10.0
pkgrel=2
pkgdesc="A web-based system administration interface for kamailio"
-url="http://git.alpinelinux.org/cgit/acf/acf-kamailio"
+url="https://git.alpinelinux.org/cgit/acf/acf-kamailio"
arch="noarch"
license="GPL2"
depends="acf-core kamailio acf-db-lib"
diff --git a/main/acf-lib/APKBUILD b/main/acf-lib/APKBUILD
index a4d6cadef8..0279472631 100644
--- a/main/acf-lib/APKBUILD
+++ b/main/acf-lib/APKBUILD
@@ -5,7 +5,7 @@ pkgname=acf-lib
pkgver=0.10.1
pkgrel=0
pkgdesc="Lua libraries for ACF"
-url="http://git.alpinelinux.org/cgit/acf/acf-lib"
+url="https://git.alpinelinux.org/cgit/acf/acf-lib"
arch="noarch"
license="GPL2"
depends="lua-subprocess"
diff --git a/main/acf-lighttpd/APKBUILD b/main/acf-lighttpd/APKBUILD
index e3fb47560b..726aefb2c0 100644
--- a/main/acf-lighttpd/APKBUILD
+++ b/main/acf-lighttpd/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-lighttpd
pkgver=0.6.0
pkgrel=2
pkgdesc="A web-based system administration interface for lighttpd"
-url="http://git.alpinelinux.org/cgit/acf/acf-lighttpd"
+url="https://git.alpinelinux.org/cgit/acf/acf-lighttpd"
arch="noarch"
license="GPL2"
depends="acf-core lighttpd"
diff --git a/main/acf-nsd/APKBUILD b/main/acf-nsd/APKBUILD
index 78371b15a3..3af0f81256 100644
--- a/main/acf-nsd/APKBUILD
+++ b/main/acf-nsd/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-nsd
pkgver=0.0.1
pkgrel=0
pkgdesc="A web-based system administration interface for nsd"
-url="http://git.alpinelinux.org/cgit/acf/acf-nsd"
+url="https://git.alpinelinux.org/cgit/acf/acf-nsd"
arch="noarch"
license="GPL2"
depends="acf-core nsd"
diff --git a/main/acf-opennhrp/APKBUILD b/main/acf-opennhrp/APKBUILD
index dd537781b8..d0f8b66c13 100644
--- a/main/acf-opennhrp/APKBUILD
+++ b/main/acf-opennhrp/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-opennhrp
pkgver=0.10.0
pkgrel=2
pkgdesc="A web-based system administration interface for opennhrp"
-url="http://git.alpinelinux.org/cgit/acf/acf-opennhrp"
+url="https://git.alpinelinux.org/cgit/acf/acf-opennhrp"
arch="noarch"
license="GPL2"
depends="acf-core lua-posix opennhrp"
diff --git a/main/acf-openntpd/APKBUILD b/main/acf-openntpd/APKBUILD
index 8ccce890fc..eec68c4557 100644
--- a/main/acf-openntpd/APKBUILD
+++ b/main/acf-openntpd/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-openntpd
pkgver=0.9.0
pkgrel=2
pkgdesc="A web-based system administration interface for openntpd"
-url="http://git.alpinelinux.org/cgit/acf/acf-openntpd"
+url="https://git.alpinelinux.org/cgit/acf/acf-openntpd"
arch="noarch"
license="GPL2"
depends="acf-core openntpd"
diff --git a/main/acf-openssh/APKBUILD b/main/acf-openssh/APKBUILD
index b55cecc127..ece979d985 100644
--- a/main/acf-openssh/APKBUILD
+++ b/main/acf-openssh/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-openssh
pkgver=0.11.2
pkgrel=0
pkgdesc="A web-based system administration interface for openssh"
-url="http://git.alpinelinux.org/cgit/acf/acf-openssh"
+url="https://git.alpinelinux.org/cgit/acf/acf-openssh"
arch="noarch"
license="GPL2"
depends="acf-core openssh"
diff --git a/main/acf-openssl/APKBUILD b/main/acf-openssl/APKBUILD
index cfb3a6d679..ba4f542459 100644
--- a/main/acf-openssl/APKBUILD
+++ b/main/acf-openssl/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-openssl
pkgver=0.10.1
pkgrel=3
pkgdesc="A web-based system administration interface for open/librelssl"
-url="http://git.alpinelinux.org/cgit/acf/acf-openssl"
+url="https://git.alpinelinux.org/cgit/acf/acf-openssl"
arch="noarch"
license="GPL2"
depends="acf-core libressl"
diff --git a/main/acf-openvpn/APKBUILD b/main/acf-openvpn/APKBUILD
index e53bf31093..b74081a3a6 100644
--- a/main/acf-openvpn/APKBUILD
+++ b/main/acf-openvpn/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-openvpn
pkgver=0.11.1
pkgrel=2
pkgdesc="A web-based system administration interface for openvpn"
-url="http://git.alpinelinux.org/cgit/acf/acf-openvpn"
+url="https://git.alpinelinux.org/cgit/acf/acf-openvpn"
arch="noarch"
license="GPL2"
depends="acf-core openvpn"
diff --git a/main/acf-pingu/APKBUILD b/main/acf-pingu/APKBUILD
index 53b2e80470..770b2630ef 100644
--- a/main/acf-pingu/APKBUILD
+++ b/main/acf-pingu/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-pingu
pkgver=0.4.0
pkgrel=2
pkgdesc="A web-based system administration interface for pingu"
-url="http://git.alpinelinux.org/cgit/acf/acf-pingu"
+url="https://git.alpinelinux.org/cgit/acf/acf-pingu"
arch="noarch"
license="GPL2"
depends="acf-core pingu"
diff --git a/main/acf-postfix/APKBUILD b/main/acf-postfix/APKBUILD
index 73a3acb9be..701379202a 100644
--- a/main/acf-postfix/APKBUILD
+++ b/main/acf-postfix/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-postfix
pkgver=0.10.0
pkgrel=2
pkgdesc="A web-based system administration interface for postfix"
-url="http://git.alpinelinux.org/cgit/acf/acf-postfix"
+url="https://git.alpinelinux.org/cgit/acf/acf-postfix"
arch="noarch"
license="GPL2"
depends="acf-core postfix"
diff --git a/main/acf-ppp/APKBUILD b/main/acf-ppp/APKBUILD
index d934798cc0..c35fb8f516 100644
--- a/main/acf-ppp/APKBUILD
+++ b/main/acf-ppp/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-ppp
pkgver=0.5.0
pkgrel=2
pkgdesc="A web-based system administration interface for ppp"
-url="http://git.alpinelinux.org/cgit/acf/acf-ppp"
+url="https://git.alpinelinux.org/cgit/acf/acf-ppp"
arch="noarch"
license="GPL2"
depends="acf-core ppp"
diff --git a/main/acf-provisioning/APKBUILD b/main/acf-provisioning/APKBUILD
index ebfb06bd16..ab6eb9a114 100644
--- a/main/acf-provisioning/APKBUILD
+++ b/main/acf-provisioning/APKBUILD
@@ -5,7 +5,7 @@ pkgname=acf-provisioning
pkgver=0.10.1
pkgrel=0
pkgdesc="ACF for provisioning templated configs to devices"
-url="http://git.alpinelinux.org/cgit/acf/acf-provisioning"
+url="https://git.alpinelinux.org/cgit/acf/acf-provisioning"
arch="noarch"
license="GPL2"
depends="acf-core lua-sql-postgres postgresql-client lua-posixtz lua-xml"
diff --git a/main/acf-quagga/APKBUILD b/main/acf-quagga/APKBUILD
index d7151e1844..fd97a88ed3 100644
--- a/main/acf-quagga/APKBUILD
+++ b/main/acf-quagga/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-quagga
pkgver=0.10.1
pkgrel=1
pkgdesc="A web-based system administration interface for quagga"
-url="http://git.alpinelinux.org/cgit/acf/acf-quagga"
+url="https://git.alpinelinux.org/cgit/acf/acf-quagga"
arch="noarch"
license="GPL2"
depends="acf-core lua-socket quagga"
diff --git a/main/acf-samba/APKBUILD b/main/acf-samba/APKBUILD
index 889b0bab86..483cb28183 100644
--- a/main/acf-samba/APKBUILD
+++ b/main/acf-samba/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-samba
pkgver=0.10.0
pkgrel=2
pkgdesc="A web-based system administration interface for samba"
-url="http://git.alpinelinux.org/cgit/acf/acf-samba"
+url="https://git.alpinelinux.org/cgit/acf/acf-samba"
arch="noarch"
license="GPL2"
depends="acf-core samba"
diff --git a/main/acf-skins/APKBUILD b/main/acf-skins/APKBUILD
index d7f7bf0f13..884eb77257 100644
--- a/main/acf-skins/APKBUILD
+++ b/main/acf-skins/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-skins
pkgver=0.6.0
pkgrel=1
pkgdesc="Skins for ACF"
-url="http://git.alpinelinux.org/cgit/acf/acf-skins"
+url="https://git.alpinelinux.org/cgit/acf/acf-skins"
arch="noarch"
license="GPL2"
depends=""
diff --git a/main/acf-snort/APKBUILD b/main/acf-snort/APKBUILD
index 89a7db4e8b..59047cf68b 100644
--- a/main/acf-snort/APKBUILD
+++ b/main/acf-snort/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-snort
pkgver=0.8.0
pkgrel=2
pkgdesc="A web-based system administration interface for snort"
-url="http://git.alpinelinux.org/cgit/acf/acf-snort"
+url="https://git.alpinelinux.org/cgit/acf/acf-snort"
arch="noarch"
license="GPL2"
depends="acf-core snort"
diff --git a/main/acf-squid/APKBUILD b/main/acf-squid/APKBUILD
index 05b6ea0878..f559a9514a 100644
--- a/main/acf-squid/APKBUILD
+++ b/main/acf-squid/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-squid
pkgver=0.11.0
pkgrel=2
pkgdesc="A web-based system administration interface for squid"
-url="http://git.alpinelinux.org/cgit/acf/acf-squid"
+url="https://git.alpinelinux.org/cgit/acf/acf-squid"
arch="noarch"
license="GPL2"
depends="acf-core squid"
diff --git a/main/acf-tcpproxy/APKBUILD b/main/acf-tcpproxy/APKBUILD
index fa74e6e379..9479b21bf9 100644
--- a/main/acf-tcpproxy/APKBUILD
+++ b/main/acf-tcpproxy/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-tcpproxy
pkgver=0.6.0
pkgrel=2
pkgdesc="A web-based system administration interface for tcpproxy"
-url="http://git.alpinelinux.org/cgit/acf/acf-tcpproxy"
+url="https://git.alpinelinux.org/cgit/acf/acf-tcpproxy"
arch="noarch"
license="GPL2"
depends="acf-core tcpproxy"
diff --git a/main/acf-tinydns/APKBUILD b/main/acf-tinydns/APKBUILD
index 76dfcaf51c..d9d7106daa 100644
--- a/main/acf-tinydns/APKBUILD
+++ b/main/acf-tinydns/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-tinydns
pkgver=0.11.0
pkgrel=2
pkgdesc="A web-based system administration interface for tinydns"
-url="http://git.alpinelinux.org/cgit/acf/acf-tinydns"
+url="https://git.alpinelinux.org/cgit/acf/acf-tinydns"
arch="noarch"
license="GPL2"
depends="acf-core tinydns"
diff --git a/main/acf-weblog/APKBUILD b/main/acf-weblog/APKBUILD
index a304da19c9..887586b7ef 100644
--- a/main/acf-weblog/APKBUILD
+++ b/main/acf-weblog/APKBUILD
@@ -4,7 +4,7 @@ pkgname=acf-weblog
pkgver=0.11.1
pkgrel=1
pkgdesc="ACF for web proxy (squid and dansguardian) logfiles"
-url="http://git.alpinelinux.org/cgit/acf/acf-weblog"
+url="https://git.alpinelinux.org/cgit/acf/acf-weblog"
arch="noarch"
license="GPL2"
depends="acf-core lua-sql-postgres wget postgresql-client lua-subprocess"
diff --git a/main/aconf/APKBUILD b/main/aconf/APKBUILD
index 8dd50c3d2c..1a0065cdb1 100644
--- a/main/aconf/APKBUILD
+++ b/main/aconf/APKBUILD
@@ -4,7 +4,7 @@ pkgname=aconf
pkgver=0.6.5
pkgrel=0
pkgdesc="Alpine Configurator"
-url="http://git.alpinelinux.org/cgit/user/kunkku/aconf/"
+url="https://git.alpinelinux.org/cgit/user/kunkku/aconf/"
arch="noarch"
license="BSD"
depends="lua5.2-augeas lua5.2-b64 lua5.2-cjson lua5.2-crypto \
diff --git a/main/acpi/APKBUILD b/main/acpi/APKBUILD
index a74113db24..e8eb918b38 100644
--- a/main/acpi/APKBUILD
+++ b/main/acpi/APKBUILD
@@ -3,7 +3,7 @@ pkgname=acpi
pkgver=1.7
pkgrel=2
pkgdesc="ACPI client for battery, power, and thermal readings"
-url="http://sourceforge.net/projects/acpiclient/files/acpiclient/"
+url="https://sourceforge.net/projects/acpiclient/files/acpiclient/"
arch="all"
license="GPL2"
depends=
diff --git a/main/alpine-baselayout/APKBUILD b/main/alpine-baselayout/APKBUILD
index 46019b235b..48c994705e 100644
--- a/main/alpine-baselayout/APKBUILD
+++ b/main/alpine-baselayout/APKBUILD
@@ -4,7 +4,7 @@ pkgname=alpine-baselayout
pkgver=3.0.5
pkgrel=2
pkgdesc="Alpine base dir structure and init scripts"
-url="http://git.alpinelinux.org/cgit/aports/tree/main/alpine-baselayout"
+url="https://git.alpinelinux.org/cgit/aports/tree/main/alpine-baselayout"
arch="all"
license="GPL2"
pkggroups="shadow"
diff --git a/main/alpine-mirrors/APKBUILD b/main/alpine-mirrors/APKBUILD
index 61a75c56ed..50b3dd2838 100644
--- a/main/alpine-mirrors/APKBUILD
+++ b/main/alpine-mirrors/APKBUILD
@@ -4,7 +4,7 @@ pkgname=alpine-mirrors
pkgver=3.5.5
pkgrel=0
pkgdesc="List of Alpine Linux Mirrors"
-url="http://alpinelinux.org/"
+url="https://alpinelinux.org/"
arch="noarch"
license="MIT"
depends=""
diff --git a/main/apache-mod-auth-kerb/APKBUILD b/main/apache-mod-auth-kerb/APKBUILD
index ce1aea3cd6..e1eb78eeec 100644
--- a/main/apache-mod-auth-kerb/APKBUILD
+++ b/main/apache-mod-auth-kerb/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=mod_auth_kerb
pkgver=5.4
pkgrel=4
pkgdesc="A Kerberos authentication module for the Apache Http Server"
-url="http://sourceforge.net/projects/modauthkerb/"
+url="https://sourceforge.net/projects/modauthkerb/"
arch="all"
license="BSD MIT"
depends="apache2 heimdal"
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index fb5a6c95c3..0614a317cf 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -15,7 +15,7 @@ fi
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
"
-url="http://git.alpinelinux.org/cgit/apk-tools/"
+url="https://git.alpinelinux.org/cgit/apk-tools/"
arch="all"
license=GPL2
diff --git a/main/appstream-glib/APKBUILD b/main/appstream-glib/APKBUILD
index 8fe4bcc1e2..74a70bb75e 100644
--- a/main/appstream-glib/APKBUILD
+++ b/main/appstream-glib/APKBUILD
@@ -3,7 +3,7 @@ pkgname=appstream-glib
pkgver=0.6.3
pkgrel=0
pkgdesc="Library for AppStream metadata"
-url="http://people.freedesktop.org/~hughsient/appstream-glib/"
+url="https://people.freedesktop.org/~hughsient/appstream-glib/"
arch="all"
license="LGPLv2+"
depends=""
@@ -13,7 +13,7 @@ makedepends="$depends_dev fontconfig-dev freetype-dev pango-dev sqlite-dev
gtk+3.0-dev json-glib-dev libgcab-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-builder"
-source="http://people.freedesktop.org/~hughsient/appstream-glib/releases/appstream-glib-$pkgver.tar.xz"
+source="https://people.freedesktop.org/~hughsient/appstream-glib/releases/appstream-glib-$pkgver.tar.xz"
_builddir="$srcdir"/appstream-glib-$pkgver
prepare() {
diff --git a/main/atk/APKBUILD b/main/atk/APKBUILD
index 72de975a8e..9e2aab44a7 100644
--- a/main/atk/APKBUILD
+++ b/main/atk/APKBUILD
@@ -3,7 +3,7 @@ pkgname=atk
pkgver=2.26.1
pkgrel=1
pkgdesc="A library providing a set of interfaces for accessibility"
-url="http://www.gtk.org/"
+url="https://www.gtk.org/"
arch="all"
license="LGPL2+"
depends=""
diff --git a/main/atop/APKBUILD b/main/atop/APKBUILD
index 69643615c4..0a75b5ebfe 100644
--- a/main/atop/APKBUILD
+++ b/main/atop/APKBUILD
@@ -3,13 +3,13 @@ pkgname=atop
pkgver=2.3.0
pkgrel=1
pkgdesc="Resource-specific view of processes"
-url="http://www.atoptool.nl/"
+url="https://www.atoptool.nl/"
arch="all"
license="GPL2+"
depends=""
makedepends="zlib-dev ncurses-dev linux-headers"
subpackages="$pkgname-doc"
-source="http://www.atoptool.nl/download/atop-$pkgver.tar.gz
+source="https://www.atoptool.nl/download/atop-$pkgver.tar.gz
atop-bb-compat.patch
atop-daily-bb.patch
atop.initd"
diff --git a/main/autoconf/APKBUILD b/main/autoconf/APKBUILD
index 3883f7b87e..e1e557365f 100644
--- a/main/autoconf/APKBUILD
+++ b/main/autoconf/APKBUILD
@@ -5,7 +5,7 @@ pkgrel=0
pkgdesc="A GNU tool for automatically configuring source code"
arch="noarch"
license="GPL2+"
-url="http://www.gnu.org/software/autoconf"
+url="https://www.gnu.org/software/autoconf"
depends="m4 perl"
subpackages="$pkgname-doc"
source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
diff --git a/main/automake/APKBUILD b/main/automake/APKBUILD
index 3debe683cd..daca451975 100644
--- a/main/automake/APKBUILD
+++ b/main/automake/APKBUILD
@@ -3,7 +3,7 @@ pkgname=automake
pkgver=1.15.1
pkgrel=0
pkgdesc="A GNU tool for automatically creating Makefiles"
-url="http://www.gnu.org/software/automake"
+url="https://www.gnu.org/software/automake"
arch="noarch"
license="GPL2+ MIT Public Domain"
depends="perl"
diff --git a/main/awall/APKBUILD b/main/awall/APKBUILD
index 6c1f969837..b871a984ac 100644
--- a/main/awall/APKBUILD
+++ b/main/awall/APKBUILD
@@ -4,7 +4,7 @@ pkgname=awall
pkgver=1.5.0
pkgrel=0
pkgdesc="Alpine Wall"
-url="http://git.alpinelinux.org/cgit/awall/"
+url="https://git.alpinelinux.org/cgit/awall/"
_luaver=5.2
arch="noarch"
license="GPL2"
diff --git a/main/bash/APKBUILD b/main/bash/APKBUILD
index 16b3c716ac..7e9de29abe 100644
--- a/main/bash/APKBUILD
+++ b/main/bash/APKBUILD
@@ -8,7 +8,7 @@ _myver=${pkgver%.*}
_patchbase=${_myver/./}
pkgrel=1
pkgdesc="The GNU Bourne Again shell"
-url="http://www.gnu.org/software/bash/bash.html"
+url="https://www.gnu.org/software/bash/bash.html"
arch="all"
license="GPL3+"
makedepends_build="bison flex"
diff --git a/main/bbsuid/APKBUILD b/main/bbsuid/APKBUILD
index 76a4f869a3..d5f3d58849 100644
--- a/main/bbsuid/APKBUILD
+++ b/main/bbsuid/APKBUILD
@@ -3,7 +3,7 @@ pkgname=bbsuid
pkgver=0.6
pkgrel=0
pkgdesc="Obsolete package that can be removed"
-url="http://git.alpinelinux.org/cgit/bbsuid"
+url="https://git.alpinelinux.org/cgit/bbsuid"
arch="all"
license="GPL2"
depends="busybox"
diff --git a/main/bcache-tools/APKBUILD b/main/bcache-tools/APKBUILD
index 6d4bad4ef9..793f8e70ae 100644
--- a/main/bcache-tools/APKBUILD
+++ b/main/bcache-tools/APKBUILD
@@ -3,7 +3,7 @@ pkgname=bcache-tools
pkgver=1.0.8
pkgrel=1
pkgdesc="tools for managing bcache"
-url="http://bcache.evilpiepirate.org/"
+url="https://bcache.evilpiepirate.org/"
arch="all"
license="GPL"
depends=""
diff --git a/main/binutils/APKBUILD b/main/binutils/APKBUILD
index c37df17080..e1cfd6df41 100644
--- a/main/binutils/APKBUILD
+++ b/main/binutils/APKBUILD
@@ -3,7 +3,7 @@ pkgname=binutils
pkgver=2.28
pkgrel=3
pkgdesc="Tools necessary to build programs"
-url="http://www.gnu.org/software/binutils/"
+url="https://www.gnu.org/software/binutils/"
depends=""
makedepends_build="bison flex texinfo"
makedepends_host="zlib-dev"
diff --git a/main/bison/APKBUILD b/main/bison/APKBUILD
index 103ba2a94d..6a1485534b 100644
--- a/main/bison/APKBUILD
+++ b/main/bison/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="The GNU general-purpose parser generator"
arch="all"
license="GPL3+"
-url="http://www.gnu.org/software/bison/bison.html"
+url="https://www.gnu.org/software/bison/bison.html"
makedepends="perl"
depends="m4"
source="ftp://ftp.gnu.org/gnu/bison/${pkgname}-${pkgver}.tar.xz"
diff --git a/main/bitlbee/APKBUILD b/main/bitlbee/APKBUILD
index 9ae31f1edc..a6e49d035b 100644
--- a/main/bitlbee/APKBUILD
+++ b/main/bitlbee/APKBUILD
@@ -4,7 +4,7 @@ pkgname=bitlbee
pkgver=3.5.1
pkgrel=1
pkgdesc="An IRC to other chat networks gateway"
-url="http://www.bitlbee.org/"
+url="https://www.bitlbee.org/"
arch="all"
license="GPL2"
makedepends="glib-dev libressl-dev libotr-dev"
diff --git a/main/brlaser/APKBUILD b/main/brlaser/APKBUILD
index fd2eb82262..a60ec8247d 100644
--- a/main/brlaser/APKBUILD
+++ b/main/brlaser/APKBUILD
@@ -4,7 +4,7 @@ pkgname=brlaser
pkgver=3
pkgrel=0
pkgdesc="Driver for Brother printers like the DCP 7030 and DCP 7065"
-url="http://github.com/pdewacht/brlaser"
+url="https://github.com/pdewacht/brlaser"
arch="all"
license="GPL2+"
depends="cups-filters"
diff --git a/main/busybox-initscripts/APKBUILD b/main/busybox-initscripts/APKBUILD
index 033d428b3c..c7be784450 100644
--- a/main/busybox-initscripts/APKBUILD
+++ b/main/busybox-initscripts/APKBUILD
@@ -4,7 +4,7 @@ pkgname=busybox-initscripts
pkgver=3.1
pkgrel=2
pkgdesc="Init scripts for busybox daemons"
-url="http://git.alpinelinux.org/cgit/aports/tree/core/busybox-initscripts"
+url="https://git.alpinelinux.org/cgit/aports/tree/core/busybox-initscripts"
arch="noarch"
license="GPL2"
depends="busybox openrc"
diff --git a/main/c-ares/APKBUILD b/main/c-ares/APKBUILD
index 3c9a518167..50f3f0033d 100644
--- a/main/c-ares/APKBUILD
+++ b/main/c-ares/APKBUILD
@@ -4,13 +4,13 @@ pkgname=c-ares
pkgver=1.13.0
pkgrel=0
pkgdesc="An asynchronously DNS/names resolver library"
-url="http://c-ares.haxx.se/"
+url="https://c-ares.haxx.se/"
arch="all"
license="MIT"
depends=""
makedepends=""
subpackages="$pkgname-doc $pkgname-dev"
-source="http://c-ares.haxx.se/download/$pkgname-$pkgver.tar.gz"
+source="https://c-ares.haxx.se/download/$pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
diff --git a/main/cabextract/APKBUILD b/main/cabextract/APKBUILD
index e2c9032d74..5b98c47e43 100644
--- a/main/cabextract/APKBUILD
+++ b/main/cabextract/APKBUILD
@@ -3,12 +3,12 @@ pkgname=cabextract
pkgver=1.6
pkgrel=1
pkgdesc="Tool for extracting Microsoft cabinet files"
-url="http://www.cabextract.org.uk/"
+url="https://www.cabextract.org.uk/"
arch="all"
license="GPL2+"
subpackages="$pkgname-doc"
makedepends="libmspack-dev"
-source="http://www.cabextract.org.uk/$pkgname-$pkgver.tar.gz"
+source="https://www.cabextract.org.uk/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/${pkgname}-${pkgver}
build () {
diff --git a/main/cgit/APKBUILD b/main/cgit/APKBUILD
index 89eb946861..b405837f92 100644
--- a/main/cgit/APKBUILD
+++ b/main/cgit/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.1
pkgrel=2
_gitver=2.10.2
pkgdesc="A fast webinterface for git"
-url="http://git.zx2c4.com/cgit/"
+url="https://git.zx2c4.com/cgit/"
arch="all"
license="GPL2"
makedepends="libressl-dev zlib-dev lua5.3-dev asciidoc"
diff --git a/main/checkbashisms/APKBUILD b/main/checkbashisms/APKBUILD
index 0be0b580e9..fb65583cb2 100644
--- a/main/checkbashisms/APKBUILD
+++ b/main/checkbashisms/APKBUILD
@@ -3,7 +3,7 @@ pkgname=checkbashisms
pkgver=2.0.0.2
pkgrel=5
pkgdesc="Basic checks on shell scripts for the presence of non portable syntax"
-url="http://sourceforge.net/projects/checkbaskisms/"
+url="https://sourceforge.net/projects/checkbaskisms/"
arch="noarch"
license="GPL2"
depends="perl"
diff --git a/main/cifs-utils/APKBUILD b/main/cifs-utils/APKBUILD
index 7afbbada18..a25f246b6e 100644
--- a/main/cifs-utils/APKBUILD
+++ b/main/cifs-utils/APKBUILD
@@ -4,7 +4,7 @@ pkgname=cifs-utils
pkgver=6.7
pkgrel=1
pkgdesc="CIFS filesystem user-space tools"
-url="http://wiki.samba.org/index.php/LinuxCIFS_utils"
+url="https://wiki.samba.org/index.php/LinuxCIFS_utils"
arch="all"
license="GPL2+"
makedepends="libcap-dev keyutils-dev krb5-dev talloc-dev
diff --git a/main/compat-pvgrub/APKBUILD b/main/compat-pvgrub/APKBUILD
index cacee3a72f..b07eedbc0d 100644
--- a/main/compat-pvgrub/APKBUILD
+++ b/main/compat-pvgrub/APKBUILD
@@ -4,7 +4,7 @@ pkgname=compat-pvgrub
pkgver=1
pkgrel=0
pkgdesc="compatibility support for PV-GRUB 1.x"
-url="http://www.alpinelinux.org/"
+url="https://www.alpinelinux.org/"
arch="noarch"
license="ISC"
depends=""
diff --git a/main/coreutils/APKBUILD b/main/coreutils/APKBUILD
index 581f33b18c..22976d5159 100644
--- a/main/coreutils/APKBUILD
+++ b/main/coreutils/APKBUILD
@@ -5,7 +5,7 @@ pkgname=coreutils
pkgver=8.28
pkgrel=0
pkgdesc="The basic file, shell and text manipulation utilities"
-url="http://www.gnu.org/software/coreutils/"
+url="https://www.gnu.org/software/coreutils/"
arch="all"
license="GPL3+"
makedepends="bash acl-dev perl"
diff --git a/main/cpufreqd/APKBUILD b/main/cpufreqd/APKBUILD
index 0004c98593..1fe3792c2f 100644
--- a/main/cpufreqd/APKBUILD
+++ b/main/cpufreqd/APKBUILD
@@ -3,7 +3,7 @@ pkgname=cpufreqd
pkgver=2.4.2
pkgrel=4
pkgdesc="A small daemon to adjust cpu speed (and indeed voltage)"
-url="http://sourceforge.net/projects/cpufreqd"
+url="https://sourceforge.net/projects/cpufreqd"
arch="all"
license="GPL2+"
subpackages="$pkgname-doc"
diff --git a/main/cpufrequtils/APKBUILD b/main/cpufrequtils/APKBUILD
index b98721f9db..2a2843030c 100644
--- a/main/cpufrequtils/APKBUILD
+++ b/main/cpufrequtils/APKBUILD
@@ -3,7 +3,7 @@ pkgname=cpufrequtils
pkgver=008
pkgrel=4
pkgdesc="Userspace tools for the kernel cpufreq subsystem"
-url="http://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils.html"
+url="https://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils.html"
arch="all"
license="GPL2"
subpackages="$pkgname-dev $pkgname-doc"
diff --git a/main/cracklib-words/APKBUILD b/main/cracklib-words/APKBUILD
index 9fee570b9f..76b6858c6c 100644
--- a/main/cracklib-words/APKBUILD
+++ b/main/cracklib-words/APKBUILD
@@ -4,7 +4,7 @@ pkgname=cracklib-words
pkgver=20080507
pkgrel=2
pkgdesc="Large list of words for crack/craclib"
-url="http://sourceforge.net/projects/cracklib"
+url="https://sourceforge.net/projects/cracklib"
arch="noarch"
license="LGPL2+"
depends=""
diff --git a/main/cracklib/APKBUILD b/main/cracklib/APKBUILD
index bded402e8c..5af7e9571a 100644
--- a/main/cracklib/APKBUILD
+++ b/main/cracklib/APKBUILD
@@ -4,7 +4,7 @@ pkgname=cracklib
pkgver=2.9.6
pkgrel=0
pkgdesc="A library used to enforce strong passwords"
-url="http://sourceforge.net/projects/cracklib"
+url="https://sourceforge.net/projects/cracklib"
arch="all"
license="LGPL2+"
depends=""
diff --git a/main/cramfs/APKBUILD b/main/cramfs/APKBUILD
index e6aeb2802a..227e05468e 100644
--- a/main/cramfs/APKBUILD
+++ b/main/cramfs/APKBUILD
@@ -4,7 +4,7 @@ pkgver=1.1
pkgrel=2
pkgdesc="Linux filesystem designed to be simple, small, and to compress things well"
arch="all"
-url="http://sourceforge.net/projects/cramfs/"
+url="https://sourceforge.net/projects/cramfs/"
license='GPL'
depends=
makedepends="zlib-dev linux-headers"
diff --git a/main/crconf/APKBUILD b/main/crconf/APKBUILD
index 71519bc871..adb8611826 100644
--- a/main/crconf/APKBUILD
+++ b/main/crconf/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0_pre2
_realver=pre2
pkgrel=0
pkgdesc="Linux crypto layer configuration tool"
-url="http://sourceforge.net/projects/crconf/"
+url="https://sourceforge.net/projects/crconf/"
arch="all"
license="GPLv2"
depends=""
diff --git a/main/cups/APKBUILD b/main/cups/APKBUILD
index cf082e9fa6..e6ea7c5d10 100644
--- a/main/cups/APKBUILD
+++ b/main/cups/APKBUILD
@@ -3,7 +3,7 @@ pkgname=cups
pkgver=2.2.5
pkgrel=0
pkgdesc="The CUPS Printing System"
-url="http://www.cups.org/"
+url="https://www.cups.org/"
arch="all"
license="GPL LGPL2+"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs ipptool $pkgname-client
diff --git a/main/daq/APKBUILD b/main/daq/APKBUILD
index 842b664ced..ea8e020db5 100644
--- a/main/daq/APKBUILD
+++ b/main/daq/APKBUILD
@@ -4,7 +4,7 @@ pkgname=daq
pkgver=2.0.6
pkgrel=2
pkgdesc="Data Acquisition library - packet I/O library"
-url="http://www.snort.org/"
+url="https://www.snort.org/"
arch="all"
license="GPL2"
depends=
diff --git a/main/darkhttpd/APKBUILD b/main/darkhttpd/APKBUILD
index 8eaa5ff3f2..8e060f7724 100644
--- a/main/darkhttpd/APKBUILD
+++ b/main/darkhttpd/APKBUILD
@@ -4,11 +4,11 @@ pkgname=darkhttpd
pkgver=1.12
pkgrel=1
pkgdesc="A simple, single-threaded, static content webserver"
-url="http://unix4lyfe.org/darkhttpd/"
+url="https://unix4lyfe.org/darkhttpd/"
arch="all"
license="BSD"
install="$pkgname.pre-install"
-source="http://unix4lyfe.org/darkhttpd/darkhttpd-$pkgver.tar.bz2
+source="https://unix4lyfe.org/darkhttpd/darkhttpd-$pkgver.tar.bz2
darkhttpd.logrotate
$pkgname.initd"
builddir="$srcdir/$pkgname-$pkgver"
diff --git a/main/db/APKBUILD b/main/db/APKBUILD
index 0b122644a3..e450562b3f 100644
--- a/main/db/APKBUILD
+++ b/main/db/APKBUILD
@@ -4,7 +4,7 @@ pkgver=5.3.28
_ver=${pkgver}
pkgrel=0
pkgdesc="The Berkeley DB embedded database system"
-url="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
+url="https://www.oracle.com/technology/software/products/berkeley-db/index.html"
arch="all"
license="custom"
options="!check" # "check target not available"
diff --git a/main/debootstrap/APKBUILD b/main/debootstrap/APKBUILD
index 2bc2a1b003..d1f161923f 100644
--- a/main/debootstrap/APKBUILD
+++ b/main/debootstrap/APKBUILD
@@ -4,7 +4,7 @@ pkgname=debootstrap
pkgver=1.0.92
pkgrel=0
pkgdesc="Debian/Ubuntu bootstrap scripts"
-url="http://packages.qa.debian.org/d/debootstrap.html"
+url="https://packages.qa.debian.org/d/debootstrap.html"
arch="noarch"
license="GPL2"
depends="debian-archive-keyring dpkg tar"
diff --git a/main/dhcpcd-dbus/APKBUILD b/main/dhcpcd-dbus/APKBUILD
index 2efc817b7a..c22d53b2ce 100644
--- a/main/dhcpcd-dbus/APKBUILD
+++ b/main/dhcpcd-dbus/APKBUILD
@@ -4,7 +4,7 @@ pkgname=dhcpcd-dbus
pkgver=0.6.1
pkgrel=3
pkgdesc="DBUS binding to dhcpcd"
-url="http://roy.marples.name/projects/dhcpcd-dbus"
+url="https://roy.marples.name/projects/dhcpcd-dbus"
arch="all"
license="BSD"
depends="dbus"
diff --git a/main/dhcpcd-ui/APKBUILD b/main/dhcpcd-ui/APKBUILD
index 3183e5a7d5..445382bd58 100644
--- a/main/dhcpcd-ui/APKBUILD
+++ b/main/dhcpcd-ui/APKBUILD
@@ -3,7 +3,7 @@ pkgname=dhcpcd-ui
pkgver=0.7.5
pkgrel=1
pkgdesc="A GTK+ monitor and configuration GUI for dhcpcd"
-url="http://roy.marples.name/projects/dhcpcd-ui"
+url="https://roy.marples.name/projects/dhcpcd-ui"
arch="all"
license="BSD-2"
depends="dhcpcd-dbus hicolor-icon-theme"
diff --git a/main/dhcpcd/APKBUILD b/main/dhcpcd/APKBUILD
index b18001934c..65db52da6c 100644
--- a/main/dhcpcd/APKBUILD
+++ b/main/dhcpcd/APKBUILD
@@ -5,7 +5,7 @@ pkgname=dhcpcd
pkgver=6.11.5
pkgrel=1
pkgdesc="RFC2131 compliant DHCP client"
-url="http://roy.marples.name/projects/dhcpcd/"
+url="https://roy.marples.name/projects/dhcpcd/"
arch="all"
license="BSD-2"
depends=""
diff --git a/main/diffutils/APKBUILD b/main/diffutils/APKBUILD
index 889844a6dd..042f5136e6 100644
--- a/main/diffutils/APKBUILD
+++ b/main/diffutils/APKBUILD
@@ -4,7 +4,7 @@ pkgver=3.6
pkgrel=0
pkgdesc="Show differences among files"
subpackages="$pkgname-doc"
-url="http://www.gnu.org/software/diffutils/"
+url="https://www.gnu.org/software/diffutils/"
arch="all"
license="GPL3+"
options="!check"
diff --git a/main/dmenu/APKBUILD b/main/dmenu/APKBUILD
index 959e2adec6..89d9e6277a 100644
--- a/main/dmenu/APKBUILD
+++ b/main/dmenu/APKBUILD
@@ -4,7 +4,7 @@ pkgname=dmenu
pkgver=4.7
pkgrel=0
pkgdesc="Dynamic menu for X"
-url="http://tools.suckless.org/dmenu/"
+url="https://tools.suckless.org/dmenu/"
arch="all"
license="MIT"
depends=""
diff --git a/main/ethtool/APKBUILD b/main/ethtool/APKBUILD
index be277b8492..24f005bb64 100644
--- a/main/ethtool/APKBUILD
+++ b/main/ethtool/APKBUILD
@@ -3,7 +3,7 @@ pkgname=ethtool
pkgver=4.13
pkgrel=0
pkgdesc="gkernel ethtool"
-url="http://sourceforge.net/projects/gkernel/"
+url="https://sourceforge.net/projects/gkernel/"
arch="all"
license="GPL2"
makedepends="linux-headers"
diff --git a/main/feh/APKBUILD b/main/feh/APKBUILD
index bcc01f2b5f..d90b74a4a5 100644
--- a/main/feh/APKBUILD
+++ b/main/feh/APKBUILD
@@ -3,7 +3,7 @@ pkgname=feh
pkgver=2.22
pkgrel=0
pkgdesc="feh is a fast, lightweight image viewer which uses imlib2"
-url="http://feh.finalrewind.org/"
+url="https://feh.finalrewind.org/"
arch="all"
license="MIT"
subpackages="$pkgname-doc"
diff --git a/main/findutils/APKBUILD b/main/findutils/APKBUILD
index f6fe091738..5b28dd6e83 100644
--- a/main/findutils/APKBUILD
+++ b/main/findutils/APKBUILD
@@ -5,7 +5,7 @@ pkgname=findutils
pkgver=4.6.0
pkgrel=0
pkgdesc="GNU utilities for finding files"
-url="http://www.gnu.org/software/findutils/"
+url="https://www.gnu.org/software/findutils/"
arch="all"
license="GPL"
depends=""
diff --git a/main/flashrom/APKBUILD b/main/flashrom/APKBUILD
index 11ca78f2de..5428659621 100644
--- a/main/flashrom/APKBUILD
+++ b/main/flashrom/APKBUILD
@@ -4,7 +4,7 @@ pkgname=flashrom
pkgver=0.9.9
pkgrel=2
pkgdesc="A utility for identifying, reading, writing, verifying and erasing flash chips"
-url="http://www.flashrom.org/Flashrom"
+url="https://www.flashrom.org/Flashrom"
arch="all"
license="GPL"
depends=dmidecode
diff --git a/main/garcon/APKBUILD b/main/garcon/APKBUILD
index bb7883c22c..1f4fdb54a1 100644
--- a/main/garcon/APKBUILD
+++ b/main/garcon/APKBUILD
@@ -3,7 +3,7 @@ pkgname=garcon
pkgver=0.6.1
pkgrel=1
pkgdesc="a freedesktop.org compliant menu implementation based on GLib and GIO"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
diff --git a/main/gawk/APKBUILD b/main/gawk/APKBUILD
index e01155fb82..6e8451babe 100644
--- a/main/gawk/APKBUILD
+++ b/main/gawk/APKBUILD
@@ -6,7 +6,7 @@ pkgname=gawk
pkgver=4.2.0
pkgrel=0
pkgdesc="GNU awk pattern-matching language"
-url="http://www.gnu.org/software/gawk/gawk.html"
+url="https://www.gnu.org/software/gawk/gawk.html"
arch="all"
license="GPL"
subpackages="$pkgname-doc"
diff --git a/main/gdbm/APKBUILD b/main/gdbm/APKBUILD
index e5f4b02734..9df6c95918 100644
--- a/main/gdbm/APKBUILD
+++ b/main/gdbm/APKBUILD
@@ -4,7 +4,7 @@ pkgname=gdbm
pkgver=1.13
pkgrel=1
pkgdesc="GNU dbm is a set of database routines that use extensible hashing"
-url="http://www.gnu.org/software/gdbm/"
+url="https://www.gnu.org/software/gdbm/"
arch="all"
license="GPL"
depends=""
diff --git a/main/gdk-pixbuf/APKBUILD b/main/gdk-pixbuf/APKBUILD
index b926f9f27a..7263e0fb8c 100644
--- a/main/gdk-pixbuf/APKBUILD
+++ b/main/gdk-pixbuf/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gdk-pixbuf
pkgver=2.36.10
pkgrel=0
pkgdesc="GDK Pixbuf library"
-url="http://www.gtk.org/"
+url="https://www.gtk.org/"
arch="all"
license="LGPL"
depends="shared-mime-info"
diff --git a/main/gdl/APKBUILD b/main/gdl/APKBUILD
index ebf8c83f1d..c0b89ce8b8 100644
--- a/main/gdl/APKBUILD
+++ b/main/gdl/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gdl
pkgver=3.22.0
pkgrel=0
pkgdesc="Gnome Devtool Libraries"
-url="http://www.gnome.org/"
+url="https://www.gnome.org/"
arch="all"
license="GPL"
makedepends="gtk+3.0-dev libxml2-dev intltool"
diff --git a/main/gengetopt/APKBUILD b/main/gengetopt/APKBUILD
index 6d07e1c426..da6b4a47cd 100644
--- a/main/gengetopt/APKBUILD
+++ b/main/gengetopt/APKBUILD
@@ -4,7 +4,7 @@ pkgname=gengetopt
pkgver=2.22.6
pkgrel=2
pkgdesc="Tool to write command line option parsing code for C programs"
-url="http://www.gnu.org/software/gengetopt/"
+url="https://www.gnu.org/software/gengetopt/"
arch="all"
license="GPLv3+"
depends=""
diff --git a/main/gettext/APKBUILD b/main/gettext/APKBUILD
index 3eeeaa53e1..b03c204938 100644
--- a/main/gettext/APKBUILD
+++ b/main/gettext/APKBUILD
@@ -4,7 +4,7 @@ pkgname=gettext
pkgver=0.19.8.1
pkgrel=1
pkgdesc="GNU locale utilities"
-url="http://www.gnu.org/software/gettext/gettext.html"
+url="https://www.gnu.org/software/gettext/gettext.html"
arch="all"
license="GPL"
depends=
diff --git a/main/ghostscript/APKBUILD b/main/ghostscript/APKBUILD
index 6bd4f341ba..bb21ac723b 100644
--- a/main/ghostscript/APKBUILD
+++ b/main/ghostscript/APKBUILD
@@ -4,7 +4,7 @@ pkgname=ghostscript
pkgver=9.22
pkgrel=0
pkgdesc="An interpreter for the PostScript language and for PDF"
-url="http://ghostscript.com/"
+url="https://ghostscript.com/"
arch="all"
license="GPL3"
makedepends="autoconf automake libjpeg-turbo-dev libpng-dev jasper-dev expat-dev
diff --git a/main/giflib/APKBUILD b/main/giflib/APKBUILD
index 34b5b620c4..83d4f34340 100644
--- a/main/giflib/APKBUILD
+++ b/main/giflib/APKBUILD
@@ -3,7 +3,7 @@ pkgname=giflib
pkgver=5.1.4
pkgrel=1
pkgdesc="A library for reading and writing gif images"
-url="http://sourceforge.net/projects/giflib/"
+url="https://sourceforge.net/projects/giflib/"
arch="all"
license="MIT"
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
diff --git a/main/gitolite/APKBUILD b/main/gitolite/APKBUILD
index 3a4290a367..9fb22bf5d4 100644
--- a/main/gitolite/APKBUILD
+++ b/main/gitolite/APKBUILD
@@ -5,7 +5,7 @@ pkgname=gitolite
pkgver=3.6.7
pkgrel=0
pkgdesc="Centralized git server, with very fine-grained access control and many powerful features"
-url="http://github.com/sitaramc/gitolite"
+url="https://github.com/sitaramc/gitolite"
arch="noarch"
license="GPL2"
depends="git perl"
diff --git a/main/glade/APKBUILD b/main/glade/APKBUILD
index 06718d02b9..0069629ff3 100644
--- a/main/glade/APKBUILD
+++ b/main/glade/APKBUILD
@@ -3,7 +3,7 @@ pkgname=glade
pkgver=3.20.1
pkgrel=0
pkgdesc="User Interface Designer for GTK+ and GNOME"
-url="http://glade.gnome.org/"
+url="https://glade.gnome.org/"
arch="all"
license="GPL"
depends=
diff --git a/main/glade3/APKBUILD b/main/glade3/APKBUILD
index 8e062d22b8..0945406dd1 100644
--- a/main/glade3/APKBUILD
+++ b/main/glade3/APKBUILD
@@ -3,7 +3,7 @@ pkgname=glade3
pkgver=3.8.5
pkgrel=4
pkgdesc="a RAD tool to enable quick & easy development of user interfaces for GTK+"
-url="http://glade.gnome.org/"
+url="https://glade.gnome.org/"
arch="all"
license="GPL"
depends=
diff --git a/main/glu/APKBUILD b/main/glu/APKBUILD
index 3b413df171..d01d350119 100644
--- a/main/glu/APKBUILD
+++ b/main/glu/APKBUILD
@@ -3,7 +3,7 @@ pkgname=glu
pkgver=9.0.0
pkgrel=3
pkgdesc="Mesa OpenGL Utility library"
-url="http://cgit.freedesktop.org/mesa/glu/"
+url="https://cgit.freedesktop.org/mesa/glu/"
arch="all"
license="LGPL"
depends=""
diff --git a/main/gmp/APKBUILD b/main/gmp/APKBUILD
index bf5e057226..4f880f70a5 100644
--- a/main/gmp/APKBUILD
+++ b/main/gmp/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gmp
pkgver=6.1.2
pkgrel=1
pkgdesc="A free library for arbitrary precision arithmetic"
-url="http://gmplib.org/"
+url="https://gmplib.org/"
arch="all"
license="LGPL3"
makedepends="m4 texinfo libtool"
diff --git a/main/gnats/APKBUILD b/main/gnats/APKBUILD
index 25a4908c60..4d1692236b 100644
--- a/main/gnats/APKBUILD
+++ b/main/gnats/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gnats
pkgver=4.2.0
pkgrel=3
pkgdesc="The GNU Bug Tracking System"
-url="http://www.gnu.org/software/gnats/"
+url="https://www.gnu.org/software/gnats/"
arch="all"
license="GPL3"
depends="postfix"
diff --git a/main/gnome-mime-data/APKBUILD b/main/gnome-mime-data/APKBUILD
index d20fca954a..7947c72143 100644
--- a/main/gnome-mime-data/APKBUILD
+++ b/main/gnome-mime-data/APKBUILD
@@ -4,7 +4,7 @@ pkgname=gnome-mime-data
pkgver=2.18.0
pkgrel=1
pkgdesc="MIME data for GNOME environment"
-url="http://www.gnome.org/"
+url="https://www.gnome.org/"
arch="noarch"
license="LGPL"
depends=
diff --git a/main/gnome-vfs/APKBUILD b/main/gnome-vfs/APKBUILD
index ffd955da80..f7ad1bbacc 100644
--- a/main/gnome-vfs/APKBUILD
+++ b/main/gnome-vfs/APKBUILD
@@ -4,7 +4,7 @@ pkgname=gnome-vfs
pkgver=2.24.4
pkgrel=6
pkgdesc="GNOME virtual filesystem subsystem"
-url="http://projects.gnome.org/gnome-vfs"
+url="https://projects.gnome.org/gnome-vfs"
arch="all"
license="LGPL"
depends="gnome-mime-data"
diff --git a/main/gnuchess/APKBUILD b/main/gnuchess/APKBUILD
index b25186e426..44c613cc6c 100644
--- a/main/gnuchess/APKBUILD
+++ b/main/gnuchess/APKBUILD
@@ -4,7 +4,7 @@ pkgname=gnuchess
pkgver=6.2.5
pkgrel=0
pkgdesc="The GNU chess program"
-url="http://www.gnu.org/software/chess/"
+url="https://www.gnu.org/software/chess/"
arch="all"
license="GPLv3+"
depends=
diff --git a/main/gperf/APKBUILD b/main/gperf/APKBUILD
index 86cad7207c..4455ad7f53 100644
--- a/main/gperf/APKBUILD
+++ b/main/gperf/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gperf
pkgver=3.1
pkgrel=1
pkgdesc="Perfect hash function generator."
-url="http://www.gnu.org/software/gperf/"
+url="https://www.gnu.org/software/gperf/"
arch="all"
license="GPL"
subpackages="$pkgname-doc"
diff --git a/main/gphoto2/APKBUILD b/main/gphoto2/APKBUILD
index b012d2cbd1..27e36b7aa4 100644
--- a/main/gphoto2/APKBUILD
+++ b/main/gphoto2/APKBUILD
@@ -12,7 +12,7 @@ depends_dev=""
makedepends="libgphoto2-dev popt-dev gettext-dev libjpeg-turbo-dev libtool"
install=""
subpackages="$pkgname-lang $pkgname-doc"
-source="http://sourceforge.net/projects/gphoto/files/gphoto/$pkgver/gphoto2-$pkgver.tar.bz2"
+source="https://sourceforge.net/projects/gphoto/files/gphoto/$pkgver/gphoto2-$pkgver.tar.bz2"
_builddir="$srcdir"/gphoto2-$pkgver
prepare() {
diff --git a/main/gpicview/APKBUILD b/main/gpicview/APKBUILD
index 4fde97a8a8..65017daab2 100644
--- a/main/gpicview/APKBUILD
+++ b/main/gpicview/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gpicview
pkgver=0.2.5
pkgrel=0
pkgdesc="Picture viewer of the LXDE Desktop"
-url="http://wiki.lxde.org/en/GPicView"
+url="https://wiki.lxde.org/en/GPicView"
arch="all"
license="GPL2"
depends=
diff --git a/main/grep/APKBUILD b/main/grep/APKBUILD
index d5322092d6..c812466bfb 100644
--- a/main/grep/APKBUILD
+++ b/main/grep/APKBUILD
@@ -4,7 +4,7 @@ pkgname=grep
pkgver=3.1
pkgrel=0
pkgdesc="Searches input files for lines containing a match to a specified pattern"
-url="http://www.gnu.org/software/grep/grep.html"
+url="https://www.gnu.org/software/grep/grep.html"
arch="all"
license="GPL"
makedepends="pcre-dev autoconf automake"
diff --git a/main/groff/APKBUILD b/main/groff/APKBUILD
index 4140be26f3..0c7201b946 100644
--- a/main/groff/APKBUILD
+++ b/main/groff/APKBUILD
@@ -3,7 +3,7 @@ pkgname=groff
pkgver=1.22.3
pkgrel=2
pkgdesc="GNU troff text-formatting system"
-url="http://www.gnu.org/software/groff/groff.html"
+url="https://www.gnu.org/software/groff/groff.html"
arch="all"
license="GPL"
depends=
diff --git a/main/gsl/APKBUILD b/main/gsl/APKBUILD
index 4ea66258f5..fd5127623c 100644
--- a/main/gsl/APKBUILD
+++ b/main/gsl/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gsl
pkgver=2.4
pkgrel=0
pkgdesc="The GNU Scientific Library (GSL) is a modern numerical library for C and C++ programmers"
-url="http://www.gnu.org/software/gsl/gsl.html"
+url="https://www.gnu.org/software/gsl/gsl.html"
arch="all"
license="GPL"
depends=
diff --git a/main/gst-plugins-bad/APKBUILD b/main/gst-plugins-bad/APKBUILD
index 3b004053f2..54f26ef704 100644
--- a/main/gst-plugins-bad/APKBUILD
+++ b/main/gst-plugins-bad/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gst-plugins-bad
pkgver=1.12.3
pkgrel=1
pkgdesc="GStreamer bad plugins"
-url="http://gstreamer.freedesktop.org/"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="LGPL GPL"
depends=""
@@ -36,7 +36,7 @@ makedepends="
spandsp-dev
xvidcore-dev
"
-source="http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz"
ldpath="/usr/lib/gstreamer-.0"
builddir="$srcdir"/gst-plugins-bad-$pkgver
diff --git a/main/gst-plugins-bad0.10/APKBUILD b/main/gst-plugins-bad0.10/APKBUILD
index cf0030a2ef..2ccbf4450a 100644
--- a/main/gst-plugins-bad0.10/APKBUILD
+++ b/main/gst-plugins-bad0.10/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gst-plugins-bad0.10
pkgver=0.10.23
pkgrel=7
pkgdesc="GStreamer bad plugins"
-url="http://gstreamer.freedesktop.org/"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="LGPL GPL"
depends=""
@@ -14,7 +14,7 @@ makedepends="gst-plugins-base0.10-dev gstreamer0.10-dev xvidcore-dev bzip2-dev
alsa-lib-dev libx11-dev sdl-dev libvpx-dev libdc1394-dev
libmms-dev gsm-dev flite-dev orc-dev jasper-dev librsvg-dev"
-source="http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.bz2
+source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.bz2
libvpx-1.4.0.patch
"
diff --git a/main/gst-plugins-base/APKBUILD b/main/gst-plugins-base/APKBUILD
index f01e6812eb..42d28a6e87 100644
--- a/main/gst-plugins-base/APKBUILD
+++ b/main/gst-plugins-base/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gst-plugins-base
pkgver=1.12.3
pkgrel=0
pkgdesc="GStreamer Multimedia Framework Base Plugins"
-url="http://gstreamer.freedesktop.org/"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="GPL LGPL"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
@@ -28,7 +28,7 @@ makedepends="
glib-dev
opus-dev
"
-source="http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-$pkgver.tar.xz"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-$pkgver.tar.xz"
ldpath="/usr/lib/gstreamer-.0"
builddir="$srcdir"/gst-plugins-base-$pkgver
diff --git a/main/gst-plugins-base0.10/APKBUILD b/main/gst-plugins-base0.10/APKBUILD
index 21629b378b..13eb871f6f 100644
--- a/main/gst-plugins-base0.10/APKBUILD
+++ b/main/gst-plugins-base0.10/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gst-plugins-base0.10
pkgver=0.10.36
pkgrel=3
pkgdesc="GStreamer Multimedia Framework Base Plugins"
-url="http://gstreamer.freedesktop.org/"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="GPL LGPL"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
@@ -13,7 +13,7 @@ depends_dev="gstreamer0.10-dev"
makedepends="$depends_dev alsa-lib-dev libvorbis-dev liboil-dev
perl libogg-dev gtk+-dev libtheora-dev libice-dev libsm-dev libxv-dev
util-linux-dev expat-dev"
-source="http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-$pkgver.tar.bz2
+source="https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-$pkgver.tar.bz2
sse.patch"
diff --git a/main/gst-plugins-good/APKBUILD b/main/gst-plugins-good/APKBUILD
index 4b689fb0ac..8a3ec3d8c9 100644
--- a/main/gst-plugins-good/APKBUILD
+++ b/main/gst-plugins-good/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gst-plugins-good
pkgver=1.12.3
pkgrel=0
pkgdesc="GStreamer Multimedia Framework Good Plugins"
-url="http://gstreamer.freedesktop.org/"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="LGPL"
subpackages="$pkgname-lang $pkgname-doc"
@@ -40,7 +40,7 @@ makedepends="$depends_dev
"
replaces=
ldpath="/usr/lib/gstreamer-.0"
-source="http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz
+source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz
"
builddir="$srcdir"/gst-plugins-good-$pkgver
diff --git a/main/gst-plugins-good0.10/APKBUILD b/main/gst-plugins-good0.10/APKBUILD
index 94e0f97baf..7c3aa3751a 100644
--- a/main/gst-plugins-good0.10/APKBUILD
+++ b/main/gst-plugins-good0.10/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gst-plugins-good0.10
pkgver=0.10.31
pkgrel=0
pkgdesc="GStreamer Multimedia Framework Good Plugins"
-url="http://gstreamer.freedesktop.org/"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="LGPL"
subpackages="$pkgname-lang"
@@ -15,7 +15,7 @@ makedepends="linux-headers $depends_dev glib-dev liboil-dev
wavpack-dev libavc1394-dev libiec61883-dev libshout-dev libdv-dev
orc-dev libxext libsm-dev libice-dev libxv-dev"
-source="http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.bz2
+source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.bz2
0001-sys-v4l2-Some-blind-compilation-fixes.patch
"
diff --git a/main/gst-plugins-ugly/APKBUILD b/main/gst-plugins-ugly/APKBUILD
index 70b918bcdc..b1bd8b9e58 100644
--- a/main/gst-plugins-ugly/APKBUILD
+++ b/main/gst-plugins-ugly/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gst-plugins-ugly
pkgver=1.12.3
pkgrel=0
pkgdesc="GStreamer Multimedia Framework Ugly Plugins (gst-plugins-ugly)"
-url="http://gstreamer.freedesktop.org/"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="LGPL"
depends=
@@ -23,7 +23,7 @@ makedepends="
orc-dev
x264-dev
"
-source="http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-$pkgver.tar.xz"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-$pkgver.tar.xz"
subpackages="$pkgname-lang"
ldpath="/usr/lib/gstreamer-.0"
builddir="$srcdir"/gst-plugins-ugly-$pkgver
diff --git a/main/gst-plugins-ugly0.10/APKBUILD b/main/gst-plugins-ugly0.10/APKBUILD
index de31453270..03758f12f4 100644
--- a/main/gst-plugins-ugly0.10/APKBUILD
+++ b/main/gst-plugins-ugly0.10/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gst-plugins-ugly0.10
pkgver=0.10.19
pkgrel=2
pkgdesc="GStreamer Multimedia Framework Ugly Plugins (gst-plugins-ugly)"
-url="http://gstreamer.freedesktop.org/"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="LGPL"
depends=
@@ -11,7 +11,7 @@ replaces="gst-plugins-ugly"
makedepends="lame-dev libmpeg2-dev a52dec-dev libid3tag-dev libmad-dev
glib-dev liboil-dev gstreamer0.10-dev gst-plugins-base0.10-dev
x264-dev libcdio-dev libcdio-paranoia-dev libid3tag-dev orc-dev"
-source="http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-$pkgver.tar.bz2
+source="https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-$pkgver.tar.bz2
cdio-cd-text-api.patch"
subpackages="$pkgname-lang"
diff --git a/main/gstreamer/APKBUILD b/main/gstreamer/APKBUILD
index c25f787e70..824b645dea 100644
--- a/main/gstreamer/APKBUILD
+++ b/main/gstreamer/APKBUILD
@@ -3,14 +3,14 @@ pkgname=gstreamer
pkgver=1.12.3
pkgrel=0
pkgdesc="GStreamer Multimedia Framework"
-url="http://gstreamer.freedesktop.org/"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="LGPL"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools $pkgname-lang"
replaces="gstreamer1"
depends_dev="libxml2-dev"
makedepends="$depends_dev bison flex gobject-introspection-dev glib-dev"
-source="http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-$pkgver.tar.xz
+source="https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-$pkgver.tar.xz
"
builddir="$srcdir"/gstreamer-$pkgver
diff --git a/main/gstreamer0.10/APKBUILD b/main/gstreamer0.10/APKBUILD
index 117df0c208..941d18d1e9 100644
--- a/main/gstreamer0.10/APKBUILD
+++ b/main/gstreamer0.10/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gstreamer0.10
pkgver=0.10.36
pkgrel=2
pkgdesc="GStreamer Multimedia Framework"
-url="http://gstreamer.freedesktop.org/"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="LGPL"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools $pkgname-lang"
@@ -11,7 +11,7 @@ depends=
replaces="gstreamer"
makedepends="libxml2-dev glib-dev bison flex gettext-dev
gobject-introspection-dev"
-source="http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-$pkgver.tar.bz2
+source="https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-$pkgver.tar.bz2
gst-bison-3.patch
"
diff --git a/main/gtk+/APKBUILD b/main/gtk+/APKBUILD
index f5832fe14a..a4c73230cd 100644
--- a/main/gtk+/APKBUILD
+++ b/main/gtk+/APKBUILD
@@ -11,7 +11,7 @@ depends="gtk+2.0>=$pkgver"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
-url="http://www.gtk.org/"
+url="https://www.gtk.org/"
dev() {
depends="gtk+2.0-dev"
diff --git a/main/gtk+2.0/APKBUILD b/main/gtk+2.0/APKBUILD
index dbaef2d5b5..1f07edb86d 100644
--- a/main/gtk+2.0/APKBUILD
+++ b/main/gtk+2.0/APKBUILD
@@ -4,7 +4,7 @@ pkgver=2.24.31
pkgrel=0
subpkg=gtk-update-icon-cache
pkgdesc="The GTK+ Toolkit (v2)"
-url="http://www.gtk.org/"
+url="https://www.gtk.org/"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
triggers="$subpkg.trigger=/usr/share/icons/*"
arch="all"
diff --git a/main/gtk+3.0/APKBUILD b/main/gtk+3.0/APKBUILD
index effd5763c5..64a7da2a45 100644
--- a/main/gtk+3.0/APKBUILD
+++ b/main/gtk+3.0/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gtk+3.0
pkgver=3.22.21
pkgrel=0
pkgdesc="The GTK+ Toolkit (v3)"
-url="http://www.gtk.org/"
+url="https://www.gtk.org/"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
arch="all"
license="LGPL"
diff --git a/main/gtk-doc/APKBUILD b/main/gtk-doc/APKBUILD
index 7932bc6130..7d6686838e 100644
--- a/main/gtk-doc/APKBUILD
+++ b/main/gtk-doc/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gtk-doc
pkgver=1.26
pkgrel=2
pkgdesc="Documentation tool for public library API"
-url="http://www.gtk.org/gtk-doc/"
+url="https://www.gtk.org/gtk-doc/"
arch="noarch"
license="GPL FDL"
depends="docbook-xsl gnome-doc-utils perl python2 py2-six pkgconf glib-dev highlight"
diff --git a/main/gtk-engines/APKBUILD b/main/gtk-engines/APKBUILD
index de3f8c279c..8d26cf2923 100644
--- a/main/gtk-engines/APKBUILD
+++ b/main/gtk-engines/APKBUILD
@@ -4,7 +4,7 @@ pkgname=gtk-engines
pkgver=2.21.0
pkgrel=2
pkgdesc="collection of gtk+ engines"
-url="http://www.gtk.org/"
+url="https://www.gtk.org/"
arch="all"
license="GPL"
depends="$pkgname-clearlooks
diff --git a/main/gtk-xfce-engine/APKBUILD b/main/gtk-xfce-engine/APKBUILD
index bac70aa89c..2fa6432e0f 100644
--- a/main/gtk-xfce-engine/APKBUILD
+++ b/main/gtk-xfce-engine/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gtk-xfce-engine
pkgver=3.2.0
pkgrel=2
pkgdesc="Xfce theme engine"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
makedepends="gtk+2.0-dev gtk+3.0-dev"
diff --git a/main/gtkglext/APKBUILD b/main/gtkglext/APKBUILD
index 88fef6143a..f54e73f3a6 100644
--- a/main/gtkglext/APKBUILD
+++ b/main/gtkglext/APKBUILD
@@ -4,7 +4,7 @@ pkgname=gtkglext
pkgver=1.2.0
pkgrel=11
pkgdesc="GTK+ OpenGL Extension"
-url="http://projects.gnome.org/gtkglext/"
+url="https://projects.gnome.org/gtkglext/"
arch="all"
license="LGPL"
depends=
diff --git a/main/guile/APKBUILD b/main/guile/APKBUILD
index 8990341252..b08c9bb5b2 100644
--- a/main/guile/APKBUILD
+++ b/main/guile/APKBUILD
@@ -8,7 +8,7 @@ pkgname=guile
pkgver=2.0.14
pkgrel=0
pkgdesc="Guile is a portable, embeddable Scheme implementation written in C"
-url="http://www.gnu.org/software/guile/"
+url="https://www.gnu.org/software/guile/"
arch="all"
license="GPL"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
diff --git a/main/gzip/APKBUILD b/main/gzip/APKBUILD
index c4e79ec3a0..2c39336a72 100644
--- a/main/gzip/APKBUILD
+++ b/main/gzip/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.8
pkgrel=0
pkgdesc="A popular data compression program"
subpackages="$pkgname-doc"
-url="http://www.gnu.org/software/gzip/"
+url="https://www.gnu.org/software/gzip/"
arch="all"
license="GPL2"
depends=
diff --git a/main/hdparm/APKBUILD b/main/hdparm/APKBUILD
index 298ee542ae..b96907c963 100644
--- a/main/hdparm/APKBUILD
+++ b/main/hdparm/APKBUILD
@@ -3,7 +3,7 @@ pkgname=hdparm
pkgver=9.52
pkgrel=0
pkgdesc="A shell utility for manipulating Linux IDE drive/driver parameters"
-url="http://sourceforge.net/projects/hdparm/"
+url="https://sourceforge.net/projects/hdparm/"
arch="all"
license="BSD"
makedepends="linux-headers"
diff --git a/main/help2man/APKBUILD b/main/help2man/APKBUILD
index cae16f8ab7..74806697a3 100644
--- a/main/help2man/APKBUILD
+++ b/main/help2man/APKBUILD
@@ -3,7 +3,7 @@ pkgname=help2man
pkgver=1.47.5
pkgrel=0
pkgdesc="Create simple man pages from --help output"
-url="http://www.gnu.org/software/help2man"
+url="https://www.gnu.org/software/help2man"
arch="noarch"
license="GPLv3+"
depends="perl"
diff --git a/main/hicolor-icon-theme/APKBUILD b/main/hicolor-icon-theme/APKBUILD
index 323176c58f..55ea76e369 100644
--- a/main/hicolor-icon-theme/APKBUILD
+++ b/main/hicolor-icon-theme/APKBUILD
@@ -3,7 +3,7 @@ pkgname=hicolor-icon-theme
pkgver=0.17
pkgrel=0
pkgdesc="Freedesktop.org Hicolor icon theme"
-url="http://icon-theme.freedesktop.org/wiki/HicolorTheme"
+url="https://icon-theme.freedesktop.org/wiki/HicolorTheme"
arch="noarch"
license="GPL2"
source="http://icon-theme.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"
diff --git a/main/i3lock/APKBUILD b/main/i3lock/APKBUILD
index 8352034cbd..9700032ece 100644
--- a/main/i3lock/APKBUILD
+++ b/main/i3lock/APKBUILD
@@ -4,7 +4,7 @@ pkgname=i3lock
pkgver=2.9.1
pkgrel=0
pkgdesc="An improved screenlocker based upon XCB and PAM"
-url="http://i3wm.org/i3lock/"
+url="https://i3wm.org/i3lock/"
arch="all"
license="MIT"
depends="xkeyboard-config"
diff --git a/main/igmpproxy/APKBUILD b/main/igmpproxy/APKBUILD
index 82b2b9f9a0..ddb3cc91d7 100644
--- a/main/igmpproxy/APKBUILD
+++ b/main/igmpproxy/APKBUILD
@@ -4,7 +4,7 @@ pkgname=igmpproxy
pkgver=0.1
pkgrel=5
pkgdesc="A simple dynamic Multicast Routing Daemon using only IGMP signalling"
-url="http://sourceforge.net/projects/igmpproxy/"
+url="https://sourceforge.net/projects/igmpproxy/"
arch="all"
license="GPL2+"
depends=""
diff --git a/main/imlib2/APKBUILD b/main/imlib2/APKBUILD
index 7a5f99f4db..ee173def9a 100644
--- a/main/imlib2/APKBUILD
+++ b/main/imlib2/APKBUILD
@@ -3,7 +3,7 @@ pkgname=imlib2
pkgver=1.4.10
pkgrel=0
pkgdesc="Library that does image file loading and saving as well as rendering, manipulation, arbitrary polygon support"
-url="http://sourceforge.net/projects/enlightenment/"
+url="https://sourceforge.net/projects/enlightenment/"
arch="all"
license="BSD"
subpackages="$pkgname-dev $pkgname-doc"
diff --git a/main/indent/APKBUILD b/main/indent/APKBUILD
index 83f12ec938..3fd8a7ebd0 100644
--- a/main/indent/APKBUILD
+++ b/main/indent/APKBUILD
@@ -4,7 +4,7 @@ pkgname=indent
pkgver=2.2.11
pkgrel=1
pkgdesc="An indenting utility"
-url="http://www.gnu.org/software/indent/"
+url="https://www.gnu.org/software/indent/"
arch="all"
license="GPL3+ BSD"
depends=""
diff --git a/main/inotify-tools/APKBUILD b/main/inotify-tools/APKBUILD
index 6c1be7fe72..3d3894b373 100644
--- a/main/inotify-tools/APKBUILD
+++ b/main/inotify-tools/APKBUILD
@@ -4,7 +4,7 @@ pkgname="inotify-tools"
pkgver=3.14
pkgrel=2
pkgdesc="C library and CLI tools providing a simple interface to inotify"
-url="http://github.com/rvoicilas/inotify-tools"
+url="https://github.com/rvoicilas/inotify-tools"
arch="all"
license="GPL2"
depends="!inotify-tools-inc"
diff --git a/main/installkernel/APKBUILD b/main/installkernel/APKBUILD
index 3a5963d85f..b27bb1a5eb 100644
--- a/main/installkernel/APKBUILD
+++ b/main/installkernel/APKBUILD
@@ -3,7 +3,7 @@ pkgname=installkernel
pkgver=3.5
pkgrel=0
pkgdesc="Alpine Linux Kernel install script"
-url="http://git.alpinelinux.org/cgit/aports/tree/main/installkernel"
+url="https://git.alpinelinux.org/cgit/aports/tree/main/installkernel"
arch="noarch"
license="GPL2"
subpackages=""
diff --git a/main/iproute2-qos/APKBUILD b/main/iproute2-qos/APKBUILD
index eaca555207..d20a20d6b1 100644
--- a/main/iproute2-qos/APKBUILD
+++ b/main/iproute2-qos/APKBUILD
@@ -4,7 +4,7 @@ pkgname=iproute2-qos
pkgver=0.5
pkgrel=1
pkgdesc="Scripts to set up quality of service with iproute2"
-url="http://git.alpinelinux.org/cgit/aports"
+url="https://git.alpinelinux.org/cgit/aports"
arch="noarch"
license="GPL2"
depends="iproute2"
diff --git a/main/irssi/APKBUILD b/main/irssi/APKBUILD
index f93b407baf..3a3ef81d43 100644
--- a/main/irssi/APKBUILD
+++ b/main/irssi/APKBUILD
@@ -3,7 +3,7 @@ pkgname=irssi
pkgver=1.0.5
pkgrel=1
pkgdesc="A modular textUI IRC client with IPv6 support"
-url="http://irssi.org/"
+url="https://irssi.org/"
arch="all"
license="GPL2+"
makedepends="glib-dev libressl-dev ncurses-dev perl-dev automake autoconf libtool"
diff --git a/main/java-common/APKBUILD b/main/java-common/APKBUILD
index a866fe8733..66a752f3df 100644
--- a/main/java-common/APKBUILD
+++ b/main/java-common/APKBUILD
@@ -4,7 +4,7 @@ pkgname=java-common
pkgver=0.1
pkgrel=0
pkgdesc="Java common (updates java links)"
-url="http://git.alpinelinux.org/aports.git"
+url="https://git.alpinelinux.org/aports.git"
arch="noarch"
license="GPL2"
depends=
diff --git a/main/java-gcj-compat/APKBUILD b/main/java-gcj-compat/APKBUILD
index 431e799648..aa30762299 100644
--- a/main/java-gcj-compat/APKBUILD
+++ b/main/java-gcj-compat/APKBUILD
@@ -9,7 +9,7 @@ pkgver=$gccver
_mypkgrel=3
pkgrel=$(( $_mypkgrel + $gccpkgrel ))
pkgdesc="JDK like environment using GCJ"
-url="http://git.alpinelinux.org/aports.git"
+url="https://git.alpinelinux.org/aports.git"
arch="all"
license="GPL"
depends="fastjar gcc-java=$gccver-r$gccpkgrel java-common"
diff --git a/main/jbig2dec/APKBUILD b/main/jbig2dec/APKBUILD
index 0a2e6fa676..2d9a52f3a4 100644
--- a/main/jbig2dec/APKBUILD
+++ b/main/jbig2dec/APKBUILD
@@ -4,7 +4,7 @@ pkgname=jbig2dec
pkgver=0.14
pkgrel=0
pkgdesc="JBIG2 image compression format decoder"
-url="http://www.ghostscript.com/jbig2dec.html"
+url="https://www.ghostscript.com/jbig2dec.html"
arch="all"
license="GPL2+"
makedepends="autoconf automake libtool"
diff --git a/main/jwhois/APKBUILD b/main/jwhois/APKBUILD
index 200877020a..ff8931af74 100644
--- a/main/jwhois/APKBUILD
+++ b/main/jwhois/APKBUILD
@@ -3,7 +3,7 @@ pkgname=jwhois
pkgver=4.0
pkgrel=4
pkgdesc="WHOIS/RWHOIS client"
-url="http://www.gnu.org/software/jwhois/"
+url="https://www.gnu.org/software/jwhois/"
license="GPL"
depends=
makedepends="autoconf automake libtool gdbm-dev"
diff --git a/main/ldoc/APKBUILD b/main/ldoc/APKBUILD
index 4e82905fd0..bb67eef8f3 100644
--- a/main/ldoc/APKBUILD
+++ b/main/ldoc/APKBUILD
@@ -5,7 +5,7 @@ pkgname=ldoc
pkgver=1.4.6
pkgrel=0
pkgdesc="Documentation tool for Lua"
-url="http://github.com/stevedonovan/LDoc"
+url="https://github.com/stevedonovan/LDoc"
arch="noarch"
license="MIT"
depends="lua$_luaver-penlight lua$_luaver"
diff --git a/main/libass/APKBUILD b/main/libass/APKBUILD
index f39883f9f7..0128770807 100644
--- a/main/libass/APKBUILD
+++ b/main/libass/APKBUILD
@@ -14,7 +14,7 @@ depends=""
depends_dev="enca-dev fontconfig-dev fribidi-dev freetype-dev"
makedepends="$depends_dev"
subpackages="$pkgname-dev"
-source="http://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
+source="https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
_builddir="$srcdir"/$pkgname-$pkgver
diff --git a/main/libavc1394/APKBUILD b/main/libavc1394/APKBUILD
index 3d2bcfb64e..1ad6a0d048 100644
--- a/main/libavc1394/APKBUILD
+++ b/main/libavc1394/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libavc1394
pkgver=0.5.4
pkgrel=1
pkgdesc="Audio/Video Control library for IEEE-1394 devices"
-url="http://sourceforge.net/projects/libavc1394/"
+url="https://sourceforge.net/projects/libavc1394/"
arch="all"
license="GPLv2+ LGPLv2+"
depends=
diff --git a/main/libbonobo/APKBUILD b/main/libbonobo/APKBUILD
index fadc6e9db3..1212f7ec0a 100644
--- a/main/libbonobo/APKBUILD
+++ b/main/libbonobo/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libbonobo
pkgver=2.32.1
pkgrel=6
pkgdesc="GNOME base library"
-url="http://www.gnome.org/"
+url="https://www.gnome.org/"
arch="all"
license="LGPL"
depends=
diff --git a/main/libbsd/APKBUILD b/main/libbsd/APKBUILD
index 55130496b3..2600ebdfb0 100644
--- a/main/libbsd/APKBUILD
+++ b/main/libbsd/APKBUILD
@@ -5,14 +5,14 @@ pkgname=libbsd
pkgver=0.8.6
pkgrel=1
pkgdesc="commonly-used BSD functions not implemented by all libcs"
-url="http://libbsd.freedesktop.org/"
+url="https://libbsd.freedesktop.org/"
arch="all"
license="BSD"
depends="musl>=1.1.16-r22"
depends_dev="bsd-compat-headers linux-headers"
makedepends="$depends_dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://libbsd.freedesktop.org/releases/$pkgname-$pkgver.tar.xz
+source="https://libbsd.freedesktop.org/releases/$pkgname-$pkgver.tar.xz
0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
"
diff --git a/main/libcddb/APKBUILD b/main/libcddb/APKBUILD
index deeebc87bb..7c67c01f58 100644
--- a/main/libcddb/APKBUILD
+++ b/main/libcddb/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libcddb
pkgver=1.3.2
pkgrel=2
pkgdesc="Library that implements the different protocols (CDDBP, HTTP, SMTP) to access data on a CDDB server (e.g. http://freedb.org)."
-url="http://sourceforge.net/projects/libcddb/"
+url="https://sourceforge.net/projects/libcddb/"
arch="all"
license="GPL"
depends=
diff --git a/main/libcdio-paranoia/APKBUILD b/main/libcdio-paranoia/APKBUILD
index c2e0cf694e..a5df234c5a 100644
--- a/main/libcdio-paranoia/APKBUILD
+++ b/main/libcdio-paranoia/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.94_p1
_pkgver="10.2+${pkgver/_p/+}"
pkgrel=0
pkgdesc="CD paranoia on top of libcdio"
-url="http://www.gnu.org/software/libcdio/"
+url="https://www.gnu.org/software/libcdio/"
arch="all"
license="GPLv2+ and LGPLv2+"
makedepends="libcdio-dev autoconf automake libtool"
diff --git a/main/libcdio/APKBUILD b/main/libcdio/APKBUILD
index d583ff4889..665aa7ae42 100644
--- a/main/libcdio/APKBUILD
+++ b/main/libcdio/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libcdio
pkgver=0.94
pkgrel=0
pkgdesc="GNU Compact Disc Input and Control Library"
-url="http://www.gnu.org/software/libcdio/"
+url="https://www.gnu.org/software/libcdio/"
arch="all"
license="GPL3"
depends=
diff --git a/main/libcrystalhd/APKBUILD b/main/libcrystalhd/APKBUILD
index 69415851d4..7e3dbc108d 100644
--- a/main/libcrystalhd/APKBUILD
+++ b/main/libcrystalhd/APKBUILD
@@ -6,7 +6,7 @@ pkgver=20130708
_date=$pkgver
pkgrel=2
pkgdesc="Broadcom CrystalHD kernel driver library"
-url="http://git.linuxtv.org/jarod/crystalhd.git"
+url="https://git.linuxtv.org/jarod/crystalhd.git"
arch="x86 x86_64"
license="GPL2"
depends=""
diff --git a/main/libdc1394/APKBUILD b/main/libdc1394/APKBUILD
index 20b417b90e..dfc2b59613 100644
--- a/main/libdc1394/APKBUILD
+++ b/main/libdc1394/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libdc1394
pkgver=2.2.5
pkgrel=1
pkgdesc="High level programming interface to control IEEE 1394 based cameras"
-url="http://damien.douxchamps.net/ieee1394/libdc1394/"
+url="https://damien.douxchamps.net/ieee1394/libdc1394/"
arch="all"
license="LGPL"
depends=
diff --git a/main/libebml/APKBUILD b/main/libebml/APKBUILD
index 3dada2979b..686fdb0aa0 100644
--- a/main/libebml/APKBUILD
+++ b/main/libebml/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libebml
pkgver=1.3.5
pkgrel=0
pkgdesc="a C++ library to parse Extensible Binary Meta-Language files"
-url="http://www.matroska.org/"
+url="https://www.matroska.org/"
arch="all"
license="LGPL"
depends=""
diff --git a/main/libepoxy/APKBUILD b/main/libepoxy/APKBUILD
index d4fde0c84c..1e498e0d99 100644
--- a/main/libepoxy/APKBUILD
+++ b/main/libepoxy/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libepoxy
pkgver=1.4.3
pkgrel=1
pkgdesc="Direct Rendering Manager runtime library"
-url="http://github.com/anholt/libepoxy"
+url="https://github.com/anholt/libepoxy"
arch="all"
license="MIT"
options="!check" # Requires dlvsym
diff --git a/main/libexecinfo/APKBUILD b/main/libexecinfo/APKBUILD
index 9fd218ae84..2a3a15306b 100644
--- a/main/libexecinfo/APKBUILD
+++ b/main/libexecinfo/APKBUILD
@@ -5,7 +5,7 @@ pkgname=libexecinfo
pkgver=1.1
pkgrel=0
pkgdesc="A quick-n-dirty BSD licensed clone of the GNU libc backtrace facility."
-url="http://www.freshports.org/devel/libexecinfo"
+url="https://www.freshports.org/devel/libexecinfo"
arch="all"
license="BSD"
depends=
diff --git a/main/libexif/APKBUILD b/main/libexif/APKBUILD
index 61fd4e3839..ff0e637812 100644
--- a/main/libexif/APKBUILD
+++ b/main/libexif/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libexif
pkgver=0.6.21
pkgrel=1
pkgdesc="A library to parse an EXIF file and read the data from those tags"
-url="http://sourceforge.net/projects/libexif"
+url="https://sourceforge.net/projects/libexif"
arch="all"
license="LGPL"
subpackages="$pkgname-dev $pkgname-doc"
diff --git a/main/libgnome/APKBUILD b/main/libgnome/APKBUILD
index cbf0ac4aba..ba711847db 100644
--- a/main/libgnome/APKBUILD
+++ b/main/libgnome/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libgnome
pkgver=2.32.1
pkgrel=7
pkgdesc="GNOME base library"
-url="http://www.gnome.org/"
+url="https://www.gnome.org/"
arch="all"
license="LGPL"
depends=
diff --git a/main/libgnomekbd/APKBUILD b/main/libgnomekbd/APKBUILD
index 6ab2be8540..038576720b 100644
--- a/main/libgnomekbd/APKBUILD
+++ b/main/libgnomekbd/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libgnomekbd
pkgver=3.6.0
pkgrel=0
pkgdesc="GNOME keyboard library"
-url="http://www.gnome.org/"
+url="https://www.gnome.org/"
arch="all"
license="LGPL"
depends=
diff --git a/main/libgsasl/APKBUILD b/main/libgsasl/APKBUILD
index efffc05f2d..34dfbad834 100644
--- a/main/libgsasl/APKBUILD
+++ b/main/libgsasl/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libgsasl
pkgver=1.8.0
pkgrel=2
pkgdesc="An implementation of the Simple Authentication and Security Layer framework"
-url="http://www.gnu.org/software/gsasl/"
+url="https://www.gnu.org/software/gsasl/"
arch="all"
license="LGPL2+"
depends=""
diff --git a/main/libgsf/APKBUILD b/main/libgsf/APKBUILD
index 486245d5bf..1b9708333f 100644
--- a/main/libgsf/APKBUILD
+++ b/main/libgsf/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libgsf
pkgver=1.14.41
pkgrel=0
pkgdesc="The GNOME Structured File Library is a utility library for reading and writing structured file formats."
-url="http://www.gnome.org/"
+url="https://www.gnome.org/"
arch="all"
license="GPL LGPL"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
diff --git a/main/libgss/APKBUILD b/main/libgss/APKBUILD
index 60e7295c81..63db210044 100644
--- a/main/libgss/APKBUILD
+++ b/main/libgss/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libgss
pkgver=0.1.5
pkgrel=1
pkgdesc="An implementation of the Generic Security Service Application Program Interface"
-url="http://www.gnu.org/software/gss/"
+url="https://www.gnu.org/software/gss/"
arch="all"
license="GPL3+"
depends=""
diff --git a/main/libidl/APKBUILD b/main/libidl/APKBUILD
index 9f139a7dda..1848784efb 100644
--- a/main/libidl/APKBUILD
+++ b/main/libidl/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libidl
pkgver=0.8.14
pkgrel=2
pkgdesc="library for parsing Interface Definition Language files"
-url="http://www.gnome.org/"
+url="https://www.gnome.org/"
license="GPL"
arch="all"
depends=
diff --git a/main/libidn/APKBUILD b/main/libidn/APKBUILD
index 599c56d1cf..b83aa9330a 100644
--- a/main/libidn/APKBUILD
+++ b/main/libidn/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libidn
pkgver=1.33
pkgrel=1
pkgdesc="An encode and decode library for internationalized domain names"
-url="http://www.gnu.org/software/libidn/"
+url="https://www.gnu.org/software/libidn/"
arch="all"
license="GPL"
depends=
diff --git a/main/libmaa/APKBUILD b/main/libmaa/APKBUILD
index 537ed69662..9e6d9e7282 100644
--- a/main/libmaa/APKBUILD
+++ b/main/libmaa/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libmaa
pkgver=1.3.2
pkgrel=0
pkgdesc="Provides many low-level data structures which are helpful for writing compilers"
-url="http://sourceforge.net/projects/dict/"
+url="https://sourceforge.net/projects/dict/"
arch="all"
license="GPL"
depends=""
diff --git a/main/libmatroska/APKBUILD b/main/libmatroska/APKBUILD
index 037f83cec8..c690faff56 100644
--- a/main/libmatroska/APKBUILD
+++ b/main/libmatroska/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libmatroska
pkgver=1.4.8
pkgrel=0
pkgdesc="a C++ library to parse Matroska files"
-url="http://www.matroska.org/"
+url="https://www.matroska.org/"
arch="all"
license="LGPL"
makedepends="libebml-dev>=1.3.3"
diff --git a/main/libmicrohttpd/APKBUILD b/main/libmicrohttpd/APKBUILD
index 96a172d697..3263fbf431 100644
--- a/main/libmicrohttpd/APKBUILD
+++ b/main/libmicrohttpd/APKBUILD
@@ -5,7 +5,7 @@ pkgname=libmicrohttpd
pkgver=0.9.55
pkgrel=0
pkgdesc="a small C library that is supposed to make it easy to run an HTTP server as part of another application."
-url="http://www.gnu.org/software/libmicrohttpd/"
+url="https://www.gnu.org/software/libmicrohttpd/"
arch="all"
license="GPL"
makedepends="curl-dev libgcrypt-dev gnutls-dev"
diff --git a/main/libmms/APKBUILD b/main/libmms/APKBUILD
index 3502b8d3c8..ba5132947c 100644
--- a/main/libmms/APKBUILD
+++ b/main/libmms/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libmms
pkgver=0.6.4
pkgrel=0
pkgdesc="MMS stream protocol library"
-url="http://sourceforge.net/projects/libmms/"
+url="https://sourceforge.net/projects/libmms/"
arch="all"
license="LGPL"
depends=
diff --git a/main/libmspack/APKBUILD b/main/libmspack/APKBUILD
index 95bc28f146..02437c1183 100644
--- a/main/libmspack/APKBUILD
+++ b/main/libmspack/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.5_alpha
_ver=${pkgver/_/}
pkgrel=1
pkgdesc="Library for CAB and related files compression and decompression"
-url="http://www.cabextract.org.uk/libmspack/"
+url="https://www.cabextract.org.uk/libmspack/"
arch="all"
license="LGPLv2"
depends=""
@@ -12,7 +12,7 @@ depends_dev=""
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
-source="http://www.cabextract.org.uk/libmspack/libmspack-$_ver.tar.gz
+source="https://www.cabextract.org.uk/libmspack/libmspack-$_ver.tar.gz
CVE-2017-6419.patch
CVE-2017-11423.patch"
diff --git a/main/libnet/APKBUILD b/main/libnet/APKBUILD
index b56651d89f..bed2163350 100644
--- a/main/libnet/APKBUILD
+++ b/main/libnet/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libnet
pkgver=1.1.6
pkgrel=2
pkgdesc="A generic networking API that provides access to several protocols."
-url="http://sourceforge.net/projects/libnet-dev/"
+url="https://sourceforge.net/projects/libnet-dev/"
arch="all"
license="BSD"
depends=
diff --git a/main/libnice/APKBUILD b/main/libnice/APKBUILD
index 3c9db230ce..8e2ba68544 100644
--- a/main/libnice/APKBUILD
+++ b/main/libnice/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libnice
pkgver=0.1.14
pkgrel=2
pkgdesc="GLib ICE implementation"
-url="http://nice.freedesktop.org/wiki/"
+url="https://nice.freedesktop.org/wiki/"
arch="all"
license="LGPLv2 and MPLv1.1"
makedepends="glib-dev gnutls-dev gstreamer-dev gst-plugins-base-dev
diff --git a/main/libnih/APKBUILD b/main/libnih/APKBUILD
index 72bd114966..99a7772eaf 100644
--- a/main/libnih/APKBUILD
+++ b/main/libnih/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libnih
pkgver=1.0.3
pkgrel=4
pkgdesc="glib-like library for embedded use"
-url="http://launchpad.net/libnih"
+url="https://launchpad.net/libnih"
arch="all"
license="LGPL"
depends=
@@ -12,7 +12,7 @@ depends_dev="dbus-dev expat-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://launchpad.net/libnih/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz
+source="https://launchpad.net/libnih/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz
musl-fix-signals.patch
"
diff --git a/main/libogg/APKBUILD b/main/libogg/APKBUILD
index 03704c7420..f7ab3735cb 100644
--- a/main/libogg/APKBUILD
+++ b/main/libogg/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libogg
pkgver=1.3.3
pkgrel=1
pkgdesc="Ogg bitstream and framing library"
-url="http://xiph.org/ogg/"
+url="https://xiph.org/ogg/"
arch="all"
license="BSD"
options="!check" # no tests available
diff --git a/main/liboil/APKBUILD b/main/liboil/APKBUILD
index b4bcd7ae84..6159b9d9a7 100644
--- a/main/liboil/APKBUILD
+++ b/main/liboil/APKBUILD
@@ -3,7 +3,7 @@ pkgname=liboil
pkgver=0.3.17
pkgrel=5
pkgdesc="Library of simple functions that are optimized for various CPUs."
-url="http://liboil.freedesktop.org/"
+url="https://liboil.freedesktop.org/"
arch="all"
license="custom"
subpackages="$pkgname-dev $pkgname-doc"
diff --git a/main/libpthread-stubs/APKBUILD b/main/libpthread-stubs/APKBUILD
index 9d9b8d0c93..1221e3c551 100644
--- a/main/libpthread-stubs/APKBUILD
+++ b/main/libpthread-stubs/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libpthread-stubs
pkgver=0.3
pkgrel=4
pkgdesc="Pthread functions stubs for platforms missing them"
-url="http://cgit.freedesktop.org/xcb/pthread-stubs"
+url="https://cgit.freedesktop.org/xcb/pthread-stubs"
arch="all"
license="X11"
options="!dbg"
diff --git a/main/libqrencode/APKBUILD b/main/libqrencode/APKBUILD
index 1e9726017b..a493616f0a 100644
--- a/main/libqrencode/APKBUILD
+++ b/main/libqrencode/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libqrencode
pkgver=4.0.0
pkgrel=0
pkgdesc="library for encoding QR codes"
-url="http://fukuchi.org/works/qrencode/index.html"
+url="https://fukuchi.org/works/qrencode/index.html"
arch="all"
license="LGPL"
makedepends="libpng-dev libtool"
diff --git a/main/libraw/APKBUILD b/main/libraw/APKBUILD
index bbf5e13047..95b4d3eaa6 100644
--- a/main/libraw/APKBUILD
+++ b/main/libraw/APKBUILD
@@ -3,13 +3,13 @@ pkgname=libraw
pkgver=0.18.5
pkgrel=0
pkgdesc="Library for reading RAW files obtained from digital photo cameras"
-url="http://www.libraw.org/"
+url="https://www.libraw.org/"
arch="all"
license="CDDL LGPL custom"
depends=""
makedepends=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://www.libraw.org/data/LibRaw-$pkgver.tar.gz"
+source="https://www.libraw.org/data/LibRaw-$pkgver.tar.gz"
builddir="$srcdir"/LibRaw-$pkgver
# secfixes:
diff --git a/main/libraw1394/APKBUILD b/main/libraw1394/APKBUILD
index 2a1e383e01..c88a226cbf 100644
--- a/main/libraw1394/APKBUILD
+++ b/main/libraw1394/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libraw1394
pkgver=2.1.2
pkgrel=0
pkgdesc="Library to provide access to Linux 1394 subsystem"
-url="http://sourceforge.net/projects/libraw1394"
+url="https://sourceforge.net/projects/libraw1394"
arch="all"
license="LGPL"
depends=
diff --git a/main/librevenge/APKBUILD b/main/librevenge/APKBUILD
index c3eb2e7f65..c8b3379173 100644
--- a/main/librevenge/APKBUILD
+++ b/main/librevenge/APKBUILD
@@ -4,7 +4,7 @@ pkgname=librevenge
pkgver=0.0.4
pkgrel=0
pkgdesc="Base library for writing document import filters"
-url="http://sourceforge.net/projects/libwpd/"
+url="https://sourceforge.net/projects/libwpd/"
arch="all"
license="MPL2"
depends=""
@@ -12,7 +12,7 @@ depends_dev="boost-dev zlib-dev cppunit-dev"
makedepends="$depends_dev doxygen"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://sourceforge.net/projects/libwpd/files/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz"
+source="https://sourceforge.net/projects/libwpd/files/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz"
_builddir="$srcdir"/$pkgname-$pkgver
diff --git a/main/libssh2/APKBUILD b/main/libssh2/APKBUILD
index c7bce28c31..7ee1979ff7 100644
--- a/main/libssh2/APKBUILD
+++ b/main/libssh2/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libssh2
pkgver=1.8.0
pkgrel=2
pkgdesc="library for accessing ssh1/ssh2 protocol servers"
-url="http://libssh2.org/"
+url="https://libssh2.org/"
arch="all"
license="BSD"
makedepends="libressl-dev zlib-dev"
diff --git a/main/libtasn1/APKBUILD b/main/libtasn1/APKBUILD
index 087c41b5e1..75b74da477 100644
--- a/main/libtasn1/APKBUILD
+++ b/main/libtasn1/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libtasn1
pkgver=4.12
pkgrel=2
pkgdesc="The ASN.1 library used in GNUTLS"
-url="http://www.gnu.org/software/gnutls/"
+url="https://www.gnu.org/software/gnutls/"
arch="all"
license="GPL3 LGPL"
makedepends="texinfo"
diff --git a/main/libtool/APKBUILD b/main/libtool/APKBUILD
index b03628dd0e..83351dcb3a 100644
--- a/main/libtool/APKBUILD
+++ b/main/libtool/APKBUILD
@@ -5,7 +5,7 @@ pkgrel=4
pkgdesc="A generic library support script"
arch="all"
license='GPL'
-url="http://www.gnu.org/software/libtool"
+url="https://www.gnu.org/software/libtool"
source="ftp://ftp.gnu.org/pub/gnu/libtool/${pkgname}-${pkgver}.tar.gz
libtool-fix-cross-compile.patch
"
diff --git a/main/libunistring/APKBUILD b/main/libunistring/APKBUILD
index 95970553a2..dff107127b 100644
--- a/main/libunistring/APKBUILD
+++ b/main/libunistring/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libunistring
pkgver=0.9.7
pkgrel=0
pkgdesc="Library for manipulating Unicode strings and C strings"
-url="http://www.gnu.org/software/libunistring/"
+url="https://www.gnu.org/software/libunistring/"
arch="all"
license="GPL"
depends=""
diff --git a/main/libvdpau/APKBUILD b/main/libvdpau/APKBUILD
index 08592c83f8..8e5942a233 100644
--- a/main/libvdpau/APKBUILD
+++ b/main/libvdpau/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libvdpau
pkgver=1.1.1
pkgrel=1
pkgdesc="Hardware-accelerated video playback library"
-url="http://cgit.freedesktop.org/~aplattner/libvdpau"
+url="https://cgit.freedesktop.org/~aplattner/libvdpau"
arch="all"
license="custom"
depends=
diff --git a/main/libvpx/APKBUILD b/main/libvpx/APKBUILD
index 9fa41ea6c8..de9a1afe83 100644
--- a/main/libvpx/APKBUILD
+++ b/main/libvpx/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libvpx
pkgver=1.6.1
pkgrel=0
pkgdesc="Library for the vp8 codec"
-url="http://www.webmproject.org/"
+url="https://www.webmproject.org/"
arch="all"
license="GPL"
depends=""
diff --git a/main/libxcb/APKBUILD b/main/libxcb/APKBUILD
index c21ec0150d..c0626d6977 100644
--- a/main/libxcb/APKBUILD
+++ b/main/libxcb/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libxcb
pkgver=1.12
pkgrel=1
pkgdesc="X11 client-side library"
-url="http://xcb.freedesktop.org/"
+url="https://xcb.freedesktop.org/"
arch="all"
license="custom"
depends=
@@ -11,7 +11,7 @@ subpackages="$pkgname-dev $pkgname-doc"
depends_dev="libxau-dev xcb-proto"
checkdepends="check-dev"
makedepends="$depends_dev libxslt python3 libpthread-stubs libxdmcp-dev"
-source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2
+source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2
python3.patch"
builddir="$srcdir"/$pkgname-$pkgver
diff --git a/main/libxfce4ui/APKBUILD b/main/libxfce4ui/APKBUILD
index c3647744f6..275678fd61 100644
--- a/main/libxfce4ui/APKBUILD
+++ b/main/libxfce4ui/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libxfce4ui
pkgver=4.12.1
pkgrel=3
pkgdesc="Widgets library for the Xfce desktop environment"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-gtk3"
diff --git a/main/libxfce4util/APKBUILD b/main/libxfce4util/APKBUILD
index 5e60541928..1abf7be6a2 100644
--- a/main/libxfce4util/APKBUILD
+++ b/main/libxfce4util/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libxfce4util
pkgver=4.12.1
pkgrel=4
pkgdesc="Basic utility non-GUI functions for Xfce"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
diff --git a/main/libxkbcommon/APKBUILD b/main/libxkbcommon/APKBUILD
index 658f2a6ca5..9b0e7d38a8 100644
--- a/main/libxkbcommon/APKBUILD
+++ b/main/libxkbcommon/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libxkbcommon
pkgver=0.7.1
pkgrel=1
pkgdesc="a keyboard handling library"
-url="http://www.xkbcommon.org/"
+url="https://www.xkbcommon.org/"
arch="all"
license="MIT"
makedepends="bison flex libxcb-dev xproto kbproto util-macros"
diff --git a/main/libxscrnsaver/APKBUILD b/main/libxscrnsaver/APKBUILD
index 4109127312..d278a5f56e 100644
--- a/main/libxscrnsaver/APKBUILD
+++ b/main/libxscrnsaver/APKBUILD
@@ -3,7 +3,7 @@ pkgname=libxscrnsaver
pkgver=1.2.2
pkgrel=1
pkgdesc="Xorg screen saver extension"
-url="http://cgit.freedesktop.org/xorg/lib/libXScrnSaver/"
+url="https://cgit.freedesktop.org/xorg/lib/libXScrnSaver/"
arch="all"
license="MIT"
depends=""
diff --git a/main/libxshmfence/APKBUILD b/main/libxshmfence/APKBUILD
index 59b55a54ef..eb37640537 100644
--- a/main/libxshmfence/APKBUILD
+++ b/main/libxshmfence/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libxshmfence
pkgver=1.2
pkgrel=2
pkgdesc="X11 shared memory fences"
-url="http://www.x.org/"
+url="https://www.x.org/"
arch="all"
license="MIT"
depends=""
@@ -12,7 +12,7 @@ depends_dev="linux-headers"
makedepends="$depends_dev util-macros xproto"
install=""
subpackages="$pkgname-dev"
-source="http://www.x.org/releases/individual/lib/libxshmfence-$pkgver.tar.bz2"
+source="https://www.x.org/releases/individual/lib/libxshmfence-$pkgver.tar.bz2"
build() {
cd "$builddir"
diff --git a/main/lsof/APKBUILD b/main/lsof/APKBUILD
index 8ed3c7b7c1..f26588e788 100644
--- a/main/lsof/APKBUILD
+++ b/main/lsof/APKBUILD
@@ -3,7 +3,7 @@ pkgname=lsof
pkgver=4.89
pkgrel=1
pkgdesc="LiSt Open Files"
-url="http://people.freebsd.org/~abe/"
+url="https://people.freebsd.org/~abe/"
arch="all"
license="custom"
subpackages="$pkgname-doc"
diff --git a/main/lua-aports/APKBUILD b/main/lua-aports/APKBUILD
index 155e700d5a..7debc34a6f 100644
--- a/main/lua-aports/APKBUILD
+++ b/main/lua-aports/APKBUILD
@@ -3,12 +3,12 @@ pkgname=lua-aports
pkgver=0.7.0
pkgrel=0
pkgdesc="Lua modules for parsing aports tree"
-url="http://dev.alpinelinux.org/archive/lua-aports/"
+url="https://dev.alpinelinux.org/archive/lua-aports/"
arch="noarch"
license="MIT"
depends="lua5.2-cjson lua5.2-filesystem lua5.2-optarg lua5.2"
replaces="abuild"
-source="http://dev.alpinelinux.org/archive/lua-aports/lua-aports-$pkgver.tar.xz"
+source="https://dev.alpinelinux.org/archive/lua-aports/lua-aports-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
package() {
diff --git a/main/lua-augeas/APKBUILD b/main/lua-augeas/APKBUILD
index ea8f1e2bbe..3009e195e8 100644
--- a/main/lua-augeas/APKBUILD
+++ b/main/lua-augeas/APKBUILD
@@ -6,7 +6,7 @@ pkgname=lua-augeas
pkgver=0.1.2
pkgrel=3
pkgdesc="Lua bindings for Augeas"
-url="http://git.alpinelinux.org/cgit/lua-augeas/"
+url="https://git.alpinelinux.org/cgit/lua-augeas/"
arch="all"
license="LGPL"
depends=""
diff --git a/main/lua-cjson/APKBUILD b/main/lua-cjson/APKBUILD
index d9111feee1..8c7cc9a8bf 100644
--- a/main/lua-cjson/APKBUILD
+++ b/main/lua-cjson/APKBUILD
@@ -5,7 +5,7 @@ pkgname=lua-cjson
pkgver=2.1.0
pkgrel=7
pkgdesc="fast JSON parsing and encoding support for Lua"
-url="http://www.kyne.com.au/~mark/software/lua-cjson.php"
+url="https://www.kyne.com.au/~mark/software/lua-cjson.php"
arch="all"
license="MIT"
depends=""
diff --git a/main/lua/APKBUILD b/main/lua/APKBUILD
index 5b9f45d7bc..14a4653c30 100644
--- a/main/lua/APKBUILD
+++ b/main/lua/APKBUILD
@@ -3,7 +3,7 @@ pkgname=lua
pkgver=5.1.5
pkgrel=4
pkgdesc="A powerful light-weight programming language designed for extending applications."
-url="http://www.lua.org/"
+url="https://www.lua.org/"
arch="noarch"
license="MIT"
depends="lua5.1"
diff --git a/main/lua5.1/APKBUILD b/main/lua5.1/APKBUILD
index b14ae11915..fed13853c9 100644
--- a/main/lua5.1/APKBUILD
+++ b/main/lua5.1/APKBUILD
@@ -6,14 +6,14 @@ pkgver="$_majorver.5"
_pkgver=$pkgver
pkgrel=3
pkgdesc="A powerful light-weight programming language designed for extending applications."
-url="http://www.lua.org/"
+url="https://www.lua.org/"
arch="all"
license="MIT"
depends=""
depends_dev="$pkgname"
makedepends="libtool autoconf automake"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="http://www.lua.org/ftp/lua-$_pkgver.tar.gz
+source="https://www.lua.org/ftp/lua-$_pkgver.tar.gz
lua-5.1-make.patch
lua-5.1-module_paths.patch
lua-5.1-readline.patch
diff --git a/main/lua5.2/APKBUILD b/main/lua5.2/APKBUILD
index a66fad3f50..3998fd2ac7 100644
--- a/main/lua5.2/APKBUILD
+++ b/main/lua5.2/APKBUILD
@@ -4,14 +4,14 @@ pkgver=5.2.4
_luaver=${pkgname#lua}
pkgrel=4
pkgdesc="Powerful light-weight programming language"
-url="http://www.lua.org/"
+url="https://www.lua.org/"
arch="all"
license="MIT"
depends=
ldpath="/usr/lib/$pkgname"
makedepends="libtool autoconf automake"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="http://www.lua.org/ftp/lua-$pkgver.tar.gz
+source="https://www.lua.org/ftp/lua-$pkgver.tar.gz
lua-5.2-make.patch
lua-5.2-module_paths.patch
"
diff --git a/main/lua5.3/APKBUILD b/main/lua5.3/APKBUILD
index 1951f8d326..da7587a381 100644
--- a/main/lua5.3/APKBUILD
+++ b/main/lua5.3/APKBUILD
@@ -5,14 +5,14 @@ pkgver=5.3.4
_luaver=${pkgname#lua}
pkgrel=2
pkgdesc="Powerful light-weight programming language"
-url="http://www.lua.org/"
+url="https://www.lua.org/"
arch="all"
license="MIT"
ldpath="/usr/lib/$pkgname"
depends_dev="$pkgname"
makedepends="libtool autoconf automake linenoise-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="http://www.lua.org/ftp/$_pkgname-$pkgver.tar.gz
+source="https://www.lua.org/ftp/$_pkgname-$pkgver.tar.gz
lua-5.3-make.patch
lua-5.3-module_paths.patch
linenoise.patch
diff --git a/main/lxdm/APKBUILD b/main/lxdm/APKBUILD
index 0219059efb..6a7cb34709 100644
--- a/main/lxdm/APKBUILD
+++ b/main/lxdm/APKBUILD
@@ -4,7 +4,7 @@ pkgname=lxdm
pkgver=0.5.3
pkgrel=1
pkgdesc="LXDE desktop login manager"
-url="http://wiki.lxde.org/en/LXDM"
+url="https://wiki.lxde.org/en/LXDM"
license="GPL"
depends="bash"
makedepends="gtk+2.0-dev consolekit2-dev autoconf automake libtool intltool
diff --git a/main/m4/APKBUILD b/main/m4/APKBUILD
index e6626e0d24..84a701ca03 100644
--- a/main/m4/APKBUILD
+++ b/main/m4/APKBUILD
@@ -3,7 +3,7 @@ pkgname=m4
pkgver=1.4.18
pkgrel=0
pkgdesc="GNU macro processor"
-url="http://www.gnu.org/software/m4"
+url="https://www.gnu.org/software/m4"
depends=
makedepends=texinfo
arch="all"
diff --git a/main/make/APKBUILD b/main/make/APKBUILD
index 9344398f47..aea893862a 100644
--- a/main/make/APKBUILD
+++ b/main/make/APKBUILD
@@ -3,7 +3,7 @@ pkgname=make
pkgver=4.2.1
pkgrel=0
pkgdesc="GNU make utility to maintain groups of programs"
-url="http://www.gnu.org/software/make"
+url="https://www.gnu.org/software/make"
arch="all"
license="GPL3+"
depends=""
diff --git a/main/man-pages/APKBUILD b/main/man-pages/APKBUILD
index 66f7be9798..4dd896a894 100644
--- a/main/man-pages/APKBUILD
+++ b/main/man-pages/APKBUILD
@@ -5,7 +5,7 @@ pkgver=4.13
_posixver=2013-a
pkgrel=0
pkgdesc="Linux man pages"
-url="http://www.kernel.org/doc/man-pages/"
+url="https://www.kernel.org/doc/man-pages/"
arch="noarch"
license="GPL"
depends=""
diff --git a/main/minicom/APKBUILD b/main/minicom/APKBUILD
index 6161e5f297..ff38b2afc2 100644
--- a/main/minicom/APKBUILD
+++ b/main/minicom/APKBUILD
@@ -4,7 +4,7 @@ pkgname=minicom
pkgver=2.7.1
pkgrel=0
pkgdesc="menu driven communications program for terminals"
-url="http://alioth.debian.org/projects/minicom"
+url="https://alioth.debian.org/projects/minicom"
arch="all"
license="GPL2+"
depends=""
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index 8c1c2493ba..21dfe72d54 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -4,7 +4,7 @@ pkgver=3.1.0
_ver=${pkgver%_git*}
pkgrel=3
pkgdesc="Tool to generate initramfs images for Alpine"
-url="http://git.alpinelinux.org/cgit/mkinitfs"
+url="https://git.alpinelinux.org/cgit/mkinitfs"
arch="all"
license="GPL2"
makedepends_build=""
diff --git a/main/mrtg/APKBUILD b/main/mrtg/APKBUILD
index 9352b6858f..d28132d83e 100644
--- a/main/mrtg/APKBUILD
+++ b/main/mrtg/APKBUILD
@@ -4,8 +4,8 @@ pkgname=mrtg
pkgver=2.17.4
pkgrel=4
pkgdesc="MRTG Network Latency Monitoring"
-url="http://oss.oetiker.ch/mrtg/"
-source="http://oss.oetiker.ch/mrtg/pub/$pkgname-$pkgver.tar.gz
+url="https://oss.oetiker.ch/mrtg/"
+source="https://oss.oetiker.ch/mrtg/pub/$pkgname-$pkgver.tar.gz
mrtg.initd mrtg.confd"
subpackages="$pkgname-doc"
depends="perl"
diff --git a/main/mtools/APKBUILD b/main/mtools/APKBUILD
index 4bf1ed2715..af7b232dd8 100644
--- a/main/mtools/APKBUILD
+++ b/main/mtools/APKBUILD
@@ -3,7 +3,7 @@ pkgname=mtools
pkgver=4.0.18
pkgrel=2
pkgdesc="A collection of utilities to access MS-DOS disks from Unix without mounting them"
-url="http://www.gnu.org/software/mtools/"
+url="https://www.gnu.org/software/mtools/"
arch="all"
license="GPL"
depends=
diff --git a/main/multisort/APKBUILD b/main/multisort/APKBUILD
index 0582eed3db..2a16faec51 100644
--- a/main/multisort/APKBUILD
+++ b/main/multisort/APKBUILD
@@ -4,7 +4,7 @@ pkgname=multisort
pkgver=1.1
pkgrel=0
pkgdesc="Tool to merge multiple logfiles"
-url="http://www.xach.com/multisort/"
+url="https://www.xach.com/multisort/"
arch="all"
license="GPL2"
depends=
diff --git a/main/nagios/APKBUILD b/main/nagios/APKBUILD
index 8fa16a1c63..639644ea67 100644
--- a/main/nagios/APKBUILD
+++ b/main/nagios/APKBUILD
@@ -4,7 +4,7 @@ pkgname=nagios
pkgver=3.5.1
pkgrel=4
pkgdesc="Popular monitoring tool"
-url="http://www.nagios.org/"
+url="https://www.nagios.org/"
arch="all"
license="GPL2"
depends="perl"
diff --git a/main/nano/APKBUILD b/main/nano/APKBUILD
index 13b13d639b..4a8ffa02a4 100644
--- a/main/nano/APKBUILD
+++ b/main/nano/APKBUILD
@@ -4,12 +4,12 @@ pkgname=nano
pkgver=2.8.7
pkgrel=0
pkgdesc="Text editor designed to be a free replacement for the Pico text editor"
-url="http://www.nano-editor.org/"
+url="https://www.nano-editor.org/"
arch="all"
license="GPL"
makedepends="ncurses-dev file-dev"
subpackages="$pkgname-doc $pkgname-syntax::noarch"
-source="http://www.nano-editor.org/dist/v${pkgver%.*}/$pkgname-$pkgver.tar.gz"
+source="https://www.nano-editor.org/dist/v${pkgver%.*}/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
diff --git a/main/ncdu/APKBUILD b/main/ncdu/APKBUILD
index b2a4e33950..e7892b7d70 100644
--- a/main/ncdu/APKBUILD
+++ b/main/ncdu/APKBUILD
@@ -4,7 +4,7 @@ pkgname=ncdu
pkgver=1.12
pkgrel=0
pkgdesc="Text-based disk usage viewer"
-url="http://dev.yorhel.nl/ncdu"
+url="https://dev.yorhel.nl/ncdu"
arch="all"
license="MIT"
depends=""
diff --git a/main/ncurses/APKBUILD b/main/ncurses/APKBUILD
index e146ab7982..76effc2c8b 100644
--- a/main/ncurses/APKBUILD
+++ b/main/ncurses/APKBUILD
@@ -4,7 +4,7 @@ pkgver=6.0_p20170930
_ver=${pkgver%_p*}-${pkgver#*_p}
pkgrel=0
pkgdesc="Console display library"
-url="http://www.gnu.org/software/ncurses/"
+url="https://www.gnu.org/software/ncurses/"
arch="all"
license=MIT
depends=
diff --git a/main/ncurses5/APKBUILD b/main/ncurses5/APKBUILD
index 200232be19..c4a1887694 100644
--- a/main/ncurses5/APKBUILD
+++ b/main/ncurses5/APKBUILD
@@ -3,7 +3,7 @@ pkgname=ncurses5
pkgver=5.9
pkgrel=1
pkgdesc="Console display library - ncurses5 compat"
-url="http://www.gnu.org/software/ncurses/"
+url="https://www.gnu.org/software/ncurses/"
arch="all"
license=MIT
depends=
diff --git a/main/newsbeuter/APKBUILD b/main/newsbeuter/APKBUILD
index 776fb85652..7b65f5542f 100644
--- a/main/newsbeuter/APKBUILD
+++ b/main/newsbeuter/APKBUILD
@@ -3,7 +3,7 @@ pkgname=newsbeuter
pkgver=2.9
pkgrel=6
pkgdesc="Configurable text-based feed reader"
-url="http://newsbeuter.org/"
+url="https://newsbeuter.org/"
arch="all"
license="MIT"
depends=""
@@ -12,7 +12,7 @@ makedepends="$depends_dev json-c-dev curl-dev ncurses-dev sqlite-dev
stfl-dev libxml2-dev gettext-dev perl libressl-dev"
install=""
subpackages="$pkgname-doc $pkgname-lang"
-source="http://newsbeuter.org/downloads/newsbeuter-$pkgver.tar.gz
+source="https://newsbeuter.org/downloads/newsbeuter-$pkgver.tar.gz
0001-Remove-iconv-translit-references.patch
newsbeuter-2.9-ncurses6.patch
fix-segfault.patch
diff --git a/main/ngircd/APKBUILD b/main/ngircd/APKBUILD
index 5c40fe15f4..ccd97dc5f2 100644
--- a/main/ngircd/APKBUILD
+++ b/main/ngircd/APKBUILD
@@ -4,14 +4,14 @@ pkgname=ngircd
pkgver=24
pkgrel=2
pkgdesc="Next Generation IRC Daemon"
-url="http://ngircd.barton.de/"
+url="https://ngircd.barton.de/"
arch="all"
license="GPL2+"
depends=""
makedepends="libressl-dev zlib-dev linux-pam-dev"
subpackages="$pkgname-doc"
install="$pkgname.pre-install"
-source="http://ngircd.barton.de/pub/ngircd/ngircd-$pkgver.tar.xz
+source="https://ngircd.barton.de/pub/ngircd/ngircd-$pkgver.tar.xz
$pkgname.initd
"
_builddir="$srcdir"/$pkgname-$pkgver
diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index bd808596e0..b50c1eae37 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -17,7 +17,7 @@ pkgname=nodejs
pkgver=8.9.1
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - LTS version"
-url="http://nodejs.org/"
+url="https://nodejs.org/"
arch="all"
license="MIT"
depends="ca-certificates"
diff --git a/main/nss-pam-ldapd/APKBUILD b/main/nss-pam-ldapd/APKBUILD
index 1718f292e0..7caf5a1ade 100644
--- a/main/nss-pam-ldapd/APKBUILD
+++ b/main/nss-pam-ldapd/APKBUILD
@@ -3,7 +3,7 @@ pkgname=nss-pam-ldapd
pkgver=0.9.8
pkgrel=0
pkgdesc="An nsswitch module which uses directory servers"
-url="http://arthurdejong.org/nss-pam-ldapd/"
+url="https://arthurdejong.org/nss-pam-ldapd/"
arch="all"
license="LGPLv2+"
depends=""
@@ -11,7 +11,7 @@ depends_dev="linux-pam-dev openldap-dev"
makedepends="$depends_dev"
install="nss-pam-ldapd.pre-install"
subpackages="$pkgname-doc"
-source="http://arthurdejong.org/nss-pam-ldapd/nss-pam-ldapd-$pkgver.tar.gz
+source="https://arthurdejong.org/nss-pam-ldapd/nss-pam-ldapd-$pkgver.tar.gz
nslcd.initd"
_builddir="$srcdir"/nss-pam-ldapd-$pkgver
diff --git a/main/ntop/APKBUILD b/main/ntop/APKBUILD
index 48872975d8..88ef6d9de9 100644
--- a/main/ntop/APKBUILD
+++ b/main/ntop/APKBUILD
@@ -15,7 +15,7 @@ makedepends="autoconf automake freetype-dev gdbm-dev geoip-dev
linux-headers"
install="$pkgname.pre-install"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://sourceforge.net/projects/$pkgname/files/$pkgname/Stable/$pkgname-$pkgver.tar.gz
+source="https://sourceforge.net/projects/$pkgname/files/$pkgname/Stable/$pkgname-$pkgver.tar.gz
include-sys-types.h.patch
automake.patch
ntop.initd
diff --git a/main/openipmi/APKBUILD b/main/openipmi/APKBUILD
index 60c5af8416..a8867b0cf7 100644
--- a/main/openipmi/APKBUILD
+++ b/main/openipmi/APKBUILD
@@ -3,7 +3,7 @@ pkgname=openipmi
pkgver=2.0.22
pkgrel=1
pkgdesc="IPMI (Intelligent Platform Management Interface) library and tools"
-url="http://sourceforge.net/projects/openipmi/"
+url="https://sourceforge.net/projects/openipmi/"
arch="all"
license="LGPLv2+ and GPLv2+ or BSD"
depends=""
diff --git a/main/opennhrp/APKBUILD b/main/opennhrp/APKBUILD
index a8ceae72cf..1e67c6748e 100644
--- a/main/opennhrp/APKBUILD
+++ b/main/opennhrp/APKBUILD
@@ -3,7 +3,7 @@ pkgname=opennhrp
pkgver=0.14.1
pkgrel=6
pkgdesc="NBMA Next Hop Resolution Protocol daemon"
-url="http://sourceforge.net/projects/opennhrp"
+url="https://sourceforge.net/projects/opennhrp"
arch="all"
license="GPL2"
depends=
diff --git a/main/openresolv/APKBUILD b/main/openresolv/APKBUILD
index 77be6c1019..5d203c1652 100644
--- a/main/openresolv/APKBUILD
+++ b/main/openresolv/APKBUILD
@@ -3,7 +3,7 @@ pkgname=openresolv
pkgver=3.9.0
pkgrel=0
pkgdesc="A framework for managing DNS information"
-url="http://roy.marples.name/projects/openresolv"
+url="https://roy.marples.name/projects/openresolv"
arch="noarch"
license="BSD"
depends=""
diff --git a/main/openvpn-ad-check/APKBUILD b/main/openvpn-ad-check/APKBUILD
index feea60386c..4f67033cbe 100644
--- a/main/openvpn-ad-check/APKBUILD
+++ b/main/openvpn-ad-check/APKBUILD
@@ -12,7 +12,7 @@ depends_dev=""
makedepends="$depends_dev"
install=""
subpackages=""
-source="http://sourceforge.net/projects/openvpnadcheck/files/$pkgname-$pkgver.tgz"
+source="https://sourceforge.net/projects/openvpnadcheck/files/$pkgname-$pkgver.tgz"
_builddir="$srcdir/$pkgname"
prepare() {
diff --git a/main/orage/APKBUILD b/main/orage/APKBUILD
index e13c7eb95d..78e4fb5730 100644
--- a/main/orage/APKBUILD
+++ b/main/orage/APKBUILD
@@ -3,7 +3,7 @@ pkgname=orage
pkgver=4.12.1
pkgrel=1
pkgdesc="A simple calendar application with reminders for Xfce"
-url="http://www.xfce.org/projects/"
+url="https://xfce.org/projects/"
arch="all"
license="GPL2"
subpackages="$pkgname-doc $pkgname-lang"
diff --git a/main/p11-kit/APKBUILD b/main/p11-kit/APKBUILD
index 45a3e87220..b2ee80f887 100644
--- a/main/p11-kit/APKBUILD
+++ b/main/p11-kit/APKBUILD
@@ -4,7 +4,7 @@ pkgname=p11-kit
pkgver=0.23.2
pkgrel=2
pkgdesc="Library for loading and sharing PKCS#11 modules"
-url="http://p11-glue.freedesktop.org/"
+url="https://p11-glue.freedesktop.org/"
arch="all"
license="BSD"
depends=""
@@ -12,7 +12,7 @@ depends_dev=""
makedepends="libtasn1-dev libffi-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-trust"
-source="http://p11-glue.freedesktop.org/releases/$pkgname-$pkgver.tar.gz"
+source="https://p11-glue.freedesktop.org/releases/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
diff --git a/main/pacman/APKBUILD b/main/pacman/APKBUILD
index 22c509f704..81832c4e36 100644
--- a/main/pacman/APKBUILD
+++ b/main/pacman/APKBUILD
@@ -4,7 +4,7 @@ pkgname=pacman
pkgver=5.0.2
pkgrel=1
pkgdesc="a simple library-based package manager"
-url="http://www.archlinux.org/pacman/"
+url="https://www.archlinux.org/pacman/"
arch="all"
license="GPL"
depends=""
diff --git a/main/pam-pgsql/APKBUILD b/main/pam-pgsql/APKBUILD
index 4620c3aabd..fbf853e338 100644
--- a/main/pam-pgsql/APKBUILD
+++ b/main/pam-pgsql/APKBUILD
@@ -4,7 +4,7 @@ pkgname=pam-pgsql
pkgver=0.7.3.2
pkgrel=0
pkgdesc="PAM module to authenticate using a PostgreSQL database"
-url="http://sourceforge.net/projects/pam-pgsql/"
+url="https://sourceforge.net/projects/pam-pgsql/"
arch="all"
license="GPL"
depends=""
diff --git a/main/parallel/APKBUILD b/main/parallel/APKBUILD
index d7881420e1..5cfee9bbb7 100644
--- a/main/parallel/APKBUILD
+++ b/main/parallel/APKBUILD
@@ -5,7 +5,7 @@ pkgver=20171022
pkgrel=0
pkgdesc="Shell tool for executing jobs in parallel"
arch="noarch"
-url="http://www.gnu.org/software/parallel/"
+url="https://www.gnu.org/software/parallel/"
license="GPL3"
depends="perl"
subpackages="$pkgname-doc"
diff --git a/main/parted/APKBUILD b/main/parted/APKBUILD
index c4ee6bf3ef..066f791fc9 100644
--- a/main/parted/APKBUILD
+++ b/main/parted/APKBUILD
@@ -3,7 +3,7 @@ pkgname=parted
pkgver=3.2
pkgrel=6
pkgdesc="Utility to create, destroy, resize, check and copy partitions"
-url="http://www.gnu.org/software/parted/parted.html"
+url="https://www.gnu.org/software/parted/parted.html"
arch="all"
license="GPL3"
subpackages="$pkgname-dev $pkgname-doc"
diff --git a/main/patch/APKBUILD b/main/patch/APKBUILD
index f6648ba890..4358fd9774 100644
--- a/main/patch/APKBUILD
+++ b/main/patch/APKBUILD
@@ -4,7 +4,7 @@ pkgname=patch
pkgver=2.7.5
pkgrel=1
pkgdesc="Utility to apply diffs to files"
-url="http://www.gnu.org/software/patch/patch.html"
+url="https://www.gnu.org/software/patch/patch.html"
arch="all"
license="GPL"
depends=""
diff --git a/main/pingu/APKBUILD b/main/pingu/APKBUILD
index 099adb8c4c..19f9bb9c18 100644
--- a/main/pingu/APKBUILD
+++ b/main/pingu/APKBUILD
@@ -4,7 +4,7 @@ pkgname=pingu
pkgver=1.5
pkgrel=1
pkgdesc="Small daemon that pings hosts and executes a script when status change"
-url="http://git.alpinelinux.org/cgit/pingu"
+url="https://git.alpinelinux.org/cgit/pingu"
arch="all"
license="GPL"
makedepends="libev-dev lua-dev asciidoc linux-headers"
diff --git a/main/poppler-qt4/APKBUILD b/main/poppler-qt4/APKBUILD
index 0ec95500b8..640dc751e1 100644
--- a/main/poppler-qt4/APKBUILD
+++ b/main/poppler-qt4/APKBUILD
@@ -9,7 +9,7 @@ _realname=poppler
pkgver=0.56.0
pkgrel=0
pkgdesc="PDF rendering library based on xpdf 3.0"
-url="http://poppler.freedesktop.org/"
+url="https://poppler.freedesktop.org/"
arch="all"
license="GPL"
subpackages="$pkgname-dev"
@@ -18,7 +18,7 @@ makedepends="jpeg-dev cairo-dev libxml2-dev fontconfig-dev qt-dev
depends=
replaces="poppler-glib"
depends_dev="$makedepends"
-source="http://poppler.freedesktop.org/poppler-$pkgver.tar.xz"
+source="https://poppler.freedesktop.org/poppler-$pkgver.tar.xz"
builddir="$srcdir/$_realname-$pkgver"
diff --git a/main/poppler/APKBUILD b/main/poppler/APKBUILD
index 8b763d2ccf..c224a6571c 100644
--- a/main/poppler/APKBUILD
+++ b/main/poppler/APKBUILD
@@ -7,7 +7,7 @@ pkgname=poppler
pkgver=0.56.0
pkgrel=0
pkgdesc="PDF rendering library based on xpdf 3.0"
-url="http://poppler.freedesktop.org/"
+url="https://poppler.freedesktop.org/"
arch="all"
license="GPL"
depends=
@@ -17,7 +17,7 @@ makedepends="$depends_dev libjpeg-turbo-dev cairo-dev libxml2-dev
openjpeg-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils $pkgname-glib
"
-source="http://poppler.freedesktop.org/poppler-$pkgver.tar.xz"
+source="https://poppler.freedesktop.org/poppler-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
diff --git a/main/postgresql/APKBUILD b/main/postgresql/APKBUILD
index 52619e5d23..b476c9f8d0 100644
--- a/main/postgresql/APKBUILD
+++ b/main/postgresql/APKBUILD
@@ -5,7 +5,7 @@ pkgname=postgresql
pkgver=10.1
pkgrel=0
pkgdesc="A sophisticated object-relational DBMS"
-url="http://www.postgresql.org/"
+url="https://www.postgresql.org/"
arch="all"
license="BSD"
depends="postgresql-client tzdata"
diff --git a/main/pptpd/APKBUILD b/main/pptpd/APKBUILD
index f70c15c75b..12ec804370 100644
--- a/main/pptpd/APKBUILD
+++ b/main/pptpd/APKBUILD
@@ -11,7 +11,7 @@ depends=""
makedepends="ppp-dev"
install=""
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::http://sourceforge.net/projects/poptop/files/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz/download
+source="$pkgname-$pkgver.tar.gz::https://sourceforge.net/projects/poptop/files/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz/download
fix_MSG_TRYHARD.patch
pptpd.patch
pptpd.confd
diff --git a/main/pth/APKBUILD b/main/pth/APKBUILD
index f037c589e4..6dd60862d9 100644
--- a/main/pth/APKBUILD
+++ b/main/pth/APKBUILD
@@ -3,7 +3,7 @@ pkgname=pth
pkgver=2.0.7
pkgrel=4
pkgdesc="The GNU Portable Threads."
-url="http://www.gnu.org/software/pth"
+url="https://www.gnu.org/software/pth"
arch="all"
license="LGPL2.1"
depends=""
diff --git a/main/putty/APKBUILD b/main/putty/APKBUILD
index f08d7e672a..e722072b9c 100644
--- a/main/putty/APKBUILD
+++ b/main/putty/APKBUILD
@@ -3,7 +3,7 @@ pkgname=putty
pkgver=0.70
pkgrel=0
pkgdesc="SSH and telnet client"
-url="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+url="https://www.chiark.greenend.org.uk/~sgtatham/putty/"
arch="all"
license="custom"
subpackages="$pkgname-doc"
diff --git a/main/pwgen/APKBUILD b/main/pwgen/APKBUILD
index 12714adde4..034705a0aa 100644
--- a/main/pwgen/APKBUILD
+++ b/main/pwgen/APKBUILD
@@ -3,7 +3,7 @@ pkgname=pwgen
pkgver=2.08
pkgrel=0
pkgdesc="A Password Generator"
-url="http://sourceforge.net/projects/pwgen/"
+url="https://sourceforge.net/projects/pwgen/"
arch="all"
license="GPL"
depends=""
diff --git a/main/py-asn1-modules/APKBUILD b/main/py-asn1-modules/APKBUILD
index a7d5b5cbe2..a28b4135ce 100644
--- a/main/py-asn1-modules/APKBUILD
+++ b/main/py-asn1-modules/APKBUILD
@@ -4,7 +4,7 @@ _pkgname=pyasn1-modules
pkgver=0.1.4
pkgrel=1
pkgdesc="A collection of ASN.1-based protocols modules"
-url="http://pypi.python.org/pypi/pyasn1-modules"
+url="https://pypi.python.org/pypi/pyasn1-modules"
arch="noarch"
license="BSD"
depends=""
diff --git a/main/py-cryptography/APKBUILD b/main/py-cryptography/APKBUILD
index a12b6732fd..558a769620 100644
--- a/main/py-cryptography/APKBUILD
+++ b/main/py-cryptography/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=${pkgname#py-}
pkgver=2.0.3
pkgrel=1
pkgdesc="A package which provides cryptographic recipes and primitives"
-url="http://pypi.python.org/pypi/cryptography"
+url="https://pypi.python.org/pypi/cryptography"
arch="all"
license="ASL-2.0"
depends="py-cffi py-idna py-asn1crypto py-six"
diff --git a/main/py-ecdsa/APKBUILD b/main/py-ecdsa/APKBUILD
index 3573c70bfa..48fcaa045b 100644
--- a/main/py-ecdsa/APKBUILD
+++ b/main/py-ecdsa/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=ecdsa
pkgver=0.13
pkgrel=5
pkgdesc="A Python cryptographic signature library"
-url="http://github.com/warner/python-ecdsa"
+url="https://github.com/warner/python-ecdsa"
arch="all"
license="MIT"
depends=""
diff --git a/main/py-egenix-mx-base/APKBUILD b/main/py-egenix-mx-base/APKBUILD
index 68037fbd29..d29b32e8f2 100644
--- a/main/py-egenix-mx-base/APKBUILD
+++ b/main/py-egenix-mx-base/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=egenix-mx-base
pkgver=3.2.9
pkgrel=0
pkgdesc="eGenix.com mx Base collection of Python extensions"
-url="http://www.egenix.com/products/python/mxBase/"
+url="https://www.egenix.com/products/python/mxBase/"
arch="all"
license="Custom"
depends=""
diff --git a/main/py-enum34/APKBUILD b/main/py-enum34/APKBUILD
index b5dcc8a55f..1221451dca 100644
--- a/main/py-enum34/APKBUILD
+++ b/main/py-enum34/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=enum34
pkgver=1.1.6
pkgrel=2
pkgdesc="Python 3.4 Enum backported"
-url="http://pypi.python.org/pypi/enum34"
+url="https://pypi.python.org/pypi/enum34"
arch="noarch"
license="BSD"
depends=""
diff --git a/main/py-flup/APKBUILD b/main/py-flup/APKBUILD
index 760f868f65..7a886a0ed9 100644
--- a/main/py-flup/APKBUILD
+++ b/main/py-flup/APKBUILD
@@ -5,12 +5,12 @@ pkgname=py-${_pkgname}
pkgver=1.0.2
pkgrel=0
pkgdesc="WSGI modules for Python"
-url="http://www.saddi.com/software/flup/"
+url="https://www.saddi.com/software/flup/"
arch="noarch"
license="BSD"
makedepends="python2-dev py-setuptools"
depends="python2"
-source="$pkgname-$pkgver.tar.gz::http://www.saddi.com/software/flup/dist/${_pkgname}-${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://www.saddi.com/software/flup/dist/${_pkgname}-${pkgver}.tar.gz"
_builddir="${srcdir}/${_pkgname}-${pkgver}"
diff --git a/main/py-gnutls/APKBUILD b/main/py-gnutls/APKBUILD
index 2e0396d49c..854d33ebce 100644
--- a/main/py-gnutls/APKBUILD
+++ b/main/py-gnutls/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=python-gnutls
pkgver=3.1.1
pkgrel=0
pkgdesc="Python wrapper for the GNUTLS library"
-url="http://pypi.python.org/pypi/python-gnutls"
+url="https://pypi.python.org/pypi/python-gnutls"
arch="noarch"
license="PSF"
makedepends="python2-dev gnutls-dev py-setuptools"
diff --git a/main/py-gst0.10/APKBUILD b/main/py-gst0.10/APKBUILD
index d5ce291eec..ccc179fbd5 100644
--- a/main/py-gst0.10/APKBUILD
+++ b/main/py-gst0.10/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=gst-python
pkgver=0.10.22
pkgrel=0
pkgdesc="python bindings for gstreamer"
-url="http://gstreamer.freedesktop.org/"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="LGPL2+"
replaces="py-gst"
@@ -14,7 +14,7 @@ makedepends="gstreamer0.10-dev gst-plugins-base0.10-dev py-gtk-dev
py-gobject-dev python2-dev"
install=""
subpackages=""
-source="http://gstreamer.freedesktop.org/src/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://gstreamer.freedesktop.org/src/$_pkgname/$_pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
diff --git a/main/py-imaging/APKBUILD b/main/py-imaging/APKBUILD
index 8d70877f71..6dfa643dbc 100644
--- a/main/py-imaging/APKBUILD
+++ b/main/py-imaging/APKBUILD
@@ -4,7 +4,7 @@ pkgname=py-imaging
pkgver=1.1.7
pkgrel=4
pkgdesc="Python image manipulation library"
-url="http://pypi.python.org/pypi/PIL"
+url="https://pypi.python.org/pypi/PIL"
arch="all"
license="PSF"
depends=""
diff --git a/main/py-itsdangerous/APKBUILD b/main/py-itsdangerous/APKBUILD
index 521ec89798..e49aeaeefe 100644
--- a/main/py-itsdangerous/APKBUILD
+++ b/main/py-itsdangerous/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=itsdangerous
pkgver=0.24
pkgrel=3
pkgdesc="A Python helper to pass trusted data to untrusted environments"
-url="http://github.com/mitsuhiko/itsdangerous"
+url="https://github.com/mitsuhiko/itsdangerous"
arch="noarch"
license="BSD"
depends=""
diff --git a/main/py-roman/APKBUILD b/main/py-roman/APKBUILD
index d4fe7afbd0..2387ec4ab0 100644
--- a/main/py-roman/APKBUILD
+++ b/main/py-roman/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=roman
pkgver=2.0.0
pkgrel=2
pkgdesc="Integer to Roman numerals converter"
-url="http://pypi.python.org/pypi/roman"
+url="https://pypi.python.org/pypi/roman"
arch="noarch"
license="Python"
depends=""
diff --git a/main/py-rsa/APKBUILD b/main/py-rsa/APKBUILD
index 74c4dae831..8c288d9fe5 100644
--- a/main/py-rsa/APKBUILD
+++ b/main/py-rsa/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=${pkgname#py-}
pkgver=3.4.2
pkgrel=2
pkgdesc="Pure-Python RSA implementation"
-url="http://stuvel.eu/rsa"
+url="https://stuvel.eu/rsa"
arch="noarch"
license="BSD"
depends="py-asn1"
diff --git a/main/py-setuptools/APKBUILD b/main/py-setuptools/APKBUILD
index c573b6f9ed..79d7be9bd3 100644
--- a/main/py-setuptools/APKBUILD
+++ b/main/py-setuptools/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=${pkgname#py-}
pkgver=33.1.1
pkgrel=1
pkgdesc="A collection of enhancements to the Python distutils"
-url="http://pypi.python.org/pypi/setuptools"
+url="https://pypi.python.org/pypi/setuptools"
arch="noarch"
license="PSF"
provides="py2-setuptools=$pkgver-r$pkgrel"
diff --git a/main/py-simplejson/APKBUILD b/main/py-simplejson/APKBUILD
index 5907c27f22..db95e0e116 100644
--- a/main/py-simplejson/APKBUILD
+++ b/main/py-simplejson/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=simplejson
pkgver=3.8.2
pkgrel=2
pkgdesc="Simple, fast, extensible JSON encoder/decoder for Python"
-url="http://pypi.python.org/pypi/simplejson/"
+url="https://pypi.python.org/pypi/simplejson/"
arch="all"
license="MIT"
depends=""
diff --git a/main/py-simpleparse/APKBUILD b/main/py-simpleparse/APKBUILD
index 8d23ac1661..6eeabf050e 100644
--- a/main/py-simpleparse/APKBUILD
+++ b/main/py-simpleparse/APKBUILD
@@ -4,7 +4,7 @@ _pkgname=SimpleParse
pkgver=2.2.0
pkgrel=0
pkgdesc="Python library providing simple and fast parser generator"
-url="http://launchpad.net/simpleparse"
+url="https://launchpad.net/simpleparse"
arch="all"
license="BSD"
depends="python2"
diff --git a/main/py-six/APKBUILD b/main/py-six/APKBUILD
index ce2109d08c..5469cb8eb5 100644
--- a/main/py-six/APKBUILD
+++ b/main/py-six/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=six
pkgver=1.11.0
pkgrel=0
pkgdesc="Python 2 and 3 compatibility library"
-url="http://pypi.python.org/pypi/six"
+url="https://pypi.python.org/pypi/six"
arch="noarch"
license="MIT"
depends=""
diff --git a/main/quazip/APKBUILD b/main/quazip/APKBUILD
index 99a5a42e46..ba88709b3f 100644
--- a/main/quazip/APKBUILD
+++ b/main/quazip/APKBUILD
@@ -4,7 +4,7 @@ pkgname=quazip
pkgver=0.7.3
pkgrel=0
pkgdesc="C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package"
-url="http://sourceforge.net/projects/quazip/"
+url="https://sourceforge.net/projects/quazip/"
arch="all"
license="LGPL"
makedepends="qt-dev cmake"
diff --git a/main/rarian/APKBUILD b/main/rarian/APKBUILD
index 0394e61c0d..23a4e6fdf9 100644
--- a/main/rarian/APKBUILD
+++ b/main/rarian/APKBUILD
@@ -3,7 +3,7 @@ pkgname=rarian
pkgver=0.8.1
pkgrel=6
pkgdesc="Documentation meta-data library, designed as a replacement for Scrollkeeper."
-url="http://rarian.freedesktop.org/"
+url="https://rarian.freedesktop.org/"
arch="all"
license="GPL"
subpackages="$pkgname-dev"
diff --git a/main/rdiff-backup/APKBUILD b/main/rdiff-backup/APKBUILD
index 024bfad662..29f76b10b5 100644
--- a/main/rdiff-backup/APKBUILD
+++ b/main/rdiff-backup/APKBUILD
@@ -5,7 +5,7 @@ pkgname=rdiff-backup
pkgver=1.2.8
pkgrel=2
pkgdesc="A backup utility that maintains extra reverse diffs so that files can be restored from previous backups"
-url="http://www.gnu.org/savannah-checkouts/non-gnu/rdiff-backup/"
+url="https://www.gnu.org/savannah-checkouts/non-gnu/rdiff-backup/"
arch="all"
license="GPL2+"
depends=""
diff --git a/main/redis/APKBUILD b/main/redis/APKBUILD
index 38d7dd1147..5425899357 100644
--- a/main/redis/APKBUILD
+++ b/main/redis/APKBUILD
@@ -4,7 +4,7 @@ pkgname=redis
pkgver=4.0.2
pkgrel=1
pkgdesc="Advanced key-value store"
-url="http://redis.io/"
+url="https://redis.io/"
arch="all"
license="BSD"
depends=""
diff --git a/main/rtapd/APKBUILD b/main/rtapd/APKBUILD
index a5af1139c5..db50044940 100644
--- a/main/rtapd/APKBUILD
+++ b/main/rtapd/APKBUILD
@@ -5,7 +5,7 @@ _altpkgname="rtnppd"
pkgver=1.7
pkgrel=6
pkgdesc="daemon for routing packets to rtnppd"
-url="http://sourceforge.net/projects/rtnppd/"
+url="https://sourceforge.net/projects/rtnppd/"
arch="all"
license="GPL"
depends="rtnppd"
diff --git a/main/rtnppd/APKBUILD b/main/rtnppd/APKBUILD
index 54563c72de..3fb80fc5f3 100644
--- a/main/rtnppd/APKBUILD
+++ b/main/rtnppd/APKBUILD
@@ -4,7 +4,7 @@ pkgname=rtnppd
pkgver=1.7b
pkgrel=8
pkgdesc="A program route TNPP 3.8 (Telocator Network Paging Protocol) packets between serial and other links"
-url="http://sourceforge.net/projects/rtnppd/"
+url="https://sourceforge.net/projects/rtnppd/"
arch="all"
license="GPL"
depends=""
diff --git a/main/run-parts/APKBUILD b/main/run-parts/APKBUILD
index 4ad80c0881..ce0d1ec38e 100644
--- a/main/run-parts/APKBUILD
+++ b/main/run-parts/APKBUILD
@@ -4,7 +4,7 @@ _pkgname=debianutils
pkgver=4.8.2
pkgrel=0
pkgdesc="run-parts from the debianutils package"
-url="http://packages.qa.debian.org/d/debianutils.html"
+url="https://packages.qa.debian.org/d/debianutils.html"
arch="all"
license="GPL"
depends=
diff --git a/main/sed/APKBUILD b/main/sed/APKBUILD
index ea63f35646..8b397ee11f 100644
--- a/main/sed/APKBUILD
+++ b/main/sed/APKBUILD
@@ -4,7 +4,7 @@ pkgver=4.4
pkgrel=1
subpackages="$pkgname-doc"
pkgdesc="GNU stream editor"
-url="http://www.gnu.org/software/sed"
+url="https://www.gnu.org/software/sed"
arch="all"
license="GPL"
makedepends="perl"
diff --git a/main/ser2net/APKBUILD b/main/ser2net/APKBUILD
index f9d7ea2beb..f76be0f2d0 100644
--- a/main/ser2net/APKBUILD
+++ b/main/ser2net/APKBUILD
@@ -4,7 +4,7 @@ pkgname=ser2net
pkgver=3.4
pkgrel=1
pkgdesc="A proxy that allows telnet/tcp connections to be made to serial ports"
-url="http://sourceforge.net/projects/ser2net"
+url="https://sourceforge.net/projects/ser2net"
arch="all"
license="GPL"
depends=""
@@ -12,7 +12,7 @@ depends_dev=""
makedepends="$depends_dev linux-headers"
install=""
subpackages="$pkgname-doc"
-source="http://sourceforge.net/projects/ser2net/files/ser2net/ser2net-$pkgver.tar.gz
+source="https://sourceforge.net/projects/ser2net/files/ser2net/ser2net-$pkgver.tar.gz
TIOCSRS485.patch
${pkgname}.confd
${pkgname}.initd"
diff --git a/main/setup-box/APKBUILD b/main/setup-box/APKBUILD
index 66fa5b2b34..647ac1a6a4 100644
--- a/main/setup-box/APKBUILD
+++ b/main/setup-box/APKBUILD
@@ -4,7 +4,7 @@ pkgname=setup-box
pkgver=1.0.1
pkgrel=0
pkgdesc="A tool to setup a variety of Alpine Linux Environments"
-url="http://git.alpinelinux.org/cgit/alacerda/setup-box/"
+url="https://git.alpinelinux.org/cgit/alacerda/setup-box/"
arch="noarch"
license="MIT"
depends="jq"
diff --git a/main/sircbot/APKBUILD b/main/sircbot/APKBUILD
index 4f66d8f4e3..9471bf99ea 100644
--- a/main/sircbot/APKBUILD
+++ b/main/sircbot/APKBUILD
@@ -4,7 +4,7 @@ pkgname=sircbot
pkgver=0.4
pkgrel=1
pkgdesc="Minimalistic IRC bot"
-url="http://git.alpinelinux.org/cgit/sircbot/"
+url="https://git.alpinelinux.org/cgit/sircbot/"
arch="all"
license="GPL2"
pkgusers="sircbot"
diff --git a/main/smokeping/APKBUILD b/main/smokeping/APKBUILD
index 0c14e3a559..5e38b506e2 100644
--- a/main/smokeping/APKBUILD
+++ b/main/smokeping/APKBUILD
@@ -7,8 +7,8 @@ pkgdesc="Smokeping network latency monitoring"
pkgusers="smokeping"
pkggroups="smokeping"
install="$pkgname.pre-install"
-url="http://oss.oetiker.ch/smokeping/"
-source="http://oss.oetiker.ch/smokeping/pub/smokeping-$pkgver.tar.gz
+url="https://oss.oetiker.ch/smokeping/"
+source="https://oss.oetiker.ch/smokeping/pub/smokeping-$pkgver.tar.gz
smokeping.initd
musl-lc_numeric-utf8.patch
"
diff --git a/main/sngtc_client/APKBUILD b/main/sngtc_client/APKBUILD
index 503cf5cea6..2f5d02e094 100644
--- a/main/sngtc_client/APKBUILD
+++ b/main/sngtc_client/APKBUILD
@@ -4,7 +4,7 @@ pkgname=sngtc_client
pkgver=1.3.7
pkgrel=1
pkgdesc="Sangoma Media Transcode client and lib"
-url="http://wiki.sangoma.com/Transcoding-distributed-install"
+url="https://wiki.sangoma.com/Transcoding-distributed-install"
arch="all"
license="LGPL"
depends=""
diff --git a/main/snort/APKBUILD b/main/snort/APKBUILD
index 19845e76bf..14cf1114e9 100644
--- a/main/snort/APKBUILD
+++ b/main/snort/APKBUILD
@@ -5,7 +5,7 @@ pkgname=snort
pkgver=2.9.11
pkgrel=0
pkgdesc="An open source network intrusion prevention and detection system"
-url="http://www.snort.org/"
+url="https://www.snort.org/"
arch="all"
license="GPL"
makedepends="pcre-dev libpcap-dev libnet-dev libdnet-dev daq-dev
diff --git a/main/sntpc/APKBUILD b/main/sntpc/APKBUILD
index 8fd8fe7d6c..e9665cb5fd 100644
--- a/main/sntpc/APKBUILD
+++ b/main/sntpc/APKBUILD
@@ -4,7 +4,7 @@ pkgname=sntpc
pkgver=0.9
pkgrel=6
pkgdesc="Simple NTP client"
-url="http://git.alpinelinux.org/cgit/hosted/sntpc/"
+url="https://git.alpinelinux.org/cgit/hosted/sntpc/"
arch="all"
license="GPL2"
depends=""
diff --git a/main/soxr/APKBUILD b/main/soxr/APKBUILD
index dcaebc1422..fe3e9a0486 100644
--- a/main/soxr/APKBUILD
+++ b/main/soxr/APKBUILD
@@ -4,7 +4,7 @@ pkgname=soxr
pkgver=0.1.2
pkgrel=0
pkgdesc="High quality, one-dimensional sample-rate conversion library"
-url="http://sourceforge.net/projects/soxr/"
+url="https://sourceforge.net/projects/soxr/"
arch="all"
license="LGPL2"
depends=""
@@ -12,7 +12,7 @@ depends_dev="cmake"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.xz::http://sourceforge.net/projects/$pkgname/files/$pkgname-$pkgver-Source.tar.xz/download"
+source="$pkgname-$pkgver.tar.xz::https://sourceforge.net/projects/$pkgname/files/$pkgname-$pkgver-Source.tar.xz/download"
_builddir="$srcdir"/$pkgname-$pkgver-Source
build() {
cd "$_builddir"
diff --git a/main/spandsp/APKBUILD b/main/spandsp/APKBUILD
index 68f169f056..8dc5adc4af 100644
--- a/main/spandsp/APKBUILD
+++ b/main/spandsp/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.0.6
_ver=${pkgver/_/}
pkgrel=0
pkgdesc="SpanDSP is a library of DSP functions for telephony"
-url="http://www.soft-switch.org/installing-spandsp.html"
+url="https://www.soft-switch.org/installing-spandsp.html"
arch="all"
license="GPL"
depends=
diff --git a/main/speex/APKBUILD b/main/speex/APKBUILD
index f62b9e417e..3b4f4c7ea9 100644
--- a/main/speex/APKBUILD
+++ b/main/speex/APKBUILD
@@ -3,7 +3,7 @@ pkgname=speex
pkgver=1.2.0
pkgrel=0
pkgdesc="an audio compression format designed for speech"
-url="http://www.speex.org/"
+url="https://www.speex.org/"
arch="all"
license="BSD"
depends=
diff --git a/main/speexdsp/APKBUILD b/main/speexdsp/APKBUILD
index d7aaa44770..7e7f0c6ad3 100644
--- a/main/speexdsp/APKBUILD
+++ b/main/speexdsp/APKBUILD
@@ -4,7 +4,7 @@ pkgver=1.2_rc3
_ver=${pkgver%_*}${pkgver#*_}
pkgrel=4
pkgdesc="A voice compression format (DSP)"
-url="http://www.speex.org/"
+url="https://www.speex.org/"
arch="all"
license="BSD"
depends=
diff --git a/main/squark/APKBUILD b/main/squark/APKBUILD
index 985edf2fd0..f6cea311e4 100644
--- a/main/squark/APKBUILD
+++ b/main/squark/APKBUILD
@@ -8,7 +8,7 @@ depends="haserl"
makedepends="net-snmp-dev cmph-dev lua-dev"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
"
-url="http://git.alpinelinux.org/cgit/squark/"
+url="https://git.alpinelinux.org/cgit/squark/"
arch="all"
license=GPL2
install="$pkgname.post-install"
diff --git a/main/ssh-getkey-ldap/APKBUILD b/main/ssh-getkey-ldap/APKBUILD
index 617b4f05f4..0f86afcf28 100644
--- a/main/ssh-getkey-ldap/APKBUILD
+++ b/main/ssh-getkey-ldap/APKBUILD
@@ -10,7 +10,7 @@ license="MIT"
depends="lua lua-ldap"
makedepends=""
install="$pkgname.post-install"
-source="$pkgname-$pkgver.tar.gz::http://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
diff --git a/main/sshguard/APKBUILD b/main/sshguard/APKBUILD
index 9bbe445162..47221eeaca 100644
--- a/main/sshguard/APKBUILD
+++ b/main/sshguard/APKBUILD
@@ -4,7 +4,7 @@ pkgname=sshguard
pkgver=2.0.0
pkgrel=1
pkgdesc="Log monitor that blocks with iptables on bad behaviour"
-url="http://www.sshguard.net/"
+url="https://www.sshguard.net/"
arch="all"
license="BSD"
depends="iptables"
diff --git a/main/st/APKBUILD b/main/st/APKBUILD
index 1c34ca6c4d..4223e0a15b 100644
--- a/main/st/APKBUILD
+++ b/main/st/APKBUILD
@@ -4,7 +4,7 @@ pkgname=st
pkgver=0.7
pkgrel=1
pkgdesc="a simple terminal implementation for X"
-url="http://st.suckless.org/"
+url="https://st.suckless.org/"
arch="all"
license="MIT/X"
depends="ncurses-terminfo"
diff --git a/main/strongswan/APKBUILD b/main/strongswan/APKBUILD
index 7330f1c788..059f7fdf36 100644
--- a/main/strongswan/APKBUILD
+++ b/main/strongswan/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.6.0
_pkgver=${pkgver//_rc/rc}
pkgrel=1
pkgdesc="IPsec-based VPN solution focused on security and ease of use, supporting IKEv1/IKEv2 and MOBIKE"
-url="http://www.strongswan.org/"
+url="https://www.strongswan.org/"
arch="all"
pkgusers="ipsec"
pkggroups="ipsec"
diff --git a/main/sudo/APKBUILD b/main/sudo/APKBUILD
index f0d08830a4..e012792a77 100644
--- a/main/sudo/APKBUILD
+++ b/main/sudo/APKBUILD
@@ -10,7 +10,7 @@ else
fi
pkgrel=1
pkgdesc="Give certain users the ability to run some commands as root"
-url="http://www.sudo.ws/sudo/"
+url="https://www.sudo.ws/sudo/"
arch="all"
license="custom ISC"
makedepends="zlib-dev bash mdocml"
diff --git a/main/swatch/APKBUILD b/main/swatch/APKBUILD
index c16ec2ad11..79d8dadd94 100644
--- a/main/swatch/APKBUILD
+++ b/main/swatch/APKBUILD
@@ -5,7 +5,7 @@ _realname=swatchdog
pkgver=3.2.4
pkgrel=4
pkgdesc="Logfile monitoring tool"
-url="http://sourceforge.net/projects/swatch/"
+url="https://sourceforge.net/projects/swatch/"
arch="noarch"
license="GPL"
depends="perl perl-date-calc perl-date-format perl-date-manip perl-file-tail perl-carp-clan"
diff --git a/main/tar/APKBUILD b/main/tar/APKBUILD
index c111e56adc..182dee5171 100644
--- a/main/tar/APKBUILD
+++ b/main/tar/APKBUILD
@@ -3,7 +3,7 @@ pkgname=tar
pkgver=1.29
pkgrel=1
pkgdesc="Utility used to store, backup, and transport files"
-url="http://www.gnu.org"
+url="https://www.gnu.org"
arch="all"
license="GPL"
depends=""
diff --git a/main/texinfo/APKBUILD b/main/texinfo/APKBUILD
index 521e794a6c..0b2640fea2 100644
--- a/main/texinfo/APKBUILD
+++ b/main/texinfo/APKBUILD
@@ -3,7 +3,7 @@ pkgname=texinfo
pkgver=6.5
pkgrel=0
pkgdesc="Utilities to work with and produce manuals, ASCII text, and on-line documentation from a single source file"
-url="http://www.gnu.org/software/texinfo/"
+url="https://www.gnu.org/software/texinfo/"
arch="all"
license='GPL3+'
depends="perl"
diff --git a/main/tftp-hpa/APKBUILD b/main/tftp-hpa/APKBUILD
index 0cb9747a52..96da3e3176 100644
--- a/main/tftp-hpa/APKBUILD
+++ b/main/tftp-hpa/APKBUILD
@@ -3,13 +3,13 @@ pkgname=tftp-hpa
pkgver=5.2
pkgrel=2
pkgdesc="Official tftp server"
-url="http://www.kernel.org/pub/software/network/tftp/"
+url="https://www.kernel.org/pub/software/network/tftp/"
arch="all"
license="BSD"
depends=""
makedepends=""
subpackages="$pkgname-doc"
-source="http://www.kernel.org/pub/software/network/tftp/tftp-hpa/$pkgname-$pkgver.tar.xz
+source="https://www.kernel.org/pub/software/network/tftp/tftp-hpa/$pkgname-$pkgver.tar.xz
in.tftpd.initd
in.tftpd.confd
"
diff --git a/main/unionfs-fuse/APKBUILD b/main/unionfs-fuse/APKBUILD
index a4accd46df..2db845f819 100644
--- a/main/unionfs-fuse/APKBUILD
+++ b/main/unionfs-fuse/APKBUILD
@@ -3,7 +3,7 @@ pkgname=unionfs-fuse
pkgver=1.0
pkgrel=0
pkgdesc="Union Filesystem in Userspace"
-url="http://podgorny.cz/moin/UnionFsFuse"
+url="https://podgorny.cz/moin/UnionFsFuse"
arch="all"
license="BSD"
depends=""
diff --git a/main/wget/APKBUILD b/main/wget/APKBUILD
index ba647b6952..d544d41240 100644
--- a/main/wget/APKBUILD
+++ b/main/wget/APKBUILD
@@ -5,7 +5,7 @@ pkgname=wget
pkgver=1.19.2
pkgrel=1
pkgdesc="A network utility to retrieve files from the Web"
-url="http://www.gnu.org/software/wget/wget.html"
+url="https://www.gnu.org/software/wget/wget.html"
arch="all"
license="GPL3+"
depends=""
diff --git a/main/wv/APKBUILD b/main/wv/APKBUILD
index 5d23fe0107..4b131238a4 100644
--- a/main/wv/APKBUILD
+++ b/main/wv/APKBUILD
@@ -3,7 +3,7 @@ pkgname=wv
pkgver=1.2.9
pkgrel=3
pkgdesc="A library that can load and parse Word 2000, 97, 95 and 6 file formats"
-url="http://sourceforge.net/projects/wvware"
+url="https://sourceforge.net/projects/wvware"
arch="all"
license="GPL2+"
subpackages="$pkgname-dev $pkgname-doc"
diff --git a/main/xcb-proto/APKBUILD b/main/xcb-proto/APKBUILD
index 48f8e2a000..72eb12d579 100644
--- a/main/xcb-proto/APKBUILD
+++ b/main/xcb-proto/APKBUILD
@@ -3,14 +3,14 @@ pkgname=xcb-proto
pkgver=1.12
pkgrel=1
pkgdesc="XML-XCB protocol descriptions"
-url="http://xcb.freedesktop.org/"
+url="https://xcb.freedesktop.org/"
arch="noarch"
license="custom"
depends=
makedepends="python3"
# no testsuite
options="!check"
-source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2
+source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2
python3.patch"
builddir="${srcdir}/${pkgname}-${pkgver}"
diff --git a/main/xcb-util-cursor/APKBUILD b/main/xcb-util-cursor/APKBUILD
index 677eb5fd2d..d074a95c51 100644
--- a/main/xcb-util-cursor/APKBUILD
+++ b/main/xcb-util-cursor/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xcb-util-cursor
pkgver=0.1.3
pkgrel=1
pkgdesc="X C-language Binding - cursor library (port of libXcursor)"
-url="http://xcb.freedesktop.org/"
+url="https://xcb.freedesktop.org/"
arch="all"
license="MIT"
depends=
@@ -13,7 +13,7 @@ makedepends="$depends_dev m4 util-macros xcb-util-image-dev xcb-util-renderutil-
checkdepends="check-dev"
install=""
subpackages="$pkgname-dev"
-source="http://xcb.freedesktop.org/dist/xcb-util-cursor-$pkgver.tar.gz
+source="https://xcb.freedesktop.org/dist/xcb-util-cursor-$pkgver.tar.gz
"
build() {
diff --git a/main/xcb-util-image/APKBUILD b/main/xcb-util-image/APKBUILD
index fea8b78805..62d641d54a 100644
--- a/main/xcb-util-image/APKBUILD
+++ b/main/xcb-util-image/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xcb-util-image
pkgver=0.4.0
pkgrel=1
pkgdesc="X C-language Binding - port of Xlib XImage and XShmImage"
-url="http://xcb.freedesktop.org/"
+url="https://xcb.freedesktop.org/"
arch="all"
license="MIT"
depends=
@@ -14,7 +14,7 @@ checkdepends="check-dev"
install=""
replaces="xcb-util"
subpackages="$pkgname-dev"
-source="http://xcb.freedesktop.org/dist/xcb-util-image-$pkgver.tar.gz
+source="https://xcb.freedesktop.org/dist/xcb-util-image-$pkgver.tar.gz
"
build() {
diff --git a/main/xcb-util-keysyms/APKBUILD b/main/xcb-util-keysyms/APKBUILD
index 4645c9a8f2..2ed1a3862f 100644
--- a/main/xcb-util-keysyms/APKBUILD
+++ b/main/xcb-util-keysyms/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xcb-util-keysyms
pkgver=0.4.0
pkgrel=1
pkgdesc="X C-language Binding - X constants and keycodes"
-url="http://xcb.freedesktop.org/"
+url="https://xcb.freedesktop.org/"
arch="all"
license="MIT"
depends=
@@ -14,7 +14,7 @@ checkdepends="check-dev"
install=""
replaces="xcb-util"
subpackages="$pkgname-dev"
-source="http://xcb.freedesktop.org/dist/xcb-util-keysyms-$pkgver.tar.gz"
+source="https://xcb.freedesktop.org/dist/xcb-util-keysyms-$pkgver.tar.gz"
build() {
cd "$builddir"
diff --git a/main/xcb-util-renderutil/APKBUILD b/main/xcb-util-renderutil/APKBUILD
index 019d9a4611..587ae5d24e 100644
--- a/main/xcb-util-renderutil/APKBUILD
+++ b/main/xcb-util-renderutil/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xcb-util-renderutil
pkgver=0.3.9
pkgrel=1
pkgdesc="X C-language Binding - Convenience functions for XRender extension"
-url="http://xcb.freedesktop.org/"
+url="https://xcb.freedesktop.org/"
arch="all"
license="MIT"
depends=
@@ -14,7 +14,7 @@ checkdepends="check-dev"
install=""
replaces="xcb-util"
subpackages="$pkgname-dev"
-source="http://xcb.freedesktop.org/dist/xcb-util-renderutil-$pkgver.tar.gz"
+source="https://xcb.freedesktop.org/dist/xcb-util-renderutil-$pkgver.tar.gz"
build() {
cd "$builddir"
diff --git a/main/xcb-util-wm/APKBUILD b/main/xcb-util-wm/APKBUILD
index ce450a3e11..0faae8742f 100644
--- a/main/xcb-util-wm/APKBUILD
+++ b/main/xcb-util-wm/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xcb-util-wm
pkgver=0.4.1
pkgrel=1
pkgdesc="X C-language Binding - helpers for ICCCM and EWMH"
-url="http://xcb.freedesktop.org/"
+url="https://xcb.freedesktop.org/"
arch="all"
license="MIT"
depends=
@@ -14,7 +14,7 @@ checkdepends="check"
install=""
replaces="xcb-util"
subpackages="$pkgname-dev"
-source="http://xcb.freedesktop.org/dist/xcb-util-wm-$pkgver.tar.gz"
+source="https://xcb.freedesktop.org/dist/xcb-util-wm-$pkgver.tar.gz"
build() {
cd "$builddir"
diff --git a/main/xdg-utils/APKBUILD b/main/xdg-utils/APKBUILD
index 7325000d23..4083607801 100644
--- a/main/xdg-utils/APKBUILD
+++ b/main/xdg-utils/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xdg-utils
pkgver=1.1.2
pkgrel=0
pkgdesc="Basic desktop integration functions"
-url="http://portland.freedesktop.org/wiki/"
+url="https://portland.freedesktop.org/wiki/"
arch="noarch"
license="MIT"
depends="xset xprop"
diff --git a/main/xf86-video-modesetting/APKBUILD b/main/xf86-video-modesetting/APKBUILD
index 4121295b07..87dc2a6e63 100644
--- a/main/xf86-video-modesetting/APKBUILD
+++ b/main/xf86-video-modesetting/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xf86-video-modesetting
pkgver=0.9.0
pkgrel=6
pkgdesc="dummy package for compat - can safelu be removed"
-url="http://cgit.freedesktop.org/xorg/driver/xf86-video-modesetting/"
+url="https://cgit.freedesktop.org/xorg/driver/xf86-video-modesetting/"
arch="all"
license="MIT"
depends="xorg-server"
diff --git a/main/xf86-video-nouveau/APKBUILD b/main/xf86-video-nouveau/APKBUILD
index 0782def286..87665dbbdc 100644
--- a/main/xf86-video-nouveau/APKBUILD
+++ b/main/xf86-video-nouveau/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xf86-video-nouveau
pkgver=1.0.15
pkgrel=0
pkgdesc="Open-source X.org drivers for nVidia video cards"
-url="http://nouveau.freedesktop.org/"
+url="https://nouveau.freedesktop.org/"
arch="all"
license="MIT"
depends="mesa-dri-nouveau"
diff --git a/main/xfce4-appfinder/APKBUILD b/main/xfce4-appfinder/APKBUILD
index e167ffed13..4bc767af52 100644
--- a/main/xfce4-appfinder/APKBUILD
+++ b/main/xfce4-appfinder/APKBUILD
@@ -3,7 +3,7 @@ pkgname=xfce4-appfinder
pkgver=4.12.0
pkgrel=0
pkgdesc="Xfce application finder"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
depends="hicolor-icon-theme"
diff --git a/main/xfce4-dev-tools/APKBUILD b/main/xfce4-dev-tools/APKBUILD
index c2f96d73c7..57c89f79ec 100644
--- a/main/xfce4-dev-tools/APKBUILD
+++ b/main/xfce4-dev-tools/APKBUILD
@@ -3,7 +3,7 @@ pkgname=xfce4-dev-tools
pkgver=4.12.0
pkgrel=0
pkgdesc="Xfce developer tools"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
depends="automake autoconf make intltool pkgconfig libtool gtk-doc glib-dev"
diff --git a/main/xfce4-mixer/APKBUILD b/main/xfce4-mixer/APKBUILD
index 5bc3112778..7d8ecfa4a2 100644
--- a/main/xfce4-mixer/APKBUILD
+++ b/main/xfce4-mixer/APKBUILD
@@ -3,7 +3,7 @@ pkgname=xfce4-mixer
pkgver=4.11.0
pkgrel=2
pkgdesc="The volume control plugin for the Xfce panel"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
depends="hicolor-icon-theme"
diff --git a/main/xfce4-panel/APKBUILD b/main/xfce4-panel/APKBUILD
index 4618185f53..5ea5aaee1a 100644
--- a/main/xfce4-panel/APKBUILD
+++ b/main/xfce4-panel/APKBUILD
@@ -3,7 +3,7 @@ pkgname=xfce4-panel
pkgver=4.12.1
pkgrel=1
pkgdesc="Panel for the Xfce desktop environment"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
diff --git a/main/xfce4-session/APKBUILD b/main/xfce4-session/APKBUILD
index fbf2a9dab7..3528801332 100644
--- a/main/xfce4-session/APKBUILD
+++ b/main/xfce4-session/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xfce4-session
pkgver=4.12.1
pkgrel=2
pkgdesc="A session manager for Xfce"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
diff --git a/main/xfce4-settings/APKBUILD b/main/xfce4-settings/APKBUILD
index 7cb718b8ba..1b095e9fb9 100644
--- a/main/xfce4-settings/APKBUILD
+++ b/main/xfce4-settings/APKBUILD
@@ -3,7 +3,7 @@ pkgname=xfce4-settings
pkgver=4.12.1
pkgrel=0
pkgdesc="Settings manager for xfce"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
depends=
diff --git a/main/xfce4-terminal/APKBUILD b/main/xfce4-terminal/APKBUILD
index 632b338148..3d7cef0d71 100644
--- a/main/xfce4-terminal/APKBUILD
+++ b/main/xfce4-terminal/APKBUILD
@@ -3,7 +3,7 @@ pkgname=xfce4-terminal
pkgver=0.6.3
pkgrel=1
pkgdesc="A modern terminal emulator primarly for the Xfce desktop environment"
-url="http://www.xfce.org/projects/terminal/"
+url="https://xfce.org/projects/terminal/"
arch="all"
license="GPL2"
subpackages="$pkgname-doc $pkgname-lang"
diff --git a/main/xfce4-whiskermenu-plugin/APKBUILD b/main/xfce4-whiskermenu-plugin/APKBUILD
index 8eeabd86cf..c33761c3c6 100644
--- a/main/xfce4-whiskermenu-plugin/APKBUILD
+++ b/main/xfce4-whiskermenu-plugin/APKBUILD
@@ -3,7 +3,7 @@ pkgname=xfce4-whiskermenu-plugin
pkgver=1.7.3
pkgrel=0
pkgdesc="alternate application launcher for Xfce"
-url="http://gottcode.org/xfce4-whiskermenu-plugin/"
+url="https://gottcode.org/xfce4-whiskermenu-plugin/"
arch="all"
license="GPL2"
depends=""
diff --git a/main/xfce4/APKBUILD b/main/xfce4/APKBUILD
index cd55adb198..8a9c08bc2f 100644
--- a/main/xfce4/APKBUILD
+++ b/main/xfce4/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xfce4
pkgver=4.12.0
pkgrel=1
pkgdesc="XFCE 4 meta package"
-url="http://www.xfce.org"
+url="https://xfce.org"
arch="noarch"
license="GPL"
# https://mail.xfce.org/pipermail/xfce-announce/2015-February/000389.html
diff --git a/main/xfconf/APKBUILD b/main/xfconf/APKBUILD
index e111b2ea63..fdb83a53fa 100644
--- a/main/xfconf/APKBUILD
+++ b/main/xfconf/APKBUILD
@@ -3,7 +3,7 @@ pkgname=xfconf
pkgver=4.12.1
pkgrel=2
pkgdesc="Hierarchical configuration system for Xfce"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
options="!check" # Requires running dbus daemon.
diff --git a/main/xfdesktop/APKBUILD b/main/xfdesktop/APKBUILD
index 250d1eaa7e..3e39ceed85 100644
--- a/main/xfdesktop/APKBUILD
+++ b/main/xfdesktop/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xfdesktop
pkgver=4.12.4
pkgrel=0
pkgdesc="A desktop manager for Xfce"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
subpackages="$pkgname-doc $pkgname-lang"
diff --git a/main/xfwm4-themes/APKBUILD b/main/xfwm4-themes/APKBUILD
index 22396744e8..8733debc99 100644
--- a/main/xfwm4-themes/APKBUILD
+++ b/main/xfwm4-themes/APKBUILD
@@ -3,7 +3,7 @@ pkgname=xfwm4-themes
pkgver=4.10.0
pkgrel=0
pkgdesc="A set of additionnal themes for the Xfce window manager"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="noarch"
license="GPL2"
depends="xfwm4"
diff --git a/main/xfwm4/APKBUILD b/main/xfwm4/APKBUILD
index cd6a751f87..b8118a65e2 100644
--- a/main/xfwm4/APKBUILD
+++ b/main/xfwm4/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xfwm4
pkgver=4.12.4
pkgrel=1
pkgdesc="Xfce window manager, compatible with Gnome, Gnome2, KDE2, and KDE3"
-url="http://www.xfce.org/"
+url="https://xfce.org/"
arch="all"
license="GPL2"
depends="hicolor-icon-theme"
diff --git a/main/xmlindent/APKBUILD b/main/xmlindent/APKBUILD
index 1808ba85d0..7c6d42672e 100644
--- a/main/xmlindent/APKBUILD
+++ b/main/xmlindent/APKBUILD
@@ -11,7 +11,7 @@ depends=""
makedepends="flex-dev"
install=""
subpackages="$pkgname-doc"
-source="http://sourceforge.net/projects/xmlindent/files/xmlindent/$pkgver/xmlindent-$pkgver.tar.gz"
+source="https://sourceforge.net/projects/xmlindent/files/xmlindent/$pkgver/xmlindent-$pkgver.tar.gz"
_builddir="$srcdir"/xmlindent-$pkgver
prepare() {
diff --git a/main/xprop/APKBUILD b/main/xprop/APKBUILD
index 83c0aa50ee..36527af89b 100644
--- a/main/xprop/APKBUILD
+++ b/main/xprop/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xprop
pkgver=1.2.1
pkgrel=1
pkgdesc="Property displayer for X"
-url="http://cgit.freedesktop.org/xorg/app/xprop/"
+url="https://cgit.freedesktop.org/xorg/app/xprop/"
arch="all"
license="AS-IS"
depends=
diff --git a/main/xscreensaver/APKBUILD b/main/xscreensaver/APKBUILD
index cc4d8239fe..92d05369e4 100644
--- a/main/xscreensaver/APKBUILD
+++ b/main/xscreensaver/APKBUILD
@@ -4,7 +4,7 @@ pkgname=xscreensaver
pkgver=5.36
pkgrel=0
pkgdesc="screensavers for X11 environment"
-url="http://www.jwz.org/xscreensaver/"
+url="https://www.jwz.org/xscreensaver/"
license="GPL"
depends="bc"
makedepends="gtk+-dev libjpeg-turbo-dev mesa-dev gettext-dev libxmu-dev perl
diff --git a/main/xwininfo/APKBUILD b/main/xwininfo/APKBUILD
index bc11ecec8d..cc4c4aea18 100644
--- a/main/xwininfo/APKBUILD
+++ b/main/xwininfo/APKBUILD
@@ -3,7 +3,7 @@ pkgname=xwininfo
pkgver=1.1.3
pkgrel=0
pkgdesc="Window information utility for X"
-url="http://cgit.freedesktop.org/xorg/app/xwininfo/"
+url="https://cgit.freedesktop.org/xorg/app/xwininfo/"
arch="all"
license="custom"
options="!check" # No test suite.
diff --git a/main/xz/APKBUILD b/main/xz/APKBUILD
index f22987e15e..a4a8b47df4 100644
--- a/main/xz/APKBUILD
+++ b/main/xz/APKBUILD
@@ -4,13 +4,13 @@ pkgname=xz
pkgver=5.2.3
pkgrel=1
pkgdesc="Library and command line tools for XZ and LZMA compressed files"
-url="http://tukaani.org/xz/"
+url="https://tukaani.org/xz/"
arch="all"
license="custom"
depends=""
makedepends=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="http://tukaani.org/xz/xz-$pkgver.tar.gz"
+source="https://tukaani.org/xz/xz-$pkgver.tar.gz"
build() {
cd "$builddir"
diff --git a/main/zd1211-firmware/APKBUILD b/main/zd1211-firmware/APKBUILD
index 45a9cc075f..ac81d9b54f 100644
--- a/main/zd1211-firmware/APKBUILD
+++ b/main/zd1211-firmware/APKBUILD
@@ -4,7 +4,7 @@ pkgname=zd1211-firmware
pkgver=1.5
pkgrel=0
pkgdesc="Firmware for ZyDAS ZD1211 USB-WLAN devices supported by the zd1211rw driver"
-url="http://sourceforge.net/projects/zd1211/"
+url="https://sourceforge.net/projects/zd1211/"
arch="noarch"
license="GPL2"
depends=""
diff --git a/main/zmap/APKBUILD b/main/zmap/APKBUILD
index 89ff815170..68b4f9ffcc 100644
--- a/main/zmap/APKBUILD
+++ b/main/zmap/APKBUILD
@@ -5,7 +5,7 @@ pkgname=zmap
pkgver=2.1.1
pkgrel=1
pkgdesc="A high performance internet scanner"
-url="http://www.zmap.io/"
+url="https://www.zmap.io/"
arch="all"
license="Apache-2"
depends=""