aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 07:26:08 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 07:26:08 -0300
commit73cdf09251eb092f395638fed16a0068dc34f408 (patch)
treebf8719cb7bde1298833696f13ccc712c3e75c53c
parent0224515a5c77e0114980724db9f5591ff76779c4 (diff)
community/py3-zope-deprecation: drop py2
-rw-r--r--community/py3-zope-deprecation/APKBUILD39
1 files changed, 9 insertions, 30 deletions
diff --git a/community/py3-zope-deprecation/APKBUILD b/community/py3-zope-deprecation/APKBUILD
index 3d425fd32f4..476a5fec402 100644
--- a/community/py3-zope-deprecation/APKBUILD
+++ b/community/py3-zope-deprecation/APKBUILD
@@ -1,52 +1,31 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-zope-deprecation
+pkgname=py3-zope-deprecation
_pkgname=zope.deprecation
pkgver=4.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Zope Deprecation Infrastructure"
-url="https://pypi.python.org/pypi/zope.deprecation"
+url="https://github.com/zopefoundation/zope.deprecation"
arch="noarch"
license="ZPL-2.1"
-depends="py-setuptools"
-makedepends="python2-dev python3-dev"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-setuptools"
+# checkdepends="py3-zope-testrunner" # Is in upper repo
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-zope-deprecation" # Backwards compatibility
+provides="py-zope-deprecation=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
- python2 setup.py test
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="62371dc45fad6715f24cdcac1d25b559ed5248da774b5ecd215fb4d0b6fc0ab655bfb9e0fbceda964e8ffb7d70536e43f8fcf09d9f2742904717a6473869fa4a zope.deprecation-4.4.0.tar.gz"