aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-21 03:23:45 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-21 10:39:21 +0000
commit7484662a3a6118f0a2bfd4b403ab946962012d8f (patch)
treeceed3e8fe28ccdb045e54d179723e4d525652713
parentccb23306bc8a14b6aba9fbe76b0d88267b02e4c0 (diff)
main/cython: upgrade to 0.29.19
-rw-r--r--main/cython/APKBUILD9
-rw-r--r--main/cython/Use-platform-dependent-test-for-unpacked_struct_with_arrays.patch31
2 files changed, 3 insertions, 37 deletions
diff --git a/main/cython/APKBUILD b/main/cython/APKBUILD
index e79fec18f93..b6b6a41127f 100644
--- a/main/cython/APKBUILD
+++ b/main/cython/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Oleg Titov <oleg.titov@gmail.com>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=cython
-pkgver=0.29.18
+pkgver=0.29.19
pkgrel=0
pkgdesc="Cython is an optimising static compiler for both the Python & the extended Cython programming languages."
url="https://cython.org/"
@@ -10,9 +10,7 @@ arch="all"
license="Apache-2.0"
makedepends="py3-setuptools python3-dev"
subpackages="cython-doc"
-source="cython-$pkgver.tar.gz::https://github.com/cython/cython/archive/$pkgver.tar.gz
- Use-platform-dependent-test-for-unpacked_struct_with_arrays.patch
- "
+source="cython-$pkgver.tar.gz::https://github.com/cython/cython/archive/$pkgver.tar.gz"
# compatible fix for removing dev subpkg from apkbuild
# cython is not a library but a compiler and does not need a dev subpackage
@@ -33,5 +31,4 @@ package() {
install -Dm 644 README.rst "$pkgdir/usr/share/doc/cython/readme.rst"
}
-sha512sums="5a1430345fbe42235a58fd44dd4e4ce17c68485349295af6c4e9a01a06117e18ee7700c34fb5974759f012acd5cf8400ed014ef16397539272c38881e905234a cython-0.29.18.tar.gz
-30f4a43dc18a6e42cec9ad7b8152f59e7856f3dc90f58fa7e76fc16dfa6364174401b4fb40be8fe810c3cf272b238d13084dc1928d5d85e72a8c609eea0b15d6 Use-platform-dependent-test-for-unpacked_struct_with_arrays.patch"
+sha512sums="402f95f82099db0ae99ca2f849a9aef97558c9c6be62d3b3c66c346ecc94efbbe824ffc77f3cc6dd1d7054a2fb0332b10fe855ca1b054095f2df2ee297fd96a7 cython-0.29.19.tar.gz"
diff --git a/main/cython/Use-platform-dependent-test-for-unpacked_struct_with_arrays.patch b/main/cython/Use-platform-dependent-test-for-unpacked_struct_with_arrays.patch
deleted file mode 100644
index 623115c6bb6..00000000000
--- a/main/cython/Use-platform-dependent-test-for-unpacked_struct_with_arrays.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 7360793bcd73f7b1238cbefe51636899741170c3 Mon Sep 17 00:00:00 2001
-From: Simon Mutch <smutch@unimelb.edu.au>
-Date: Wed, 20 May 2020 17:52:57 +1000
-Subject: [PATCH] Use platform dependent test for unpacked_struct_with_arrays
-
----
- tests/buffers/buffmt.pyx | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/tests/buffers/buffmt.pyx b/tests/buffers/buffmt.pyx
-index 5d015e4bff..0aa0cb3259 100644
---- a/tests/buffers/buffmt.pyx
-+++ b/tests/buffers/buffmt.pyx
-@@ -1,4 +1,5 @@
- from __future__ import unicode_literals
-+import struct
-
- # Tests buffer format string parsing.
-
-@@ -442,7 +443,10 @@ def packed_struct_with_arrays(fmt):
- @testcase
- def unpacked_struct_with_arrays(fmt):
- """
-- >>> unpacked_struct_with_arrays("T{i:a:(8)f:b:f:c:Q:d:(5)i:e:i:f:i:g:xxxx(4)d:h:i:i:}")
-+ >>> if struct.calcsize('P') == 8: # 64 bit
-+ ... unpacked_struct_with_arrays("T{i:a:(8)f:b:f:c:Q:d:(5)i:e:i:f:i:g:xxxx(4)d:h:i:i:}")
-+ ... elif struct.calcsize('P') == 4: # 32 bit
-+ ... unpacked_struct_with_arrays("T{i:a:(8)f:b:f:c:Q:d:(5)i:e:i:f:i:g:(4)d:h:i:i:}")
- """
-
- cdef object[UnpackedStructWithArrays] buf = MockBuffer(