aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAiden Grossman <agrossman154@yahoo.com>2022-10-09 23:46:11 +0000
committeralice <alice@ayaya.dev>2022-10-10 04:55:44 +0000
commit7587bb5421cc19da99fdaa5d3fca8c14df403683 (patch)
treeff6703c2e647701331665465e9f3126dd1cfc1f4
parentf4a1390eea0f6ea21714b835b79a3e95991ce9e9 (diff)
testing/opencascade: rebuild against vtk 9.2.2
-rw-r--r--testing/opencascade/APKBUILD6
-rw-r--r--testing/opencascade/x11vtkconflict.patch19
2 files changed, 23 insertions, 2 deletions
diff --git a/testing/opencascade/APKBUILD b/testing/opencascade/APKBUILD
index 21322fbc6c0..4c73f582a50 100644
--- a/testing/opencascade/APKBUILD
+++ b/testing/opencascade/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
pkgname=opencascade
pkgver=7.6.3
-pkgrel=0
+pkgrel=1
pkgdesc="An SDK for development of applications dealing with 3D CAD data"
url="https://dev.opencascade.org/"
# s390x blocked by vtk -> netcdf
@@ -32,6 +32,7 @@ source="$pkgname-$pkgver-updatecache.tar.gz::https://github.com/Open-Cascade-SAS
cmake_add_buildtype_none.patch
no_backtrace.patch
fix-tbb-2021.patch
+ x11vtkconflict.patch
"
builddir="$srcdir/OCCT-${pkgver//./_}"
options="!check" # No tests provided :-/
@@ -49,7 +50,7 @@ build() {
-DUSE_FFMPEG=OFF \
-DUSE_VTK=ON \
-DUSE_TBB=ON \
- -D3RDPARTY_VTK_INCLUDE_DIR=/usr/include/vtk-9.1/
+ -D3RDPARTY_VTK_INCLUDE_DIR=/usr/include/vtk-9.2/
cmake --build build
}
@@ -65,4 +66,5 @@ b039b8fce696bfd0f53309a72adab4065780bf1755da6208040157e9383deb0061ad8927a6f16073
4bdedc8f0e011530115777cddeeb898750242999725347c3392d8858e5cc9543c791814aa41e1543c575a6a79b0b32fd72970bb83c8948fe42f33993244db1cf cmake_add_buildtype_none.patch
86dceb6e8309e18f5ea72ce2e3524ff08dc761ffe76557d62a1a4f2824ca0e2f9dfc194cae22164aaaf5ad9a15a6ec0f1fef443241aa2ccb0a2140de217c8a90 no_backtrace.patch
80a5fdfec8159bfcfa2dce8f6635c8567eef64b0b142046ed2b7fc7a77849d14ae9b588b04daf5b5789d18130cbc40c5396af22787f38d8cd425f9f53d1fff9c fix-tbb-2021.patch
+8f5abf58f4a1b84aee99c75bbaeb2267655f306b6a3e12600a4db34201106dd380c7e30e37d4db81841be8ba9455604a10bfaa6e50e73801097ce141840f3d8e x11vtkconflict.patch
"
diff --git a/testing/opencascade/x11vtkconflict.patch b/testing/opencascade/x11vtkconflict.patch
new file mode 100644
index 00000000000..16c89b944c2
--- /dev/null
+++ b/testing/opencascade/x11vtkconflict.patch
@@ -0,0 +1,19 @@
+--- ./src/IVtkDraw/IVtkDraw_Interactor.cxx.orig
++++ ./src/IVtkDraw/IVtkDraw_Interactor.cxx
+@@ -27,6 +27,16 @@
+ #undef AllValues
+ #endif
+
++// Prevent naming collisions between X11
++// and VTK versions 9.2.0 and above.
++// X11 is included through glx
++#ifdef Status
++#undef Status
++#endif
++#ifdef Success
++#undef Success
++#endif
++
+ #include <vtkXRenderWindowInteractor.h>
+ #include <vtkXOpenGLRenderWindow.h>
+ #endif