aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-11-16 13:13:37 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2019-11-16 13:20:56 +0100
commit7598d3dac27f3ac3965d6d743e19f947243e0ec2 (patch)
tree3037142368f58049484474461f4ddfafc4d88d99
parent50566d702ebe539af978b0ebb1ea5f3aa4f9264c (diff)
main/atop: don't patch the makefile
Instead modify it using sed in prepare(). More consistent since existing modifications to the Makefile are already made in this place.
-rw-r--r--main/atop/APKBUILD6
-rw-r--r--main/atop/fix-Makefile.patch13
2 files changed, 3 insertions, 16 deletions
diff --git a/main/atop/APKBUILD b/main/atop/APKBUILD
index de2a2d25a41..717ccf9b58a 100644
--- a/main/atop/APKBUILD
+++ b/main/atop/APKBUILD
@@ -13,7 +13,6 @@ source="https://www.atoptool.nl/download/atop-$pkgver.tar.gz
atop-daily-bb.patch
atop-include-macros.patch
atop.initd
- fix-Makefile.patch
"
options="suid"
@@ -22,7 +21,9 @@ prepare() {
default_prepare
sed -i -e '/^CFLAGS/s: = -O : += :' \
+ -e '/DEFPATH/d' \
-e '/^LDFLAGS/s: = : += :' Makefile
+
cp "$srcdir"/atop.initd atop.init
chmod a+rx atop.init
}
@@ -48,5 +49,4 @@ sha512sums="675bbd902d8fe584b1ff47c275ee06d7bfe9127fadf79825ca64bbb6bcb6c34cab48
165e5f17f1a752f8663a774d72476eac5693f93922b32fa198f09233ca6dfde2d6c63b10c31d0388ac9f10d210e7067787f30ef25e0ef9419a1520486f290b15 atop-bb-compat.patch
664225450074962aac0e13484c9b2feaf08620bbe1e0f9c5dc1b02f1ecd315224cd04df53134f2d107210fc9223a64d8885ae70d33d0663c2335fa6d46f6ddfd atop-daily-bb.patch
f30c9e6051332af8c8cafcd881f89a0e2d2a8e1d84eee8ac0c8c6b58f3ae3431fcf9c40dea6d03e271f8969802de449d33b4323c13045bdb38a539732c81a8b6 atop-include-macros.patch
-172c9d367b936427ccbbbd1140c7808ec8ffe3194b3557ba024820dac8fa68c9919f7dc34d332e91283fde64d731db7bdbfee3c2d6caad3cd291e0f1c227cb03 atop.initd
-9e3d2c5c4ead0ce60c7dd74d2f2362777176bff64c28779a20a8837c0f4b2bf5413836f7ae4b9de74aa5aa07892f511f62b56702b6126248eef780a5db855e02 fix-Makefile.patch"
+172c9d367b936427ccbbbd1140c7808ec8ffe3194b3557ba024820dac8fa68c9919f7dc34d332e91283fde64d731db7bdbfee3c2d6caad3cd291e0f1c227cb03 atop.initd"
diff --git a/main/atop/fix-Makefile.patch b/main/atop/fix-Makefile.patch
deleted file mode 100644
index a6cbc709787..00000000000
--- a/main/atop/fix-Makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/Makefile 2019-11-09 13:53:03.712153728 +0100
-+++ b/Makefile 2019-11-09 13:54:27.943704512 +0100
-@@ -151,8 +151,8 @@
- if [ ! -d $(DESTDIR)$(MAN8PATH) ]; \
- then mkdir -p $(DESTDIR)$(MAN8PATH); fi
- #
-- touch $(DESTDIR)$(DEFPATH)/atop
-- chmod 644 $(DESTDIR)$(DEFPATH)/atop
-+ #touch $(DESTDIR)$(DEFPATH)/atop
-+ #chmod 644 $(DESTDIR)$(DEFPATH)/atop
- #
- cp atop $(DESTDIR)$(BINPATH)/atop
- chown root $(DESTDIR)$(BINPATH)/atop