aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2021-03-27 12:30:17 +0100
committerRasmus Thomsen <oss@cogitri.dev>2021-03-27 12:55:05 +0000
commit75a4782528b5a62d46984a9401ab904f843cc898 (patch)
tree4095432c5f44c9c4ca9eb80df49b370a1cb2a6cb
parent730380cd0aaa7bdf1155f30e7bbc30f5cec63941 (diff)
downloadaports-75a4782528b5a62d46984a9401ab904f843cc898.tar.gz
aports-75a4782528b5a62d46984a9401ab904f843cc898.tar.bz2
aports-75a4782528b5a62d46984a9401ab904f843cc898.tar.xz
main/gcr: upgrade to 3.40.0
-rw-r--r--main/gcr/APKBUILD6
-rw-r--r--main/gcr/allow-building-without-gpg.patch39
2 files changed, 2 insertions, 43 deletions
diff --git a/main/gcr/APKBUILD b/main/gcr/APKBUILD
index d510afd46d0..3f8b3b23be8 100644
--- a/main/gcr/APKBUILD
+++ b/main/gcr/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gcr
-pkgver=3.38.1
+pkgver=3.40.0
pkgrel=0
pkgdesc="library for bits of crypto UI and parsing"
options="!check" # Testsuite requires community/xvfb-run
@@ -14,7 +14,6 @@ makedepends="glib-dev gtk+3.0-dev libgcrypt-dev p11-kit-dev
checkdepends="xvfb-run dbus-x11"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-base"
source="https://download.gnome.org/sources/gcr/${pkgver%.*}/gcr-$pkgver.tar.xz
- allow-building-without-gpg.patch
dont-run-gpg-tests.patch
fix-64-bit-time_t-32-bit.patch"
@@ -42,7 +41,6 @@ base() {
"$subpkgdir"/usr/lib
}
-sha512sums="4dc8c3f84023a7cd6f069f4529cb063d7153e589c2f9547410c7eeb5298dc238ea7fc4f22e22d8c237391f31bfcd814190e55125195f20b913665b9ca81d9c21 gcr-3.38.1.tar.xz
-7cca3fd0512621129f0a0c532a3592b4ea0e49f887cf5935b1a104363d08fca05dbba470672561efa4b8b02efdbe22c948f989af26fdb32833a82383393207f0 allow-building-without-gpg.patch
+sha512sums="7118608e7bef7d0cf2eea33cb3286b7f9c3622a38892ce88cf33ed453d343cc33e070831e7b4d0c5cdb43c2e57b3f0b91c7cbd6aa8463982d3af8844b59bcb81 gcr-3.40.0.tar.xz
e4fc2248497e7103980e9baf9444505649ee93c657c7a82c042ae62d7c54b2764ad7bc9780467ceda5e53a23fa11dc4957898929c7d7f995d9d0d205d18d5eb7 dont-run-gpg-tests.patch
579b229d6f310ed035974a92a65804deae7b047cf6109e259844ecdc75df32653a2c9f9dcddba9092da335f44d07d5d82056ae0cf5775057bdb9be5b52e29bcc fix-64-bit-time_t-32-bit.patch"
diff --git a/main/gcr/allow-building-without-gpg.patch b/main/gcr/allow-building-without-gpg.patch
deleted file mode 100644
index 7560419e8d1..00000000000
--- a/main/gcr/allow-building-without-gpg.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Upstream: See https://gitlab.gnome.org/GNOME/gcr/-/merge_requests/50
-diff --git a/meson.build b/meson.build
-index f19af0f..57b625b 100644
---- a/meson.build
-+++ b/meson.build
-@@ -41,7 +41,10 @@ gobject_dep = dependency('gobject-2.0', version: '>=' + min_glib_version)
- gio_dep = dependency('gio-2.0', version: '>=' + min_glib_version)
- gio_unix_dep = dependency('gio-unix-2.0',version: '>=' + min_glib_version)
- glib_deps = [ glib_dep, gmodule_dep, gthread_dep, gobject_dep, gio_dep, gio_unix_dep, ]
--gpg_bin = find_program('gpg2', 'gpg')
-+gpg_path = get_option('gpg_path')
-+if gpg_path == ''
-+ gpg_path = find_program('gpg2', 'gpg').path()
-+endif
- libgcrypt_dep = dependency('libgcrypt', version: '>= 1')
- p11kit_dep = dependency('p11-kit-1', version: '>= 0.19.0')
- p11_system_config_modules = p11kit_dep.get_pkgconfig_variable('p11_system_config_modules')
-@@ -65,7 +68,7 @@ conf.set('HAVE_GETTEXT', true)
- conf.set('HAVE_LOCALE_H', cc.has_header('locale.h'))
- conf.set('HAVE_TIMEGM', cc.has_function('timegm'))
- conf.set('HAVE_MLOCK', cc.has_function('mlock'))
--conf.set_quoted('GPG_EXECUTABLE', gpg_bin.path())
-+conf.set_quoted('GPG_EXECUTABLE', gpg_path)
- conf.set_quoted('LIBGCRYPT_VERSION', libgcrypt_dep.version())
- config_file = configure_file(
- output: 'config.h',
-diff --git a/meson_options.txt b/meson_options.txt
-index bbdc8e3..ae0f524 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -13,3 +13,8 @@ option('gtk_doc',
- value: true,
- description: 'Build the reference documentation (requires gtk-doc)',
- )
-+option('gpg_path',
-+ type: 'string',
-+ value: '',
-+ description: 'Path to gpg, autodetected if not set',
-+)