aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-12-31 10:03:14 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-12-31 10:03:46 +0200
commit75f774b240ee496c4fac80a4978ec3a943a3b422 (patch)
tree56e446dd31a66927b6c4b08932b971d397ae3c2e
parent0d54ca29debcb927176f0b6045bee3169a4acf18 (diff)
main/raspberrypi: fix build on builders
Remove bash dependency. Any shall will do.
-rw-r--r--main/raspberrypi/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/raspberrypi/APKBUILD b/main/raspberrypi/APKBUILD
index 573366fb914..d0a30c6ce5f 100644
--- a/main/raspberrypi/APKBUILD
+++ b/main/raspberrypi/APKBUILD
@@ -18,6 +18,11 @@ source="raspberrypi-$pkgver.tar.gz::https://github.com/raspberrypi/userland/arch
builddir="$srcdir"/userland-$_commitid
+prepare() {
+ default_prepare
+ sed -i 's/ bash / sh /g' host_applications/linux/apps/raspicam/CMakeLists.txt
+}
+
build() {
cd "$builddir"
case "$CARCH" in
@@ -34,7 +39,7 @@ build() {
package() {
cd "$builddir"
- make install DESTDIR="$pkgdir" || return 1
+ make install DESTDIR="$pkgdir"
# nuke the unwanted stuff
rm -rf "$pkgdir"/opt/vc/src