aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2021-05-06 13:36:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2021-05-06 13:36:19 +0000
commit76e4f92ab575b040457503f1bd548922a92e2e58 (patch)
tree9c02d8e81a23affd4b36b0ca884f2e5bcccb966e
parent1b1ab7bc2153bb43006c0186f7cd74c2865246c3 (diff)
main/abuild: upgrade to 3.8.0_rc2
-rw-r--r--main/abuild/0001-tests-fix-with-busybox-sha512sum-and-misc-cleanups.patch51
-rw-r--r--main/abuild/0002-tests-fix-abump-to-work-without-configured-git-user.patch33
-rw-r--r--main/abuild/APKBUILD10
3 files changed, 3 insertions, 91 deletions
diff --git a/main/abuild/0001-tests-fix-with-busybox-sha512sum-and-misc-cleanups.patch b/main/abuild/0001-tests-fix-with-busybox-sha512sum-and-misc-cleanups.patch
deleted file mode 100644
index d0599acae84..00000000000
--- a/main/abuild/0001-tests-fix-with-busybox-sha512sum-and-misc-cleanups.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 57ec5043f079fcf312442d26ce8421ef0b122890 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 30 Apr 2021 13:57:20 +0200
-Subject: [PATCH 1/2] tests: fix with busybox sha512sum and misc cleanups
-
----
- tests/abuild.bats | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/tests/abuild.bats b/tests/abuild.bats
-index 79e146a..e46cee4 100644
---- a/tests/abuild.bats
-+++ b/tests/abuild.bats
-@@ -88,7 +88,7 @@ teardown() {
-
- @test "abuild: test checksum generation" {
- mkdir -p "$tmpdir"/foo
-- cat >> "$tmpdir"/foo/APKBUILD <<-EOF
-+ cat > "$tmpdir"/foo/APKBUILD <<-EOF
- pkgname="foo"
- pkgver="1.0"
- source="test.txt"
-@@ -96,14 +96,14 @@ teardown() {
- echo "foo" > "$tmpdir"/foo/test.txt
- cd "$tmpdir"/foo
- $ABUILD checksum
-- . ./APKBUILD && echo "$sha512sums" > sums
-+ . ./APKBUILD && echo "$sha512sums" | sed '/^$/d' > sums
- cat sums
- sha512sum -c sums
- }
-
- @test "abuild: test duplicates in checksum generation" {
- mkdir -p "$tmpdir"/foo "$tmpdir"/foo/dir1 "$tmpdir"/foo/dir2
-- cat >> "$tmpdir"/foo/APKBUILD <<-EOF
-+ cat > "$tmpdir"/foo/APKBUILD <<-EOF
- pkgname="foo"
- pkgver="1.0"
- source="dir1/testfile dir2/testfile"
-@@ -117,7 +117,7 @@ teardown() {
-
- @test "abuild: test that -dbg should be first" {
- mkdir -p "$tmpdir"/foo
-- cat >> "$tmpdir"/foo/APKBUILD <<-EOF
-+ cat > "$tmpdir"/foo/APKBUILD <<-EOF
- # Maintainer: Test user <user@example.com>
- pkgname="foo"
- pkgver="1.0"
---
-2.31.1
-
diff --git a/main/abuild/0002-tests-fix-abump-to-work-without-configured-git-user.patch b/main/abuild/0002-tests-fix-abump-to-work-without-configured-git-user.patch
deleted file mode 100644
index 8583e5c1511..00000000000
--- a/main/abuild/0002-tests-fix-abump-to-work-without-configured-git-user.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 8aacd4783fa30fe11fb323103f0b901c674acb71 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 30 Apr 2021 15:55:22 +0200
-Subject: [PATCH 2/2] tests: fix abump to work without configured git user
-
----
- tests/abump.bats | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/tests/abump.bats b/tests/abump.bats
-index e9bda21..1dc77e5 100644
---- a/tests/abump.bats
-+++ b/tests/abump.bats
-@@ -6,6 +6,7 @@ setup() {
- export ABUILD_CONF=/dev/null
- tmpdir="$BATS_TMPDIR"/abump
- export ABUILD_USERDIR="$tmpdir"/.config
-+ export PACKAGER="Test User <user@example.com>"
- export REPODEST="$tmpdir"/packages
- mkdir -p $tmpdir
- export CLEANUP="srcdir bldroot pkgdir deps"
-@@ -16,7 +17,7 @@ setup() {
- $ABUILD_KEYGEN --append -n
-
- cd "$tmpdir"
-- git init
-+ git init --quiet
- }
-
- teardown() {
---
-2.31.1
-
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 9fc7dd2c1ff..6c88acb220e 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abuild
-pkgver=3.8.0_rc1
+pkgver=3.8.0_rc2
_ver=${pkgver%_git*}
-pkgrel=1
+pkgrel=0
pkgdesc="Script to build Alpine Packages"
url="https://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -27,8 +27,6 @@ subpackages="
options="suid"
pkggroups="abuild"
source="https://git.alpinelinux.org/abuild/snapshot/abuild-$pkgver.tar.xz
- 0001-tests-fix-with-busybox-sha512sum-and-misc-cleanups.patch
- 0002-tests-fix-abump-to-work-without-configured-git-user.patch
"
builddir="$srcdir"/abuild-$pkgver
@@ -86,7 +84,5 @@ _rootbld() {
}
sha512sums="
-a0130200c094676a4e1cc851edc44217c4a7fb1aed192319b60d8b368b45d576a85750869d531a60ff61c06e521cd9094c0f2809994fce0494b20f7af9565132 abuild-3.8.0_rc1.tar.xz
-aeaa77b3576f7eb8ad96d9e59e5eef4e3ae9da64becea9aa04ed01352476f5fb16868a47f61fbdfcd08c25369fb1fbc37e16d488403985d55eb4619e43b593a1 0001-tests-fix-with-busybox-sha512sum-and-misc-cleanups.patch
-73a167b93238a577156b324c6b3ce50d8a3a892d260d958a6747dc0ac36bb136990328420b64db8ff1c41fb22817e4ac2499553d2d059de7921da682b1537897 0002-tests-fix-abump-to-work-without-configured-git-user.patch
+8e272666403ffb11a6d565e271754fa7b7ce90f5e746c8f5bd80694ece6786a12d27372d25880fe07e03bef18b3690e89e7a5a761766599a575c8db07e365b65 abuild-3.8.0_rc2.tar.xz
"