aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Jaekel <holger.jaekel@gmx.de>2020-05-06 19:13:26 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-06 21:47:44 +0000
commit78e54610996dc24987ead5d129dd87a8ee7ff8bb (patch)
tree6e865975bf1f11c6e046911c68bf0673f2ff8cac
parentbbc158e361899dd00260d5ecbb6dc14980600eb5 (diff)
community/geos: fix build with ruby 2.7
fixes #11499
-rw-r--r--community/geos/20-ruby27.patch16
-rw-r--r--community/geos/APKBUILD6
2 files changed, 20 insertions, 2 deletions
diff --git a/community/geos/20-ruby27.patch b/community/geos/20-ruby27.patch
new file mode 100644
index 00000000000..dbb231a518a
--- /dev/null
+++ b/community/geos/20-ruby27.patch
@@ -0,0 +1,16 @@
+Author: Holger Jaekel <holger.jaekel@gmx.de>
+Summary: Patch for modified 'rb_define_virtual_variable' signature in Ruby 2.7
+ This patch can hopefully be removed when Swig supports Ruby 2.7
+Url: https://github.com/swig/swig/issues/1689
+----
+
+--- a/swig/ruby/Makefile.in
++++ b/swig/ruby/Makefile.in
+@@ -873,6 +873,7 @@ uninstall-am: uninstall-rubyextensiondir
+
+ @ENABLE_RUBY_TRUE@@ENABLE_SWIG_TRUE@geos_wrap.cxx: ../geos.i ruby.i
+ @ENABLE_RUBY_TRUE@@ENABLE_SWIG_TRUE@ $(SWIG) -c++ -ruby -autorename -o $@ $<
++@ENABLE_RUBY_TRUE@@ENABLE_SWIG_TRUE@ sed -i 's/swig_ruby_trackings_count, NULL/(rb_gvar_getter_t *)swig_ruby_trackings_count, (rb_gvar_setter_t *)NULL/g' $@
+
+ @ENABLE_RUBY_TRUE@@ENABLE_SWIG_FALSE@geos_wrap.cxx: ../geos.i ruby.i
+ @ENABLE_RUBY_TRUE@@ENABLE_SWIG_FALSE@ @echo "SWIG is disabled, can't build geos_wrap.cxx"
diff --git a/community/geos/APKBUILD b/community/geos/APKBUILD
index 2954e0218c1..6c760992119 100644
--- a/community/geos/APKBUILD
+++ b/community/geos/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
pkgname=geos
pkgver=3.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="GEOS is a library providing OpenGIS and JTS spatial operations in C++."
url="https://trac.osgeo.org/geos/"
arch="all !s390x !mips !mips64"
@@ -20,6 +20,7 @@ subpackages="
source="
http://download.osgeo.org/geos/geos-$pkgver.tar.bz2
10-configure-python3.patch
+ 20-ruby27.patch
"
build() {
@@ -71,4 +72,5 @@ ruby() {
rm -rf "${pkgdir:?}"/usr/local
}
sha512sums="1d8d8b3ece70eb388ea128f4135c7455899f01828223b23890ad3a2401e27104efce03987676794273a9b9d4907c0add2be381ff14b8420aaa9a858cc5941056 geos-3.8.1.tar.bz2
-a76aceadb30c6a078ef9c671d8335647bd6b94094bd4bdda5958f0d50271552e8f1f7b4e9d4295986f4371a446071c3cc3a446ef520543e820bde83833fea18e 10-configure-python3.patch"
+a76aceadb30c6a078ef9c671d8335647bd6b94094bd4bdda5958f0d50271552e8f1f7b4e9d4295986f4371a446071c3cc3a446ef520543e820bde83833fea18e 10-configure-python3.patch
+964d9001e49ac3bec415c36cf3d536f4e959b800fd6770344eca6c58e9bc7bfa23c2722422ffb3677c231a00b5d758e6657ba13e9f8920eb530d71eaa03f989e 20-ruby27.patch"