aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-27 21:54:21 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-27 21:54:40 +0000
commit7903938353cb75620222aeed8728fca0ed48b660 (patch)
tree94a184576c1114c66146d1fb0adeed0ca57e31c6
parentc4a470206a7582f46c68ba2b0d60b486ffbf8406 (diff)
community/youtube-dl: add simple check
As upstream doesn't provide a test suite, add a simple test.
-rw-r--r--community/youtube-dl/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/youtube-dl/APKBUILD b/community/youtube-dl/APKBUILD
index db20b0c7f2e..0cf7e166586 100644
--- a/community/youtube-dl/APKBUILD
+++ b/community/youtube-dl/APKBUILD
@@ -4,12 +4,11 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=youtube-dl
pkgver=2017.11.26
-pkgrel=0
+pkgrel=1
pkgdesc="A small command-line program to download videos from YouTube"
url="http://youtube-dl.org"
arch="noarch"
license="Unlicense"
-options="!check"
depends="python2 py-setuptools ffmpeg"
subpackages="
$pkgname-doc
@@ -25,6 +24,11 @@ prepare() {
sed -i 's|etc/fish/completions|share/fish/completions|' setup.py
}
+check() {
+ cd "$builddir"
+ ./youtube-dl --help > /dev/null
+}
+
package() {
cd "$builddir"
python2 setup.py install --root="$pkgdir/" --optimize=1