aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-12-19 13:04:42 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-21 07:34:02 +0000
commit7a09e2c4fcdbe15b42c3d07bb4b7d3a79ae2fd2c (patch)
treef89fbdaa17a28fde44212af4c983a24a9deafc7e
parentb068910f898592c96e5f7295bff12033c771f114 (diff)
testing/py-pycodestyle: new aport
-rw-r--r--testing/py-pycodestyle/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py-pycodestyle/APKBUILD b/testing/py-pycodestyle/APKBUILD
new file mode 100644
index 00000000000..16d2941adc6
--- /dev/null
+++ b/testing/py-pycodestyle/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-pycodestyle
+pkgver=2.3.1
+pkgrel=0
+pkgdesc="Check your Python code against some of the style conventions in PEP 8"
+url="https://pypi.python.org/pypi/pycodestyle/"
+arch="noarch"
+license="Unknown"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+options="!check" #no testsuite
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/PyCQA/pycodestyle/archive/$pkgver.tar.gz"
+builddir="$srcdir"/pycodestyle-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="78d6a6aad32a31de9852c68c78e91c4aec51224148b0538097e7bb9f0cf60fa13c06aecd0630446fbe72df3523ba8147566a22b0f303c88ada42d828eb81949e py-pycodestyle-2.3.1.tar.gz"