aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-17 18:20:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 09:02:53 +0000
commit7a27e87fafbd5438cd054f532f1cff1b4a0f603e (patch)
treed3a5c62f3ff848d2ce297220b7a003fa62cc825e
parent2d1d39bb1be4d1e2e6ac8f64c2f507e81259f234 (diff)
testing/py-sphinx-theme-bw: new aport
A black and white Sphinx theme http://pypi.python.org/pypi/bw_sphinxtheme
-rw-r--r--testing/py-sphinx-theme-bw/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinx-theme-bw/APKBUILD b/testing/py-sphinx-theme-bw/APKBUILD
new file mode 100644
index 00000000000..b45ecb4f7e3
--- /dev/null
+++ b/testing/py-sphinx-theme-bw/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinx-theme-bw
+_pkgname=bw_sphinxtheme
+pkgver=0.1.8
+pkgrel=0
+pkgdesc="A black and white Sphinx theme"
+url="http://pypi.python.org/pypi/bw_sphinxtheme"
+arch="noarch"
+license="BSD"
+depends="python py-sphinx"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="c4c19facbb902fb46c8c1b93cd3967c9 bw_sphinxtheme-0.1.8.tar.gz"
+sha256sums="dde9d9003e044367c28a8a63ee0c38fb53306241b71a04abb97a567f2ddefca9 bw_sphinxtheme-0.1.8.tar.gz"
+sha512sums="a89d9892d431ddf916d6ad4eebe43c2fa7ce2a079c926f9f8e12ea54e3a0c2a76cc933e9365ea811c72cd19a7737c6972b9cc52009ee1d4bfda81bd7a948b50e bw_sphinxtheme-0.1.8.tar.gz"