aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-03-10 12:09:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-03-10 12:11:25 +0000
commit7b75f9ab7d15988af3af605939cf9455ec46d2a9 (patch)
treea8358663613055d8d823e1ba01112b049d1a22ff
parent7bdef03546195f0affb6e3f3c33543d2635b5938 (diff)
testing/xfce4-statusnotifier-plugin: new aport
Panel area status notifier plugin for Xfce4 https://docs.xfce.org/panel-plugins/xfce4-statusnotifier-plugin
-rw-r--r--testing/xfce4-statusnotifier-plugin/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/xfce4-statusnotifier-plugin/APKBUILD b/testing/xfce4-statusnotifier-plugin/APKBUILD
new file mode 100644
index 00000000000..c8b3bb8796b
--- /dev/null
+++ b/testing/xfce4-statusnotifier-plugin/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname="xfce4-statusnotifier-plugin"
+pkgver="0.2.2"
+pkgrel=0
+pkgdesc="Panel area status notifier plugin for Xfce4"
+url="https://docs.xfce.org/panel-plugins/xfce4-statusnotifier-plugin"
+arch="all"
+license="GPL-2.0-only"
+makedepends="glib-dev libxfce4ui-dev xfce4-panel-dev libdbusmenu-gtk3-dev"
+subpackages="$pkgname-lang"
+source="https://archive.xfce.org/src/panel-plugins/xfce4-statusnotifier-plugin/${pkgver%.*}/xfce4-statusnotifier-plugin-$pkgver.tar.bz2"
+builddir="$srcdir/xfce4-statusnotifier-plugin-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="76f719ffed4ec9e178a844173cb0728888beba9a1ad69c9da025cb2d1fb3ad18448b4b4a60a94bb329ec7b80760307000550d451859c33f4b5d7bb8590cf227d xfce4-statusnotifier-plugin-0.2.2.tar.bz2"