aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-29 04:46:55 -0300
committerTimo Teräs <timo.teras@iki.fi>2019-05-28 14:18:43 +0300
commit7b9af7fc90a456968f258e3c417a20808345994a (patch)
treecf0e7b9a20815a11c5c4d1425e9d0682ec768500
parentcf27c56733d5ca8b624e380f6541ec2017d5722b (diff)
main/perl-inline: fix license, modernize
- Fix wrong license - use $() instead of backticks ``
-rw-r--r--main/perl-inline/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/perl-inline/APKBUILD b/main/perl-inline/APKBUILD
index 3edc9cea3d9..5cf53324e34 100644
--- a/main/perl-inline/APKBUILD
+++ b/main/perl-inline/APKBUILD
@@ -3,11 +3,11 @@
pkgname=perl-inline
_pkgname=Inline
pkgver=0.83
-pkgrel=0
+pkgrel=1
pkgdesc="Write Perl subroutines in other programming languages"
url="http://search.cpan.org/~ingy/Inline/"
arch="noarch"
-license="Artistic-1.0-Perl"
+license="Artistic-1.0-Perl GPL-1.0-or-later"
depends="perl"
makedepends="perl-dev"
checkdepends="perl-test-warn"
@@ -17,12 +17,12 @@ builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
default_prepare
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}