aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-02-11 05:54:53 +0000
committerpsykose <alice@ayaya.dev>2023-02-11 06:54:53 +0100
commit7ca15b43d10f6ffedfa9d7cbfc62c486ee1d57f7 (patch)
treed228f9f403220cc521ef4c5c9374f33e84b25e4b
parentb8d6f9d5c7b7cfcc898034681334a0b3f8b59844 (diff)
testing/mediastreamer2-plugin-x264: rebuild
-rw-r--r--testing/mediastreamer2-plugin-x264/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/testing/mediastreamer2-plugin-x264/APKBUILD b/testing/mediastreamer2-plugin-x264/APKBUILD
index f2153dbf5d9..737c1d03a08 100644
--- a/testing/mediastreamer2-plugin-x264/APKBUILD
+++ b/testing/mediastreamer2-plugin-x264/APKBUILD
@@ -3,13 +3,13 @@
_commit=f4fe74056d0474b42025d95449ec859e984d78ea
pkgname=mediastreamer2-plugin-x264
pkgver=20200722
-pkgrel=3
+pkgrel=4
pkgdesc="GPL plugin to bring video H264 encoding/decoding capabilities to mediastreamer2 applications"
url="https://gitlab.linphone.org/BC/public/msx264"
arch="all"
license="GPL-2.0-or-later"
options="!check" # no test available
-makedepends="cmake ortp-dev bctoolbox-dev mediastreamer2-dev x264-dev"
+makedepends="cmake ortp-dev bctoolbox-dev mediastreamer2-dev x264-dev samurai"
source="$pkgname-$_commit.tar.gz::https://gitlab.linphone.org/BC/public/msx264/-/archive/$_commit.tar.gz
"
@@ -22,7 +22,7 @@ prepare() {
}
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -31,10 +31,12 @@ build() {
-DENABLE_STRICT=NO \
-DENABLE_SHARED=YES
- make -C build
+ cmake --build build
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="cc295d06b13fddaf97669ef20bf239622ea0690bd8d193df0f435831caf433f5b036be83bfdd9a261af8d51c272d4e2b614cfd2af04766797c86314d46782065 mediastreamer2-plugin-x264-f4fe74056d0474b42025d95449ec859e984d78ea.tar.gz"
+sha512sums="
+cc295d06b13fddaf97669ef20bf239622ea0690bd8d193df0f435831caf433f5b036be83bfdd9a261af8d51c272d4e2b614cfd2af04766797c86314d46782065 mediastreamer2-plugin-x264-f4fe74056d0474b42025d95449ec859e984d78ea.tar.gz
+"