aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-10-15 09:41:04 +0200
committerBart Ribbers <bribbers@disroot.org>2021-10-15 08:18:14 +0000
commit7cf7089273621c6ca3ee1a756932fee44eee535f (patch)
treea7a703aad6a3e6d5df538324377110d9736c184a
parentdddb0cd0d4e97e5a8fc44f8158d918b3be37c4a3 (diff)
community/plasma-workspace: backport upstream requested patch
-rw-r--r--community/plasma-workspace/0001-sddm-theme-fix-missing-password-field-on-other-page.patch49
-rw-r--r--community/plasma-workspace/APKBUILD7
2 files changed, 54 insertions, 2 deletions
diff --git a/community/plasma-workspace/0001-sddm-theme-fix-missing-password-field-on-other-page.patch b/community/plasma-workspace/0001-sddm-theme-fix-missing-password-field-on-other-page.patch
new file mode 100644
index 00000000000..43a0bf1205f
--- /dev/null
+++ b/community/plasma-workspace/0001-sddm-theme-fix-missing-password-field-on-other-page.patch
@@ -0,0 +1,49 @@
+From d5a3e749a30613294f41386180aaf31dfb1a9bee Mon Sep 17 00:00:00 2001
+From: Nate Graham <nate@kde.org>
+Date: Thu, 14 Oct 2021 15:44:33 -0600
+Subject: [PATCH] sddm-theme: fix missing password field on "Other" page
+
+On this page there is no concept of the user being passwordless because
+no username has been specified by the user yet; we cannot know ahead of
+time. As a result, userList.currentItem.needsPassword is blank so the
+password field gets hidden.
+
+We should just assume that in username/password entry mode, all users
+have a password set. For any users where this is not the case, they can
+just leave the password blank, and it's not any worse than it was in
+Plasma 5.22.
+
+BUG: 443737
+FIXED-IN: 5.23.1
+
+
+(cherry picked from commit f038ab3f494f26b443b10ff5dc9f156e1ec16341)
+---
+ sddm-theme/Login.qml | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/sddm-theme/Login.qml b/sddm-theme/Login.qml
+index 8829666f1..6d3d62804 100644
+--- a/sddm-theme/Login.qml
++++ b/sddm-theme/Login.qml
+@@ -83,7 +83,7 @@ SessionManagementScreen {
+ }
+ }
+
+- visible: userList.currentItem.needsPassword
++ visible: root.showUsernamePrompt || userList.currentItem.needsPassword
+
+ Keys.onEscapePressed: {
+ mainStack.currentItem.forceActiveFocus();
+@@ -119,7 +119,7 @@ SessionManagementScreen {
+
+ icon.name: text.length == 0 ? "go-next" : ""
+
+- text: userList.currentItem.needsPassword ? "" : i18n("Log In")
++ text: root.showUsernamePrompt || userList.currentItem.needsPassword ? "" : i18n("Log In")
+ onClicked: startLogin();
+ }
+ }
+--
+GitLab
+
diff --git a/community/plasma-workspace/APKBUILD b/community/plasma-workspace/APKBUILD
index c0555f0a5a0..cd5db77bcf9 100644
--- a/community/plasma-workspace/APKBUILD
+++ b/community/plasma-workspace/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-workspace
pkgver=5.23.0
-pkgrel=0
+pkgrel=1
pkgdesc="KDE Plasma Workspace"
# armhf blocked by kirigami2
# s390x, mips64 and riscv64 blocked by polkit -> kio-extras
@@ -77,7 +77,9 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz"
+source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz
+ 0001-sddm-theme-fix-missing-password-field-on-other-page.patch
+ "
subpackages="$pkgname-dev $pkgname-libs $pkgname-doc $pkgname-lang"
replaces="plasma-desktop<5.22 breeze<5.22.90"
@@ -107,4 +109,5 @@ package() {
}
sha512sums="
db11e9425fd90efe50cbe1d59ee863b1d06345a6bb476bf75ac731008970fbb2a92e058c6db5c9f83b084e10953ad3eb333472c5b2596170b6f38475e60dc2c9 plasma-workspace-5.23.0.tar.xz
+ffbd5ba5ff5fa8deb8f10bb8dee906f7678aeab2e2a6248ac55a5b4e375797665e086513095c5e4e2b7107e1dd684b6c5b0ddfb3e4b44c559c6127b98d10096d 0001-sddm-theme-fix-missing-password-field-on-other-page.patch
"