aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-09-18 20:59:51 +0000
committerpsykose <alice@ayaya.dev>2022-09-18 22:59:51 +0200
commit7d4a783d3584e34b775abd3ff8f4148b26756643 (patch)
tree5f8b646d14508e7d4628ed0ad6648944bfd30824
parente47e9bb2fcc47fd52659f243481fc84d4853ae78 (diff)
community/deluge: fix web ui js files
needed a minifier at build time
-rw-r--r--community/deluge/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/community/deluge/APKBUILD b/community/deluge/APKBUILD
index 07d2d5a0afa..0b48b970d87 100644
--- a/community/deluge/APKBUILD
+++ b/community/deluge/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: psykose <alice@ayaya.dev>
pkgname=deluge
pkgver=2.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="lightweight, Free Software, cross-platform BitTorrent client"
url="https://deluge-torrent.org/"
arch="noarch"
@@ -28,8 +28,9 @@ depends="
py3-zope-interface
"
makedepends="
- py3-build
+ py3-gpep517
py3-installer
+ py3-rjsmin
"
checkdepends="
py3-mock
@@ -42,7 +43,11 @@ source="http://download.deluge-torrent.org/source/${pkgver%.*}/deluge-$pkgver.ta
replaces="$pkgname-lang" # Overwrite removed subpackage
build() {
- python3 -m build --no-isolation --wheel
+ mkdir dist
+ python3 -m gpep517 build-wheel \
+ --wheel-dir dist \
+ --output-fd 1
+
}
check() {