aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanct12 <danct12@disroot.org>2020-02-12 05:29:03 +0700
committerLeo <thinkabit.ukim@gmail.com>2020-02-11 20:08:39 -0300
commit7e5e21c15e92be8ba958ccf156158c69c5414d6a (patch)
tree3552bc508bfebbefd9986213ad26c80369b78ff0
parent29ecd9d1826b85b865175b90b326c9be2070be78 (diff)
testing/gnome-2048: change minimum window size to 350x350
Signed-off-by: Danct12 <danct12@disroot.org>
-rw-r--r--testing/gnome-2048/APKBUILD8
-rw-r--r--testing/gnome-2048/smaller-window.patch28
2 files changed, 33 insertions, 3 deletions
diff --git a/testing/gnome-2048/APKBUILD b/testing/gnome-2048/APKBUILD
index 3d16f77a632..a605e21ef3a 100644
--- a/testing/gnome-2048/APKBUILD
+++ b/testing/gnome-2048/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-2048
pkgver=3.34.4
-pkgrel=1
+pkgrel=2
arch="all"
url="https://wiki.gnome.org/Apps/2048"
pkgdesc="Obtain the 2048 tile"
license="GPL-3.0-or-later"
makedepends="meson ninja itstool vala gtk+3.0-dev clutter-dev clutter-gtk-dev libgee-dev libgnome-games-support-dev"
-source="https://download.gnome.org/sources/gnome-2048/${pkgver%.*}/gnome-2048-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/gnome-2048/${pkgver%.*}/gnome-2048-$pkgver.tar.xz
+ smaller-window.patch"
subpackages="$pkgname-doc $pkgname-lang"
build() {
@@ -30,4 +31,5 @@ package() {
DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="a085c77acef29241ddeab1c00f91dab3a6c51e3c1dc5baaafd25515a23dd5461e60b1423a96cb0830d844e96b1fd9ec81e9451cf8201329b59c31ad83b84fe27 gnome-2048-3.34.4.tar.xz"
+sha512sums="a085c77acef29241ddeab1c00f91dab3a6c51e3c1dc5baaafd25515a23dd5461e60b1423a96cb0830d844e96b1fd9ec81e9451cf8201329b59c31ad83b84fe27 gnome-2048-3.34.4.tar.xz
+4d0f024d2cb3db1a5f3193a171958e81128bfec5e0a3e21d9942f508ea7a2427251eeca8904ea5088d49c9f32d327a2ee0f33e73cc1cb2df9e5fd38eb0d0b314 smaller-window.patch"
diff --git a/testing/gnome-2048/smaller-window.patch b/testing/gnome-2048/smaller-window.patch
new file mode 100644
index 00000000000..3fede9fe860
--- /dev/null
+++ b/testing/gnome-2048/smaller-window.patch
@@ -0,0 +1,28 @@
+From 4767894600906cd55ce7e43e1a142d617b82fbd8 Mon Sep 17 00:00:00 2001
+From: Sebastian Krzyszkowiak <dos@dosowisko.net>
+Date: Thu, 12 Sep 2019 22:50:24 +0000
+Subject: [PATCH] Change the minimum window size to 350x350
+
+This allows to run the game on smaller screens, such as phones.
+---
+ src/game-window.vala | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/game-window.vala b/src/game-window.vala
+index 8ff248e..c8aef57 100644
+--- a/src/game-window.vala
++++ b/src/game-window.vala
+@@ -123,8 +123,8 @@ private class GameWindow : ApplicationWindow
+ * * window state
+ \*/
+
+- private const int WINDOW_MINIMUM_SIZE_HEIGHT = 600;
+- private const int WINDOW_MINIMUM_SIZE_WIDTH = 600;
++ private const int WINDOW_MINIMUM_SIZE_HEIGHT = 350;
++ private const int WINDOW_MINIMUM_SIZE_WIDTH = 350;
+
+ private int _window_width;
+ private int _window_height;
+--
+2.24.1
+