aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-10 17:57:52 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-10 17:57:59 -0300
commit7f4bc38833b59f6a4ec4f967e1463ab53b23b295 (patch)
tree56ce4c7f8f3ab08cf7d6e465909a9a5c6540c792
parentb799a7d5c3a0aaf625ebe2526875c8fd704ccde2 (diff)
testing/py3-ansi2html: add missing dependency on py3-setuptools
fixes #11289
-rw-r--r--testing/py3-ansi2html/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/testing/py3-ansi2html/APKBUILD b/testing/py3-ansi2html/APKBUILD
index e447a9a663f..549d4cbccc9 100644
--- a/testing/py3-ansi2html/APKBUILD
+++ b/testing/py3-ansi2html/APKBUILD
@@ -3,26 +3,24 @@
pkgname=py3-ansi2html
_pkgname=ansi2html
pkgver=1.5.2
-pkgrel=3
+pkgrel=4
pkgdesc="Convert text with ANSI color codes to HTML"
url="https://github.com/ralphbean/ansi2html"
arch="noarch"
license="LGPL-3.0-or-later"
-replaces="py-ansi2html" # for backwards compatibility
-provides="py-ansi2html=$pkgver-r$pkgrel" # for backwards compatibility
-depends="python3 py3-six"
-makedepends="py3-setuptools python3-dev"
+depends="python3 py3-six py3-setuptools"
+makedepends="python3-dev"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-ansi2html" # for backwards compatibility
+provides="py-ansi2html=$pkgver-r$pkgrel" # for backwards compatibility
+
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}