aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2017-09-30 18:00:09 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-10-01 07:42:53 +0000
commit7fcf5c6509a1f8eb33ced56e21cf9640913d0d55 (patch)
tree74006b07323e26ba0e40e8b8494bfa6ff2fb5462
parent70303464852d47ac8e30e612d906b6acbc465089 (diff)
testing/py-pykka: upgrade to 1.2.1
-rw-r--r--testing/py-pykka/APKBUILD22
1 files changed, 5 insertions, 17 deletions
diff --git a/testing/py-pykka/APKBUILD b/testing/py-pykka/APKBUILD
index 4245fd292a2..da7aad0cb4a 100644
--- a/testing/py-pykka/APKBUILD
+++ b/testing/py-pykka/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=py-pykka
-pkgver=1.2.0
+pkgver=1.2.1
pkgrel=0
pkgdesc="Easy to use concurrency abstractions for Python using the actor model"
url="http://pykka.readthedocs.org/"
@@ -9,32 +9,20 @@ arch="noarch"
license="Apache"
depends="python2"
depends_dev=""
-makedepends="python2-dev"
+makedepends="python2-dev py2-setuptools"
install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/P/Pykka/Pykka-$pkgver.tar.gz"
-
_builddir="$srcdir"/Pykka-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
build() {
cd "$_builddir"
- python2 setup.py build || return 1
+ python2 setup.py build
}
package() {
cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="27cb69507f89e34dc1ff34636c4bc165 Pykka-1.2.0.tar.gz"
-sha256sums="01cfbfc5a9a32c01ee68303614269b5b1c6e3d698270c92be7488f8c1edb5885 Pykka-1.2.0.tar.gz"
-sha512sums="9fd6537d3ee8a6ef1882737bdcb8542aa411a857adbe1c4464a825baf1d30f9b000f523abd947b89bcf9e08437eaa589b10aaeb16cc78aa5f41ca40e531ecb34 Pykka-1.2.0.tar.gz"
+sha512sums="22eaa735915e33146d8a3fa3f9dd5ea1dd608e7ad45ab21721a108b01ddf058b4cd00da67b762a95ede650c9ba1a79ee3d6fd22a491bc7ff348a56b7c0139cfd Pykka-1.2.1.tar.gz"