aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-02 16:10:25 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-03 07:52:28 -0300
commit7ff14ae54c238f33c5a41ba6c07724f8e4d3c47e (patch)
tree2cc957fcecba0dd48e55dc08647321c2ed3a85f5
parentb5f8ece2e2ec2b90bd37ce1972932a2592cef85d (diff)
testing/*: add --buildtype=plain to meson packages which don't specify a buildtype
-rw-r--r--testing/dav1d/APKBUILD3
-rw-r--r--testing/dxvk/APKBUILD16
-rw-r--r--testing/gnome-software/APKBUILD4
-rw-r--r--testing/kgx/APKBUILD3
-rw-r--r--testing/moka-icon-theme/APKBUILD7
-rw-r--r--testing/openhmd/APKBUILD7
-rw-r--r--testing/snes9x/APKBUILD3
-rw-r--r--testing/viewnior/APKBUILD6
-rw-r--r--testing/waypipe/APKBUILD3
-rw-r--r--testing/zathura-pdf-mupdf/APKBUILD8
10 files changed, 37 insertions, 23 deletions
diff --git a/testing/dav1d/APKBUILD b/testing/dav1d/APKBUILD
index 4d15157cf0c..0d1ade18942 100644
--- a/testing/dav1d/APKBUILD
+++ b/testing/dav1d/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=dav1d
pkgver=0.5.2
-pkgrel=0
+pkgrel=1
pkgdesc="small and fast AV1 Decoder"
url="https://code.videolan.org/videolan/dav1d"
arch="all"
@@ -19,6 +19,7 @@ build() {
meson \
--prefix=/usr \
+ --buildtype=plain \
-Denable_tests=true \
-Denable_tools=true \
-Dfuzzing_engine=none \
diff --git a/testing/dxvk/APKBUILD b/testing/dxvk/APKBUILD
index f20df98d84e..7c8a43f18b4 100644
--- a/testing/dxvk/APKBUILD
+++ b/testing/dxvk/APKBUILD
@@ -2,9 +2,9 @@
# Maintainer:
pkgname=dxvk
pkgver=1.5.5
-pkgrel=0
+pkgrel=1
pkgdesc="Vulkan-based compatibility layer for Direct3D 10/11"
-options="!strip !check"
+options="!check"
url="https://github.com/doitsujin/dxvk"
arch="x86_64 x86"
license="Zlib"
@@ -33,12 +33,12 @@ esac
build() {
meson . $_outdir \
- --cross-file $_crossfile \
- --prefix $_prefix \
- --bindir "" --libdir "" \
- --buildtype release \
- --strip \
- -D enable_tests=false
+ --cross-file=$_crossfile \
+ --prefix=$_prefix \
+ --bindir="" \
+ --libdir="" \
+ --buildtype=plain \
+ -Denable_tests=false
ninja -C $_outdir
}
diff --git a/testing/gnome-software/APKBUILD b/testing/gnome-software/APKBUILD
index a1c11276279..b5e41a2b607 100644
--- a/testing/gnome-software/APKBUILD
+++ b/testing/gnome-software/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-software
pkgver=3.34.2
-pkgrel=0
+pkgrel=1
pkgdesc="Software lets you install and update applications and system extensions"
url="https://wiki.gnome.org/Apps/Software"
arch="all !s390x"
@@ -30,7 +30,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=debugoptimized \
+ --buildtype=plain \
-Dvalgrind=false \
-Dmalcontent=false \
-Dpackagekit=false \
diff --git a/testing/kgx/APKBUILD b/testing/kgx/APKBUILD
index f3b49a10c7a..b00c8c3121f 100644
--- a/testing/kgx/APKBUILD
+++ b/testing/kgx/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: David Heidelberg <david@ixit.cz>
pkgname=kgx
pkgver=0.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="A minimal terminal for GNOME"
url="https://gitlab.gnome.org/ZanderBrown/kgx"
arch="all !s390x !ppc64le" # !s390x !ppc64le due gnome-shell
@@ -19,6 +19,7 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
+ --buildtype=plain \
-Dgtop=true \
-Dgtk_doc=false \
-Dgir=false \
diff --git a/testing/moka-icon-theme/APKBUILD b/testing/moka-icon-theme/APKBUILD
index 9df531da6c3..21af3325ffe 100644
--- a/testing/moka-icon-theme/APKBUILD
+++ b/testing/moka-icon-theme/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=moka-icon-theme
pkgver=5.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="Moka Icon Theme"
url="https://snwh.org/moka"
arch="noarch"
@@ -12,7 +12,10 @@ options="!strip"
source="moka-icon-theme-$pkgver.tar.gz::https://github.com/snwh/moka-icon-theme/archive/v$pkgver.tar.gz"
build() {
- meson --prefix=/usr output
+ meson \
+ --prefix=/usr \
+ --buildtype=plain \
+ output
ninja -C output
}
diff --git a/testing/openhmd/APKBUILD b/testing/openhmd/APKBUILD
index e98716456c7..0e40e101f02 100644
--- a/testing/openhmd/APKBUILD
+++ b/testing/openhmd/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=openhmd
pkgver=0.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Free and Open Source API and drivers for immersive (VR) technology"
url="http://www.openhmd.net/"
arch="all"
@@ -14,8 +14,9 @@ options="!check" # https://github.com/OpenHMD/OpenHMD/issues/248
build() {
meson \
- --prefix /usr \
- --libdir /usr/lib \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --buildtype=plain \
-Dexamples='' \
. build
ninja -C build
diff --git a/testing/snes9x/APKBUILD b/testing/snes9x/APKBUILD
index 7337cdfd936..757a74c2aa6 100644
--- a/testing/snes9x/APKBUILD
+++ b/testing/snes9x/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Taner Tas <taner76@gmail.com>
pkgname=snes9x
pkgver=1.60
-pkgrel=0
+pkgrel=1
pkgdesc="Super NES Emulator"
options="!check" # No testsuite
url="http://www.snes9x.com"
@@ -30,6 +30,7 @@ builddir="$srcdir/$pkgname-$pkgver/gtk"
build() {
meson \
--prefix=/usr \
+ --buildtype=plain \
-Dopengl=true \
-Dgtk3=true \
-Dpulseaudio=false \
diff --git a/testing/viewnior/APKBUILD b/testing/viewnior/APKBUILD
index af3ba75625a..d67603ed040 100644
--- a/testing/viewnior/APKBUILD
+++ b/testing/viewnior/APKBUILD
@@ -3,7 +3,7 @@
pkgname=viewnior
_pkgname=Viewnior
pkgver=1.7
-pkgrel=1
+pkgrel=2
pkgdesc="A fast and simple image viewer"
url="http://siyanpanayotov.com/project/viewnior"
arch="all"
@@ -22,7 +22,9 @@ prepare() {
build() {
cd "$builddir"
- meson builddir --prefix=/usr
+ meson builddir \
+ --prefix=/usr \
+ --buildtype=plain
ninja -C builddir
}
diff --git a/testing/waypipe/APKBUILD b/testing/waypipe/APKBUILD
index a095b4b63c9..b3acd938f9e 100644
--- a/testing/waypipe/APKBUILD
+++ b/testing/waypipe/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Simon Zeni <simon@bl4ckb0ne.ca>
pkgname="waypipe"
pkgver="0.6.1"
-pkgrel=0
+pkgrel=1
pkgdesc="A proxy for Wayland protocol applications."
url="https://gitlab.freedesktop.org/mstoeckl/waypipe"
arch="all"
@@ -17,6 +17,7 @@ prepare() {
meson build \
--prefix=/usr \
--mandir=/usr/share/man \
+ --buildtype=plain \
-Dwerror=false \
-Db_ndebug=true
}
diff --git a/testing/zathura-pdf-mupdf/APKBUILD b/testing/zathura-pdf-mupdf/APKBUILD
index 7cc0fdf8fe7..f81920d9f60 100644
--- a/testing/zathura-pdf-mupdf/APKBUILD
+++ b/testing/zathura-pdf-mupdf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=zathura-pdf-mupdf
pkgver=0.3.5
-pkgrel=0
+pkgrel=1
pkgdesc="mupdf plugin to zathura"
url="https://git.pwmt.org/pwmt/zathura-pdf-mupdf"
arch="all"
@@ -16,7 +16,11 @@ options="!check"
build() {
export=LDFLAGS="-ljpeg -lopenjp2 -ljbig2dec"
- meson -Dlink-external=true build --prefix=/usr
+ meson \
+ --prefix=/usr \
+ --buildtype=plain \
+ -Dlink-external=true \
+ build
ninja -C build
}