aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraptalca <aptalca@linuxserver.io>2019-08-14 14:36:20 -0400
committerJakub Jirutka <jakub@jirutka.cz>2019-10-26 16:59:13 +0200
commit84e3b8b062591cb33f03fdf4b6cdb31d1fd4a1d8 (patch)
treed09f1622e4db1e7ae0f69f9bdd8fccafae55b666
parentecfed56a101ec46ef4daaf3e879c210b28a57000 (diff)
main/nginx: fix support for more so libs per module
When there is more than one so defined for a module, the line echo "load_module \"modules/$soname\";" > ./etc/nginx/modules/$name.conf only writes the last so listed into the conf file. Related to GH-9234
-rw-r--r--main/nginx/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 49cbc4f0904..5f456125e66 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -320,7 +320,7 @@ _module() {
local soname; for soname in $sonames; do
mv "$pkgdir"/$_modules_dir/$soname ./$_modules_dir/$soname
- echo "load_module \"modules/$soname\";" > ./etc/nginx/modules/$name.conf
+ echo "load_module \"modules/$soname\";" >> ./etc/nginx/modules/$name.conf
done
}