aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2020-01-23 19:32:27 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-01-23 19:31:51 +0100
commit86a2ffd43dfbdd1cececa63e7f513ecb075f8dc7 (patch)
tree04f2aa9e3ece74a10b0749187e052166c26599a1
parent426927d771f045ec18443f26ce1189c5a527ec63 (diff)
testing/lowjs: upgrade to 1.4.5
-rw-r--r--testing/lowjs/APKBUILD6
-rw-r--r--testing/lowjs/lib-path.patch33
2 files changed, 2 insertions, 37 deletions
diff --git a/testing/lowjs/APKBUILD b/testing/lowjs/APKBUILD
index bd7d4675194..d6a2e25771e 100644
--- a/testing/lowjs/APKBUILD
+++ b/testing/lowjs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lowjs
-pkgver=1.4.2
+pkgver=1.4.5
_gitrev_open62541="9f1cbfa96fd050220c86d3e5939d88cab1b680ce"
_gitrev_duktape="44ca54f726bfa651a7ab59286dd5c371dba2ddfc"
pkgrel=1
@@ -15,7 +15,6 @@ source="https://github.com/neonious/lowjs/archive/v$pkgver/$pkgname-$pkgver.tar.
https://github.com/neonious/open62541/archive/$_gitrev_open62541/open62541-$_gitrev_open62541.tar.gz
https://github.com/svaarala/duktape/archive/$_gitrev_duktape/duktape-$_gitrev_duktape.tar.gz
use-npm-ci.patch
- lib-path.patch
open62541-gcc9.patch
unbundle-c-ares.patch
unbundle-mbedtls.patch
@@ -70,11 +69,10 @@ package() {
install -D -m 0644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha512sums="fa7f41eb7753060a0c613301f2ce12622c12521a668d65f2d6198b1489b5542b9bf7cd2c1c2946eaa92e1ed9b852c8cd7d4316a1775b0a89eb428bdf2e11484d lowjs-1.4.2.tar.gz
+sha512sums="8003d9bc65b20f4e6342ff6f3cc4a3fd86d1bebcda5ab1987f350e75ff64a0cf00753efa5095dad7183305f923fa20111b654572f08be337b18af5561a9a61e9 lowjs-1.4.5.tar.gz
7c71ff0ce8cda56e4a4cc8e416172fd847f7289d45c4e44e54e56f3081b914d9401c86341ae3d0a4bccd7b6e9c3b274c92892e67e3cd300824bf900cd9f02ac1 open62541-9f1cbfa96fd050220c86d3e5939d88cab1b680ce.tar.gz
e7f4eaf3f5cb8c791a25c9a1a213953423c6e063d7e3049ccab70fee977bfb4949e23aed50d9720539b798dc9d2e65227bca165ad4faa04797318492b4f06cfc duktape-44ca54f726bfa651a7ab59286dd5c371dba2ddfc.tar.gz
b8aecec6aa87eb2ab7ffecaca1989f922042ee534612229872bad10bc0e304951cb66a1d1aa3ba4e76384ca2ea28b8c5b7176eacf6b7df3d59ea7435b7894a48 use-npm-ci.patch
-f1ce54e839160f559b31d588cc61b068b28e7844d4f6987f17396d7dfee8417ae861896742c746131c25686204c729f305610644c5526963622c4a8bc5517b41 lib-path.patch
c2c7f10d327d2e56d2824db02c647c05773c652179f40eff7b376dfbf7eecd72b7d07c18458d59fd195993b261cb9a48e9f521ccb1a519807270c036ed8d5746 open62541-gcc9.patch
a0ff4c6ad0891be0d8246cd2cddd7d6015d948778ec52e49fcd1eb8da53c2b7f861b3d38e52f3bf7ec1ad6c2cdba35657cee7dddeb1e7e77e9430995cce23291 unbundle-c-ares.patch
d90f1f16390530cc328804f8232f821217a705e12e8d3cd47b787f779ec2f9cafbb7416c05d8d8ed96cc71e52bd86deee8deffded80ee297c50735998b9af70e unbundle-mbedtls.patch
diff --git a/testing/lowjs/lib-path.patch b/testing/lowjs/lib-path.patch
deleted file mode 100644
index e6711783e38..00000000000
--- a/testing/lowjs/lib-path.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/app/low_config.h
-+++ b/app/low_config.h
-@@ -25,4 +25,8 @@
-
- #define LOW_ESP32_LWIP_SPECIALITIES 0
-
-+#ifndef LOW_LIB_PATH
-+#define LOW_LIB_PATH "../lib/"
-+#endif
-+
- #endif /* __LOW_CONFIG_H__ */
---- a/app/main.cpp
-+++ b/app/main.cpp
-@@ -37,7 +37,7 @@
- if(*argc < 2)
- return;
-
-- const char postfix[] = "../lib/low-exe";
-+ const char postfix[] = LOW_LIB_PATH "/low-exe";
- int len = strlen((*argv)[0]);
- if(len < sizeof(postfix) || strcmp((*argv)[0] + len - (sizeof(postfix) - 1), postfix) != 0)
- return;
---- a/src/low_system.cpp
-+++ b/src/low_system.cpp
-@@ -129,7 +129,7 @@
-
- g_low_system.lib_path = NULL;
-
-- const char lib_add_path[] = "../lib/";
-+ const char lib_add_path[] = LOW_LIB_PATH;
- int lib_add_path_len = sizeof(lib_add_path) - 1;
-
- #ifdef __APPLE__