aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Frankenberger <simon@fraho.eu>2020-03-21 19:30:35 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-21 19:54:48 +0000
commit871ed4a6bc808cc692663c6aab25ecee6a78848b (patch)
tree19e7580447b639941ead6f41eb0e686b68836fd8
parentaec6c45daf7c78ebb4d0153a05bf19ca35dfdeca (diff)
testing/thefuck: Upgrade to 3.30
-rw-r--r--testing/thefuck/APKBUILD9
-rw-r--r--testing/thefuck/ash.patch12
2 files changed, 10 insertions, 11 deletions
diff --git a/testing/thefuck/APKBUILD b/testing/thefuck/APKBUILD
index c37b3abdc52..59ad252e9b9 100644
--- a/testing/thefuck/APKBUILD
+++ b/testing/thefuck/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Simon Frankenberger <simon-alpine@fraho.eu>
# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
pkgname=thefuck
-pkgver=3.28
-pkgrel=1
+pkgver=3.30
+pkgrel=0
pkgdesc="The Fuck is a magnificent app that corrects errors in previous console commands."
url="https://github.com/nvbn/thefuck"
arch="noarch"
@@ -11,7 +11,6 @@ depends="py3-colorama py3-six py3-decorator py3-psutil py3-pyte"
makedepends="py3-setuptools"
source="thefuck-$pkgver.tar.gz::https://github.com/nvbn/thefuck/archive/$pkgver.tar.gz
ash.patch"
-builddir="$srcdir"/$pkgname-$pkgver
check() {
python3 setup.py check
@@ -26,5 +25,5 @@ package() {
}
-sha512sums="6c3edcfff604567a18209bf46aceb662ed4549efd0e3b0daee1abee8a93fbe3ff4dfa260eb74c3d560b3a798e3cc90f911072d694a0d986a09c8581e951421d2 thefuck-3.28.tar.gz
-2ba9588057e986e47739463ae9c311be17f6248ce60af5d746db8ab9dea2faf7685cd7d9a1999e1e52f2623e1eb23f0b5f756816aae486b721f1782a7265ab64 ash.patch"
+sha512sums="99b270d0aa535673c09e7e932212af4ded5639fcf30ad0aeedc89a54e94c0a072a37883b1a1a56301efb82ea1c72cf53d4dacf2e83edcafcf4fbaa55ecd35f3a thefuck-3.30.tar.gz
+3750797396d8bd9bc9eaff30caa6d05edcb3f75a44ac2136f489d0c2e4a8d4cb89d74083b4ef5a4affc112c3c825ffa4e5bf0e4f72b9eec066df4f1501b2f3c3 ash.patch"
diff --git a/testing/thefuck/ash.patch b/testing/thefuck/ash.patch
index 1efe00808ac..157c9068f03 100644
--- a/testing/thefuck/ash.patch
+++ b/testing/thefuck/ash.patch
@@ -2,14 +2,14 @@ This patch replaces the default call to "fc" (which is a builtin
function in many shells) to a sed command to work on the alpine
default shell (ash).
---- a/thefuck/shells/generic.py 2018-12-20 16:25:30.217136599 +0000
-+++ b/thefuck/shells/generic.py 2018-12-20 16:26:11.156565614 +0000
-@@ -35,7 +35,7 @@
+--- old/thefuck/shells/generic.py
++++ new/thefuck/shells/generic.py
+@@ -37,7 +37,7 @@
def app_alias(self, alias_name):
- return "alias {0}='eval $(TF_ALIAS={0} PYTHONIOENCODING=utf-8 " \
-- "thefuck $(fc -ln -1))'".format(alias_name)
-+ "thefuck $(sed -n '\"'x;\\$p'\"' /home/build/.ash_history))'".format(alias_name)
+ return """alias {0}='eval "$(TF_ALIAS={0} PYTHONIOENCODING=utf-8 """ \
+- """thefuck "$(fc -ln -1)")"'""".format(alias_name)
++ """thefuck "$(sed -n '\"'x;\\$p'\"' /home/build/.ash_history)")'""".format(alias_name)
def instant_mode_alias(self, alias_name):
warn("Instant mode not supported by your shell")