aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-09-28 03:09:21 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-11 11:12:09 -0300
commit88668001388ee76944d6ae7493665e620a1f4a57 (patch)
tree5b061569d425818d17ff98872cfa20163a1ac1c3
parentc752c485a18227d1b8351a94e030848380ed061c (diff)
community/exim: patch CVE-2019-16928
ref #10834
-rw-r--r--community/exim/APKBUILD11
-rw-r--r--community/exim/CVE-2019-16928.patch36
2 files changed, 44 insertions, 3 deletions
diff --git a/community/exim/APKBUILD b/community/exim/APKBUILD
index c671d894183..ecc09719a0d 100644
--- a/community/exim/APKBUILD
+++ b/community/exim/APKBUILD
@@ -6,7 +6,7 @@
# Maintainer: Jesse Young <jlyo@jlyo.org>
pkgname=exim
pkgver=4.92.2
-pkgrel=0
+pkgrel=1
pkgdesc="Message Transfer Agent"
url="https://www.exim.org/"
arch="all"
@@ -20,15 +20,19 @@ makedepends="bash db-dev gawk libidn-dev openssl-dev libspf2-dev linux-headers m
install="exim.pre-install"
subpackages="$pkgname-cdb $pkgname-dbmdb $pkgname-dnsdb $pkgname-sqlite $pkgname-mysql $pkgname-postgresql
$pkgname-utils $pkgname-scripts::noarch $pkgname-doc $pkgname-openrc"
-source="https://ftp.exim.org/pub/exim/exim4/$pkgname-$pkgver.tar.xz
+source="https://ftp.exim.org/pub/exim/exim4/old/exim-4.92.tar.xz
+ CVE-2019-16928.patch
bounce-charset.patch
exim.Makefile
exim.confd
exim.initd
exim.logrotate
exim.gencert"
+builddir="$srcdir/exim-${pkgver%.*}"
# secfixes:
+# 4.92.2-r1:
+# - CVE-2019-16928
# 4.92.2-r0:
# - CVE-2019-15846
# 4.92.1-r0:
@@ -118,7 +122,8 @@ cdb() { _mv_ext cdb; }
dbmdb() { _mv_ext dbmdb; }
dnsdb() { _mv_ext dnsdb; }
-sha512sums="d27aca4d4e9df267b0afcbe7b3f74c9ca6e96e7e6eb4d2f86ff00b0e2234eaec90271405eb387a36a2e0d4ec5597b2920753f85318a5618ddbc8af475a7d81cd exim-4.92.2.tar.xz
+sha512sums="62c327e6184a358ba7f0dbc38b44d2537234be91727a5bfac97e74af64a8d77e376b3221dcfdd8f6eca7d812f9233595503dc6e50e2972bed40a1b74eb209c31 exim-4.92.tar.xz
+99cb232ee47f7cb8289662aad1d06df2a268f8c5c00262441e6cc36a0858a82ad22e2fadeabf293b87cc2601f579346176af841080ad40155aaf8d55abfd8f39 CVE-2019-16928.patch
691df92954f015711398350963ea321d143127bc731a985bcacc5364c71b6df84b6c21a2e8dc3cc2048fcd3dd02def3dc8015f4d84dd672f23d5a41348e72dc7 bounce-charset.patch
f764a09ac7b6dfa34a5cd8bf5ad8b5fea355ac3b21a14f7218c84804bce420c6212cbebd2811fa40b0034dba626f0c9b293de77dbd634432edd31b237003515e exim.Makefile
bb6f5ead067af19ace661cc92bcd428da97570aedd1f9dc5b61a34e7e3fb3e028be6c96d51df73353bdfcaf69a3ee053fb03d245f868d63ebf518aa96ec82d66 exim.confd
diff --git a/community/exim/CVE-2019-16928.patch b/community/exim/CVE-2019-16928.patch
new file mode 100644
index 00000000000..b920d761e15
--- /dev/null
+++ b/community/exim/CVE-2019-16928.patch
@@ -0,0 +1,36 @@
+From 478effbfd9c3cc5a627fc671d4bf94d13670d65f Mon Sep 17 00:00:00 2001
+From: Jeremy Harris <jgh146exb@wizmail.org>
+Date: Fri, 27 Sep 2019 12:21:49 +0100
+Subject: [PATCH] Fix buffer overflow in string_vformat. Bug 2449
+
+---
+ src/src/string.c | 4 ++--
+ test/scripts/0000-Basic/0214 | 11 +++++++++++
+ test/stdout/0214 | 7 +++++++
+ 3 files changed, 20 insertions(+), 2 deletions(-)
+
+diff --git a/src/src/string.c b/src/src/string.c
+index c6549bf..3445f8a 100644
+--- a/src/string.c
++++ b/src/string.c
+@@ -1132,7 +1132,7 @@ store_reset(g->s + (g->size = g->ptr + 1));
+ Arguments:
+ g the growable-string
+ p current end of data
+- count amount to grow by
++ count amount to grow by, offset from p
+ */
+
+ static void
+@@ -1590,7 +1590,7 @@ while (*fp)
+ }
+ else if (g->ptr >= lim - width)
+ {
+- gstring_grow(g, g->ptr, width - (lim - g->ptr));
++ gstring_grow(g, g->ptr, width);
+ lim = g->size - 1;
+ gp = CS g->s + g->ptr;
+ }
+--
+1.9.1
+