aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2016-01-20 23:20:00 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-01-21 06:28:23 +0000
commit89209ade4acd6741aae257f8c38c5d22ab664f85 (patch)
tree2e642d2fe2d8e61a08efa4f20d5e4458846334e8
parenta8e883ce8bbfadc9c60bdec17c6be75964760140 (diff)
main/coreutils: upgrade to 8.25
remove upstreamed patch
-rw-r--r--main/coreutils/APKBUILD15
-rw-r--r--main/coreutils/coreutils-8.22-shuf-segfault.patch74
2 files changed, 6 insertions, 83 deletions
diff --git a/main/coreutils/APKBUILD b/main/coreutils/APKBUILD
index 8d9a63441a5..6d1ac36f869 100644
--- a/main/coreutils/APKBUILD
+++ b/main/coreutils/APKBUILD
@@ -1,7 +1,8 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=coreutils
-pkgver=8.24
+pkgver=8.25
pkgrel=0
pkgdesc="The basic file, shell and text manipulation utilities"
url="http://www.gnu.org/software/coreutils/"
@@ -12,8 +13,7 @@ makedepends="bash acl-dev perl"
install=
subpackages="$pkgname-doc"
install="$pkgname.post-deinstall"
-source="http://ftp.gnu.org/gnu/coreutils/$pkgname-$pkgver.tar.xz
- coreutils-8.22-shuf-segfault.patch"
+source="http://ftp.gnu.org/gnu/coreutils/$pkgname-$pkgver.tar.xz"
_builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -51,9 +51,6 @@ package() {
mv chroot "$pkgdir"/usr/sbin/
}
-md5sums="40efdbce865d2458d8da0a9dcee7c16c coreutils-8.24.tar.xz
-94f7e6f373f37beb236caabed8fcdb52 coreutils-8.22-shuf-segfault.patch"
-sha256sums="a2d75286a4b9ef3a13039c2da3868a61be4ee9f17d8ae380a35a97e506972170 coreutils-8.24.tar.xz
-3d9074964b3be7ccf2a384de4a48ef372db13fd77c2fc7316d5a94f3fdcae17e coreutils-8.22-shuf-segfault.patch"
-sha512sums="b42bb233340353647bb9a1c3d9122c1a5379cf3602ba9197c3c935fc899897e7d4685148dfaf93eccc096bee0a9b03416d79dc9bb81d5d2dea6e04ed134a3d1b coreutils-8.24.tar.xz
-1e2ff3b4d32c3c833ee7b4fb29d7509bebfb3c8c5ea0c2bcfff48d221d03d3a6da47be6be5f723d792a26c66063a99293ab9a7b609726357bc45fb2a01bad844 coreutils-8.22-shuf-segfault.patch"
+md5sums="070e43ba7f618d747414ef56ab248a48 coreutils-8.25.tar.xz"
+sha256sums="31e67c057a5b32a582f26408c789e11c2e8d676593324849dcf5779296cdce87 coreutils-8.25.tar.xz"
+sha512sums="571f95d44987d373081ed4c6ac82155ad3dcd95621d7b1a7163597e80ecbbafef2cd74b2ef594587a443a1a4355083879f898a286bb0230c48112d43d076ccd6 coreutils-8.25.tar.xz"
diff --git a/main/coreutils/coreutils-8.22-shuf-segfault.patch b/main/coreutils/coreutils-8.22-shuf-segfault.patch
deleted file mode 100644
index e22b3c7b200..00000000000
--- a/main/coreutils/coreutils-8.22-shuf-segfault.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 24eb395471176e24762b08bfcef7562911537504 Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Sun, 23 Feb 2014 15:34:48 -0800
-Subject: [PATCH] shuf: with -r, don't dump core if the input is empty
-
-Problem reported by valiant xiao in <http://bugs.gnu.org/16855>.
-* NEWS: Document this.
-* src/shuf.c (main): With -r, report an error if the input is empty.
-* tests/misc/shuf.sh: Test for the bug.
----
- NEWS | 3 +++
- src/shuf.c | 15 +++++++++++----
- tests/misc/shuf.sh | 4 ++++
- 3 files changed, 18 insertions(+), 4 deletions(-)
-
-diff --git a/NEWS b/NEWS
-index e72942b..2df246d 100644
---- a/NEWS
-+++ b/NEWS
-@@ -22,6 +22,9 @@ GNU coreutils NEWS -*- outline -*-
- it would display an error, requiring --no-dereference to avoid the issue.
- [bug introduced in coreutils-5.3.0]
-
-+ shuf -r no longer dumps core if the input is empty.
-+ [bug introduced in coreutils-8.22]
-+
- ** New features
-
- od accepts a new option: --endian=TYPE to handle inputs with different byte
-diff --git a/src/shuf.c b/src/shuf.c
-index d4641fe..2a91072 100644
---- a/src/shuf.c
-+++ b/src/shuf.c
-@@ -576,11 +576,18 @@ main (int argc, char **argv)
- /* Generate output according to requested method */
- if (repeat)
- {
-- if (input_range)
-- i = write_random_numbers (randint_source, head_lines,
-- lo_input, hi_input, eolbyte);
-+ if (head_lines == 0)
-+ i = 0;
- else
-- i = write_random_lines (randint_source, head_lines, line, n_lines);
-+ {
-+ if (n_lines == 0)
-+ error (EXIT_FAILURE, 0, _("No lines to repeat"));
-+ if (input_range)
-+ i = write_random_numbers (randint_source, head_lines,
-+ lo_input, hi_input, eolbyte);
-+ else
-+ i = write_random_lines (randint_source, head_lines, line, n_lines);
-+ }
- }
- else
- {
-diff --git a/tests/misc/shuf.sh b/tests/misc/shuf.sh
-index d3ea1f2..d7251d1 100755
---- a/tests/misc/shuf.sh
-+++ b/tests/misc/shuf.sh
-@@ -43,6 +43,10 @@ compare in out1 || { fail=1; echo "not a permutation" 1>&2; }
- t=$(shuf -e a b c d e | sort | fmt)
- test "$t" = 'a b c d e' || { fail=1; echo "not a permutation" 1>&2; }
-
-+# coreutils-8.22 dumps core.
-+shuf -er
-+test $? -eq 1 || fail=1
-+
- # Before coreutils-6.3, this would infloop.
- # "seq 1860" produces 8193 (8K + 1) bytes of output.
- seq 1860 | shuf > /dev/null || fail=1
---
-1.8.5.3
-