aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-25 11:17:23 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-29 18:24:02 +0100
commit8a07ba175be150103fc5d4382f6a7a92d19f60d6 (patch)
tree7993b0017d14172718a213c05e89a4a95ec7217f
parent40fafb64236b09a535d4ba807ed5e366fc7cbe64 (diff)
community/abiword: upgrade to 3.0.4
-rw-r--r--community/abiword/APKBUILD10
-rw-r--r--community/abiword/fix-black-drawing-regression.patch54
-rw-r--r--community/abiword/fix-nullptr-c++98.patch34
3 files changed, 4 insertions, 94 deletions
diff --git a/community/abiword/APKBUILD b/community/abiword/APKBUILD
index 976affe98b1..4bb2b3b3398 100644
--- a/community/abiword/APKBUILD
+++ b/community/abiword/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
-pkgver=3.0.2
-pkgrel=4
+pkgver=3.0.4
+pkgrel=0
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
arch="all !s390x"
@@ -29,8 +29,7 @@ for _i in $_plugins; do
subpackages="$subpackages $pkgname-plugin-$_i:_plugin"
done
-source="http://www.abisource.com/downloads/abiword/$pkgver/source/abiword-$pkgver.tar.gz
- fix-black-drawing-regression.patch"
+source="http://www.abisource.com/downloads/abiword/$pkgver/source/abiword-$pkgver.tar.gz"
build() {
./configure \
@@ -64,5 +63,4 @@ plugins() {
mkdir -p "$subpkgdir"
}
-sha512sums="29ce9e80b3b85ab2933e7d39216771d8c4e05db5255eaed0cf8e1d032ffaac2cb1880bf24e754196ad5dae4969a1c2101ce4dc9c1db14604adc2f852b6a17fe3 abiword-3.0.2.tar.gz
-cae9a08047cd97d11acea25a2f0b0ca4e8e4556b462eb476507fa178a7412221839febfeb36bebf491bb94d53525c4584d86230f96c403a7ceb2dec4223be8fe fix-black-drawing-regression.patch"
+sha512sums="121708e010cef6722cab5622dc762f2f92c46e43b65b90b881b4f25ff32c1696fa2d281a3a6f2c04d5b9231bbbd0040281e9d4d7e594ec0ace6caae9c9021ec4 abiword-3.0.4.tar.gz"
diff --git a/community/abiword/fix-black-drawing-regression.patch b/community/abiword/fix-black-drawing-regression.patch
deleted file mode 100644
index dbce8c696da..00000000000
--- a/community/abiword/fix-black-drawing-regression.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From cec2fda355b67b5b814a803c5ed128c425cbb030 Mon Sep 17 00:00:00 2001
-From: Hubert Figuiere <hub@figuiere.net>
-Date: Thu, 8 Dec 2016 02:03:10 +0000
-Subject: [PATCH] Bug 13815 - draw event should return TRUE
-
-This fix the black drawing regression with Gtk3.22
-
-git-svn-id: svn+ssh://svn.abisource.com/svnroot/abiword/branches/ABI-3-0-0-STABLE@35394 bcba8976-2d24-0410-9c9c-aab3bd5fdfd6
----
- src/af/xap/gtk/xap_UnixFrameImpl.cpp | 6 +++---
- src/af/xap/gtk/xap_UnixFrameImpl.h | 4 ++--
- 2 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.cpp b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
-index 780000e..10f8e00 100644
---- a/src/af/xap/gtk/xap_UnixFrameImpl.cpp
-+++ b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
-@@ -1208,9 +1208,9 @@ gint XAP_UnixFrameImpl::_fe::delete_event(GtkWidget * w, GdkEvent * /*event*/, g
- }
-
- #if GTK_CHECK_VERSION(3,0,0)
--gint XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
-+gboolean XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
- #else
--gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
-+gboolean XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
- #endif
- {
- XAP_UnixFrameImpl * pUnixFrameImpl = static_cast<XAP_UnixFrameImpl *>(g_object_get_data(G_OBJECT(w), "user_data"));
-@@ -1243,7 +1243,7 @@ gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
- pView->draw(&rClip);
- #endif
- }
-- return FALSE;
-+ return TRUE;
- }
-
- static bool bScrollWait = false;
-diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.h b/src/af/xap/gtk/xap_UnixFrameImpl.h
-index 30ee5d8..a0ff57f 100644
---- a/src/af/xap/gtk/xap_UnixFrameImpl.h
-+++ b/src/af/xap/gtk/xap_UnixFrameImpl.h
-@@ -152,9 +152,9 @@ class XAP_UnixFrameImpl : public XAP_FrameImpl
- static gint key_release_event(GtkWidget* w, GdkEventKey* e);
- static gint delete_event(GtkWidget * w, GdkEvent * /*event*/, gpointer /*data*/);
- #if GTK_CHECK_VERSION(3,0,0)
-- static gint draw(GtkWidget * w, cairo_t * cr);
-+ static gboolean draw(GtkWidget * w, cairo_t * cr);
- #else
-- static gint expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
-+ static gboolean expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
- #endif
- static gint do_ZoomUpdate( gpointer /* xap_UnixFrame * */ p);
- static void vScrollChanged(GtkAdjustment * w, gpointer /*data*/);
diff --git a/community/abiword/fix-nullptr-c++98.patch b/community/abiword/fix-nullptr-c++98.patch
deleted file mode 100644
index f09319693fe..00000000000
--- a/community/abiword/fix-nullptr-c++98.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Replace 'nullptr' by NULL in order to allow compiling in C++98 mode.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=599618
-
---- a/src/af/gr/gtk/gr_UnixCairoGraphics.cpp
-+++ b/src/af/gr/gtk/gr_UnixCairoGraphics.cpp
-@@ -180,7 +180,7 @@
- if (m_styleBg) {
- g_object_unref(m_styleBg);
- }
-- m_styleBg = XAP_GtkStyle_get_style(nullptr, "GtkButton"); // "button"
-+ m_styleBg = XAP_GtkStyle_get_style(NULL, "GtkButton"); // "button"
- // guess colours
- // WHITE
- GdkRGBA rgba2;
-@@ -627,7 +627,7 @@
- _setProps();
- cairo_save (m_cr);
-
-- GtkStyleContext *context = nullptr;
-+ GtkStyleContext *context = NULL;
- switch(c) {
- case GR_Graphics::CLR3D_Background:
- context = m_styleBg;
---- a/src/wp/ap/xp/ap_Dialog_Spell.cpp
-+++ b/src/wp/ap/xp/ap_Dialog_Spell.cpp
-@@ -251,7 +251,7 @@
- UT_return_val_if_fail (m_Suggestions, false);
-
- // get suggestions from spelling engine
-- const UT_GenericVector<UT_UCSChar*> *cpvEngineSuggestions = nullptr;
-+ const UT_GenericVector<UT_UCSChar*> *cpvEngineSuggestions = NULL;
-
- if (checker->checkWord(m_pWord, m_iWordLength) == SpellChecker::LOOKUP_FAILED)
- {