aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-09-12 18:38:46 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-09-17 20:10:56 +0000
commit8a961cbfeb5b3c826d72f9ff77c71b37014baff4 (patch)
tree19f6d08c3944bfbe56c6bc973517f7bbba1e3468
parentda28baa43f4310ad68cbfb53f7b45b60b93b3907 (diff)
downloadaports-8a961cbfeb5b3c826d72f9ff77c71b37014baff4.tar.gz
aports-8a961cbfeb5b3c826d72f9ff77c71b37014baff4.tar.bz2
aports-8a961cbfeb5b3c826d72f9ff77c71b37014baff4.tar.xz
community/kde-frameworks: upgrade to 5.74.0
-rw-r--r--community/attica/APKBUILD4
-rw-r--r--community/baloo/APKBUILD6
-rw-r--r--community/bluez-qt/APKBUILD4
-rw-r--r--community/breeze-icons/APKBUILD4
-rw-r--r--community/extra-cmake-modules/APKBUILD4
-rw-r--r--community/frameworkintegration/APKBUILD6
-rw-r--r--community/kactivities-stats/APKBUILD4
-rw-r--r--community/kactivities/APKBUILD4
-rw-r--r--community/kapidox/APKBUILD21
-rw-r--r--community/karchive/APKBUILD4
-rw-r--r--community/kauth/APKBUILD6
-rw-r--r--community/kbookmarks/APKBUILD6
-rw-r--r--community/kcalendarcore/APKBUILD4
-rw-r--r--community/kcmutils/APKBUILD6
-rw-r--r--community/kcodecs/APKBUILD4
-rw-r--r--community/kcompletion/APKBUILD4
-rw-r--r--community/kconfig/APKBUILD4
-rw-r--r--community/kconfigwidgets/APKBUILD6
-rw-r--r--community/kcontacts/APKBUILD4
-rw-r--r--community/kcoreaddons/APKBUILD4
-rw-r--r--community/kcrash/APKBUILD4
-rw-r--r--community/kdav/APKBUILD6
-rw-r--r--community/kdbusaddons/APKBUILD4
-rw-r--r--community/kdeclarative/APKBUILD6
-rw-r--r--community/kded/APKBUILD4
-rw-r--r--community/kdelibs4support/APKBUILD6
-rw-r--r--community/kdesignerplugin/APKBUILD6
-rw-r--r--community/kdesu/APKBUILD4
-rw-r--r--community/kdewebkit/APKBUILD6
-rw-r--r--community/kdnssd/APKBUILD4
-rw-r--r--community/kdoctools/APKBUILD4
-rw-r--r--community/kemoticons/APKBUILD4
-rw-r--r--community/kfilemetadata/APKBUILD4
-rw-r--r--community/kglobalaccel/APKBUILD4
-rw-r--r--community/kguiaddons/APKBUILD4
-rw-r--r--community/kholidays/APKBUILD4
-rw-r--r--community/khtml/APKBUILD6
-rw-r--r--community/ki18n/APKBUILD6
-rw-r--r--community/kiconthemes/APKBUILD8
-rw-r--r--community/kidletime/APKBUILD4
-rw-r--r--community/kimageformats/APKBUILD4
-rw-r--r--community/kinit/APKBUILD6
-rw-r--r--community/kio/0001-remove-old-kio_fonts-hack.patch41
-rw-r--r--community/kio/0002-accomodate-local-protocols-that-use-hostname-in-url.patch49
-rw-r--r--community/kio/APKBUILD48
-rw-r--r--community/kirigami2/APKBUILD4
-rw-r--r--community/kitemmodels/APKBUILD4
-rw-r--r--community/kitemviews/APKBUILD4
-rw-r--r--community/kjobwidgets/APKBUILD4
-rw-r--r--community/kjs/APKBUILD4
-rw-r--r--community/kjsembed/APKBUILD4
-rw-r--r--community/kmediaplayer/APKBUILD6
-rw-r--r--community/knewstuff/APKBUILD6
-rw-r--r--community/knotifications/APKBUILD4
-rw-r--r--community/knotifyconfig/APKBUILD6
-rw-r--r--community/kpackage/APKBUILD4
-rw-r--r--community/kparts/APKBUILD6
-rw-r--r--community/kpeople/APKBUILD4
-rw-r--r--community/kplotting/APKBUILD4
-rw-r--r--community/kpty/APKBUILD4
-rw-r--r--community/kquickcharts/APKBUILD4
-rw-r--r--community/kross/APKBUILD6
-rw-r--r--community/krunner/APKBUILD6
-rw-r--r--community/kservice/APKBUILD4
-rw-r--r--community/ktexteditor/APKBUILD6
-rw-r--r--community/ktextwidgets/APKBUILD6
-rw-r--r--community/kunitconversion/APKBUILD4
-rw-r--r--community/kwallet/APKBUILD6
-rw-r--r--community/kwayland/APKBUILD4
-rw-r--r--community/kwidgetsaddons/APKBUILD4
-rw-r--r--community/kwindowsystem/APKBUILD6
-rw-r--r--community/kxmlgui/APKBUILD6
-rw-r--r--community/kxmlrpcclient/APKBUILD6
-rw-r--r--community/modemmanager-qt/APKBUILD4
-rw-r--r--community/networkmanager-qt/APKBUILD4
-rw-r--r--community/oxygen-icons/APKBUILD4
-rw-r--r--community/plasma-framework/APKBUILD6
-rw-r--r--community/prison/APKBUILD4
-rw-r--r--community/purpose/APKBUILD6
-rw-r--r--community/qqc2-desktop-style/APKBUILD6
-rw-r--r--community/solid/APKBUILD6
-rw-r--r--community/sonnet/APKBUILD4
-rw-r--r--community/syndication/APKBUILD4
-rw-r--r--community/syntax-highlighting/APKBUILD4
-rw-r--r--community/threadweaver/APKBUILD4
85 files changed, 336 insertions, 211 deletions
diff --git a/community/attica/APKBUILD b/community/attica/APKBUILD
index 291aba1fd5..7123f9350f 100644
--- a/community/attica/APKBUILD
+++ b/community/attica/APKBUILD
@@ -1,7 +1,7 @@
# Contributor:
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=attica
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Freedesktop OCS binding for Qt"
url="http://www.kde.org/"
@@ -30,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="ca8787af5e7c5d6b88fad4f52b4fa4d34be40c27020f54cd05a81c135b2269702733094e917db7dd8bce07a0b39ad19b57f4dc0e686eb16b809b712078beb964 attica-5.73.0.tar.xz"
+sha512sums="261bcec9836c36c3e22df6d629dee35512dac6d8194a393bf2d818432696eb053edee04f5474383f4ab69559f5b875ac392a4c41727eedbea2df9d51b81a19e0 attica-5.74.0.tar.xz"
diff --git a/community/baloo/APKBUILD b/community/baloo/APKBUILD
index e40836cfa1..8f6d4ad580 100644
--- a/community/baloo/APKBUILD
+++ b/community/baloo/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=baloo
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="A framework for searching and managing metadata"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends_dev="qt5-qtdeclarative-dev lmdb-dev kcoreaddons-dev kconfig-dev kdbusaddons-dev ki18n-dev kidletime-dev solid-dev kfilemetadata-dev kcrash-dev kio-dev kservice-dev kbookmarks-dev kcompletion-dev kjobwidgets-dev"
@@ -24,4 +24,4 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="588938d14142d673bf04d782ed1ae91c4380b539b752b968430064835435726f62109924b02906bfd432ce155a272f35483ca9dfda55be937d532d1e65ef2338 baloo-5.73.0.tar.xz"
+sha512sums="e044b3d0aa924154e32d2a7a66c6de0c4a8b572d3357d5c2600e9a64ae3e32751ea5953a37bbb8a0bde939732b1298486ccceaa64a84400f6179e44cd360ec5f baloo-5.74.0.tar.xz"
diff --git a/community/bluez-qt/APKBUILD b/community/bluez-qt/APKBUILD
index 71cb4bd4cf..477559ad2c 100644
--- a/community/bluez-qt/APKBUILD
+++ b/community/bluez-qt/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=bluez-qt
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
pkgdesc="Qt wrapper for Bluez 5 DBus API"
@@ -25,4 +25,4 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="1cb59003eaa3c43c998c43c9037e7dd9c1ade09789f02bd4dc4400c82040c0e722349493b9965f9ece341055dbee9fe20dfb1288fb65e7a63eeac6f27fabdc04 bluez-qt-5.73.0.tar.xz"
+sha512sums="dfd13e5610233453596e633766c0da30d4f6ba219af32249ce502f5f6a64e9315d26408a5bfd6fc2f51043df531c73127d9c431ff51a0159a043aa681bd743c6 bluez-qt-5.74.0.tar.xz"
diff --git a/community/breeze-icons/APKBUILD b/community/breeze-icons/APKBUILD
index 36ba2c6f7e..23b1a19722 100644
--- a/community/breeze-icons/APKBUILD
+++ b/community/breeze-icons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=breeze-icons
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Breeze icon themes"
arch="noarch !armhf" # armhf blocked by extra-cmake-modules
@@ -30,6 +30,6 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="aa135c1784dd30682887ff8c7d568b3f046d693401d69f72d4587902e36f1a8bb7ed2e6630d8aaf1aeabd01214814d860edf6f923e4983daf7aa0229ef6ba44f breeze-icons-5.73.0.tar.xz
+sha512sums="735bfd7349a400b9709a1387119187ba1ca712020a8fbfc5acced97200f17b7dc8a8a6e823d7a3223012e2a990ef46af25293c013b5ffff231526ab18fd86935 breeze-icons-5.74.0.tar.xz
5fbfe9c5bf0a01504274040d97bb3c58ae18580f9ab63ea5701149c508fccb02f6566435b355264008731a7778939f08c5de1820a24b521386e19248ae82ff96 busybox-grep-q.patch
146ea6635feaf05541ca82839fd315dfa10cb6daaf364cbe79f324451617d53f405c52fe5ed5a2abfe6d3e01109795afc3a385dce78b0cb0f78702d1b434a250 busybox-sed-i.patch"
diff --git a/community/extra-cmake-modules/APKBUILD b/community/extra-cmake-modules/APKBUILD
index 82c1462e30..165bbb6bb3 100644
--- a/community/extra-cmake-modules/APKBUILD
+++ b/community/extra-cmake-modules/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Ivan Tham <pickfire@riseup.net>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=extra-cmake-modules
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Extra CMake modules"
url="https://projects.kde.org/projects/kdesupport/extra-cmake-modules"
@@ -32,4 +32,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="2ecfbfb757de92e6f0855c102c1b9374807fbffdf2b38a9e5c270baae2382b649c88944ed95c27f2519fb8432a0da32122735eb6f986569ed3229cc5d7f74cad extra-cmake-modules-5.73.0.tar.xz"
+sha512sums="5d4f612758bda73d8327cc582bda3550807de90e1b729d24a59ac7e70db127da208a53590f48cda9775f2be6e22a7db47958e3f01577b4baf0b8ef86672579a1 extra-cmake-modules-5.74.0.tar.xz"
diff --git a/community/frameworkintegration/APKBUILD b/community/frameworkintegration/APKBUILD
index 1806a1ce2b..30b692bb09 100644
--- a/community/frameworkintegration/APKBUILD
+++ b/community/frameworkintegration/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=frameworkintegration
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Framework providing components to allow applications to integrate with a KDE Workspace"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://www.kde.org"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kconfig-dev kconfigwidgets-dev kiconthemes-dev knotifications-dev knewstuff-dev kwidgetsaddons-dev kpackage-dev ki18n-dev appstream-dev"
@@ -30,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="23366afa4ac57a9b642f93eac2a4bb31ca18afbc1073688bd9e95e317a9b0f3f7854311948ab962e536eea9d04a07411ac7bf1d5863fe79e7d82819761130cfd frameworkintegration-5.73.0.tar.xz"
+sha512sums="4bf533b261c149a10ed4b4607f532b57b989f6e130c417a0398216ddbe1b4b3ab964009aa5c021bdc92960f8c25c7f5c66cf8606ed7956b25adfa401d0f08e68 frameworkintegration-5.74.0.tar.xz"
diff --git a/community/kactivities-stats/APKBUILD b/community/kactivities-stats/APKBUILD
index aabe3e3199..5eb0e3b930 100644
--- a/community/kactivities-stats/APKBUILD
+++ b/community/kactivities-stats/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
# Contributor: Bart Ribbers <bribbers@disroot.org>
pkgname=kactivities-stats
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
pkgdesc="A library for accessing the usage data collected by the activities system"
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="b50aecc46098339ccc5728d0667d645dc90621b7c9f01b07a62845092f85c4f1b9d76cd6b55dbaa3e4e07f5178d16562f022a31eb7725da7202c172e52408a5a kactivities-stats-5.73.0.tar.xz"
+sha512sums="0caa8afb52b7643cf21a6d3fdaa3e987b632f1414e9888fc174623fe8b646c3eef4a8f57a2d0d22f7d726e9952a074550d1f35fb0f65cc5d061222746a6dbbac kactivities-stats-5.74.0.tar.xz"
diff --git a/community/kactivities/APKBUILD b/community/kactivities/APKBUILD
index a2b3aabc0b..6d5e57433b 100644
--- a/community/kactivities/APKBUILD
+++ b/community/kactivities/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kactivities
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
pkgdesc="Core components for the KDE's Activities"
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="aa3baa20c8584bf57020fe53ac09750b5e002c737581f545a64db8239357c3295a9974d6769084a119a125970631d22835aca3f24375e7420721918ffd4f4839 kactivities-5.73.0.tar.xz"
+sha512sums="fcfae3047e19dc7b41c0f0752c6aa95a652d635947c78ba9a3d069e365f9c68475b325c591a3a864c63ef285d243b473720f63e92d86802df661bfdd7826b7e7 kactivities-5.74.0.tar.xz"
diff --git a/community/kapidox/APKBUILD b/community/kapidox/APKBUILD
index 3b3cd43137..cc5b5b9133 100644
--- a/community/kapidox/APKBUILD
+++ b/community/kapidox/APKBUILD
@@ -1,23 +1,30 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kapidox
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
arch="noarch !armhf" # armhf blocked by extra-cmake-modules
pkgdesc="Scripts and data for building API documentation (dox) in a standard format and style"
url="https://community.kde.org/Frameworks"
license="BSD-3-Clause"
-depends="python3 py3-yaml py3-jinja2 doxygen"
-makedepends="extra-cmake-modules python3-dev"
+depends="
+ doxygen
+ py3-jinja2
+ py3-yaml
+ python3
+ "
+makedepends="
+ extra-cmake-modules
+ py3-setuptools
+ python3-dev
+ "
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kapidox-$pkgver.tar.xz"
subpackages="$pkgname-doc"
build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_QCH=ON
+ -DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
@@ -29,4 +36,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="72343766922641e9fb86c360e8d3f165a6ee3743af3a6abea2be0dc75cf2708ff539fff07e5318dc7ad9ad0101d90efd0f3fd2e42da6826edf89abc94ecf4fd1 kapidox-5.73.0.tar.xz"
+sha512sums="0292f1836576e67d2a0b439ca3890d10b580ec6dfcf947760c305320ba67f688d2e75323d9976be0673dfbf241f7d1978cfbfc5954de8ff7b2fdbab88bf62b1f kapidox-5.74.0.tar.xz"
diff --git a/community/karchive/APKBUILD b/community/karchive/APKBUILD
index e0fa9844d7..176c0f8d9d 100644
--- a/community/karchive/APKBUILD
+++ b/community/karchive/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=karchive
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Qt 5 addon providing access to numerous types of archives"
arch="all !armhf" # qtdeclarative
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="89de205d9cbd58e21db19b575fc34fbf044f84554f85ba3f59657a7c0682041fb1e9537a208c80626c1568d4430c7e5fb5ed5f994b9f4e545210259e56530a09 karchive-5.73.0.tar.xz"
+sha512sums="c43aef33cd5cd1128637ab8ac3f7c8f26eaa27fb9f14ce0f2b5d122be2cf08f4b758fe08147c570969834600f714c1e236d1e7c05864ce1cd2dd8ca2f4e62069 karchive-5.74.0.tar.xz"
diff --git a/community/kauth/APKBUILD b/community/kauth/APKBUILD
index 9d0c693b9c..1e5302f68e 100644
--- a/community/kauth/APKBUILD
+++ b/community/kauth/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kauth
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Abstraction to system policy and authentication features"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kcoreaddons-dev polkit-qt-1-dev"
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="c514d898c7e4c7b4794799af03754090099cdfd2afb0679034f0209bbfa3541585461e9161abb787e0fcd1dcb887e0d1b5c7f314aee107e0a89cc897ef17bc79 kauth-5.73.0.tar.xz"
+sha512sums="277ff88cf447fdcf6c413997b4a3be871e7bddc0cd23cb379cb35f05c4b93cf68d7f0792eabc5d56ec7f043bf6de53ba9cec223750c4569a72e88c27f8d36036 kauth-5.74.0.tar.xz"
diff --git a/community/kbookmarks/APKBUILD b/community/kbookmarks/APKBUILD
index 5630cb4115..c971e4b261 100644
--- a/community/kbookmarks/APKBUILD
+++ b/community/kbookmarks/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kbookmarks
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Support for bookmarks and the XBEL format"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kconfig-dev kcoreaddons-dev kcodecs-dev kconfigwidgets-dev kwidgetsaddons-dev kxmlgui-dev"
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="b6ef0c40fc8da56cb80d2c654f2c0c97669560bdf112eaa890fdf89a8476c207aafcff0ddf138e16f4e1678dd84839b93617db8de81d9986ae048cf4dd36048a kbookmarks-5.73.0.tar.xz"
+sha512sums="c12bf2f54f64bb2bb7ff3c7e4124d404369878f29ae095d919aed2ea57b07b78b8c9b66f8c8631fd0653ea7623a05425a5bc7d383d69ae079cf0cfaeec662be7 kbookmarks-5.74.0.tar.xz"
diff --git a/community/kcalendarcore/APKBUILD b/community/kcalendarcore/APKBUILD
index 11a099daf5..95012dc32d 100644
--- a/community/kcalendarcore/APKBUILD
+++ b/community/kcalendarcore/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kcalendarcore
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="The KDE calendar access library"
options="!check" # RecursOn-ConnectDaily(2|3|6) make the builders stuck
@@ -33,4 +33,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="111c1fbf5fa5e9ab5835eaad0dd3f5dfb44b970795cfbe107450da9c6af5fbb5f40624c0da380f831163729e5c84d1d0a0179c799dd7c4bd2d5261d3c76b8dab kcalendarcore-5.73.0.tar.xz"
+sha512sums="f6b48283d5433e171a1961abcbf47422fb8ce1e6412d0a83de20c16b2e81e065e16c1525440e1a29791b31ec74fbe672878cd554fceab703cc0c9c45c23524af kcalendarcore-5.74.0.tar.xz"
diff --git a/community/kcmutils/APKBUILD b/community/kcmutils/APKBUILD
index bc3914cba3..b5b6f37611 100644
--- a/community/kcmutils/APKBUILD
+++ b/community/kcmutils/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kcmutils
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Utilities for interacting with KCModules"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="kitemviews-dev kconfigwidgets-dev kcoreaddons-dev ki18n-dev kiconthemes-dev kservice-dev kxmlgui-dev kdeclarative-dev"
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="499555f9ea298ce371ff64533236112f1a50388ac0b877c304b07a861894e8f19d011fe561c21ce7a974c98d14a5fe5bcb26c26a314068833e6ed11fbe0406db kcmutils-5.73.0.tar.xz"
+sha512sums="105664749e73eeb0b911479d3befe813eef290d7dafa4ec51c134a79c58826361f90e18acf6d8f5d5b7e8d5d6a5956a73bc31e2c6f3de9ad45fec80341963c7a kcmutils-5.74.0.tar.xz"
diff --git a/community/kcodecs/APKBUILD b/community/kcodecs/APKBUILD
index c46ef6c9f0..ab6c15df9b 100644
--- a/community/kcodecs/APKBUILD
+++ b/community/kcodecs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kcodecs
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Provide a collection of methods to manipulate strings using various encodings"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -28,4 +28,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="acf2098158767f6b2d32412fdccd38f31141cc3db1b7706b05c9e6c01d21900e5aeeff5de0ef456431a3a606508828606d4404ef55f5bb4dedc0b8f89c86ee8b kcodecs-5.73.0.tar.xz"
+sha512sums="1858eb0d18b79ee197e780d995a30bf208d63acc17d8f474d27ddb67ffb4e0e7c8a909a1f3750a1121088735b4a6087609bba6d7cbf0838d414adec2c53d6491 kcodecs-5.74.0.tar.xz"
diff --git a/community/kcompletion/APKBUILD b/community/kcompletion/APKBUILD
index f7b7990cde..446a308a1c 100644
--- a/community/kcompletion/APKBUILD
+++ b/community/kcompletion/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kcompletion
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Text completion helpers and widgets"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="d46a8cdf1c75c6a51f6edcc59a2ad7204b42f630fde6df986c1d2476f4d2e49cdf2b825e22afd0bf21fca6ea9963f72c0844b7d012ea2dca8051c95f4bb9d8a9 kcompletion-5.73.0.tar.xz"
+sha512sums="d63bb7a1f4a2ed42888b3811328416d0a63ff3f9cd2fd64f836cbaaabcdd5a11847e26d00e96ab2794f08c02cbfd60a969caa53f9210c21c0a85a3ce688cdaba kcompletion-5.74.0.tar.xz"
diff --git a/community/kconfig/APKBUILD b/community/kconfig/APKBUILD
index 42e6bf8e10..863657fbab 100644
--- a/community/kconfig/APKBUILD
+++ b/community/kconfig/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kconfig
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Configuration system"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="18b4f2912912018bdcfdcfa8961ea4009ec6799d2c766300bd25d0bb64d953d2849f13d3f52f13a8b770f70a5422adb2d97e4c0a6e2ee639de8dc6bb1402f69f kconfig-5.73.0.tar.xz"
+sha512sums="6c2bbf8aabef7344e5e085664d77c50b97541f2412e2c60f64f76b553034369b7a25cfbdd251f2b62e3bb91c2cd98749051cea3855ed09fb5baf80a098274242 kconfig-5.74.0.tar.xz"
diff --git a/community/kconfigwidgets/APKBUILD b/community/kconfigwidgets/APKBUILD
index aadc0f313c..fc56f72966 100644
--- a/community/kconfigwidgets/APKBUILD
+++ b/community/kconfigwidgets/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kconfigwidgets
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Widgets for KConfig"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="kauth-dev kcoreaddons-dev kcodecs-dev kconfig-dev kguiaddons-dev ki18n-dev kwidgetsaddons-dev"
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="6fd537d50a26ab688750bb68a22a83e2c79343a98d9f4231305a918275b63a4c5267f2248f006f113461c692c22f46a1d06a779a43fcc259862c6b36c80ec5fa kconfigwidgets-5.73.0.tar.xz"
+sha512sums="c51f005494aed3587a3f39a8582d5cb3e1f9e4c6da0074d9e9ad78038e63663278c891231c6358ca38ee9b41e00fe13da2bf0719b3213507eae8e5da35275e76 kconfigwidgets-5.74.0.tar.xz"
diff --git a/community/kcontacts/APKBUILD b/community/kcontacts/APKBUILD
index 9899ddbe94..43b03ca385 100644
--- a/community/kcontacts/APKBUILD
+++ b/community/kcontacts/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kcontacts
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Address book API for KDE"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -31,4 +31,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="1567d2a32110f6f256005aa9a7f145f5feb88a7b3777ebd47df49d2c10da7b9519853054f8c777353d9f111206753fcb7acb9e0e16f6cbad67cd2be3a03bba4f kcontacts-5.73.0.tar.xz"
+sha512sums="a4c78e0676a52abbee473310924280a7776c79bec3cf2273379f0c90e904ea0a31f5b5bd372472b29bfa5ec3a7ca5764af9e422bfc6a06fe3158287182815c71 kcontacts-5.74.0.tar.xz"
diff --git a/community/kcoreaddons/APKBUILD b/community/kcoreaddons/APKBUILD
index db33d9182d..30f569efd3 100644
--- a/community/kcoreaddons/APKBUILD
+++ b/community/kcoreaddons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kcoreaddons
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Addons to QtCore"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -36,4 +36,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="62bbba090daf269a4540620c9d8e5415bb9b4454021fabd39689416d975cd77d99e79aa62c3541bec0ce63edb88fb3b8c9b8efa9708118dc23e53e058d0f1c5a kcoreaddons-5.73.0.tar.xz"
+sha512sums="bbb1bdba02cf745ac705753558719d2b8b6b8279bdde2b77013da25f44f56421c5199efc061257f729ee4430e2674c4818941d89fd908b76a5a044628bbf9d3c kcoreaddons-5.74.0.tar.xz"
diff --git a/community/kcrash/APKBUILD b/community/kcrash/APKBUILD
index bb2b225099..2cb3807a8d 100644
--- a/community/kcrash/APKBUILD
+++ b/community/kcrash/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kcrash
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Support for application crash analysis and bug report from apps"
arch="all !armhf"
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="c4f4fc5b42bc8a5300f26b3da1ccace32b5323b13766cc785e16a8c55f143523870457cd41d534d8d925b66f60d9ab4c1c06cc5537fa50707142d1c98d6a4b6f kcrash-5.73.0.tar.xz"
+sha512sums="082a18aa69e62b05c262111396fbda62a5a5192f345ed9563f9f549ca05be34d6027e7339aef66d46d02a3fa7abc57c362db49dbbb71e94111815644890f0447 kcrash-5.74.0.tar.xz"
diff --git a/community/kdav/APKBUILD b/community/kdav/APKBUILD
index 7327731e9d..d7ea81c8da 100644
--- a/community/kdav/APKBUILD
+++ b/community/kdav/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdav
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="A DAV protocol implementation with KJobs"
url="https://community.kde.org/Frameworks"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
license="LGPL-2.0-or-later"
depends_dev="qt5-qtbase-dev qt5-qtxmlpatterns-dev kcoreaddons-dev kio-dev ki18n-dev"
makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
@@ -29,4 +29,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="1617fe65dd90f119f5181be7f234787eb43bb3a90e73b78503c45a3b1a843e3c8078b1cbfde97781fb7a531d987536662126e3eab41014bc18f05b7b0caa0ca1 kdav-5.73.0.tar.xz"
+sha512sums="77d789edc670d5930010185f5969c6b34678f39a4e3c0c2e05b79fb9cb029c7bc152b2418ee3a57659fb40472cd9fd8b40beeae4834299cf8dc1f9ede189fa4c kdav-5.74.0.tar.xz"
diff --git a/community/kdbusaddons/APKBUILD b/community/kdbusaddons/APKBUILD
index 74ea933450..a7aa494800 100644
--- a/community/kdbusaddons/APKBUILD
+++ b/community/kdbusaddons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdbusaddons
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Addons to QtDBus"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="edf29af24711de88ab91af1a9cca4b55d32dd3c555952d834bba43dfb12d5c0dd8cb698fb22539a2ac786c7a8a3745ddeb054d8da2cb4e1543744143fa5ca941 kdbusaddons-5.73.0.tar.xz"
+sha512sums="752726ff477e0159491a4002b60720f962bc832fbf824c342cfd16194b253ef5d94963e2aaefa0daad46af73fe62b4afa888a05846123533f2a8b875be90e72a kdbusaddons-5.74.0.tar.xz"
diff --git a/community/kdeclarative/APKBUILD b/community/kdeclarative/APKBUILD
index 0b36d07c89..0952d178e8 100644
--- a/community/kdeclarative/APKBUILD
+++ b/community/kdeclarative/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdeclarative
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Provides integration of QML and KDE Frameworks"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtdeclarative-dev kconfig-dev ki18n-dev kiconthemes-dev kio-dev kwidgetsaddons-dev kwindowsystem-dev kglobalaccel-dev kguiaddons-dev kpackage-dev libepoxy-dev"
@@ -32,4 +32,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="1b91e206d6d5a90badc39a242e4ea6f988a7bcc48b254fbf711af1c7dc4c1e96a4343e98e8c9dc0e516aef8f02f7a37a8b632e112f67bdd493825ce002afc6f4 kdeclarative-5.73.0.tar.xz"
+sha512sums="8428a60146275dff201518764678bb7c5acce473bcfa584ea1b4924db485ade1b45e55f3aa758fbcf326b15e0e24dcb0913fbabbedd795b7b47e3b3f7e897f78 kdeclarative-5.74.0.tar.xz"
diff --git a/community/kded/APKBUILD b/community/kded/APKBUILD
index f135d85756..87dd41b444 100644
--- a/community/kded/APKBUILD
+++ b/community/kded/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kded
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Extensible deamon for providing system level services"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="b6a7516d46be657cbfa655fcaff3c16c3758576ff91e0a720ce318bde85d853560fc196e75c99dbf0df295cf7b85adca670b15c72a88e6a32b723247901f7395 kded-5.73.0.tar.xz"
+sha512sums="625ffe6667a228d3330535d2049870fbee83a4c95ae221b733f9d22c608b37f4795c2e24c1cb91f87c78cf2863710062ea87c57146764323e14653d4baeedec3 kded-5.74.0.tar.xz"
diff --git a/community/kdelibs4support/APKBUILD b/community/kdelibs4support/APKBUILD
index b961e92b5f..a29197c608 100644
--- a/community/kdelibs4support/APKBUILD
+++ b/community/kdelibs4support/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdelibs4support
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Porting aid from KDELibs4"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND MIT AND LGPL-2.1-only AND LGPL-2.0-only AND (LGPL-2.1-only OR LGPL-3.0-only) AND (LGPL-2.0-only OR LGPL-3.0-only)"
depends_dev="qt5-qtbase-dev qt5-qttools-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kcrash-dev kdesignerplugin kdesignerplugin-dev kglobalaccel-dev kemoticons-dev kguiaddons-dev ki18n-dev kiconthemes-dev kio-dev knotifications-dev kparts-dev kservice-dev ktextwidgets-dev kunitconversion-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kdbusaddons-dev kded-dev kinit-dev perl-uri kdoctools-dev kitemmodels-dev"
@@ -31,4 +31,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="acbcd46606b695a82480561082e9e949e5dd980859c2bc59a2c459b3ecc38d9fd1f05e9d05300d88867490759a4ba7cf0f04dedc1032a6f59ddabfa7ed041fea kdelibs4support-5.73.0.tar.xz"
+sha512sums="a1b19ec933a947a1ebe3a60004341e1fa4fecd3a64de197ee997bbba6a14fae114e3409180d01de04d20e32e52182eeb9e85e131cba51601689f12eff4af3eab kdelibs4support-5.74.0.tar.xz"
diff --git a/community/kdesignerplugin/APKBUILD b/community/kdesignerplugin/APKBUILD
index fff7fc1e40..4e075ce38c 100644
--- a/community/kdesignerplugin/APKBUILD
+++ b/community/kdesignerplugin/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdesignerplugin
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Integration of Frameworks widgets in Qt Designer/Creator"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only"
depends_dev="kcoreaddons-dev kconfig-dev kcompletion-dev kconfigwidgets-dev kiconthemes-dev kio-dev kitemviews-dev kplotting-dev ktextwidgets-dev kwidgetsaddons-dev kxmlgui-dev sonnet-dev"
@@ -30,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="5ded7036a14ada32dd46153ad8a5867a49fb212841d8a57fc58ed152b75e1541a12b905f95a925fcda0479cdd70963b04a9cc3e1c79b3fda8276eb33f0978d28 kdesignerplugin-5.73.0.tar.xz"
+sha512sums="3d1fe367322ace3dcc665775d5503e9d8d413de6b0a8af710b1f774e33cd7b335b7a42ba619191a6bb6729def7913ed7e606cd9adce8aeeee9ca96c5241e899e kdesignerplugin-5.74.0.tar.xz"
diff --git a/community/kdesu/APKBUILD b/community/kdesu/APKBUILD
index 1768140af7..6db286dbcb 100644
--- a/community/kdesu/APKBUILD
+++ b/community/kdesu/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdesu
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Integration with su for elevated privileges"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -31,4 +31,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="331faee23d9946ea81b57a25bc52fdc4985e04c7373225d8fe7d5b285a6de3fce1b161453357dd6886778080e6d59a9f11c9db866d0dff99c1d7a08be656df4e kdesu-5.73.0.tar.xz"
+sha512sums="7d04ded1fd6e466d4d851bc87475c1ab9d459fe1b8c25f284a196ce90fb1ceb16d0c532a14f1bf75b005cf0f09049d07268270ffb508e0c334b8eb1a8af13b5f kdesu-5.74.0.tar.xz"
diff --git a/community/kdewebkit/APKBUILD b/community/kdewebkit/APKBUILD
index fb12877a1a..6286b6a14b 100644
--- a/community/kdewebkit/APKBUILD
+++ b/community/kdewebkit/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdewebkit
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Integration of the HTML rendering engine WebKit"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
arch="$arch !mips !mips64" # mips blocked by qt5-qtwebkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
@@ -31,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="edf7d35253402a931696b360ecb9efbc2a897642e3edbfa31fad1c85c056eccbcfe68c9a37c3e3925b83a70cdbbc25d3ea27f666cae7547aa3c53ea27fead269 kdewebkit-5.73.0.tar.xz"
+sha512sums="2363bbcf1d83ddc4ab30c80347c44a0c5ec1a3527772ee476ba488d5e58ae7ff6cba942e5da46d4400844ea56afdd116ffdb8693571753b7d50aa1b73ca53c0d kdewebkit-5.74.0.tar.xz"
diff --git a/community/kdnssd/APKBUILD b/community/kdnssd/APKBUILD
index fb8e896ab7..8c6a959dcf 100644
--- a/community/kdnssd/APKBUILD
+++ b/community/kdnssd/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdnssd
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
arch="all !armhf" # armhf blocked by extra-cmake-modules
pkgdesc="Network service discovery using Zeroconf"
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="3328c9bb10c94b1c4c924edd96ef292aa6f936da63724e31dd7714c29397f813cb5c1360be0492eadf2c584167ccfae5e93a60218b5c452de1418773775ebc88 kdnssd-5.73.0.tar.xz"
+sha512sums="ec9ad5b4c3117accaabec7d02fea28cff503788d3dd8a3696f35478b677925071dbea2d714e5ffceeb76ad898fb66030f0e4c3dfbcc7cf7292e05a0fd5102ccc kdnssd-5.74.0.tar.xz"
diff --git a/community/kdoctools/APKBUILD b/community/kdoctools/APKBUILD
index 4e5834fe4e..b274fc0abd 100644
--- a/community/kdoctools/APKBUILD
+++ b/community/kdoctools/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdoctools
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Documentation generation from docbook"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -32,4 +32,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="e4c0199a3b22a3cf545d8367c793f042242f9daad92d0b9c263a55da6b6399b1ac9e5729df696b55ca9ea9ab9f78b53c992f104c277f92cbeb825fab6a05d309 kdoctools-5.73.0.tar.xz"
+sha512sums="51a410c7cb9440926b27908be77ea9c26050943e4d3bfc24125b803b4104e22c0ca2963c7ccf968ab0d334846a4a3588fa7ade341cf02ec7d8ede4a06fe20327 kdoctools-5.74.0.tar.xz"
diff --git a/community/kemoticons/APKBUILD b/community/kemoticons/APKBUILD
index a1a8e18d0b..8b4c1c39e7 100644
--- a/community/kemoticons/APKBUILD
+++ b/community/kemoticons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kemoticons
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Support for emoticons and emoticons themes"
arch="all !armhf"
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="1eacd17ce103354474cd99c72e724562683bbe9eede49a827a2f96e3972e92a2eb80a3d30bc4ccd8bfeee0d23b75198f98cd3ce0de0e40fd15693886ea1c5fd3 kemoticons-5.73.0.tar.xz"
+sha512sums="b4f2a232cac9b997d204b8bdc1a217d643091c7bb723208d3f35268997b6eb07dbb9dff1d26c4732c8dd5f96e0c2e37549293532d412f8c175b5498b6d472ea7 kemoticons-5.74.0.tar.xz"
diff --git a/community/kfilemetadata/APKBUILD b/community/kfilemetadata/APKBUILD
index 42099432ee..69b4feacac 100644
--- a/community/kfilemetadata/APKBUILD
+++ b/community/kfilemetadata/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kfilemetadata
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="A library for extracting file metadata"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -44,4 +44,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="361ea23b60024639449be9151f612986ac803508ef57fcc30fef6ddf7640821eae13802794806e326db2456abe456c8cb3bc3297a6fa8c080f4aa5deacbd3a93 kfilemetadata-5.73.0.tar.xz"
+sha512sums="7b07d051f1bd339af6e24450c7ad325685d2ba1e4eda2adb14a25b91536f80d3a045d77501b143a41aa54012b043aed3a324f7c24fef60e72e63f42830034010 kfilemetadata-5.74.0.tar.xz"
diff --git a/community/kglobalaccel/APKBUILD b/community/kglobalaccel/APKBUILD
index a510b707b1..4802cb95b3 100644
--- a/community/kglobalaccel/APKBUILD
+++ b/community/kglobalaccel/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kglobalaccel
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Add support for global workspace shortcuts"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="356b0baa2f93b9ca9af8b495ab14804424ba174b72a5d8293b95218847c811f96bee0629b7b794e28f0ad742f26e50b80a2b03a7d8c4dd6fed9b4cff4090e5ed kglobalaccel-5.73.0.tar.xz"
+sha512sums="c97e35d0b2f2932f622dae406d385f2d98504fd5970ac75f48b66277283da2a5957e5d547fe6dc21369631a32827b561139f99307a30343e7bc93f54c8cd5918 kglobalaccel-5.74.0.tar.xz"
diff --git a/community/kguiaddons/APKBUILD b/community/kguiaddons/APKBUILD
index 380c2cedcd..2eb31803b3 100644
--- a/community/kguiaddons/APKBUILD
+++ b/community/kguiaddons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kguiaddons
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Addons to QtGui"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -31,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="907143a5c5bc8abb90cddfd28a8cc5c2f5d31ea6155a5407a52378d9596c0fe5a49c278d1006a6e4c446fca4410d45fa5cda4177150780c2aa5840154b423f80 kguiaddons-5.73.0.tar.xz"
+sha512sums="9943b908fefc12a82678102f439d79ccf4207dd8ebd00ac9cd23d0428cbdc5fcc41d11c04deaf7d63a76a1be24b28c1998e80098b620d7a9c7476ae412640686 kguiaddons-5.74.0.tar.xz"
diff --git a/community/kholidays/APKBUILD b/community/kholidays/APKBUILD
index fc0bd67fdc..d2a17f5937 100644
--- a/community/kholidays/APKBUILD
+++ b/community/kholidays/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kholidays
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Support for icon themes"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -31,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="6b9270a93bab8bf518fcf82f7790fa791b36c6e91ddb0dc49973eacf5edfefdb45413ed30fdf7c168ecb675b7f7438740da36396625c68064cea3202482dec29 kholidays-5.73.0.tar.xz"
+sha512sums="f35ba7c9ee42383ff629ed61dbc054656d40c7f59172bde313e897e718ee7151db79c8827582abfeb286f05c5c7b4d875c75d9790800b43c5831eb98a66e2195 kholidays-5.74.0.tar.xz"
diff --git a/community/khtml/APKBUILD b/community/khtml/APKBUILD
index 023cba6c59..e9443a300e 100644
--- a/community/khtml/APKBUILD
+++ b/community/khtml/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=khtml
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="The KDE HTML library, ancestor of WebKit"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND LGPL-2.1-only"
depends_dev="qt5-qtbase-dev perl-dev giflib-dev libjpeg-turbo-dev karchive-dev kcodecs-dev kglobalaccel-dev ki18n-dev kiconthemes-dev kio-dev kjs-dev knotifications-dev kparts-dev sonnet-dev ktextwidgets-dev kwallet-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev"
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="a0f329d53203f64a269a76d327a5f28f4c25dd0cb2413149aaeff118b35a414b74bce8c44e4c4136f6afd08b7d4d05a9c922461e410b4fbc2d58c6753b0f21ca khtml-5.73.0.tar.xz"
+sha512sums="c8c8453d05475196c6d91ec9289d1c396d7dc149d07955912119ce6c9cca44071d9e51676375499b23a923f626e906f18b0bd564db6760e53628985f1b7deb2e khtml-5.74.0.tar.xz"
diff --git a/community/ki18n/APKBUILD b/community/ki18n/APKBUILD
index be1f4a0d81..2379915468 100644
--- a/community/ki18n/APKBUILD
+++ b/community/ki18n/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=ki18n
-pkgver=5.73.0
-pkgrel=1
+pkgver=5.74.0
+pkgrel=0
pkgdesc="Advanced internationalization framework"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url="https://community.kde.org/Frameworks"
@@ -32,4 +32,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="39f663092f7697f711fcf1e4e9f4081d73d7f73f3b110a151063967712bbdcab18ecf5e96350ff4db494b58f48cf1976e7fb002a7ba298386fa77cef2f8766b1 ki18n-5.73.0.tar.xz"
+sha512sums="5027dbd316ea429f72aa45ac215675d970ab5625741fe0908c63957646ec4f12b1d21e7649787364d2d716cd1ceab11a505a4271f28b85a0e18dcbc6c3b15ffe ki18n-5.74.0.tar.xz"
diff --git a/community/kiconthemes/APKBUILD b/community/kiconthemes/APKBUILD
index 6a4a3efd02..c911a0f06c 100644
--- a/community/kiconthemes/APKBUILD
+++ b/community/kiconthemes/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kiconthemes
-pkgver=5.73.0
-pkgrel=1
+pkgver=5.74.0
+pkgrel=0
pkgdesc="Support for icon themes"
-arch="all !armhf"
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only"
depends_dev="qt5-qtsvg-dev karchive-dev ki18n-dev kcoreaddons-dev kconfigwidgets-dev kwidgetsaddons-dev kitemviews-dev"
@@ -32,4 +32,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="9f9454f2c94b87ebb3d13d3b36e2626c52deb4cf23ea5d4e2e768e97dd206a66aa0692833d82aa999e566bb88d477d87bffd3f162194d76b504aa3645f6da1b0 kiconthemes-5.73.0.tar.xz"
+sha512sums="1d34c98b2ec7c59f6960aacc222a9478212c5224eee883c4c6082dbfcba312d4fbedf164b11b5fc07d6f19a1bac65a593ed91ca65c38f998274f02c5b4ed2cfb kiconthemes-5.74.0.tar.xz"
diff --git a/community/kidletime/APKBUILD b/community/kidletime/APKBUILD
index 58a0339b09..2eda662be8 100644
--- a/community/kidletime/APKBUILD
+++ b/community/kidletime/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kidletime
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Monitoring user activity"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="d6cd6de43f295b68cd8bc1cd3ab8817f091b0bb859748eaceae7552d0a7c2bf512136ac59f90c0ce433b04325c53daccf676c24cd35312712593ed86b928806b kidletime-5.73.0.tar.xz"
+sha512sums="4edc4b6ac3164da38401552bab8645ee2db025d519eadc87d9c2d93284b7e7d5b91410d18f443d64d7b1b0573d9e58b04945e3847e07401d62dd8826accccae3 kidletime-5.74.0.tar.xz"
diff --git a/community/kimageformats/APKBUILD b/community/kimageformats/APKBUILD
index 37576f2eea..48ab766d84 100644
--- a/community/kimageformats/APKBUILD
+++ b/community/kimageformats/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kimageformats
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Image format plugins for Qt5"
arch="all !armhf !mips64" # armhf blocked by extra-cmake-modules, mips64 blocked by openexr
@@ -27,4 +27,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="fe389364c95b3e6774f4a107019623e1107c9ce4edfbe90016b0bacb7f2d15293e8805220e19cfbd1a66e70857debd4f33dc3516a1fa4092c964d903be22b107 kimageformats-5.73.0.tar.xz"
+sha512sums="08a74183bed30679523993b3b2a170e96f676954d6ad89fda61903c5797fbbf936e5620625f6f382f2a9cbf6c131be779f223603a51e7e2e5e61af6ec818efd1 kimageformats-5.74.0.tar.xz"
diff --git a/community/kinit/APKBUILD b/community/kinit/APKBUILD
index 7b106954b0..22f0a51f19 100644
--- a/community/kinit/APKBUILD
+++ b/community/kinit/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kinit
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Process launcher to speed up launching KDE applications"
-arch="all !armhf"
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="qt5-qtbase-dev libcap-dev kservice-dev kio-dev ki18n-dev kwindowsystem-dev kcrash-dev kconfig-dev"
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="48a5e7336352ac3e0ca06af32d7fd7c3167fbab9b3c475daa47433bce2aff894f4c6f3d4063dde5b7f4fa222d4db13d753a0bde610e344ee6fffebe2b15c92ee kinit-5.73.0.tar.xz"
+sha512sums="a75e972fc2b4d967c3a7600260b7aef0754b40e0b5ae8803ee29c2186736222fd88b22349431393a9731d59ef7ed9bb184f413a39df82ed735d82130042423a8 kinit-5.74.0.tar.xz"
diff --git a/community/kio/0001-remove-old-kio_fonts-hack.patch b/community/kio/0001-remove-old-kio_fonts-hack.patch
new file mode 100644
index 0000000000..8b7839a9de
--- /dev/null
+++ b/community/kio/0001-remove-old-kio_fonts-hack.patch
@@ -0,0 +1,41 @@
+From dbc0d5323cf55b797ce1dba1ca0f948f26b25869 Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Fri, 11 Sep 2020 18:26:47 +0200
+Subject: [PATCH] Remove old kio_fonts hack in KCoreDirLister, hostname was
+ stripped incorrectly
+
+https://bugs.kde.org/show_bug.cgi?id=160057 worked around the fact that
+kio_fonts was creating URLs like fonts://System/, and yet there's no
+hostname during directory listing afterwards.
+
+Nowadays:
+1) this hack isn't needed anymore, kio_fonts does fonts:/System/
+2) removing it actually fixes navigating from `dolphin fonts:/`
+---
+ src/core/kcoredirlister.cpp | 10 ----------
+ 1 file changed, 10 deletions(-)
+
+diff --git a/src/core/kcoredirlister.cpp b/src/core/kcoredirlister.cpp
+index e9a756a4..8a548949 100644
+--- a/src/core/kcoredirlister.cpp
++++ b/src/core/kcoredirlister.cpp
+@@ -90,16 +90,6 @@ bool KCoreDirListerCache::listDir(KCoreDirLister *lister, const QUrl &_u,
+ QUrl _url(_u);
+ _url.setPath(QDir::cleanPath(_url.path())); // kill consecutive slashes
+
+- if (!_url.host().isEmpty() && KProtocolInfo::protocolClass(_url.scheme()) == QLatin1String(":local")
+- && _url.scheme() != QLatin1String("file")) {
+- // ":local" protocols ignore the hostname, so strip it out preventively - #160057
+- // kio_file is special cased since it does honor the hostname (by redirecting to e.g. smb)
+- _url.setHost(QString());
+- if (_keep == false) {
+- emit lister->redirection(_url);
+- }
+- }
+-
+ // like this we don't have to worry about trailing slashes any further
+ _url = _url.adjusted(QUrl::StripTrailingSlash);
+
+--
+GitLab
+
diff --git a/community/kio/0002-accomodate-local-protocols-that-use-hostname-in-url.patch b/community/kio/0002-accomodate-local-protocols-that-use-hostname-in-url.patch
new file mode 100644
index 0000000000..95b7ef9bec
--- /dev/null
+++ b/community/kio/0002-accomodate-local-protocols-that-use-hostname-in-url.patch
@@ -0,0 +1,49 @@
+From 43f764413009c29fedf496b097c37491a0bab261 Mon Sep 17 00:00:00 2001
+From: Ahmad Samir <a.samirh78@gmail.com>
+Date: Sat, 12 Sep 2020 20:45:44 +0200
+Subject: [PATCH] KUrlCompletion: accommodate ":local" protocols that use
+ hostname in url
+
+An example of that is kdeconnect://, offering completions for it is
+redundant since it uses the hostname part of the url as the deviceId (a
+sequence of letters and numbers that's not easy to remember), so can't use
+that, and the UDS_NAME is the pretty name (e.g. SM-J500H) users see listed in
+kdeconnect:// but kdeconnect://SM-J500H doesn't work. Also because the code in
+KUrlCompletion::_k_slotEntries() is expecting a list of files/dirs to offer
+as completions, and not hostnames (_k_slotEntries uses addPathtoUrl helper
+method), no useful completions are feasible.
+
+Instead if the "filename" part of the url is empty we just skip it.
+
+Note that this prevents the code from hitting an assert in addPathToUrl
+(after applying https://invent.kde.org/frameworks/kio/-/merge_requests/127
+which is needed to make accessing devices using the kdeconnect ioslave
+actually work at all).
+---
+ src/widgets/kurlcompletion.cpp | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/src/widgets/kurlcompletion.cpp b/src/widgets/kurlcompletion.cpp
+index 88bbaace..849a0f38 100644
+--- a/src/widgets/kurlcompletion.cpp
++++ b/src/widgets/kurlcompletion.cpp
+@@ -1213,9 +1213,14 @@ void KUrlCompletionPrivate::_k_slotEntries(KIO::Job *, const KIO::UDSEntryList &
+ entry_name = entry.stringValue(KIO::UDSEntry::UDS_NAME);
+ }
+
+- //qDebug() << "name:" << name;
++ // This can happen with kdeconnect://deviceId as a completion for kdeconnect:/,
++ // there's no fileName [and the UDS_NAME is unrelated, can't use that].
++ // This code doesn't support completing hostnames anyway (see addPathToUrl below).
++ if (entry_name.isEmpty()) {
++ continue;
++ }
+
+- if ((!entry_name.isEmpty() && entry_name.at(0) == QLatin1Char('.')) &&
++ if (entry_name.at(0) == QLatin1Char('.') &&
+ (list_urls_no_hidden ||
+ entry_name.length() == 1 ||
+ (entry_name.length() == 2 && entry_name.at(1) == QLatin1Char('.')))) {
+--
+GitLab
+
diff --git a/community/kio/APKBUILD b/community/kio/APKBUILD
index 98375c65e5..986dff3a26 100644
--- a/community/kio/APKBUILD
+++ b/community/kio/APKBUILD
@@ -1,20 +1,46 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kio
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Resource and network access abstraction"
-arch="all !armhf"
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
-depends_dev="qt5-qtscript-dev karchive-dev kconfig-dev kcoreaddons-dev
- kcrash-dev kdbusaddons-dev ki18n-dev kservice-dev solid-dev kbookmarks-dev
- kcompletion-dev kconfigwidgets-dev kiconthemes-dev kitemviews-dev
- kjobwidgets-dev kwidgetsaddons-dev kwindowsystem-dev kwallet-dev
- knotifications-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev libxslt-dev libxml2-dev kdoctools-dev"
+depends_dev="
+ karchive-dev
+ kbookmarks-dev
+ kcompletion-dev
+ kconfig-dev
+ kconfigwidgets-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ ki18n-dev
+ kiconthemes-dev
+ kitemviews-dev
+ kjobwidgets-dev
+ knotifications-dev
+ kservice-dev
+ kwallet-dev
+ kwidgetsaddons-dev
+ kwindowsystem-dev
+ qt5-qtscript-dev
+ solid-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ kdoctools-dev
+ libxml2-dev
+ libxslt-dev
+ qt5-qttools-dev
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kio-$pkgver.tar.xz"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kio-$pkgver.tar.xz
+ 0001-remove-old-kio_fonts-hack.patch
+ 0002-accomodate-local-protocols-that-use-hostname-in-url.patch
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="!check" # Fails due to requiring physical devices not normally available and test 14 hangs
@@ -35,4 +61,6 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="6bce25a3bbb4c49dc4fff7ca376c5e67803da4d37e9d74424f9109a1c753af57646dc1492861f5cb3f02d6e4a2ed844f8019537b40a4f80e44566127ca3debcb kio-5.73.0.tar.xz"
+sha512sums="f7bcc25bf131debb67c7ae1787d17280c6e4f7098a6c807a657f9313d1f72607e35ebb71d1ae3789253d5298d7a7546a7bc5c7af6095a7c2e886360dd9b64f92 kio-5.74.0.tar.xz
+3af4673da70fc530dc204098c0901fb3d1ca5b0aa27e0924da00b411dadd1aa63fc2829d00eafbbfb8dd4c4ba94dde30a9067898a142c5ace81e272798aa689a 0001-remove-old-kio_fonts-hack.patch
+be464b71b9e5168373ae3fdc50201dc19324255d598961593fdd1a99edc3cc70e57f93226844d1bf75409eb955c5cbe29ba57736020f8ef7633cbc302fde0f0a 0002-accomodate-local-protocols-that-use-hostname-in-url.patch"
diff --git a/community/kirigami2/APKBUILD b/community/kirigami2/APKBUILD
index 8f6d042ea1..b0440f21a1 100644
--- a/community/kirigami2/APKBUILD
+++ b/community/kirigami2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kirigami2
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="A QtQuick based components set"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="e9b7e2ecc7775d418dee172f75e926cd7f3bab0874bcc90f4d0bd9aaa8ddadaf82b592f2ed117085dbb635382ed2f97cc6fb2a4a4927be571565c4adb4fc1f25 kirigami2-5.73.0.tar.xz"
+sha512sums="43059bc682e2d729a0a926e26ce5ba68947f275ffdd74836c124d9e063273429ccde8c0cebaef53168c46cfd62f41cb2c33d86f1f515ca619bde604aa7f5da5f kirigami2-5.74.0.tar.xz"
diff --git a/community/kitemmodels/APKBUILD b/community/kitemmodels/APKBUILD
index 13449f3568..6da155a881 100644
--- a/community/kitemmodels/APKBUILD
+++ b/community/kitemmodels/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kitemmodels
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Models for Qt Model/View system"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="820567c71219923cad84a9e72227500b870d8765bc254795642a2e077b6343d55dd560eed46b53567298ccbeba7b44ee226b54926645bf490835300ca0b35fac kitemmodels-5.73.0.tar.xz"
+sha512sums="f160c9dfb81bf1d835aef2930a7274ca22edbedb31a6423d5989661eb84bf958077f0ef24d63fc74f87a2c0d18b8f96abc110e3a40aa062f72d8c407b5f0d9db kitemmodels-5.74.0.tar.xz"
diff --git a/community/kitemviews/APKBUILD b/community/kitemviews/APKBUILD
index ebeb58a682..78afbd5d27 100644
--- a/community/kitemviews/APKBUILD
+++ b/community/kitemviews/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kitemviews
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Widget addons for Qt Model/View"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="3a7163735544e0b2dd701322c1befd9f6ef25a55b6ce8b7cae082461611f4c00526231d255ed105e7e7a77cba8820b94f26684e35ec57b1e892bf2479f4f5b81 kitemviews-5.73.0.tar.xz"
+sha512sums="873786ec95177b29be9456c39fbf77eb04f56b0dc48cc3dd6e6377c77eb5bfea493b9f044920267fc5363d6cff86610ef4a431f45427771aacedc580859d9503 kitemviews-5.74.0.tar.xz"
diff --git a/community/kjobwidgets/APKBUILD b/community/kjobwidgets/APKBUILD
index 0bdccb9845..1e8bd77c3e 100644
--- a/community/kjobwidgets/APKBUILD
+++ b/community/kjobwidgets/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kjobwidgets
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Widgets for tracking KJob instances"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="4cb9448e72b27106c33837a3c95778fa44dc38e53c02d767de8e10e288f7340d2c1a22d62819eb5c1b4f2f1653bfc1a5a673ebf86d9524509576f9c09e9b2440 kjobwidgets-5.73.0.tar.xz"
+sha512sums="0f7c16f360627b133e101e340e67aa22959b8539581f7495bb950e031ba69e931d6a3a2619b5f6f0c0d5164b6397b2edcd4afb8c8b2e4874477547dd200bee48 kjobwidgets-5.74.0.tar.xz"
diff --git a/community/kjs/APKBUILD b/community/kjs/APKBUILD
index 3c29432c3f..0ee72581a2 100644
--- a/community/kjs/APKBUILD
+++ b/community/kjs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kjs
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Support for JS scripting in applications"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -28,4 +28,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="9e26b6b070e4367c36b95f28e39109ef516106e5307d73192494892620af2c4acdbad907b3e81e69c3ac302fc8f6eb457b8370d04b713e4c953971466236e066 kjs-5.73.0.tar.xz"
+sha512sums="2b592547048dc7ecd2546e02adeeee20693e5f403e7efb9c8a134aefddb1a105e5baf4c7c55e1d3c3e60072cf0f4c17631c4a7d4c1760641114798a1da0f07e1 kjs-5.74.0.tar.xz"
diff --git a/community/kjsembed/APKBUILD b/community/kjsembed/APKBUILD
index 1a22a46b2e..2defcb4113 100644
--- a/community/kjsembed/APKBUILD
+++ b/community/kjsembed/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kjsembed
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="JavaScript bindings for QObject"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -28,4 +28,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="f3467deaeec46aa29fbc6b2115b2698601a0d6b04dcfa51efdca2bd76bf9f7ed20828ef381c3f1007229514a0db08d9246636e3094f9fd7b7ce9a8449750f93e kjsembed-5.73.0.tar.xz"
+sha512sums="b9a317b62b4605effd59a24b55e37155adfbad0b802c885da666e7e9560ad8f7ed3ce65ac49622f47c185190394d722b73d5888077510e6e616c8ddcb92160f1 kjsembed-5.74.0.tar.xz"
diff --git a/community/kmediaplayer/APKBUILD b/community/kmediaplayer/APKBUILD
index a54b6e1dd0..8be8b5e9cc 100644
--- a/community/kmediaplayer/APKBUILD
+++ b/community/kmediaplayer/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kmediaplayer
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Media player framework for KDE 5"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="X11 AND LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kparts-dev kxmlgui-dev"
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="f5b7ccfe83c9b2ef9e31d3de40181ce5394740e3be70730c8363930a3b8b94964acbc29f8e1e127ebc182627b5d48f23144a6eb2e791041f0c3893b44bce0705 kmediaplayer-5.73.0.tar.xz"
+sha512sums="e7d0ba3d2720b9d1dc99cf4f4b11ab2f7c949181d6f1a8bd83ab476d248a67c4f6440e7786b26424347c08b3b8e03fbbf3de1184ce09a7071de501be452eec4c kmediaplayer-5.74.0.tar.xz"
diff --git a/community/knewstuff/APKBUILD b/community/knewstuff/APKBUILD
index d553fe22ae..f732f1ae15 100644
--- a/community/knewstuff/APKBUILD
+++ b/community/knewstuff/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=knewstuff
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Framework for downloading and sharing additional application data"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends="kirigami2"
@@ -33,4 +33,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="98199b35260cb4ca692fe15b87f0456058245073ae5dfe7da5c06faab18def4a1c58189e106f1887a806af4fb85fb821f8edbe45e4070fdc0096e18287aab487 knewstuff-5.73.0.tar.xz"
+sha512sums="038af364cf048035bc2d1a505e4f4c8318fd90efbfdd9c2fdffd9c22b1196a29b0d153643e838a98d472c19094e994a55983f84c63ef50f47574013a8b9f697a knewstuff-5.74.0.tar.xz"
diff --git a/community/knotifications/APKBUILD b/community/knotifications/APKBUILD
index e1a9a8864f..a4b78e76e3 100644
--- a/community/knotifications/APKBUILD
+++ b/community/knotifications/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=knotifications
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Abstraction for system notifications"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="0d893a655d1ebd791132457d4a9cb42b52c1f9ca6aa135cb2dc4e3ca3c550506898261ff0600054fff5badff910ee9f195e42d3e0fb4c98487eb3f1d6cf5d4e7 knotifications-5.73.0.tar.xz"
+sha512sums="a44d0b0ebb7e825adc8c0c5b99f999769149cb3a12c147b81570737736030449136f86b9934b3b2287131f3c41f639c8cba92256ea1ebd39f5083fd6b7158bff knotifications-5.74.0.tar.xz"
diff --git a/community/knotifyconfig/APKBUILD b/community/knotifyconfig/APKBUILD
index 483ccdf466..2a66d166f5 100644
--- a/community/knotifyconfig/APKBUILD
+++ b/community/knotifyconfig/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=knotifyconfig
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Configuration system for KNotify"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-only"
depends_dev="kcompletion-dev kconfig-dev ki18n-dev kio-dev"
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="16555379c8f43be43906d0c01283438eafc88bc498bf6565d5fafa2125bb1d4c5aa96009d000207567ebbd6ce49862c57acc4b09fb3737cb0e72ff1809d8200e knotifyconfig-5.73.0.tar.xz"
+sha512sums="73957b4977ebccc47c53fa65c6352ff333af7a170a55a6021e5426df3715c167a43170fc6d82ee7a452246560cc57a976341a013c9ed7afc243b74a18c755ffe knotifyconfig-5.74.0.tar.xz"
diff --git a/community/kpackage/APKBUILD b/community/kpackage/APKBUILD
index da1fe4d9ef..d22c0274be 100644
--- a/community/kpackage/APKBUILD
+++ b/community/kpackage/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kpackage
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Framework that lets applications manage user installable packages of non-binary assets"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -31,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="a01570a293ee2508aaf86e43dfe2e257e2f04782f6a842c7b92927a14b8c30750c2e6517875c381ffdad2da2ccc242f94ea85ef5152b25fe9f73ce6e096df793 kpackage-5.73.0.tar.xz"
+sha512sums="93790ed0cf527c93b2ba434ce0d4e753dcd31ab027c86e69d65a6f8075771b7d4b9ca9628a5164d1ff5aa4a69f84f11093df8f8d63f284127e2943aa8e443e72 kpackage-5.74.0.tar.xz"
diff --git a/community/kparts/APKBUILD b/community/kparts/APKBUILD
index a02a5ccba1..cfa9c921bf 100644
--- a/community/kparts/APKBUILD
+++ b/community/kparts/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kparts
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Document centric plugin system"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends_dev="qt5-qtbase-dev kconfig-dev kcoreaddons-dev ki18n-dev kiconthemes-dev
@@ -31,4 +31,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="5a727188938e10979911e24dcb5aba6e5ad19990c8f339749aec5bd76c6c4faa220dffd7ade3995de7cebebfc5b224c1d2f90b9e5e91d1b8914538ded606247b kparts-5.73.0.tar.xz"
+sha512sums="477dc2bbb9f66ad9064d362e898072c3b33a59267ec46627c140cd0784858b1d2b1c2eddfe7addf50356523e86e37f1cc138c4e73ce80c61eb96711fceec86b0 kparts-5.74.0.tar.xz"
diff --git a/community/kpeople/APKBUILD b/community/kpeople/APKBUILD
index 6127c91c62..77b0af9bba 100644
--- a/community/kpeople/APKBUILD
+++ b/community/kpeople/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kpeople
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="A library that provides access to all contacts and the people who hold them"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -31,4 +31,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="654afd785da04433972f743f8b10d7e95653697e810318307d1239a47b38385a280af7980b19ab9b30fe4963288910f89cd0dbd7797014cac1811755faa82d37 kpeople-5.73.0.tar.xz"
+sha512sums="c85ed5e3010d25153957159f6bda46882dbe806b9029aeeb5326ecde6b8e4f3a43bd37a57104757563f1ee7014fb216385c962a25bc0438cf4633bb4b41016cc kpeople-5.74.0.tar.xz"
diff --git a/community/kplotting/APKBUILD b/community/kplotting/APKBUILD
index d0f4b6153d..516359cdab 100644
--- a/community/kplotting/APKBUILD
+++ b/community/kplotting/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kplotting
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Lightweight plotting framework"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -31,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="f5a41804806bf395fbdf46394d3b9d2a5ec418f762705e61f896940f48b9ca929a8be39d0e2bd9fa8a4f2e4565e26ba04ea0851082da13abb6a28702978e8b52 kplotting-5.73.0.tar.xz"
+sha512sums="54559904c8d2a5ce6827aee23587838c97aff173682652e192e0e180d6643ec98d4dff6e85e89baa7fdbb92e5b8f99079beb300c3f71c589bad8cc2f21bd7426 kplotting-5.74.0.tar.xz"
diff --git a/community/kpty/APKBUILD b/community/kpty/APKBUILD
index 513661d8d4..bb9fa6c1e7 100644
--- a/community/kpty/APKBUILD
+++ b/community/kpty/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kpty
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Pty abstraction"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="a9430bd6f22a724ad145602247c39b2465b37ccaee8ff9d37fcd4dfd20fd93e46fc7d041babe3fae8ceeeb9ee7b701bb47201ed41c21cf84e8fa68336a64c3a4 kpty-5.73.0.tar.xz"
+sha512sums="2fda1f9598401e3993d4a0ad1988e92856e4c6b3b682aec0e57cd6434256274a31da43d44b0141531d61fee64120511dbe844dbef9ccf805307f33c9a0d60172 kpty-5.74.0.tar.xz"
diff --git a/community/kquickcharts/APKBUILD b/community/kquickcharts/APKBUILD
index d9f35fce4c..387ab06bdb 100644
--- a/community/kquickcharts/APKBUILD
+++ b/community/kquickcharts/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kquickcharts
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="A QtQuick plugin providing high-performance charts"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="b08d36d14b016fc23982133c3f5275dda348e7ad79d1f58354c99c1aae63e6416de7b41ad24e763e533e276bbcd5f2a5fb2f82e01ce6cc45da90c79012948994 kquickcharts-5.73.0.tar.xz"
+sha512sums="873b5d40b20c995c5cd0ad7e5303dcf29083a8e7bef42f7e5370638e5589728df95fd074de00f7f5276c46a37a37b9b31c9722229d660e024041a8d99ec29e2b kquickcharts-5.74.0.tar.xz"
diff --git a/community/kross/APKBUILD b/community/kross/APKBUILD
index 1e25d9bc11..e45363c0d9 100644
--- a/community/kross/APKBUILD
+++ b/community/kross/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kross
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Framework for scripting KDE applications"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev qt5-qttools-dev kcompletion-dev kcoreaddons-dev ki18n-dev kiconthemes-dev kio-dev kparts-dev kwidgetsaddons-dev kxmlgui-dev"
@@ -28,4 +28,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="54e4e82e2a1b23081514638821b12b067362ee43e1168617dfbead2419bc465b2dfcd293a1d6d7387fbf16f75cb43a058a487952be59a0e472ce92a04c469112 kross-5.73.0.tar.xz"
+sha512sums="0fd08d620d90f78ad0ce62aaea372dab4ad4df17533aa29fc1d86b718d0c7ca19a691298498b59a1d0d057eae902ec838f68f5238b482c91d568595543964456 kross-5.74.0.tar.xz"
diff --git a/community/krunner/APKBUILD b/community/krunner/APKBUILD
index bd2a7bc9ed..964067ef87 100644
--- a/community/krunner/APKBUILD
+++ b/community/krunner/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=krunner
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Framework for providing different actions given a string query"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kconfig-dev kcoreaddons-dev ki18n-dev kio-dev
@@ -32,4 +32,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="e148d54ea1b517c8e54c769c0f5cf0d54704df86b63214393e6fe4404a3f34069f3bb2888eab9789257660d3170a73bfe8a2862dd4e9ad9506c9fa0bd1365de9 krunner-5.73.0.tar.xz"
+sha512sums="504fb43acff3337920477a8f67e995a79bdc9e3816e8a92ff5f259a6e50201e4a4edb90cc483a7496daa87c26e39597ffec2b91fd9b315850ace4677f9ac0796 krunner-5.74.0.tar.xz"
diff --git a/community/kservice/APKBUILD b/community/kservice/APKBUILD
index 47f33446a3..42a139aeb9 100644
--- a/community/kservice/APKBUILD
+++ b/community/kservice/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kservice
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Advanced plugin and service introspection"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -32,4 +32,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="cb1d8974746b1db1eb0fb7f2748ba309798f6507e90311116b7ab4041694a0320b9244d6f98a58f4f2e5ff29c03e7957e30ddb1ccac51e0e4ca7e79d25fb9191 kservice-5.73.0.tar.xz"
+sha512sums="7756047069ff22d1e78494770ec3fb56a07ce96459a759b8275188f75a9e9e5d334df0f7bc7c09fdf6f357c0e144cc115ba077a15079f8598bb042f37e5ce490 kservice-5.74.0.tar.xz"
diff --git a/community/ktexteditor/APKBUILD b/community/ktexteditor/APKBUILD
index f68179f560..f0ab20bd2d 100644
--- a/community/ktexteditor/APKBUILD
+++ b/community/ktexteditor/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=ktexteditor
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Advanced embeddable text editor"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later AND (LGPL-2.0-only OR LGPL-3.0-only)"
depends_dev="karchive-dev kconfig-dev kguiaddons-dev ki18n-dev kio-dev kparts-dev sonnet-dev kiconthemes-dev syntax-highlighting-dev kauth-dev"
@@ -31,4 +31,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="61ebffb30c22c136c5e5cb32b0ac2dcdd73ad546c22aeec7ed97e257cc2ebcab4eae2e83f3ca9d897747bbd675e7bb3a6f2b777d0c4a76f4ed035b13aa8581b7 ktexteditor-5.73.0.tar.xz"
+sha512sums="d37d8f132cd33d403f0c4dc3b8773661dc4e708ffea17a37344534f5370c9d41ce947f6a3045fa740bda7ca0021de0f4519be5a21e8cbd2038bca6ff4b9e8e3c ktexteditor-5.74.0.tar.xz"
diff --git a/community/ktextwidgets/APKBUILD b/community/ktextwidgets/APKBUILD
index dafe8a7b2f..8b7c9639d7 100644
--- a/community/ktextwidgets/APKBUILD
+++ b/community/ktextwidgets/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=ktextwidgets
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Advanced text editing widgets"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtspeech-dev kcompletion-dev kconfig-dev kconfigwidgets-dev ki18n-dev kiconthemes-dev kservice-dev kwidgetsaddons-dev sonnet-dev"
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="461ae15dd44ce0343dc269723462b3ef51d2343f61c8de6a201bc81068615262498da60683610585888291f66d27f19093f6b15ba753f3be423be399e57fefd5 ktextwidgets-5.73.0.tar.xz"
+sha512sums="f471ea1b09cb73f2e32d506139e45a3f928d834d559f6d25df5bf05e74dcee5b756ba3b87a38eb2de3fc69c9248a8982e1bfec8c9fc5cba6061e24f8ff62ce5c ktextwidgets-5.74.0.tar.xz"
diff --git a/community/kunitconversion/APKBUILD b/community/kunitconversion/APKBUILD
index 9f2f0bafc5..cde511de9d 100644
--- a/community/kunitconversion/APKBUILD
+++ b/community/kunitconversion/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kunitconversion
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Support for unit conversion"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="13be497ec1a9434073d7121d52326f88fb5cdc68f3c6279d4dbb1632870a07817329ebc18583dcfc9b73858b9e9de63e16e01a3c231635070f332ab8835bebbc kunitconversion-5.73.0.tar.xz"
+sha512sums="065e6f5e48e1c76996d46bddf030edfd7ff3a5d221d93599030874779492ee4d6df89cd736e565ef9a7b0ece1068ea5fcf3f59bdc6dc65ca9fcd94806955c598 kunitconversion-5.74.0.tar.xz"
diff --git a/community/kwallet/APKBUILD b/community/kwallet/APKBUILD
index 1c0b00a58d..30c6b38bed 100644
--- a/community/kwallet/APKBUILD
+++ b/community/kwallet/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwallet
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Secure and unified container for user passwords"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="libgcrypt-dev kcoreaddons-dev kconfig-dev kwindowsystem-dev ki18n-dev kconfigwidgets-dev kdbusaddons-dev kiconthemes-dev knotifications-dev kservice-dev"
@@ -41,4 +41,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="fc0f162e95242a45c9642d4e8caca356fc6fb9aca0776d0dffe5f1809635be0109f369cbc660a34d3cfc376b79c022c73858d8ad8d5970e299d00c18d84b973e kwallet-5.73.0.tar.xz"
+sha512sums="e18de73657c4b51c3150de88e2d764f710932527dc6e9fbfc8778e853b66e0776619fc5d8918cbf8fb6384f92d7b74836797c374d45a50223aa7d543cf743fa2 kwallet-5.74.0.tar.xz"
diff --git a/community/kwayland/APKBUILD b/community/kwayland/APKBUILD
index 7e5ada5a2b..b8f0bf8111 100644
--- a/community/kwayland/APKBUILD
+++ b/community/kwayland/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwayland
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Qt-style Client and Server library wrapper for the Wayland libraries"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -31,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="e39f546111b86020b9110e659a901c2f217599b102934a1bf875b819b67b7d8b36d43818f82a680ce0a7ddcb35c49f957157b8d5880d3766d064d40c087b771e kwayland-5.73.0.tar.xz"
+sha512sums="347841dd5dabedd9de13e92275a2b6edb201a45c177c757b69af681e2f3b60c261087c5387c97305869c0a125a5f07de08113208a174ccb946f6ace310445ebd kwayland-5.74.0.tar.xz"
diff --git a/community/kwidgetsaddons/APKBUILD b/community/kwidgetsaddons/APKBUILD
index 0c7ba623e8..8ecb46cb8a 100644
--- a/community/kwidgetsaddons/APKBUILD
+++ b/community/kwidgetsaddons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwidgetsaddons
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Addons to QtWidgets"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -31,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="fe7b25630fa652da22b9a6f1055dec58ba97c5c94b8242a921ecf1b2f85ddbaf7c8fba4ed56ff5220668e7a59b250a630d649fae028fdeb680eb7a7a0db257f7 kwidgetsaddons-5.73.0.tar.xz"
+sha512sums="90e8d0806933b3735fd510e497b3ce7dae1c017265931799ec2c2012b9c4576a251739b7f7da69aa8dfae1b688322305fd95b94fa0baa49c254c5bc73caaf079 kwidgetsaddons-5.74.0.tar.xz"
diff --git a/community/kwindowsystem/APKBUILD b/community/kwindowsystem/APKBUILD
index 5a997bd0b6..6ba2605738 100644
--- a/community/kwindowsystem/APKBUILD
+++ b/community/kwindowsystem/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwindowsystem
-pkgver=5.73.0
-pkgrel=1
+pkgver=5.74.0
+pkgrel=0
pkgdesc="Access to the windowing system"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
@@ -51,4 +51,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="57d9f92c034d85e71dd9817813f93788e9fc755009e4e618db6d347ba339e0644381e90370692ab85a056475f4c368ea6560274367309cb4f98ed56a152f3785 kwindowsystem-5.73.0.tar.xz"
+sha512sums="f27c2676a2b21ed0cb8b876aa75c9beeebef0403288af8e354a444c63cb653bb8e9b9d349cd06352699a749488441b0a05344c876724f20fd86f06a40ec71fda kwindowsystem-5.74.0.tar.xz"
diff --git a/community/kxmlgui/APKBUILD b/community/kxmlgui/APKBUILD
index 0dc91acf44..323c1e1d6e 100644
--- a/community/kxmlgui/APKBUILD
+++ b/community/kxmlgui/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kxmlgui
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="User configurable main windows"
-arch="all !armhf"
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kcoreaddons-dev kitemviews-dev kconfig-dev kconfigwidgets-dev ki18n-dev kiconthemes-dev ktextwidgets-dev kwidgetsaddons-dev kwindowsystem-dev attica-dev kglobalaccel-dev"
@@ -31,4 +31,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="71f69e7917872829cf971b903cc1ceac319a4d4f3ed7d4a9091a1766184fb10664952616874cbcab06d52c34a30904d9034ea483640e99f59d9760191301376a kxmlgui-5.73.0.tar.xz"
+sha512sums="98f3e65c30a095d17c0512894bbba0bb172b2044652a0d23324f843489f5bb726359be40a9d68a7916d45a2a6e135f0bbbf7924b35a1939611b75ad6d44ccd92 kxmlgui-5.74.0.tar.xz"
diff --git a/community/kxmlrpcclient/APKBUILD b/community/kxmlrpcclient/APKBUILD
index ef36d7ae4a..7a7d331921 100644
--- a/community/kxmlrpcclient/APKBUILD
+++ b/community/kxmlrpcclient/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kxmlrpcclient
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="XML-RPC client library for KDE"
-arch="all !armhf"
+arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://projects.kde.org/projects/kde/pim/kxmlrpcclient"
license="BSD-2-Clause"
depends_dev="ki18n-dev kio-dev"
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="f9b664e892410feaf652ebc144f6a59f13f9c942fc7c1e392bd0ed9c950790cd69dc3f0ca4cdba01ed40c4366ab6dfb2057037b5fdc64c1915a5e7844b8897cb kxmlrpcclient-5.73.0.tar.xz"
+sha512sums="87221fc5166312030af1c40d95ccbbdc68c791d0278d9ac181f98aa37328fa713e82bb178932a18d23f1bb1483c0571b4267ec0ae5970046e23426b3a93bf135 kxmlrpcclient-5.74.0.tar.xz"
diff --git a/community/modemmanager-qt/APKBUILD b/community/modemmanager-qt/APKBUILD
index aa7b8a2c9e..e03af0fe44 100644
--- a/community/modemmanager-qt/APKBUILD
+++ b/community/modemmanager-qt/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=modemmanager-qt
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Qt wrapper for ModemManager DBus API"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -31,4 +31,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="b9a93f67a3520e92f933bb56e3a2aa6c3328b8aea85ab14cfd5b4d288b6ef64858d2fab5c794381879782e5ccb9288b27d9b065d91bffbb114a371564ef2270f modemmanager-qt-5.73.0.tar.xz"
+sha512sums="c8dfaeca27a81b5a779f774b0edb4e4c670d1f92fc52f9e4863bacf725ae42f7d4b9dd813e47f56996a3427f0d813fb21162c609615e3523467e4fae0c4b6c1a modemmanager-qt-5.74.0.tar.xz"
diff --git a/community/networkmanager-qt/APKBUILD b/community/networkmanager-qt/APKBUILD
index 59f26d4ecd..c1f02d0ce0 100644
--- a/community/networkmanager-qt/APKBUILD
+++ b/community/networkmanager-qt/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=networkmanager-qt
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Qt wrapper for NetworkManager API"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -32,4 +32,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="e8136359faa01dbae3725b13c1ddc64737ba4ef87993809eb22919a66002bdf1fdcf9fe8b08be9bbdf2cd0fd19608f44b7ab66c84f782c1d6fc69c85acd56e3a networkmanager-qt-5.73.0.tar.xz"
+sha512sums="62953a2738cf15633733cd0ae9930c640abe90523495d1481893fc8bd3f2de7ace6f683e541c24f641731e014aff8b2f02520c2644dda4b25fa0460c57110cf3 networkmanager-qt-5.74.0.tar.xz"
diff --git a/community/oxygen-icons/APKBUILD b/community/oxygen-icons/APKBUILD
index ce78f36b34..877f1a31b7 100644
--- a/community/oxygen-icons/APKBUILD
+++ b/community/oxygen-icons/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=oxygen-icons
_pkgname=oxygen-icons5
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
arch="noarch !armhf" # # armhf blocked by extra-cmake-modules
pkgdesc="Oxygen icon theme"
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="6a58cf8ad6192f20bc18487e3941769d3b4fb1e906893603425072ad568659a425836f9e14c54b403eab4204c77d68226fd45051a4ec868b48795b332d6afd79 oxygen-icons5-5.73.0.tar.xz"
+sha512sums="bc00190778edd4b5b154f210ad3e3479f84d6f65b8114f0901966cebb4bfd0f6cabb7d68b1ac2759d7553360167fa620f258078c3c60437a04ef6fbe84243284 oxygen-icons5-5.74.0.tar.xz"
diff --git a/community/plasma-framework/APKBUILD b/community/plasma-framework/APKBUILD
index a530171916..b4e2aa146c 100644
--- a/community/plasma-framework/APKBUILD
+++ b/community/plasma-framework/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-framework
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Plasma library and runtime components based upon KF5 and Qt5"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND GPL-2.0-or-later"
depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev kactivities-dev karchive-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev kdeclarative-dev kglobalaccel-dev kguiaddons-dev ki18n-dev kiconthemes-dev kio-dev kservice-dev kwindowsystem-dev kxmlgui-dev knotifications-dev kpackage-dev kirigami2-dev kwayland-dev"
@@ -31,4 +31,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="57f8781673f32848759aaf6138070bb4242a93985a836669d074ea830a9b2f92937f333fb5e8738b64e496f5a23ddf70719538ec62e0933d094c3773a7b8fddb plasma-framework-5.73.0.tar.xz"
+sha512sums="7aae44d94a175dcdbd779a6801626d20e8d986597d1d05c82c5c035997b874ebb9b4412191e1fa7a26aa4e045ceaf22a7ef359d3e817d812357d51219eb5fb46 plasma-framework-5.74.0.tar.xz"
diff --git a/community/prison/APKBUILD b/community/prison/APKBUILD
index 7fd8e371ed..34818f1c45 100644
--- a/community/prison/APKBUILD
+++ b/community/prison/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=prison
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="A barcode API to produce QRCode barcodes and DataMatrix barcodes"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="e2bfa12c6346234cb48293864e99c4f5654a69f64cc197cdced83438907ab8d345daf985483fe0b23b3f33e7ab14ea121fe2488ed60962d7d039eed1019b917a prison-5.73.0.tar.xz"
+sha512sums="3d7ed0517a36e8cf3ff6956f61502ee02f9cf06876e842c3575e469701495b3ffaa05fb992d635573a43070ae6c7a5e7bad7c2073eb69c8d6bb6c2b5256c0b62 prison-5.74.0.tar.xz"
diff --git a/community/purpose/APKBUILD b/community/purpose/APKBUILD
index 26045b12ab..10fe403cce 100644
--- a/community/purpose/APKBUILD
+++ b/community/purpose/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=purpose
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Framework for providing abstractions to get the developer's purposes fulfilled"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev ki18n-dev kconfig-dev kio-dev
@@ -33,4 +33,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="964e2b47e4c81f5d4dccfabd964bc5d118fbd70ab0dd615d7ec282b3281e95ebec2df82e35420006accb7b1e89fe38b4ea288e98fd169014446e35454fdd0d52 purpose-5.73.0.tar.xz"
+sha512sums="dea52fd5d10cc0c34ecab742b691675076ddf1346e2b352cd5f74cd266576f85eb9d721bf68a29cea62f9879b826bf375b70580451c31bdd33509f57ae3cf23a purpose-5.74.0.tar.xz"
diff --git a/community/qqc2-desktop-style/APKBUILD b/community/qqc2-desktop-style/APKBUILD
index 4a404ceb75..5dd256d987 100644
--- a/community/qqc2-desktop-style/APKBUILD
+++ b/community/qqc2-desktop-style/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qqc2-desktop-style
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="A style for Qt Quick Controls 2 to make it follow your desktop theme"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-3.0-only AND (GPL-2.0-only OR GPL-3.0-only)"
depends="qt5-qtgraphicaleffects qt5-qtquickcontrols2"
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="dfdd4290c7d728cbd69ef6c36d3c74fbad21e4b29b34ad73138bbe24fc38f1d3eb2922b12ef558aba6125288452a937571222460bab8f8e629bf6fcb37952253 qqc2-desktop-style-5.73.0.tar.xz"
+sha512sums="88c91d5933bc2c0020a574be05a851aea54382b6c1dd5f459cba792e4ac784782bc88a36670c28f2df29188cf001bf2c9af98b3e9bc84dd59c110fd7bf936258 qqc2-desktop-style-5.74.0.tar.xz"
diff --git a/community/solid/APKBUILD b/community/solid/APKBUILD
index 05aa0caa41..1060b7d212 100644
--- a/community/solid/APKBUILD
+++ b/community/solid/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=solid
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Hardware integration and detection"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf !s390x" # armhf blocked by qt5-qtdeclarative and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="qt5-qtdeclarative-dev"
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="4ab8b555622e09e7b3611dfd33ead65598c2310458fe0cdcd8e34f7cd242abc1e634faf09fd43d231ebfccb486cd64bcd4c49272551d16b43029115462cc8506 solid-5.73.0.tar.xz"
+sha512sums="cc0190327552c63bca8627b96d9f59ec9fb4e4c1842d36c42455e8a458f97f972274765a94b70f311a4105d33f0abbd921b10a2db2b1e7f4c492e92268ca68b1 solid-5.74.0.tar.xz"
diff --git a/community/sonnet/APKBUILD b/community/sonnet/APKBUILD
index f94f2916ae..7dc69774d8 100644
--- a/community/sonnet/APKBUILD
+++ b/community/sonnet/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=sonnet
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Spelling framework for Qt5"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -33,4 +33,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="b5b69d34cda323bc5cbbe1bfafaaff324194ce241bef80f8f3c74ff3cd00e00cdeff20eafca870d6d99c5f080fd44e54458d261c2c795ba2179233d4ad8f70c1 sonnet-5.73.0.tar.xz"
+sha512sums="80f19d6f7c168f6daed208769c5abe1c664b48cd5d8f3ddd75f3992f917859d14281ed12b819b5bc9f501849243de639388a8e47dc60e0d3bda0e5b8426a54e6 sonnet-5.74.0.tar.xz"
diff --git a/community/syndication/APKBUILD b/community/syndication/APKBUILD
index 4a1adfa238..c66fb110a1 100644
--- a/community/syndication/APKBUILD
+++ b/community/syndication/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=syndication
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="An RSS/Atom parser library"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="dc6b5de4073701ba34982af055f005d6ad6b23916581d5dbf3605ecd506211c8942161ab25048729dc3c765acae62ea8292654042cf4784022853be4d9167b2a syndication-5.73.0.tar.xz"
+sha512sums="c524ea90c4fbe80040a772e967dc024707ed32c124b0efcf4324e5bc60093472762f7b48fcadd1f288747464defd16abe185fdff00c8e414db37a00bc1e6fe53 syndication-5.74.0.tar.xz"
diff --git a/community/syntax-highlighting/APKBUILD b/community/syntax-highlighting/APKBUILD
index 256e075673..171b35c331 100644
--- a/community/syntax-highlighting/APKBUILD
+++ b/community/syntax-highlighting/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=syntax-highlighting
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="Syntax highlighting engine for structured text and code"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="e283fb750266053d5c452caeba53e8126203c8cec14ea5458ef979e8cc79ad9f161fab9728ad36703dae15edd71aaec2c1f3263c06b8c97aab85e458c3df2dea syntax-highlighting-5.73.0.tar.xz"
+sha512sums="6dfc9540ca4ec2c76c9b96a864a24bba6923529d72605dcd36136809250be12c366f52bf3dda02564169744729172eec2f0d3f69137d374d81af826ec97bc3b7 syntax-highlighting-5.74.0.tar.xz"
diff --git a/community/threadweaver/APKBUILD b/community/threadweaver/APKBUILD
index 5b3ba61a46..5bf8d8a860 100644
--- a/community/threadweaver/APKBUILD
+++ b/community/threadweaver/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=threadweaver
-pkgver=5.73.0
+pkgver=5.74.0
pkgrel=0
pkgdesc="High-level multithreading framework"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -30,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="e6ef3b7b7a95e9450a0a732ee5a4ad22f4f80ab252867e357311a84582daf5a10a1df526404a909cbd43653452e141a83dc4e2094eb82e2d8bce60cc6bef98d8 threadweaver-5.73.0.tar.xz"
+sha512sums="b419a80eb13366d3a71cd2d894a57f7834a9afb8472f88603fb9b24d678fa546da9fc96ff3a0af5e4db14f5bbbb52e2eb00f7ef2429a94b3b413a0026b69d899 threadweaver-5.74.0.tar.xz"