aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2022-01-25 06:24:59 +0000
committerDuncan Bellamy <dunk@denkimushi.com>2022-01-25 06:36:57 +0000
commit8b1fcdeecc730f821a33dc6e323e22232d95473f (patch)
treece6dd7b5be7e8f467c39c4b0e7b1896a4ef1a9d8
parent6241eccfb6af2d73afddfcb938b3120ab4a2c488 (diff)
community/vectorscan: revert to -march=core2 for x86_64
As AVX options have no effect, causing test failure on the builder which lacks avx2 and avx512 Fixes #13470
-rw-r--r--community/vectorscan/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/vectorscan/APKBUILD b/community/vectorscan/APKBUILD
index 588180e202d..ba6985b26c7 100644
--- a/community/vectorscan/APKBUILD
+++ b/community/vectorscan/APKBUILD
@@ -13,8 +13,8 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/VectorCamp/vectorscan/archiv
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
build() {
case "${CARCH:-native}" in
- x86_64) CMAKE_EXTRAOPTS="-DBUILD_AVX2=off -DBUILD_AVX512=off \
- -DBUILD_AVX512VBMI=off -DFAT_RUNTIME=on" ;;
+ x86_64) CMAKE_EXTRAOPTS="-DCMAKE_C_FLAGS=$CFLAGS -march=core2 \
+ -DCMAKE_CXX_FLAGS=$CXXFLAGS -march=core2" ;;
esac
if [ "$CBUILD" != "$CHOST" ]; then