aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-12-18 09:46:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-12-18 13:02:36 +0000
commit8b6ebb09c6475669d8996aadec6c9bbe28900d90 (patch)
tree80cf81a41835015330b106da6e64495bd6c6cb34
parentf540fecaced35775dc37ba1c1b94d20c98dbf1d6 (diff)
community/libwacom: upgrade to 1.7
-rw-r--r--community/libwacom/APKBUILD11
-rw-r--r--community/libwacom/disable-tests.patch14
2 files changed, 13 insertions, 12 deletions
diff --git a/community/libwacom/APKBUILD b/community/libwacom/APKBUILD
index 620f9d5a38c..ce9f70c9c18 100644
--- a/community/libwacom/APKBUILD
+++ b/community/libwacom/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Ivan Tham <pickfire@riseup.net>
# Maintainer: Ivan Tham <pickfire@riseup.net>
pkgname=libwacom
-pkgver=1.6
+pkgver=1.7
pkgrel=0
pkgdesc="Library to help implement Wacom tablet settings"
url="https://github.com/linuxwacom/libwacom/wiki"
arch="all !s390x !mips !mips64" # librsvg
license="MIT"
-makedepends="librsvg-dev gtk+2.0-dev glib-dev libgudev-dev libxml2-dev meson"
-checkdepends="bash findutils diffutils"
+makedepends="librsvg-dev gtk+2.0-dev glib-dev libgudev-dev libxml2-dev meson
+ py3-udev py3-libevdev"
+checkdepends="bash findutils diffutils py3-pytest"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/linuxwacom/libwacom/releases/download/libwacom-$pkgver/libwacom-$pkgver.tar.bz2
disable-tests.patch
@@ -27,5 +28,5 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="2aeba01535092b26301ec9b675932bf88f8150c513274449341143a641ee942977ed3b0d35cf1d2513da056701ca0d75eff9fd44830c5a00764e37fcbfb2c051 libwacom-1.6.tar.bz2
-dd5a2b9b4a1e999a7b91da01d8a2f0127d98ccb50802f4286737007341dd16fe25a99db2484e592edecc6d0edeb93953030831ac15909dbfb9cbfd3063a02e40 disable-tests.patch"
+sha512sums="0cdd34c54a4477ffb763c4a291f0a6b33d2df6b1d237332b116e792685201a63a50c3ec98b84e9dc7c0b97c9e407c3531cd67c0af5a8398b5bbf8be6ca103066 libwacom-1.7.tar.bz2
+9fab4bc66f6cef27b3a4a332b9bf143bae665b41833b66882edc2d1bf4bece5c9fcb87f77e5337a3b4055d8961801622226cbb5647bc5db8e05af6f2da7d28b0 disable-tests.patch"
diff --git a/community/libwacom/disable-tests.patch b/community/libwacom/disable-tests.patch
index ac6afca382c..2c1b37bf6d5 100644
--- a/community/libwacom/disable-tests.patch
+++ b/community/libwacom/disable-tests.patch
@@ -2,14 +2,13 @@ Upstream: Not Applicable
Reason: Remove test that fails
diff --git a/meson.build b/meson.build
-index 1482fa5..86c665b 100644
+index 6a38b36..814ae55 100644
--- a/meson.build
+++ b/meson.build
-@@ -253,22 +253,6 @@ if get_option('tests').enabled()
- else
+@@ -256,22 +256,6 @@ if get_option('tests').enabled()
message('valgrind not found, disabling valgrind test suite')
endif
--
+
- # because of the tricks we use in calling the function and exposing
- # it to begin with, LTO gets confused and this fails to link.
- # Let's just disable it here.
@@ -25,6 +24,7 @@ index 1482fa5..86c665b 100644
- env:['LD_LIBRARY_PATH=@0@'.format(meson.build_root())],
- suite: ['all'])
- endif
- endif
-
- # This is a non-optional test
+-
+ if meson.version().version_compare('>= 0.51.0')
+ python = import('python')
+ python.find_installation(modules: ['libevdev', 'pyudev', 'pytest'])