aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-16 17:51:42 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-11-16 17:02:29 +0000
commit8bb5586fea347052fe0debde4c2ba06fbf3e61ba (patch)
tree51a041bc82684da579f0c315d8e084edab360346
parent357a1791e9e5f8c6835b5b2523937fd10ff0c0b4 (diff)
main/argon2: fix pkgconfig version
Closes !1322
-rw-r--r--main/argon2/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/main/argon2/APKBUILD b/main/argon2/APKBUILD
index 7ce733ad9e7..b3eb0b1e8a5 100644
--- a/main/argon2/APKBUILD
+++ b/main/argon2/APKBUILD
@@ -4,7 +4,7 @@
pkgname=argon2
_pkgname=phc-winner-argon2
pkgver=20190702
-pkgrel=0
+pkgrel=1
pkgdesc="The password hash Argon2, winner of PHC"
url="https://github.com/P-H-C/phc-winner-argon2"
arch="all"
@@ -15,17 +15,14 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/P-H-C/$_pkgname/archive/$pkg
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
- make OPTTARGET=none
+ make OPTTARGET=none ARGON2_VERSION=$pkgver
}
check() {
- cd "$builddir"
make OPTTARGET=none test
}
package() {
- cd "$builddir"
make OPTTARGET=none LIBRARY_REL=lib DESTDIR="$pkgdir" install
}