aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Berthault <justin.berthault@zaclys.net>2020-06-02 18:56:55 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-05 00:34:24 +0000
commit8c3db47b185cb8aee167f7c4f4cfb3d563a67cfd (patch)
treead54303c054f1d51d5030e3877911d5140f4fc81
parent0b04bce70d781df1245cb9ae1ded3d00a46fb7f1 (diff)
community/py3-requests-mock: upgrade to 1.8.0
-rw-r--r--community/py3-requests-mock/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/py3-requests-mock/APKBUILD b/community/py3-requests-mock/APKBUILD
index 3f91b2884fa..38ababb6e0b 100644
--- a/community/py3-requests-mock/APKBUILD
+++ b/community/py3-requests-mock/APKBUILD
@@ -1,8 +1,7 @@
# Contributor: Robert Sacks <robert@sacks.email>
# Maintainer: Robert Sacks <robert@sacks.email>
pkgname=py3-requests-mock
-_pyname=requests-mock
-pkgver=1.7.0
+pkgver=1.8.0
pkgrel=0
pkgdesc="Mock out responses from the requests package"
url="https://pypi.org/project/requests-mock/"
@@ -10,10 +9,9 @@ arch="noarch"
license="Apache-2.0"
depends="python3 py3-requests py3-six"
makedepends="py3-pbr"
-checkdepends="py3-fixtures py3-mock py3-purl py3-pytest py3-sphinx
- py3-testrepository py3-testtools"
-source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
-builddir="$srcdir/$_pyname-$pkgver"
+checkdepends="py3-fixtures py3-mock py3-purl py3-pytest py3-sphinx py3-testrepository py3-testtools"
+source="https://files.pythonhosted.org/packages/source/r/requests-mock/requests-mock-$pkgver.tar.gz"
+builddir="$srcdir/requests-mock-$pkgver"
prepare() {
default_prepare
@@ -32,4 +30,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="6ad71fb87519f93812e8ae0d058a4b65a4492e86f05cacc37f95be1a6f0239a2c3f3d20a7e6f44bcc21f009574e4e78c2149394c2570d305efbdd68ec07b24a2 requests-mock-1.7.0.tar.gz"
+sha512sums="252bce965e0fca03cd5ce09912c726045f9c632e90bfee13b06c9f3e2c6b70eab7f39cf8e7efb3b7d2cf2b5d79cc5c5ba6e2379b3d48ce33bf78861ada911918 requests-mock-1.8.0.tar.gz"