aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2023-05-05 17:37:29 +0200
committerpsykose <alice@ayaya.dev>2023-05-06 02:24:53 +0200
commit8d1c6f9173bb31256c80fd35cebcb1ea80ed0d45 (patch)
tree7ab222f154a348eea0e0e1bc1c09f1549bce05e4
parent7f386b1e091b2aa6ed8ddc479e0bbb9e564894a2 (diff)
community/openjdk8: security upgrade to 8.372.07
-rw-r--r--community/openjdk8/APKBUILD23
1 files changed, 18 insertions, 5 deletions
diff --git a/community/openjdk8/APKBUILD b/community/openjdk8/APKBUILD
index 82af9483cf8..78d3085c8c0 100644
--- a/community/openjdk8/APKBUILD
+++ b/community/openjdk8/APKBUILD
@@ -2,11 +2,11 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=openjdk8
-_icedteaver=3.26.0
+_icedteaver=3.27.0
# pkgver is <JDK version>.<JDK update>.<JDK build>
# Check https://icedtea.classpath.org/wiki/Main_Page when updating!
-pkgver=8.362.09
-pkgrel=1
+pkgver=8.372.07
+pkgrel=0
pkgdesc="OpenJDK 8 provided by IcedTea"
provider_priority=8
url="https://icedtea.classpath.org/"
@@ -104,6 +104,14 @@ source="https://icedtea.classpath.org/download/source/icedtea-$_icedteaver.tar.x
builddir="$srcdir/icedtea-$_icedteaver"
# secfixes:
+# 8.372.07-r0:
+# - CVE-2023-21930
+# - CVE-2023-21937
+# - CVE-2023-21938
+# - CVE-2023-21939
+# - CVE-2023-21954
+# - CVE-2023-21967
+# - CVE-2023-21968
# 8.362.09-r0:
# - CVE-2022-21619
# - CVE-2022-21624
@@ -284,6 +292,11 @@ build() {
# cannot pass -j through here
unset MAKEFLAGS
+ # we want to build hotspot with better optimisations; it's set to this
+ # (prepended) anyway, and it's huge
+ export CFLAGS="$CFLAGS -O3"
+ export CXXFLAGS="$CXXFLAGS -O3"
+
bash ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -412,8 +425,8 @@ demos() {
}
sha512sums="
-99fc64ba877cd1a942b33b266dffd966b43fe16b50e1f49c33750bf7d89cc3010137cfba01ce1655a9fc50a31a6e0b3cd32bd3ad2422f1a19dd8468207667b73 icedtea-3.26.0.tar.xz
-8a18cc9639bb6aa26cf5a57deb60f65a3c58a07a1001dfcc260d84463f3562ede34e2fb78d4996a354c2cc03ef66ea64e9ad8090fbe8cb3f61f2933532e88f6d openjdk-3.26.0.tar.xz
+ee16aeb4f1564a1fb6132ed5165f925ca8edc8cef13b46291589ceaff42e8f9922f0834e4aba899da061e78ea48805e4ac5bba73a73d5389c05ba4efd1663812 icedtea-3.27.0.tar.xz
+227fa26be948f4405e3d8c363a7d196b66aa0c00139c2c4cbfda28ba8d554b6f983765eb0499a63bcae3c6166d5fa51499a3558fc5efee35d1d9b14bc1075aa1 openjdk-3.27.0.tar.xz
28709285390a997adbd56ebda42ef718fbc08daf572b8568f484436d255514f9d25f033e3333dff8aa352fc9846057ac5bb42fa955d3e5e44eddc96dc273c07c icedtea-hotspot-musl.patch
e6fff8ab886f42006ad5c210f46e82a3a4c0b654edecc4764a0d20f0e5dc81138c2c5181b034095b93f94b5aa96b7e5068f42bafa283809f6fe9d2c8655d64d7 icedtea-hotspot-musl-ppc.patch
19459dbb922f5a71cd15b53199481498626a783c24f91d2544d55b7dddd2cdb34a64bbf0226b99548612dd1743af01b3f9ff32c30abbbc90ce727ca2dbbbd1f9 icedtea-hotspot-noagent-musl.patch