aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorInsanePrawn <insane.prawny@gmail.com>2021-08-27 18:31:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2021-09-17 08:38:21 +0000
commit8e1f6d0b0f4cca3d659519153071083ca92e3594 (patch)
tree57de68ad2c4937c0779a4ecf997b860a2bf53837
parent35ca6e3acb4e50d06098c0efb67a7ad2e716c18b (diff)
main/pixman: add aarch64 NEON support
See https://gitlab.freedesktop.org/pixman/pixman/-/merge_requests/20 Signed-off-by: InsanePrawn <insane.prawny@gmail.com>
-rw-r--r--main/pixman/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/main/pixman/APKBUILD b/main/pixman/APKBUILD
index 74507f860bd..694f27e0488 100644
--- a/main/pixman/APKBUILD
+++ b/main/pixman/APKBUILD
@@ -1,25 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pixman
pkgver=0.40.0
-pkgrel=2
+pkgrel=3
pkgdesc="Low-level pixel manipulation library"
url="https://gitlab.freedesktop.org/pixman"
arch="all"
license="MIT"
makedepends="meson libpng-dev linux-headers"
subpackages="$pkgname-static $pkgname-dev $pkgname-dbg"
-source="https://gitlab.freedesktop.org/pixman/pixman/-/archive/pixman-$pkgver/pixman-pixman-$pkgver.tar.gz"
+source="https://gitlab.freedesktop.org/pixman/pixman/-/archive/pixman-$pkgver/pixman-pixman-$pkgver.tar.gz
+ https://gitlab.freedesktop.org/pixman/pixman/-/commit/04f662a3ee0dbab1b4755a6faf491751f6f29627.patch
+ "
builddir="$srcdir/pixman-pixman-$pkgver"
case "$CARCH" in
# broken test (likely due to endianness assumptions)
s390x) options="!check" ;;
+ aarch64) simd="-Da64-neon=enabled" ;;
esac
+
build() {
# We need to increase the stacksize here: https://gitlab.gnome.org/GNOME/librsvg/-/issues/595
LDFLAGS="$LDFLAGS -Wl,-z,stack-size=2097152" abuild-meson \
-Ddefault_library=both \
+ $simd \
. output
meson compile ${JOBS:+-j ${JOBS}} -C output
}
@@ -32,4 +37,7 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="18774e22add5c5442edede5467fa07234c2b9e57a79d88110f25424e4253c6ab0c2921e951c5686cefebf4724ff19ad053d0c28f4d2f8d642bbcf6fc71764ef6 pixman-pixman-0.40.0.tar.gz"
+sha512sums="
+18774e22add5c5442edede5467fa07234c2b9e57a79d88110f25424e4253c6ab0c2921e951c5686cefebf4724ff19ad053d0c28f4d2f8d642bbcf6fc71764ef6 pixman-pixman-0.40.0.tar.gz
+4c383bd629dfab9dc3b491a9b06c4192b0f4fb417d62dba494b0efa622fc557ab570d24ac1ef4a9cc0a8104d383dde4f687978c5456f39290a591e34e41e31a2 04f662a3ee0dbab1b4755a6faf491751f6f29627.patch
+"