aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2021-10-23 11:32:53 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2021-10-23 11:32:53 +0000
commit8f819c210b5dae7f74ece098a262d956ef286105 (patch)
treed7d42bb5beb93576dbe28c595231f98c254c2e15
parenta49aec09fb772ad23d19b4e51b5586d46745a30c (diff)
community/xdg-desktop-portal: fix building docs
docs are only built when /usr/share/dbus-1/interfaces/org.freedesktop.Flatpak.xml is available. The package that provides this is 'flatpak', but that's not being pulled in by 'flatpak-dev', resulting in an empty -doc subpackage failing the build. Add flatpak as a direct makedepends to fix this.
-rw-r--r--community/xdg-desktop-portal/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/xdg-desktop-portal/APKBUILD b/community/xdg-desktop-portal/APKBUILD
index cb9d77d57bd..5b916745497 100644
--- a/community/xdg-desktop-portal/APKBUILD
+++ b/community/xdg-desktop-portal/APKBUILD
@@ -12,7 +12,7 @@ arch="all !mips64 !s390x !riscv64"
license="LGPL-2.1-or-later"
depends="bubblewrap"
makedepends="gettext-dev glib-dev json-glib-dev fontconfig-dev
- geoclue-dev xmlto flatpak-dev pipewire-dev fuse-dev autoconf automake libtool"
+ geoclue-dev xmlto flatpak flatpak-dev pipewire-dev fuse-dev autoconf automake libtool"
checkdepends="dbus"
subpackages="$pkgname-lang $pkgname-doc"
source="https://github.com/flatpak/xdg-desktop-portal/releases/download/$pkgver/xdg-desktop-portal-$pkgver.tar.xz"
@@ -40,6 +40,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
+ --enable-docbook-docs \
--disable-libportal # Unpackaged, has no stable tags
make
}