aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-28 15:39:19 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-05-06 20:36:43 +0000
commit8f9956a9b454502120a7676ec165a598be8d37df (patch)
treea5fa1f80ca1f42b71472bee56be4d66b6b5c7c8d
parent88bdffc20ac1da2fdc23c2850c4afb7f299835e6 (diff)
testing/py3-lingua-franca: new aport
-rw-r--r--testing/py3-lingua-franca/APKBUILD30
-rw-r--r--testing/py3-lingua-franca/relax-dep-requirements.patch10
2 files changed, 40 insertions, 0 deletions
diff --git a/testing/py3-lingua-franca/APKBUILD b/testing/py3-lingua-franca/APKBUILD
new file mode 100644
index 00000000000..853bb4e9c65
--- /dev/null
+++ b/testing/py3-lingua-franca/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-lingua-franca
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="Mycroft's multilingual text parsing and formatting library"
+url="https://github.com/MycroftAI/lingua-franca"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-dateutil"
+makedepends="py3-setuptools"
+source="https://github.com/MycroftAI/lingua-franca/archive/$pkgver/lingua-franca-$pkgver.tar.gz
+ relax-dep-requirements.patch
+ "
+builddir="$srcdir/lingua-franca-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f4e7a4345330463d19ab7dc547d70cead7ae30f1dd4e9f4ef63d7b62b144e0f2eb17a3a6127ba8a2a07cf01552319ca977510ea5d567bc8469908883cd26d538 lingua-franca-0.2.1.tar.gz
+09ccfb7e18c32e8049f9da101a18d0e69918656c9bba1160794bd1196315fd1fdf1b2603212ec52f0f7604e232c5272aa93e04ca5b7ef1ab27016d8626fbcc9f relax-dep-requirements.patch"
diff --git a/testing/py3-lingua-franca/relax-dep-requirements.patch b/testing/py3-lingua-franca/relax-dep-requirements.patch
new file mode 100644
index 00000000000..80239b6b63c
--- /dev/null
+++ b/testing/py3-lingua-franca/relax-dep-requirements.patch
@@ -0,0 +1,10 @@
+We can't ship such strict versions of dependencies as other packages will need newer versions
+
+diff --git a/requirements.txt b/requirements.txt
+index d431540..1f1bb30 100644
+--- a/requirements.txt
++++ b/requirements.txt
+@@ -1 +1 @@
+-python-dateutil==2.6.0
+\ No newline at end of file
++python-dateutil>=2.6.0<3