aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrubicon <5662-rubicon@users.gitlab.alpinelinux.org>2022-06-23 11:49:37 +0800
committerrubicon <5662-rubicon@users.gitlab.alpinelinux.org>2022-06-23 12:13:07 +0800
commit92b749319b81f576b99e86ea80586831c0013723 (patch)
tree96cbee49607958baa6456c802c7ea10397083903
parent495b837359ab6b93a8fc0ea8898c3dd5eb3dd091 (diff)
testing/lfe: new aport
-rw-r--r--testing/lfe/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/lfe/APKBUILD b/testing/lfe/APKBUILD
new file mode 100644
index 00000000000..7ba66a1c4e2
--- /dev/null
+++ b/testing/lfe/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: rubicon <rubicon@mailo.com>
+# Maintainer: rubicon <rubicon@mailo.com>
+pkgname=lfe
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="Lisp Flavoured Erlang"
+url="https://lfe.io/"
+arch="all"
+license="Apache-2.0"
+depends="erlang"
+makedepends="erlang-dev"
+subpackages="$pkgname-doc"
+source="https://github.com/lfe/lfe/archive/$pkgver/lfe-$pkgver.tar.gz"
+
+build() {
+ make compile
+}
+
+check() {
+ ./bin/lfe -e '(help)'
+}
+
+package() {
+ make PREFIX="$pkgdir/usr" install
+
+ install -Dvm644 doc/*.txt \
+ -t "$pkgdir"/usr/share/doc/$pkgname/
+
+ cd "$pkgdir"/usr/bin
+ ln -svf ../lib/lfe/bin/* .
+}
+
+sha512sums="
+47d062fcd1910580ba5d84f8887a27d0717cb7aae2a90fb3a7e7411fd46886dd73e342ccd4627227c70d13dcd2c5f66077d351812e9bc0c17d64e9ef65d04f96 lfe-2.0.1.tar.gz
+"