aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-22 01:13:08 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-22 01:14:08 +0200
commit9387cc16c0338e286bd8a5cf917683065ff53745 (patch)
treef8fe1371accc695f78f733a731c71519496c7a77
parentde202d057c94d8d5c8cc5f1b6647da7a9ee54ea3 (diff)
main/py-urllib3: improve abuild
-rw-r--r--main/py-urllib3/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/main/py-urllib3/APKBUILD b/main/py-urllib3/APKBUILD
index c6ea0b5383c..3080676bfe9 100644
--- a/main/py-urllib3/APKBUILD
+++ b/main/py-urllib3/APKBUILD
@@ -5,20 +5,15 @@ pkgname=py-urllib3
_pkgname=${pkgname/py-/}
pkgver=1.21.1
pkgrel=0
-pkgdesc="HTTP library with thread-safe connection pooling, file post, and more."
+pkgdesc="HTTP library with thread-safe connection pooling, file post, and more"
url="https://github.com/shazow/urllib3"
arch="noarch"
license="MIT"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="$pkgname-$pkgver.tar.gz::https://github.com/shazow/urllib3/archive/$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+builddir="$srcdir/$_pkgname-$pkgver"
-check() {
- cd "$builddir"
- python2 setup.py check
- python3 setup.py check
-}
build() {
cd "$builddir"
@@ -26,6 +21,12 @@ build() {
python3 setup.py build
}
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
package() {
mkdir -p "$pkgdir"
}
@@ -42,6 +43,7 @@ _py3() {
_py() {
local python="$1"
pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"