aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2018-12-04 19:19:51 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-17 15:01:24 +0000
commit9495f812bdbce09e519b44b3caa452f79ae8ba06 (patch)
treea001af94bc327d5bdf92a04da49b20fedde1931e
parent610072d44b6b988b341e2890b63de436228819a7 (diff)
testing/py-pygal: Added missing dependency
-rw-r--r--testing/py-pygal/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/testing/py-pygal/APKBUILD b/testing/py-pygal/APKBUILD
index 5dcaf53d406..6c35c067fe2 100644
--- a/testing/py-pygal/APKBUILD
+++ b/testing/py-pygal/APKBUILD
@@ -2,12 +2,13 @@
pkgname=py-pygal
_pkgname=pygal
pkgver=2.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="pygal is a dynamic SVG charting library written in python"
url="https://pygal.org"
arch="noarch"
license="LGPL-3.0-or-later"
-makedepends="python2-dev python3-dev py-setuptools"
+depends="py-setuptools"
+makedepends="python2-dev python3-dev"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
options="!check" # no test suite
@@ -24,10 +25,12 @@ package() {
}
_py2() {
+ depends="${depends//py-/py2-}"
_py python2
}
_py3() {
+ depends="${depends//py-/py3-}"
_py python3
}