aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo L F Walbon <gwalbon@linux.ibm.com>2020-11-10 07:54:45 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-12-14 09:56:13 +0000
commit9607aed094c5206475d810f0726aab61c5aeaff2 (patch)
treec5c8764ce9e8938a8850bd39a2ec023204e9cbaa
parent71e3070f8f0ede84b9f759012fb4525f2b3a57ab (diff)
community/cassandra-cpp-driver: fix build
The build was emitting an error due to -Werror. ``` /home/devel/aports/community/cassandra-cpp-driver/src/cpp-driver-2.15.2/src/cloud_secure_connection_config.cpp:123:62: required from here /home/devel/aports/community/cassandra-cpp-driver/src/cpp-driver-2.15.2/src/third_party/rapidjson/rapidjson/reader.h:1013:53: error: comparison is always true due to limited range of data type [-Werror=type-limits] cc1plus: all warnings being treated as errors make[2]: *** [src/CMakeFiles/cassandra_static.dir/build.make:238: src/CMakeFiles/cassandra_static.dir/cloud_secure_connection_config.cpp.o] Error 1 make[1]: *** [CMakeFiles/Makefile2:258: src/CMakeFiles/cassandra_static.dir/all] Error 2 make: *** [Makefile:149: all] Error 2 >>> ERROR: cassandra-cpp-driver: build failed ``` Signed-off-by: Gustavo L F Walbon <gwalbon@linux.ibm.com>
-rw-r--r--community/cassandra-cpp-driver/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/community/cassandra-cpp-driver/APKBUILD b/community/cassandra-cpp-driver/APKBUILD
index 4aa986e5eea..d90598504fd 100644
--- a/community/cassandra-cpp-driver/APKBUILD
+++ b/community/cassandra-cpp-driver/APKBUILD
@@ -18,7 +18,7 @@ builddir="$srcdir/$_pkgname-$pkgver"
build() {
mkdir -p "$builddir"/build
cd "$builddir"/build
- export CXXFLAGS="$CXXFLAGS -Wno-error=deprecated-copy"
+ export CXXFLAGS="$CXXFLAGS -Wno-error=deprecated-copy -Wno-error=type-limits"
cmake \
-DCMAKE_BUILD_TYPE=None \
-DCASS_BUILD_STATIC=ON \